以前总结Redis 的一些基本的安装和使用,大家可以这这里查看Redis 系列文章:https://www.cnblogs.com/zhangweizhong/category/771056.html。

今天补一下redis集群功能吧。需要注意,Redis 3.0 以后才有集群的功能,下载Redis的时候注意下版本。

1. Redis集群原理

先看看redis-cluster架构图:

架构细节:

(1)所有的redis节点彼此互联(PING-PONG机制),内部使用二进制协议优化传输速度和带宽。

(2)节点的fail是通过集群中超过半数的节点检测失效时才生效。

(3)客户端与redis节点直连,不需要中间proxy层,客户端不需要连接集群所有节点,连接集群中任何一个可用节点即可。

(4)redis-cluster把所有的物理节点映射到[0-16383]slot(哈希槽)上,cluster 负责维护node<->slot<->value。

Redis 集群中内置了 16384 个slot(哈希槽),当需要在 Redis 集群中放置一个 key-value 时,redis 先对 key 使用 crc16 算法算出一个结果,然后把结果对 16384 求余数,这样每个 key 都会对应一个编号在 0-16383 之间的哈希槽,redis 会根据节点数量大致均等的将哈希槽映射到不同的节点。

容错机制: redis-cluster投票

(1)领着投票过程是集群中所有master参与,如果半数以上master节点与master节点通信超过(cluster-node-timeout),认为当前master节点挂掉.

(2):什么时候整个集群不可用(cluster_state:fail)?

a:如果集群任意master挂掉,且当前master没有slave.集群进入fail状态,也可以理解成集群的slot映射[0-16383]不完成时进入fail状态.

b:如果集群超过半数以上master挂掉,无论是否有slave集群进入fail状态.

注意:1. 当集群不可用时,所有对集群的操作做都不可用,收到((error) CLUSTERDOWN The cluster is down)错误。

    2. redis-3.0.0.rc1加入cluster-require-full-coverage参数,默认关闭,打开改配置,允许集群兼容部分失败。

2. 安装Redis

redis 的单机安装之前已经讲过,网络上也有很多教程,这里就不重复了。

文章最后提供了Redis 3.0 的源码,Redis集群脚本等资源。大家可以用我提供的版本来测试。

3. 安装ruby环境

redis3.0 源码中自带的集群管理工具redis-trib.rb依赖ruby环境,首先需要安装ruby环境:

1. 安装ruby环境

yum install ruby

yum install rubygems   

2. 安装ruby和redis的接口程序

拷贝redis-3.0.0.gem至/usr/local下

执行:gem install /usr/local/redis-3.0.0.gem

4. 创建集群

集群结点规划

一般Redis集群的实例,都安装在各个主从服务器上,这里为了演示方便,只是在同一台服务器用不同的端口表示不同的redis服务器,如下:

主节点:172.16.0.17:7001,172.16.0.17:7002,172.16.0.17:7003

从节点:172.16.0.17:7004,172.16.0.17:7005,172.16.0.17:7006

1. 在/usr/local下创建redis-cluster目录,其下创建Redis01到Redis06等6个redis实例,端口号为:7001-7006,具体目录如下:

2. 将redis源码目录src下的redis-trib.rb拷贝到redis-cluster目录下。

3. 修改每个redis实例的redis.conf配置文件:

port   //这里要改成各个实例对应的端口,7001-7006
#bind 172.16.0.17
cluster-enabled yes

启动每个结点redis服务

分别进入Redis01、Redis02、...Redis06目录,执行:

./redis-server ./redis.conf

查看redis进程:ps aux|grep redis

以上,Redis 的6个实例,就已经启动了。

执行创建集群命令

执行redis-trib.rb,此脚本是ruby脚本,它依赖ruby环境。

./redis-trib.rb create --replicas  172.16.0.17: 172.16.0.17: 172.16.0.17: 172.16.0.17: 172.16.0.17:  172.16.0.17:

说明:

redis集群至少需要3个主节点,每个主节点有一个从节点总共6个节点

replicas指定为1表示每个主节点有一个从节点

注意:

如果执行时报如下错误:

[ERR] Node XXXXXX is not empty. Either the node already knows other nodes (check with CLUSTER NODES) or contains some key in database 0

解决方法是删除生成的配置文件nodes.conf,如果不行则说明现在创建的结点包括了旧集群的结点信息,需要删除redis的持久化文件后再重启redis,比如:appendonly.aof、dump.rdb

创建集群输出如下:

>>> Creating cluster

Connecting to node 172.16.0.17:: OK

Connecting to node 172.16.0.17:: OK

Connecting to node 172.16.0.17:: OK

Connecting to node 172.16.0.17:: OK

Connecting to node 172.16.0.17:: OK

Connecting to node 172.16.0.17:: OK

>>> Performing hash slots allocation on  nodes...

Using  masters:

172.16.0.17:

172.16.0.17:

172.16.0.17:

Adding replica 172.16.0.17: to 172.16.0.17:

Adding replica 172.16.0.17: to 172.16.0.17:

Adding replica 172.16.0.17: to 172.16.0.17:

M: cad9f7413ec6842c971dbcc2c48b4ca959eb5db4 172.16.0.17:

   slots:- ( slots) master

M: 4e7c2b02f0c4f4cfe306d6ad13e0cfee90bf5841 172.16.0.17:

   slots:- ( slots) master

M: 1a8420896c3ff60b70c716e8480de8e50749ee65 172.16.0.17:

   slots:- ( slots) master

S: 69d94b4963fd94f315fba2b9f12fae1278184fe8 172.16.0.17:

   replicates cad9f7413ec6842c971dbcc2c48b4ca959eb5db4

S: d2421a820cc23e17a01b597866fd0f750b698ac5 172.16.0.17:

   replicates 4e7c2b02f0c4f4cfe306d6ad13e0cfee90bf5841

S: 444e7bedbdfa40714ee55cd3086b8f0d5511fe54 172.16.0.17:

   replicates 1a8420896c3ff60b70c716e8480de8e50749ee65

Can I set the above configuration? (type 'yes' to accept): yes

>>> Nodes configuration updated

>>> Assign a different config epoch to each node

>>> Sending CLUSTER MEET messages to join the cluster

Waiting for the cluster to join...

>>> Performing Cluster Check (using node 172.16.0.17:)

M: cad9f7413ec6842c971dbcc2c48b4ca959eb5db4 172.16.0.17:

   slots:- ( slots) master

M: 4e7c2b02f0c4f4cfe306d6ad13e0cfee90bf5841 172.16.0.17:

   slots:- ( slots) master

M: 1a8420896c3ff60b70c716e8480de8e50749ee65 172.16.0.17:

   slots:- ( slots) master

M: 69d94b4963fd94f315fba2b9f12fae1278184fe8 172.16.0.17:

   slots: ( slots) master

   replicates cad9f7413ec6842c971dbcc2c48b4ca959eb5db4

M: d2421a820cc23e17a01b597866fd0f750b698ac5 172.16.0.17:

   slots: ( slots) master

   replicates 4e7c2b02f0c4f4cfe306d6ad13e0cfee90bf5841

M: 444e7bedbdfa40714ee55cd3086b8f0d5511fe54 172.16.0.17:

   slots: ( slots) master

   replicates 1a8420896c3ff60b70c716e8480de8e50749ee65

[OK] All nodes agree about slots configuration.

>>> Check for open slots...

>>> Check slots coverage...

[OK] All  slots covered.

5. 查询集群信息

集群创建成功登陆任意redis结点查询集群中的节点情况。

客户端以集群方式登陆:

./redis-cli -c -h 172.16.0.17 -p 7001 -c //其中-c表示以集群方式连接redis,-h指定ip地址,-p指定端口号

查询集群信息

cluster nodes 查询集群结点信息

cluster info 查询集群状态信息

6. 添加主节点

集群创建成功后可以向集群中添加节点,下面是添加一个master主节点

1. 增加Redis07实例,参考集群结点规划章节添加一个“7007”目录作为新节点。

2. 将Redis07实例添加到集群中,执行下边命令:

./redis-trib.rb add-node  172.16.0.17: 172.16.0.17:

3. 查看集群结点发现7007已添加到集群中:

[root@VM_0_17_centos redis-cluster]# ./redis-trib.rb add-node  172.16.0.17: 172.16.0.17:
>>> Adding node 172.16.0.17: to cluster 172.16.0.17:
Connecting to node 172.16.0.17:: OK
.
.
.
Connecting to node 172.16.0.17:: OK
Connecting to node 172.16.0.17:: OK
Connecting to node 172.16.0.17:: OK
Connecting to node 172.16.0.17:: OK
Connecting to node 172.16.0.17:: OK
>>> Performing Cluster Check (using node 172.16.0.17:)
M: 977962f18ec51f363747961137dc903f0078b248 172.16.0.17:
slots:- ( slots) master
additional replica(s)
M: defe4ce0421ee6b50bdab3da58754e98cc80fca3 172.16.0.17:
slots:- ( slots) master
additional replica(s)
S: a64fc273c0b90700397f5bac2b393dc5587d8ba8 172.16.0.17:
slots: ( slots) slave
replicates f277758189eba36c5b5732e9189d8554bf4385cb
M: f277758189eba36c5b5732e9189d8554bf4385cb 172.16.0.17:
slots:- ( slots) master
additional replica(s)
S: 4f16e5adcc141ca284d4a9ec6d04f455aee84a48 172.16.0.17:
slots: ( slots) slave
replicates defe4ce0421ee6b50bdab3da58754e98cc80fca3
S: 479d5a077893184cd0b05a8e1b6cb5c0625215f4 172.16.0.17:
slots: ( slots) slave
replicates 977962f18ec51f363747961137dc903f0078b248
[OK] All nodes agree about slots configuration.
>>> Check for open slots...
>>> Check slots coverage...
[OK] All slots covered.
Connecting to node 172.16.0.17:: OK
.
.
.
>>> Send CLUSTER MEET to node 172.16.0.17: to make it join the cluster.
[OK] New node added correctly.

哈希槽重新分配

添加完主节点后,集群并不会自动给新添加的节点分配哈希槽,需要我们手动对主节点进行hash槽分配重新分配,这样该主节才可以存储数据。

redis集群有16384个槽,集群中的每个结点分配自已槽,通过查看集群结点可以看到槽占用情况。可以看到刚才添加的主节点Redis07,没有分配哈希槽(slot)。

下面就来说说如何给刚添加的Redis01结点分配槽:

第一步:连接上集群

./redis-trib.rb reshard 172.16.0.17:7001   //(连接集群中任意一个可用结点都行)

第二步:输入要分配的槽数量

第三步:输入接收槽的结点id

这里准备给Redis07分配哈希槽,通过cluster nodes查看Redis07节点id为:e8461f9743e186ae8f67ed301d2d971186b1cc93

输入:e8461f9743e186ae8f67ed301d2d971186b1cc93,

第四步:输入源结点id

如果只是想从单个主节点获取哈希槽,那直接输入相应的节点id即可。

如果想从所有的主节点获取输入:all,

第五步:输入yes开始移动槽到目标结点id

第六步:分配完成之后,可以查询集群节点信息,查看哈希槽是否分配成功。

7. 添加从节点

集群创建成功后可以向集群中添加节点,下面是添加一个slave从节点的命令。

./redis-trib.rb add-node --slave --master-id 主节点id 添加节点的ip和端口 集群中已存在节点ip和端口

1. 添加Redis08实例为从结点,将Redis08作为Redis07的从结点。

执行如下命令:

./redis-trib.rb add-node --slave --master-id e8461f9743e186ae8f67ed301d2d971186b1cc93  172.16.0.17: 172.16.0.17:

e8461f9743e186ae8f67ed301d2d971186b1cc93  是Redis07实例的节点id,可通过cluster nodes查看。

注意:如果原来该结点在集群中的配置信息已经生成集群节点的配置文件(如果集群配置cluster-config-file默认指定则为nodes.conf),这时可能会报错:

[ERR] Node XXXXXX is not empty. Either the node already knows other nodes (check with CLUSTER NODES) or contains some key in database 0

解决方法是:删除生成的配置文件nodes.conf,删除后再执行./redis-trib.rb add-node指令

2. 查看集群中的结点,刚添加的Redis08已经成为Redis07的从节点:

8. 删除结点:

集群创建成功后可以向集群中删除其中的一个节点,应该怎么删除呢?

执行如下命令即可:

./redis-trib.rb del-node 172.16.0.17 : e8461f9743e186ae8f67ed301d2d971186b1cc93

注意:删除已经分配了有hash槽的节点会失败,报错如下:

[ERR] Node 172.16.0.17:7007 is not empty! Reshard data away and try again.

解决办法就是:将该结点占用的hash槽分配出去,请参考前面哈希槽重新分配的操作,这里就不重复了。

最后

以上就已经将如何搭建redis的集群讲完了。

redis3.0源码和ruby脚本,点击这里下载。

Redis总结(八)如何搭建高可用的Redis集群的更多相关文章

  1. keepalived工作原理和配置说明 腾讯云VPC内通过keepalived搭建高可用主备集群

    keepalived工作原理和配置说明 腾讯云VPC内通过keepalived搭建高可用主备集群 内网路由都用mac地址 一个mac地址绑定多个ip一个网卡只能一个mac地址,而且mac地址无法改,但 ...

  2. K8S 使用Kubeadm搭建高可用Kubernetes(K8S)集群 - 证书有效期100年

    1.概述 Kubenetes集群的控制平面节点(即Master节点)由数据库服务(Etcd)+其他组件服务(Apiserver.Controller-manager.Scheduler...)组成. ...

  3. 快速掌握RabbitMQ(五)——搭建高可用的RabbitMQ集群

    RabbitMQ的集群是依赖erlang集群的,而erlang集群是通过.erlang.cookie文件进行通信认证的,所以我们使用RabbitMQ集群时只需要配置一下.erlang.cookie文件 ...

  4. 搭建高可用的rabbitmq集群 + Mirror Queue + 使用C#驱动连接

    我们知道rabbitmq是一个专业的MQ产品,而且它也是一个严格遵守AMQP协议的玩意,但是要想骚,一定需要拿出高可用的东西出来,这不本篇就跟大家说 一下cluster的概念,rabbitmq是erl ...

  5. 搭建高可用的MongoDB集群

    http://www.csdn.net/article/2014-04-09/2819221-build-high-avialable-mongodb-cluster-part-1/1 在大数据的时代 ...

  6. 手动搭建高可用的kubernetes 集群

    之前按照和我一步步部署 kubernetes 集群的步骤一步一步的成功的使用二进制的方式安装了kubernetes集群,在该文档的基础上重新部署了最新的v1.8.2版本,实现了kube-apiserv ...

  7. Hadoop搭建高可用的HA集群

    一.工具准备 1.7台虚拟机(至少需要3台),本次搭建以7台为例,配好ip,关闭防火墙,修改主机名和IP的映射关系(/etc/hosts),关闭防火墙 2.安装JDK,配置环境变量 二.集群规划: 集 ...

  8. MyCAT+MySQL 搭建高可用企业级数据库集群——第2章 MyCat入门

    2-1 章节综述 2-2 什么是MyCat 2-3 什么是数据库中间层 2-4 MyCat的主要作用 2-5 MyCat基本元素 2-6 MyCat的安装 2-1 章节综述 1.掌握Mycat的基础概 ...

  9. MyCAT+MySQL搭建高可用企业级数据库集群视频课程

    原文地址:https://www.guangboyuan.cn/mycatmysql%E6%90%AD%E5%BB%BA%E9%AB%98%E5%8F%AF%E7%94%A8%E4%BC%81%E4% ...

  10. 从零开始搭建高可用的k8s集群

    一.环境准备 使用Hyper-V虚拟机功能搭建三台Centos虚拟机系统,配置好静态IP,分别为k8s-node1(192.168.0.8),k8s-node2(192.168.0.9),k8s-no ...

随机推荐

  1. python数据库-MySQL与python的交互

    一.python3中安装PyMySQL模块 命令安装: sudo apt-get install python-mysql 或者 pip install pymysql 2.使用在pyCharm中安装 ...

  2. 7.秋招复习简单整理之请你讲讲 Statement 和 PreparedStatement 的区别?哪个性能更好?

    Statement和PreparedStatement都是数据库用于执行SQL语句的句柄,但是PreparedStatement代表一个预编译的SQL. 以下是PreparedStatement和St ...

  3. 『开发技术』Docker开发教程(一)安装与测试(Windows 家庭版)

    0.前言 针对其他系统和版本,Docker都很容易安装,可以参考官方教程:https://docs.docker.com/docker-hub/ 由于Windows10家庭版无法安装docker,因此 ...

  4. 深入学习Spring框架(三)- AOP面向切面

    1.什么是AOP? AOP为 Aspect Oriented Programming 的缩写,即面向切面编程, 通过预编译方式和运行期动态代理实现程序功能的统一维护的一种技术..AOP是OOP的延续, ...

  5. 【POJ - 3050】Hopscotch (dfs+回溯)

    -->Hopscotch 这接写中文了 Descriptions: 奶牛们以一种独特的方式玩孩子们的跳房子游戏. 奶牛们创造了一个5x5的格子 他们熟练地跳上其中的一个格子,可以前后左右地跳(不 ...

  6. 剑指offer第二版-总结:排序算法

    1.排序算法比较: 2.java实现 快排: /** * 快排 * * @since 2019年2月26日 下午1:37:34 * @author xuchao */ public class Qui ...

  7. 分布式事务(4)---RocketMQ实现分布式事务项目

    RocketMQ实现分布式事务 有关RocketMQ实现分布式事务前面写了一篇博客 1.RocketMQ实现分布式事务原理 下面就这个项目做个整体简单介绍,并在文字最下方附上项目Github地址. 一 ...

  8. bash 遍历目录

    bash遍历目录脚本traverse.sh: #!/bin/bash datadir=$ declare -a dirlist dirlist=`>/dev/null` for i in ${d ...

  9. 个人永久性免费-Excel催化剂功能第88波-批量提取pdf文件信息(图片、表格、文本等)

    日常办公场合中,除了常规的Excel.Word.PPT等文档外,还有一个不可忽略的文件格式是pdf格式,而对于想从pdf文件中获取信息时,常规方法将变得非常痛苦和麻烦.此篇给大家送一pdf文件提取信息 ...

  10. http面试笔试常考知识点(一)

    1.什么是http HTTP是客户端和服务器端请求和应答的标准.通过使用Web浏览器.网络爬虫或者其它的工具,客户端发起一个到服务器上指定端口(默认端口为80)的HTTP请求.(我们称这个客户端)叫用 ...