ECS Linux服务器xfs磁盘扩容
ECS Linux服务器xfs磁盘扩
ECS Linux服务器xfs磁盘使用阿里云官方提供的磁盘扩容方法扩容会有报错:
[root@iZ28u04wmy2Z ~]# e2fsck /dev/xvdb1
e2fsck 1.42.9 (28-Dec-2013)
ext2fs_open2: Bad magic number in super-block
e2fsck: Superblock invalid, trying backup blocks...
e2fsck: Bad magic number in super-block while trying to open /dev/xvdb1
The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193
可以看到报错是超级块不可用。
超级块不可用有两种可能性:
1. 超级块损坏,导致不可用。
2. 不同的文件系统,使用ext文件系统去检查xfs的文件系统,超级块不能识别。
此处是由于第二中原因导致的,查看分区的文件系统的方法:
[root@iZ28u04wmy2Z ~]# df -T
Filesystem Type 1K-blocks Used Available Use% Mounted on
/dev/xvda1 ext4 20510332 1660744 17784680 9% /
devtmpfs devtmpfs 934320 0 934320 0% /dev
tmpfs tmpfs 942004 0 942004 0% /dev/shm
tmpfs tmpfs 942004 8508 933496 1% /run
tmpfs tmpfs 942004 0 942004 0% /sys/fs/cgroup
/dev/xvdb1 xfs 10474496 33088 10441408 1% /mnt
可以看到/dev/xvdb1是xfs的文件系统。
对xfs的文件系统扩容方法如下:
1. 不需要卸载已经挂载的磁盘,否则扩容会报错。
[root@iZ28u04wmy2Z ~]# xfs_growfs /dev/xvdb1
xfs_growfs: /dev/xvdb1 is not a mounted XFS filesystem
2. 可以在分区挂载的情况扩容xfs的文件系统:
[root@iZ28u04wmy2Z ~]# xfs_growfs /dev/xvdb1
meta-data=/dev/xvdb1 isize=256 agcount=4, agsize=327616 blks
= sectsz=512 attr=2, projid32bit=1
= crc=0
data = bsize=4096 blocks=1310464, imaxpct=25
= sunit=0 swidth=0 blks
naming =version 2 bsize=4096 ascii-ci=0 ftype=0
log =internal bsize=4096 blocks=2560, version=2
= sectsz=512 sunit=0 blks, lazy-count=1
realtime =none extsz=4096 blocks=0, rtextents=0
data blocks changed from 1310464 to 2621184
可以看到blocks 的数量从131046扩容到了2621184,实现了扩容。
扩容前/dev/xvdb1是5G的容量:
[root@iZ28u04wmy2Z ~]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/xvda1 20G 1.5G 18G 9% /
devtmpfs 913M 0 913M 0% /dev
tmpfs 920M 0 920M 0% /dev/shm
tmpfs 920M 8.3M 912M 1% /run
tmpfs 920M 0 920M 0% /sys/fs/cgroup
/dev/xvdb1 5.0G 33M 5.0G 1% /mnt
扩容后的/dev/xvdb1的容量为10G:
[root@iZ28u04wmy2Z ~]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/xvda1 20G 1.5G 18G 9% /
devtmpfs 913M 0 913M 0% /dev
tmpfs 920M 0 920M 0% /dev/shm
tmpfs 920M 8.3M 912M 1% /run
tmpfs 920M 0 920M 0% /sys/fs/cgroup
/dev/xvdb1 10G 33M 10G 1% /mnt
ECS Linux服务器xfs磁盘扩容的更多相关文章
- 阿里云ECS 实例Centos7系统磁盘扩容
需求:一台阿里云的数据盘磁盘空间不足,需要扩容,我这里只有一个主分区,ext4文件系统. 因为磁盘扩容场景不同,阿里云的文档比较全面一些,所以先奉上阿里云的文档,下面开始我的操作步骤: 1.登录控制台 ...
- KVM之XFS磁盘扩容
1.前言 根据目前我们使用的需求,以前规划的100G磁盘空间不够,这里将演示XFS文件系统的扩容,因为我使用的是KVM所以也会演示KVM的扩容方式. 2.KVM磁盘扩容 扩容前一定要先备份,或者做快照 ...
- 【转载】阿里云ECS Linux服务器禁止某些IP访问
在阿里云ECS Linux服务器运维过程中,如果发现某些IP访问异常,如怀疑有攻击行为或者怀疑是别人写的爬虫程序长时间占用你的服务器资源,则可以通过相关的设置来禁止这些IP段的访问,拒绝这些IP的请求 ...
- 如何为Linux服务器添加磁盘
Linux服务器如果磁盘不够用了,就需要增加新的磁盘,磁盘添加到使用通常有4个步骤.其中第一个步骤虚拟机和实体服务器有差别,后面三个步骤都是相同的,这里以VMWare虚拟机来进行演示如何添加磁盘. ( ...
- 云服务器 ECS Linux 服务器修改时区的两种方式
在云服务器 ECS Linux 系统中,以 Centos6.5 为例,可以通过如下两种方式,修改系统时区: 可以使用命令 tzselect,修改时区.操作示例: [root@localhost ~]# ...
- (二)阿里云ECS Linux服务器外网无法连接MySQL解决方法(报错2003- Can't connect MySQL Server on 'x.x.x.x'(10038))(自己亲身遇到的问题是防火墙的问题已经解决)
我的服务器买的是阿里云ECS linux系统.为了更好的操作数据库,我希望可以用navicat for mysql管理我的数据库. 当我按照正常的模式去链接mysql的时候, 报错提示: - Can' ...
- [linux] LVM原磁盘扩容(非增加磁盘)
阿里云机器,ECS运行时磁盘由300G扩容到500,重启机器生效后登录.可以看到/data目录总大小300G,/dev/vdb已经扩容到500G. [root@HD1g-elasticsearch2 ...
- linux下 lvm 磁盘扩容
打算给系统装一个oracle,发现磁盘空间不足.在安装系统的时候我选择的是自动分区,系统就会自动以LVM的方式分区.为了保证系统后期的可用性,建议所有新系统安装都采用LVM,之后生产上的设备我也打算这 ...
- VM下--Linux根分区磁盘扩容
转载请注明源出处:http://www.cnblogs.com/lighten/p/6825938.html 1.缘由 由于需要对虚拟机中的软件进行升级,执行yum update的时候,整个更新包在8 ...
随机推荐
- mysql分享一:运维角度浅谈MySQL数据库优化
转于:http://lizhenliang.blog.51cto.com/7876557/1657465 1.数据库表设计要合理避免慢查询.低效的查询语句.没有适当建立索引.数据库堵塞(死锁)等 2. ...
- Java操作XML的JAXB工具
在java中操作XML的工作中中,比较方便的工具是JAXB(Java Architecture for XML Binding). 利用这个工具很方便生成XML的tag和Java类的对应关系.参照网上 ...
- redisHelper
using System; using System.Collections.Generic; using System.Linq; using System.Text; using ServiceS ...
- Android API Guides---Drag and Drop
Drag and Drop 随着Android拖/放框架,能够同意用户将数据从一个视图使用图形拖动移动到还有一个查看当前布局和下降的手势. 该框架包含一个拖放事件类,拖累听众和辅助方法和类. 尽管该框 ...
- 菜鸟学Java(十三)——将MyEclipse项目导入到Eclipse
最近由于种种原因,需要将以前用MyEclipse写的项目迁移到Eclipse中.但是当我将之前的项目import到Eclipse中后,发现根本不能运行.经过一番寻觅,终于让我找到了一种解决的办法.一起 ...
- NonWindowJoin
package org.apache.flink.table.runtime.join /** * Connect data for left stream and right stream. Bas ...
- 利用babel-cli搭建支持ES6的node环境
现在ES6盛行,开始大量使用ES6的特性敲代码,但限于Node.js本身对ES6的特性支持的不够完备,那么需要借助于其他工具来完成. 基本上,现在都直接写ES6的代码,然后使用babel-cli提供的 ...
- position: absolute;
.recent-contac { position: absolute; overflow: auto; overflow-x: hidden; top: -2px; bottom: 0; -webk ...
- pyspark实现自动提示以及代码高亮
pyspark实现自动提示以及代码高亮 起因 打开pyspark发现啥提示都没有,太不友好了啊,然后忍不住谷歌了一下,发现了这篇文章,内容如下: 1.pip install ptpython; 2.e ...
- Ubuntu 16.04 64位安装arm-linux-gcc交叉编译器以及samba服务器
交叉编译器是嵌入式开发的必要工具,但是由于目前大多数人使用64位ubuntu,在照着很多教程做的时候,就会失败,失败原因是64位ubuntu需要额外安装32位的兼容包.以arm-linux-gcc-3 ...