opesntack 底层共享存储 迁移配置
底层共享存储在迁移配置:
每台compute 节点都需要配置一下
让nova用户可以登陆
usermod -s /bin/bash nova
设置nova 用户密码
echo "nova"|passwd --stdin nova
切换nova并生成key同步其它节点上
su - nova
ssh-keygen -t rsa -N '' -f ~/.ssh/id_rsa
ssh-copy-id nova@x.x.x.x```
没有做上面的处理在更改配置或者热迁移将会报如下错误:
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server six.reraise(self.type_, self.value, self.tb)
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server File "/usr/lib/python2.7/site-packages/nova/compute/manager.py", line 122, in decorated_function
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server return function(self, context, *args, **kwargs)
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server File "/usr/lib/python2.7/site-packages/nova/compute/manager.py", line 216, in decorated_function
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server kwargs['instance'], e, sys.exc_info())
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server File "/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 220, in __exit__
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server self.force_reraise()
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server File "/usr/lib/python2.7/site-packages/oslo_utils/excutils.py", line 196, in force_reraise
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server six.reraise(self.type_, self.value, self.tb)
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server File "/usr/lib/python2.7/site-packages/nova/compute/manager.py", line 204, in decorated_function
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server return function(self, context, *args, **kwargs)
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server File "/usr/lib/python2.7/site-packages/nova/compute/manager.py", line 3856, in resize_instance
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server self.instance_events.clear_events_for_instance(instance)
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server File "/usr/lib64/python2.7/contextlib.py", line 35, in __exit__
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server self.gen.throw(type, value, traceback)
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server File "/usr/lib/python2.7/site-packages/nova/compute/manager.py", line 6632, in _error_out_instance_on_exception
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server raise error.inner_exception
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server ResizeError: Resize error: not able to execute ssh command: Unexpected error while running command.
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server Command: ssh -o BatchMode=yes 172.16.20.1 mkdir -p /gpfs/nova//instances/e946ffb3-c797-42c5-b7ab-16aa8ceab84d
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server Exit code: 255
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server Stdout: u''
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server Stderr: u'Host key verification failed.\r\n'
2018-04-11 14:19:34.574 10770 ERROR oslo_messaging.rpc.server
opesntack 底层共享存储 迁移配置的更多相关文章
- [k8s]k8s配置nfs做后端存储&配置多nginx共享存储&&statefulset配置
所有节点安装nfs yum install nfs-utils rpcbind -y mkdir -p /ifs/kubernetes echo "/ifs/kubernetes 192.1 ...
- 虚拟机在 OpenStack 里没有共享存储条件下的在线迁移[转]
原文链接:http://www.ibm.com/developerworks/cn/cloud/library/1508_wangyx_openstacklivemigrate/ 迁移(Migrati ...
- 虚拟机在 OpenStack 里没有共享存储条件下的在线迁移
虚拟机在 OpenStack 里没有共享存储条件下的在线迁移 本文尝试回答与 Live migration 相关的几个问题:Live migration 是什么?为什么要做 Live migratio ...
- 基于NFS共享存储实现KVM虚拟机动态迁移
基于NFS共享存储实现KVM虚拟机动态迁移 一:配置环境 二:安装相关的依赖包 三:实现NFS共享存储 四:KVM机配置相同的步骤 五:安装KVM01安装虚拟机 六:实现迁移 实验初始配置:所有主机 ...
- Openfiler配置RAC共享存储
将 Openfiler 用作 iSCSI 存储服务器,主要操作步骤如下: 1.设置 iSCSI 服务 2.配置网络访问 3.指定物理存储器并对其分区 4.创建新的卷组 5.创建所有逻辑卷 6.为每个逻 ...
- Linux之nginx反向代理+三台web+nfs共享存储实现集群配置
作业四:nginx反向代理+三台web+nfs共享存储实现集群配置 在各个web服务器上挂载nfs [root@localhost nginx]# mount -t nfs 192.168.152.1 ...
- iscsi共享存储的简单配置和应用
1.环境介绍 SCSI(Small Computer System Interface)是块数据传输协议,在存储行业广泛应用,是存储设备最基本的标准协议.从根本上说,iSCSI协议是一种利用IP网络来 ...
- Oracle 11g Rac 用rman实现把本地数据文件迁移到ASM共享存储中
在Oracle Rac环境中,数据文件都是要存放在ASM共享存储上的,这样两个节点才能同时访问.而当你在某一节点下把数据文件创建在本地磁盘的时候,那么在另一节点上要访问该数据文件的时候就会报错,因为找 ...
- bay——vSphere Oracle12cR2的RAC搭建安装之配置共享存储 - 副本
vSphere Oracle12cR2的RAC搭建安装之配置共享存储 https://blog.csdn.net/yuzifen/article/details/82496503 一.第一台机器添加两 ...
随机推荐
- vue父组件调用子组件资源
通过上篇博文提到的方法我们可以触发子组件的某个事件来实现调用子组件的某些资源(例如数据和方法),但是更多的情况下我们会想不通过触发子组件的事件,而直接调用子组件的资源 这个时候我们就需要用到ref了, ...
- spring boot 事务配置
事务的作用这里不细说,相信很多人也在工作中使用过. 那么在spring-boot是如何配置事务的,事实上非常简便. 直接贴代码吧. 首先配置数据源 myqlDataSource,这个就不说了.之前的 ...
- Content-Type:几种常用数据编码格式
Content-Type: 用于定义用户的浏览器或相关设备如何显示将要加载的数据,或者如何处理将要加载的数据. 内容类型,一般指网页中存在的Content-Type,Content-Type属性指定请 ...
- AngularJS开发指南:表达式
---恢复内容开始--- 表达式是类似Javascript的代码片段,通常在绑定中用到,写在双大括号中如{{表达式}}.表达式是用$parse方法来处理的. 下面是一些合法的AngularJS表达式 ...
- 360 / 小米 / 百度 随身wifi Ubuntu 下作为无线网卡使用
这篇文章说得其实很好了,http://www.freemindworld.com/blog/2013/131010_360_wifi_in_linux.shtml 不过因为专利问题,官网貌似不直接提供 ...
- Bug Bounty Reference
https://github.com/ngalongc/bug-bounty-reference/blob/master/README.md#remote-code-execution Bug Bou ...
- Linux 串口、usb转串口驱动分析(2-1) 【转】
转自:http://blog.chinaunix.net/xmlrpc.php?r=blog/article&uid=26807463&id=4186851 Linux 串口.usb转 ...
- python抓取猫眼电影列表
抓取地址:http://maoyan.com/board/4 分析url分页规则:http://maoyan.com/board/4?offset=0 其中offset参数值为0到90 用到的库: P ...
- 【linux】crontab无效解决办法
参考来源:http://www.tennfy.com/3088.html 问题: 我在crontab中添加了一条定时任务 * * * sh test.sh 出乎意料的是,该定时任务并没有执行.可是我直 ...
- redis配置文件redis.conf翻译、解释以及常用注意事项(持续更新中...)
# Redis configuration file example. #Redis 配置文件的示例 #如何利用配置文件启动Redis # Note that in order to read the ...