安装DHCP服务器

  DHCP配置文件

  可以使用RHEL 6.0自身携带的RPM包安装,安装结束后DHCP端口监督程序dhcpd配置文件是/etc/dhcp目录中的名为dhcpd.conf的文件。下面手工建立/etc/dhcp/dhcpd.conf文件,该文件通常包括3个部分,即parameters参数、declarations声明和option选项。

  1.DHCP配置文件中的parameters(参数)

  parameters表明如何执行任务,以及是否要执行任务或将哪些网络配置选项发送给客户

DHCP配置文件中的主要参数

参 数

解 释

ddns-update-style

配置DHCP-DNS互动更新模式

default-lease-time

指定默认租赁时间的长度,单位是秒

max-lease-time

指定最大租赁时间长度,单位是秒

hardware

指定网卡接口类型和MAC地址

server-name

通知DHCP客户端服务器名称

get-lease-hostnames flag

检查客户端使用的IP地址

fixed-address ip

分配给客户端一个固定的地址

authoritative

拒绝不正确的IP地址的要求

  2.DHCP配置文件中的declarations(声明)

  declarations用来描述网络布局及提供客户的IP地址等。

主要声明

声 明

解 释

shared-network

用来告知是否一些子网络共享相同网络

subnet

描述一个IP地址是否属于该子网

range起始IP终止IP

提供动态分配IP的范围

host主机名称

参考特别的主机

group

为一组参数提供声明

allow unknown-clients﹔deny unknown-client

是否动态分配IP给未知的使用者

allow bootp;deny bootp

是否响应激活查询

allow booting﹔deny booting    

是否响应使用者查询

filename

开始启动文件的名称,应用于无盘工作站

next-server

设置服务器从引导文件中装入主机名,应用于无盘工作站

3.DHCP配置文件中的option(选项)

option用来配置DHCP可选参数,全部用option关键字作为开始。

主要选项

选 项

解 释

subnet-mask

为客户端设定子网掩码

domain-name

为客户端指明DNS名字

domain-name-servers

为客户端指明DNS服务器的IP地址

host-name

为客户端指定主机名称

routers

为客户端设定默认网关

broadcast-address

为客户端设定广播地址

ntp-server

为客户端设定网络时间服务器的IP地址

time-offset

为客户端设定格林威治时间的偏移时间,单位是秒

nis-server

为客户端设定nis域名

4.配置实例

Radhad RHEL 6.2 DHCP服务器安装过程

安装DHCP服务之前先为本服务器分配好IP地址:192.168.x.1/24,网关:192.168.x.254,DNS地址:192.168.x.1

1),加载光驱

首先插入Redhat的安装光盘,挂载光驱

先在/mnt下新建一个目录RHEL:

#mkdir /mnt/RHEL

接下来把光驱挂载到RHEL

# mount –t iso9660 /dev/sr1 /mnt/RHEL(注:sr1为第二块光驱,所以挂载前要在第二块光驱装载linux的ISO文件)

mount: block device /dev/cdrom is write-protected, mounting read-only

加载成功!

2),安装DHCPD服务软件

# rpm -ivh /mnt/RHEL/Packages/dhcp-4.1.1-47.P1.el6.i686.rpm

warning: /media/Packages/dhcp-4.1.1-25.P1.el6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID fd431d51: NOKEY

Preparing...                ########################################### [100%]

1:dhcp                   ########################################### [100%]

提示100%说明安装成功.

3)DHCP服务的配置

dhcpd.conf 是DHCP服务的配置文件,DHCP服务所有参数都是通过修改dhcpd.conf 文件来实现,安装后dhcpd.conf 是没有做任何配置的,dhcpd.conf文件是在/etc/dhcp/目录下的.

我们可以使用 #cat dhcpd.conf  命令来查看一下文件内容:

#

# DHCP Server Configuration file.

#   see /usr/share/doc/dhcp*/dhcpd.conf.sample

#   see 'man 5 dhcpd.conf'

这里的意思告诉我们,这个文件是一个dhcp 服务器的配置文件,配置要参考dhcpd.conf.sample来配置.

接下来我们就将/usr/share/doc/ dhcp-4.1.1/dhcpd.conf.sample 复制为dhcpd.conf 文件进行配置:

# cp /usr/share/doc/dhcp-4.1.1/dhcpd.conf.sample /etc/dhcp/dhcpd.conf

cp:是否覆盖"dhcpd.conf"? y

复制好了,通过vi命令去修改dhcpd.conf文件的内容:

#vi /etc/dhcp/dhcpd.conf  修改里面一个子网subnet,即创建一个作用域:

subnet 192.168.x.0 netmask 255.255.255.0 {

range 192.168.x.100 192.168.x.200;

option domain-name-servers 192.168.55.1;

  option domain-name "www.abc.com";

  option routers 192.168.x.254;

  }

  上面的实例配置文件分为两个部分,即子网配置信息和全局配置信息。可以有多个子网,这里为了简化,只指定了一个子网。

    Subnet。

  在上面的例子中,一个子网声明以“subset”关键字开始,所以子网信息包括在{}中。{}中的配置信息只对该子网有效,会覆盖全局配置。

  

  2.启动DHCP服务器

  使用命令启动DHCP服务器:

  #service dhcpd start

 设置服务器重启后也自动重启dhcpd服务

#chkconfig  dhcpd on

3.在客户端XP测试能否自动从DHCP服务器地址池中正确获取到IP地址。

进入到XP系统CMD控制台,通过命令ipconfig/release(释放IP)、ipconfig/renew(重新获取IP)、ipconfig/all,查看能否正确获取IP地址。

LINUX_RHEl6_DHCP服务器配置的更多相关文章

  1. Linux服务器配置之加载硬盘

    Linux服务器配置之加载硬盘 1.修改密码 passwd 2.测试密码是否成功 3.查看硬盘信息 fdisk –l 4.格式化分区 fdisk /dev/vdb 5.查看分区 6.快速格式化/dev ...

  2. Windows Server 2008 R2 WEB服务器配置系列文章索引

    最近这段时间趁天翼云1元主机活动,购买了一个1元主机,主要是为了写一些服务器配置的教程. 已经完成如下几篇文章,送给大家. 国内云主机比较 天翼云/阿里云/腾讯云 Windows Server 200 ...

  3. Window下python2.7+Apache+mod_wsgi+Django服务器配置

    前言:试着使用python搭建一个网页,分别在windows下和linux下,本篇文章主要讲解Window下python+Apache+mod_wsgi+Django服务器配置过程中遇见的问题和解决方 ...

  4. Samba服务器配置

    Samba服务器配置流程: (1)安装samba服务器先用#rpm -ivh samba-列出与samba有关的rpm包然后选择第一个包,用tab键补齐文件名 (2)创建新用户和其密码#useradd ...

  5. 【原创】我所理解的自动更新-外网web服务器配置

    ClientDownload和ClientUpdate共享渠道配置信息: channel-0.php //以appstore的渠道为例 <?php define('APPNAME', 'TOKE ...

  6. iOS app 企业内部发布及HTTPS服务器配置

    转自: http://www.cnblogs.com/cocoajin/p/4082488.html iOS企业内部发布及HTTPS服务器配置 一:所需的条件 1. 苹果开发者证书,企业版 299$ ...

  7. django服务器配置

    服务器配置是Ubuntu14.04 64位OS ubuntu14.04默认是安装好了python2.7版本不用自己安装了. 先更新下源 sudo apt-get update 第一步先安装pip su ...

  8. "错误消息 401.2。: 未经授权: 服务器配置导致登录失败。"的解决办法

    [详细报错如下]: “/”应用程序中的服务器错误. 访问被拒绝. 说明: 访问服务此请求所需的资源时出错.服务器可能未配置为访问所请求的 URL. 错误消息 401.2.: 未经授权: 服务器配置导致 ...

  9. VS2012 asp.net mvc 4 运行项目提示:"错误消息 401.2。: 未经授权: 服务器配置导致登录失败"

    创建mvc4 应用程序发布,运行出错.出现未经授权: 服务器配置导致登录失败.请验证您是否有权基于您提供的凭,后来找得解决方法: 打开点站的web.confg文件,将: <authorizati ...

随机推荐

  1. Android Timer的应用示例

    package com.hyzhou.timerdemo1; import java.util.Timer; import java.util.TimerTask; import android.os ...

  2. UE4.16播放全景视频

    全景视频有两种:一种是常见的一帧画面里面包含一张全景图,另外一种是一帧画面里面包含了左眼和右眼两张全景图. 根据种类的不同,选择不同的材质分别对应MAT_Single_Image和MAT_Stereo ...

  3. 15个常用GCC命令

    GCC编译器非常强大 ,在各个发行的Linux系统中都非常流行,本文介绍的是一些常用的gcc编译选项 下面这段代码将回围绕整个文章: 编辑main.c如下. #include<stdio.h&g ...

  4. Oracle12cWindows安装、介绍及简单使用(图文)

    1.下载 地址为:http://www.oracle.com/technetwork/cn/database/enterprise-edition/downloads/index.html 含企业版和 ...

  5. MQTT协议笔记之mqtt.io项目Websocket协议支持

    前言 MQTT协议专注于网络.资源受限环境,建立之初不曾考虑WEB环境,倒也正常.虽然如此,但不代表它不适合HTML5环境. HTML5 Websocket是建立在TCP基础上的双通道通信,和TCP通 ...

  6. Java虚拟机原理图解

    具体详情参考: http://blog.csdn.net/luanlouis/article/details/41046443 http://blog.csdn.net/luanlouis/artic ...

  7. 封装JDBC工具类

    JDBC连接数据库基本的步骤是固定的,这样就可以考虑封装一个工具类来简化数据库操作. 封装时用到了Java中的properties配置文件,是以一种键值对的形式存在的,可以把连接数据库要动态的信息保存 ...

  8. Fatal error Using $this when not in object context in

    大致意思是 $this 没有上下文,原因是没有对此类进行实例化. 出现此错误的原因是:在FileCommand.php中使用 $this->方法/属性. $this 不是不可以用,而是要看情况用 ...

  9. 【Android】Android软件开发之ListView 详解

    原创作品,允许转载,转载时请务必以超链接形式标明文章 原始出处 .作者信息和本声明.否则将追究法律责任.http://xys289187120.blog.51cto.com/3361352/65717 ...

  10. angular -- 自定义指令和模板

    angular 可以自定义一些指令,来简化我们前端的工作量. 第一种:简单指令示例: <h3>自定义指令</h3> <sheng></sheng> &l ...