Linux:搭建samba服务器
samba服务器的搭建
修改防火墙设置
firewall-cmd --permanent --add-service=samba //设置防火墙
firewall-cmd --reload //重新加载防火墙
安装samba服务并启动samba服务
yum install -y samba samba-client //安装服务
systemctl start smb.service nmb.service //启动服务
建立共享目录
mkdir /home/company
创建访问账号
useradd -s /sbin/nologin xzusr
smbpasswd -a xzusr
选项说明:
-a 添加 smb 帐号;
-x 删除 smb 帐号;
-d 禁用 smb 帐号;
-e 启用 smb 帐号
修改配置文件
修改配置文件:/etc/samba/smb.conf
[company] //共享名称为 company
comment = company share//共享注释
path = /home/company //指定共享路径
browseable = yes //所有人可见
guest ok = no //拒绝匿名访问
writeable = yes //支持写入数据
valid users=xzusr,gcusr,xsusr //允许访问的用户列表
write list=xzusr //允许写入的用户列表
修改配置文件以后,必须重启服务(systemctl restart smb nmb)使更改生效
测试配置文件
testparm 当配置文件的语法出错时会给出提示,修改再次运行 testparm 测试
测试samba服务器
在 linux 客户端访问测试:smbclient -U smbuser //xxx.xxx.xxx.xxx/company
查看服务器的共享文件有哪些:smbclient -L xxx.xxx.xxx.xxx
查看 smbuser 用户可以访问的共享文件:smbclient -L xxx.xxx.xxx.xxx -U smbuser
匿名共享
1)创建共享目录:
[root@localhost home]# mkdir share
[root@localhost home]# echo 'hello,world!'>/home/share/hello.txt
2)修改配置文件
[root@localhost home]# vim /etc/samba/smb.conf
security=share
[share] 共享名
comment=Linux share 共享目录的注释、说明信息
path=/home/share 共享目录
public=yes 允许所有samba用户访问该共享目录
writable = yes
printable = no
write list = +staff
3)修改后重启samba服务
[root@localhost home]#service smb restart
4)在windows客户端测试访问:
开始--运行--\\xxx.xxx.xxx.xxx
此时发现可以看到共享文件,但无法查看其内容,这是由于samba服务器上的
selinux导致的,需要将selinux改为许可模式:
[root@localhost home]# setenforce 0
带身份验证的文件共享
(1)创建samb用户:
[root@localhost home]# useradd smbuser
[root@localhost home]# smbpasswd -a smbuser
New SMB password:
Retype new SMB password:
使用smbpasswd命令可以对samba用户进行管理,主要选项有:
-h 显示smbpasswd命令的帮助信息
-a 添加指定的samba用户
-d 禁用指定的samba用户
-e 启用指定的samba用户
-x 删除指定的samba用户
(2)修改配置文件
将global中的 security=share 改为:security=user
改完后需要重启smb服务
[root@localhost home]#service smb restart
(3)访问测试
在windows客户端:开始--运行--\\192.168.10.1
此时你会发现需要输入用户和密码进行验证。
如果利用smbuser用户连接共享文件后,你想用smbadmin用户连接共享文件时你会发现是直接连接的。这是因为windows访问时会缓存,用如下办法可解决此办法:
开始--运行--cmd--net use * /del--y
设置共享权限
所有用户都可以写入
(1)修改配置文件
[root@localhost home]# vim /etc/samba/smb.conf
[share]
comment=Linux share
path=/home/share
public=yes
writable=yes
(2)修改共享目录的权限:
[root@localhost home]#chmod 777 /home/share
setfacl -m u:nobody:rwx /home/share 访问控制列表ACL
setfacl -x
只有指定用户可以写入
[root@localhost home]# vim /etc/samba/smb.conf
[share]
comment=Linux share
path=/home/share
public=yes
write list=smbadmin
writable=yes表示所有用户都有写入权限
write list=smbadmin表示指定smbadmin用户有写入权限
如果要指定多个用户有写入权限,用户之间用,号隔开:write list=smbadmin,smbuser
只有指定用户可以访问
[root@localhost home]# vim /etc/samba/smb.conf
[share]
comment=Linux share
path=/home/share
valid users=smbuser,smbadmin
write list=smbadmin
允许/拒绝指定用户的访问
只允许在IP地址为x.x.x.x的客户端上访问teach共享目录
[tech]
comment=technet
path=/home/technet
writable=yes
hosts allow=x.x.x.x
允许地址段x.x.x.x/xx内的用户访问tech共享目录,IP地址为x.x.x.x的计算机除外
[tech]
Comment=technet
path=/home/technet
writable=yes
hosts allow=x.x.x.x EXCEPT x.x.x.x
teach(/home/tech),只有tech组的成员可以访问和写入权限
[tech]
Comment=technet
path=/home/technet
valid users=@tech
write list=@tech
Linux:搭建samba服务器的更多相关文章
- Android源码浅析(三)——Android AOSP 5.1.1源码的同步sync和编译make,搭建Samba服务器进行更便捷的烧录刷机
Android源码浅析(三)--Android AOSP 5.1.1源码的同步sync和编译make,搭建Samba服务器进行更便捷的烧录刷机 最近比较忙,而且又要维护自己的博客,视频和公众号,也就没 ...
- 使用Linux搭建FTP服务器实现文件共享
使用Linux搭建FTP服务器实现文件共享... ---------------- Linux中的文件共享:FTPVSFTPDVSFTPD虚拟用户 FTP可以用在Linux与Linux 和Window ...
- Linux 之 Samba服务器
Samba服务器 参考教程:[千峰教育] 一:Samba简介: 360百科: Samba是在Linux和UNIX系统上实现SMB协议的一个免费软件,由服务器及客户端程序构成. SMB(Server M ...
- Linux 搭建SVN 服务器(转)
一. SVN 简介 Subversion(SVN) 是一个开源的版本控制系統, 也就是说 Subversion 管理着随时间改变的数据. 这些数据放置在一个中央资料档案库 (repository) 中 ...
- 原 Linux搭建SVN 服务器2
原 Linux搭建SVN 服务器 发表于1年前(2014-08-05 17:55) 阅读(12257) | 评论(3) 31人收藏此文章, 我要收藏 赞3 摘要 Linux搭建SVN 服务器 目录 ...
- 原 Linux搭建SVN 服务器
原 Linux搭建SVN 服务器 发表于1年前(2014-08-05 17:55) 阅读(12257) | 评论(3) 31人收藏此文章, 我要收藏 赞3 摘要 Linux搭建SVN 服务器 目录 ...
- Linux搭建SVN 服务器
Linux搭建SVN 服务器 1 安装SVN 2 使用客户端连接 2.1 使用windows的客户端 2.2 使用Linux下的命令行 3 ...
- Linux搭建SVN 服务器(转)
转自:http://my.oschina.net/lionel45/blog/298305 Linux搭建SVN 服务器 作者: 沈小然 日期:2014年 8月 5日 1 安装 ...
- Linux 搭建SVN 服务器
一. SVN 简介 Subversion(SVN) 是一个开源的版本控制系統, 也就是说 Subversion 管理着随时间改变的数据. 这些数据放置在一个中央资料档案库 (repository) 中 ...
- Linux搭建SVN服务器(服务端)
Linux搭建SVN服务器(服务端) 1 安装SVN SVN客户端:TortoiseSVN,官网下载:https://tortoisesvn.net/downloads.html(客户端) # yum ...
随机推荐
- sap-abap 权限控制
FORM AUTH_CHECK . "工厂 LOOP AT S_WERKS. AUTHORITY-CHECK OBJECT 'M_BANF_WRK' ID 'WERKS' FIELD S_W ...
- tornado框架中redis使用
一.安装依赖 pip3 install tornado-redis 二.导入模块 import tornadoredis 三.创建redis对象 import tornadoredis CONNECT ...
- RSA加解密&RSA加验签详解
RSA 加密算法是目前最有影响力的 公钥加密算法,并且被普遍认为是目前 最优秀的公钥方案 之一.RSA 是第一个能同时用于 加密 和 数字签名 的算法,它能够 抵抗 到目前为止已知的 所有密码攻击,已 ...
- JQuery 实现多个checkbox 只选中一个
<!DOCTYPE HTML> <html> <head> <meta http-equiv="Content-Type" content ...
- windows系统搭建zookeeper
安装&配置 在apache的官方网站提供了好多镜像下载地址,然后找到对应的版本 下载地址: http://mirrors.cnnic.cn/apache/zookeeper/zookeeper ...
- python将字符串插入表中避免单双引号问题
调用pymysql.escape_string('向数据库插入的数据') 例如: import pymysql str = 'as"sdf' print(pymysql.escape_str ...
- 使用navicat连接只开放内网ip连接的数据库
无法通过Navicat来连接MySQL,比较常见的两种问题? 服务器上自己安装的MySQL数据库,且未开通外网登录账号 直接购买服务商的MySQL数据库不创建公网访问,只有内网访问 背景: 公司数 ...
- 一个简单的WebServer,socket+threading
一个简单的WebServer import socket import threading body = '<h1> web server </h1>' response_pa ...
- 洛谷 SP263 Period
洛谷 SP263 Period 题目描述 For each prefix of a given string S* with N* characters (each character has an ...
- xamarin调试android部署到模拟器错误记录:Deployment failed Mono.AndroidTools.InstallFailedException: Unexpected install output: Error: Could not access the Package Manager. Is the system running?
问题记录: 1.生成 ok. 2.昨天也是能部署到模拟器的. 但是今天部署的时候就报了这样的一个错误 Deployment failed Mono.AndroidTools.InstallFailed ...