最近,捣腾了一阵子在xp系统上安装ArcGIS Server10.0(下方均简称server),解决了一些初学者可能面临的problem,给大家贴出来,

希望能够给初学者一些有益的帮助。

我的系统环境:

  1. XP系统
  2. 已安装了VS2010(安装过了.net framework 4.0)
  3. 安装好了arcgis desktop 和engine以及AO sdk
  4. 同时,也安装了arcgis server 10.0(未正确安装,表现特征有:arcgis server菜单中没有arcgis server manager链接,无法在浏览器打开arcgis server manager)

以下是我的修复安装的基本流程:

1.卸载ArcGIS Server 10.0;

a)     卸载GIS Services(ps:需要关闭som和soc进程

b)     卸载web adf application;

2.安装xp系统的IIS;详细安装步骤,可以参考这里;(xp的iis安装包见文章最下方 XP系统IIS 5.1安装包

3.正常安装ArcGIS Server(详细安装说明见文章最下方 ArcGIS Server 10.0安装教程)

a)     安装GIS Services;

b)     GIS服务器安装后配置;

c)     手动系统配置;(添加arcgissom、本地账户到agsadmin、agsusers组)

d)     安装Web application;

e)     安装完成后,使用Server进行创建、发布和管理GIS服务,并可进行Web app 开发。(发布服务详细流程见文章最下方 Arcgis Server 10.0发布地图

另附:

Arcgis Server10.0 Error Collection(错误集锦):

1.登录ArcGIS server manager,出现“访问IIS元数据库失败”错误,如下:

访问 IIS 元数据库失败。

说明: 执行当前 Web 请求期间,出现未处理的异常。请检查堆栈跟踪信息,以了解有关该错误以及代码中导致错误的出处的详细信息。

异常详细信息: System.Web.Hosting.HostingEnvironmentException: 访问 IIS 元数据库失败。

用于运行 ASP.NET 的进程帐户必须具有对 IIS 元数据库( IIS://servername/W3SVC)的读访问权。有关如何修改元数据库权限的信息,请参见 http://support.microsoft.com/?kbid=267904

造成此问题多是因为我本机电脑先安装了.net framework,后装IIS ;

解决方法:
开始——程序——vs2010——vs tools——SDK 命令提示
输入:
aspnet_regiis -i,然后,单击回车键;

成功解决问题!
 
 
2.arcgis server10.0,使用arcgissom账户无法登录arcgis server manager,提示:必须以agsadmin的组成员的账户进行登录;
原因:
agsadmin组成的账户成员具有登录arcgis server manager的权限;
解决方法:
打开本地用户和组;选择计算机,右键属性,选择管理,打开计算机管理窗口,选择本地用户和组,双击打开组,如截图:
添加自己的管理员账户、arcgissom到agsadmin组中;
添加管理员账户、arcgissom、arcgiswebservices到agsusers组中;
 
再次使用arcgissom登录,发现能够成功了!
 
 
3.使用arcgis server manager,创建web application,发现以下问题——“Insufficient privilege,the current logged on user  does not have administrative access to the web server.”
如下图:
 
解决方法:
添加本地账户到administrators组中;
刷新server manager页面,可能出现下方的错误:
没关系,只需要你重启你的浏览器,最终如下图:
 
 
4.使用vs2010创建web mapping application,出现“连接到无法连接到asp.net development server”的错误
解决方法:
打开网址属性页,网站的目标Framework由4.0改为3.5
如下图:
最终,发布网站成功(arcgis server 不是很稳定,有时候发布的地图为空白的,有时候又不会,坑爹啊!!!):
 

一些参考资料(百度网盘):

ArcGIS Server 10.0安装教程

Arcgis Server 10.0发布地图

XP系统IIS 5.1安装包

arcgis server10.0的配置

欢迎转载,版权所有:博客园|ArcScofield

本文地址:http://www.cnblogs.com/ArcScofield/p/arcgisserver_installation_error.html

分享ArcGIS Server 10.0修复安装心得的更多相关文章

  1. ArcGIS Server 10.0 安装及使用完整攻略

    引言 ArcGIS Server 10.0在使用和安装的过程中,需要进行比较全面的学习,才能正确使用.缺乏正确的指引,用户很容易在安装及使用中遇到问题.所以笔者在此总结Server 10.0的安装及使 ...

  2. ArcGIS Server开发教程系列(1) Arcgis server 10.1 的安装

    本系列所使用的软件版本如下: Windows 7 X64 / Windows server 2008 X64 Arcgis for Desktop 10.1 Arcgis 10.1 for serve ...

  3. Arcgis Server 10.4.1 搭建集群环境

    1.准备工作 Arcgis Server 10.4.1  以及许可一枚 共享存储(通过UNC路径访问,如"\\server1\arcgisserver\") 服务器两台(虚拟机也可 ...

  4. 【149】ArcGIS Desktop 10.0 & Engine 10.0 安装及破解

    写在前面:可能会出现按照此方法无法破解的情况,那请确保您有将 ArcGIS 10.0 已经完全卸载干净,直接通过控制面板进行卸载的时候并不能将其卸载干净,需要进行更深层次的卸载,包括删除注册表,各种文 ...

  5. arcgis server 10.2安装后,忘记Manager的用户名和密码

    arcgis server 10.2安装完毕后,需要创建站点,创建站点时,填写管理站点的用户名和密码.自己不小心,创建完毕后,给忘记了用户名和密码.求助Esri,解决方法如下: (1)找到arcgis ...

  6. ArcGIS Server 10 Java 版的Rest服务的部署方法

    使用ArcGIS Server 10 Java版发布GIS服务,当使用ArcGIS Manager创建好服务后,然后打开“ArcGIS Services Directory”的链接时发现网页报出了找不 ...

  7. ArcGIS Server 10.1发布GP服务

    ArcGIS Server 10.1发布GP服务 ArcGIS Server 10.1发布GP服务确实更简单了,只是刚使用不怎么习惯.ArcGIS Server 10.1发布GP服务需要先在ArcCa ...

  8. Arcgis Server 10.2默认服务端口号修改方法

    本人安装Arcgis Server 10.2之后发布了一个地图服务,该服务默认使用的端口号是6080,本人使用的是教育网,使用教育网均能正常使用该服务,但是使用电信或者移动网络均不能正常访问该网站. ...

  9. ArcGIS Server 10.2 实战(二)动态修改要素数据的地理处理服务

    上一篇<ArcGIS Server 10.2 实战(一)Asp.net MVC与JSON数据妙用实现动态生成要素图层>介绍了如何用JSON转要素的地理处理服务,实现了动态创建点要素并加载到 ...

随机推荐

  1. [python学习篇][书籍学习][python standrad library][内建函数]之[all,any,basestring,isinstance,bin,bool,@classmethod,@staticmethod,cmp,enumerate

    Python 解释器内置了一些函数,它们总是可用的.这里将它们按字母表顺序列出.     Built-in Functions     abs() divmod() input() open() st ...

  2. Convolutional Networks for Image Semantic Segmentation

    本系列文章由 @yhl_leo 出品,转载请注明出处. 文章链接: http://blog.csdn.net/yhl_leo/article/details/52857657 把前段时间自己整理的一个 ...

  3. php中 ob_start()有什么作用

    <?php ob_start(); //开启缓冲区 echo "这是第一次输出内容!\n"; $ff[1] = ob_get_contents() ; //获取当前缓冲区内容 ...

  4. 刷题总结——date(ssoj)

    题目: 题目背景 SOURCE:NOIP2015-SHY-9 题目描述 小Y和小Z好不容易有机会相见啦,可是邪恶的小H却不想让他们相见.现在有一些城市,城市之间有双向路径相连,有路径相连的城市之间可以 ...

  5. java面试题之Thread类中的start()和run()方法有什么区别

    start()方法被用来启动新创建的线程,而且start()内部调用了run()方法, 区别: 当你调用run()方法的时候,只会是在原来的线程中调用,没有新的线程启动: start()方法才会启动新 ...

  6. linux jenkins安装(四)

    Jenkins是基于Java开发的一种持续集成工具,用于监控秩序重复的工作,包括:软件版本发布/测试的持续集成.外部调用执行工作的监控等. 1. Jenkins 下载 Jenkins 下载网址:htt ...

  7. No change while using CSS <form target="blank">

    I want to open another Window when I use <form> to request a query. So I used target="bla ...

  8. django无法同步数据库 Error loading MySQLdb module: No module named ‘MySQLdb‘

    最近在学习Python,打算先看两个在线教程,再在github上找几个开源的项目练习一下,在学到“被解放的姜戈”时遇到django同步数据库时无法执行的错误,记录一下. 错误现象: 执行python ...

  9. 需要打印真实尺寸大小等需求的,css的单位可以使用mm等做单位

    今天甲方那边改需求了,要求打印出来的尺寸是85mm/55mm的,开始还一直在网上找px和mm的相关换算,结果去w3c看了,竟然还有mm单位的, 在这里做个笔记

  10. spring boot-html和templates

    静态页面 spring boot项目只有src目录,没有webapp目录,会将静态访问(html/图片等)映射到其自动配置的静态目录,如下 /static /public /resources / ...