SQL SERVER 2012 AlwaysOn– 数据库层面 02
搭建 AlwaysOn 是件非常繁琐的工作,需要从两方面考虑,操作系统层面和数据库层面,AlwaysOn 非常依赖于操作系统,域控,群集,节点等概念;
DBA 不但要熟悉数据库也要熟悉操作系统的一些概念;否则理解的会不深刻,一旦AlwaysOn 出现故障,首先根据错误日志,来排查是操作系统问题还是数据库问题;
部署AlwaysOn 分三部分:
1,操作系统层面; https://www.cnblogs.com/lvzf/p/10565298.html
2,数据库层面; https://www.cnblogs.com/lvzf/p/10566598.html
3,维护AlwaysOn; https://www.cnblogs.com/lvzf/p/10569857.html
本篇文章详细介绍- 数据库层面的部署;
接上文 SQL SERVER 2012 AlwaysOn - 操作系统层面 01 下面开始对AlwaysOn 数据库层面的部署
1,搭建AlwaysOn - 可用性组
1.1 安装 SQLSERVER 2012( - sp2)
点击【全新 SQLSERVER 独立安装…….】不要点击【新的 SQLSERER 故障转移群集安
装 】做 AlwaysOn 可用性组 不需要 SQLSERER 群集





















安装 SP2 补丁包






1.2 配置 AlwaysOn
因为生产环境数据库较大,为了不影响业务运行,短时间内能创建 AlwaysOn , 我们采用备份+还原方式配置 AlwaysOn ;
各个节点担当的角色如下:
主: 192.168.140.124
辅同:192.168.140.128
辅异:192.168.140.129
启用 AlwaysOn 可用性组 (三个节点做同样的操作)

右键 SQLSERVER 服务 – 属性-AlwaysOn 高可用性 – 启用 AlwaysOn 可用性组 ;

- 重启 SQLSERER 服务(三个节点做同样的操作)
- AlwaysOn 初始化数据库
- DB124 创建数据库 Flow

- 完整备份数据库[Flow]
USE MASTER
GO
BACKUP DATABASE [Flow] TO DISK='E:\Backup\Flow_full_20160122.bak' WITH CHECKSUM,NOFORMAT,INIT,SKIP
GO
- 数据库[Flow]日志备份
USE MASTER
GO
BACKUP LOG [Flow] TO DISK='E:\BackupLog\FlowLog_1.bak'
GO
- 把完整备份和日志备份拷贝到 DB128,DB129 服务器;
- DB128,DB129 还原数据库[Flow];( 注意:NORECOVERY 模式,非常重要 )
USE [master]
GO
RESTORE DATABASE [Flow] FROM DISK = N'E:\Backup\Flow_full_20160122.bak' WITH FILE = 1, NORECOVERY, NOUNLOAD, STATS = 5
GO
- DB128,DB129 还原日志[UCardFlow];( 注意:NORECOVERY 模式,非常重要 )
USE MASTER
GO
RESTORE LOG [Flow] FROM DISK = N'E:\BackupLog\FlowLog_1.bak' WITH FILE = 1, NORECOVERY, NOUNLOAD, STATS = 10
GO

- 以 DB124 为主节点 创建 AlwaysOn
右键[AlwaysOn 高可用性] - 新建可用性组向导


点击 【下一步】,输入可用性组名称【FlowCluster】

点击【下一步】 选中 Flow 数据库

点击【下一步】添加副本,添加 DB128,DB129 副本

点击【端点】输入对应的 IP 地址

点击【备份首选项】 选中主副本


下一步,选中【仅联接】因为前期已经做完数据库初始化

下一步,出现警告(正在检查侦听器配置),不用理会,因为我们还没有配置侦听器;

下一步

点击【完成】
也可以点击【脚本】生成 SQL 脚本,下次利用脚本配置 AlwaysON 能快速完成

- 配置侦听器
DB124 – 可用性组侦听器-右键-添加侦听器
(因为我们前面没有配置侦听器,到这一步我们手动配置,其实道理一样)

输入侦听器 DNS 名称 DB150,端口 1433,IP 192.168.140.150

点击确定;
- 下图是整个 AODB 配置完成后 主服务器实例的情况;

查看 AlwaysOn 可用性组的详情
可用性组名称 – FlowCluster 右键 – 属性 如下图

我们是三个节点的 AlwaysOn ,其中 DB124 是主角色,DB128,DB129 是辅助角色
DB124 对外提供读写服务。DB128,DB129 对外提供只读服务,根据业务情况,选择具体
的只读服务器。其中 DB129 异步提交可以做为异地灾备服务器;

打开域控服务器 AD1074 DNS 记录,发现服务器 IP,以及群集,侦听器 IP 都记录在内

至此AlwaysOn 数据库层面配置完成;
部署AlwaysOn 分三部分:
1,操作系统层面; https://www.cnblogs.com/lvzf/p/10565298.html
2,数据库层面; https://www.cnblogs.com/lvzf/p/10566598.html
3,维护AlwaysOn; https://www.cnblogs.com/lvzf/p/10569857.html
SQL SERVER 2012 AlwaysOn– 数据库层面 02的更多相关文章
- SQL SERVER 2012 AlwaysOn - 操作系统层面 01
搭建 AlwaysOn 是件非常繁琐的工作,需要从两方面考虑,操作系统层面和数据库层面,AlwaysOn 非常依赖于操作系统,域控,群集,节点等概念: DBA 不但要熟悉数据库也要熟悉操作系统的一些概 ...
- SQL SERVER 2012 AlwaysOn - 维护篇 03
搭建 AlwaysOn 是件非常繁琐的工作,需要从两方面考虑,操作系统层面和数据库层面,AlwaysOn 非常依赖于操作系统,域控,群集,节点等概念: DBA 不但要熟悉数据库也要熟悉操作系统的一些概 ...
- SQL Server 2012 AlwaysOn集群配置指南
1. AlwaysOn介绍 AlwaysOn是SQL Server 2012提供的全新综合.灵活.高效经济的高可用性和灾难恢复解决方案.它整合了镜像和群集的功能,基于OS 故障转移群集(Windows ...
- 从0开始搭建SQL Server 2012 AlwaysOn 第三篇(安装数据,配置AlwaysOn)
这一篇是从0开始搭建SQL Server 2012 AlwaysOn 的第三篇,这一篇才真正开始搭建AlwaysOn,前两篇是为搭建AlwaysOn 做准备的 操作步骤: 1.安装SQL server ...
- SQL SERVER 2012 修改数据库默认位置不立即生效
今天修改SQL SERVER 2012的数据库默认位置:即数据文件.日志文件默认位置时遇到一个问题,单击"服务器属性"(Server Properties)--> 数据库设置 ...
- 从0开始搭建SQL Server 2012 AlwaysOn 第二篇(配置故障转移集群)
本篇主要讲配置Windows 故障转移集群及遇到的相关问题(坑),因为AlwaysOn是基于Windows的故障转移集群的 在讲解步骤之前需要了解一下故障转移集群仲裁配置 四种集群的仲裁配置: 1.多 ...
- 从0开始搭建SQL Server 2012 AlwaysOn 第一篇(AD域与DNS)
随着业务发展,公司需要提高数据安全与性能需求,所以需要对新技术预研(先采坑),做技术积累: 了解相关AlwaysOn 故障转移集群(热备),数据路由(ICX),Moebius(莫比斯数据路由) 决定测 ...
- 疑难杂症--SQL SERVER 2012下数据库内存异常回收
--=================================================================== --背景: 在一台SQL SERVER 2012 SP1(1 ...
- SQL Server 2012附加数据库时,错误提示如下:尝试打开或创建物理时,CREATE FILE 遇到操作系统错误 5(拒绝访问。)
错误提示:Create File遇到操作系统错误5(拒绝访问) 解决方案: 在所有程序-SQL Server 2012-"SQL Server 配置管理器",点击"SQL ...
随机推荐
- css基础系列
盒子模型 盒子模型的概念 高和宽的设置 边框的设置 内边距的设置 外边距的设置 盒子的计算 元素显示的方式 盒子模型: border边框,margin外边距,padding内部距,content内容, ...
- Variable SQLLOGDIR not found
昨天在一数据库(SQL Server 2008 R2 SP3)上部署了一个作业,今天早上收到告警邮件,作业执行报错"Unable to start execution of step 1 ( ...
- winfrom 图片裁剪 圆形头像
效果 核心代码 public Region DrawingCircle(Rectangle r) { GraphicsPath gp = new GraphicsPath(); gp.AddEllip ...
- 【Git之旅】2.Git对象
1.块(blob)对象 (1)文件的每一个版本表示为一个块 (2)二进制大对象(binary large object)的缩写,是计算机领域的常用术语,用来指代某些可以包含任意数据的变量或文件,同时其 ...
- Python:SQLMap源码精读—基于时间的盲注(time-based blind)
建议阅读 Time-Based Blind SQL Injection Attacks 基于时间的盲注(time-based blind) 测试应用是否存在SQL注入漏洞时,经常发现某一潜在的漏洞难以 ...
- qml demo分析(objectlistmodel-自定义qml数据)
一.效果展示 如图1所示,是一个ListView窗口,自定义了文本内容和项背景色. 图1 ListView 二.源码分析 代码比较简单,主要使用了QQmlContext类的setContextProp ...
- Java〜slf4日志框架的使用
slf4日志可以支持注解的方式开启它,然后在使用时直接使用占位符,而不需要手动拼接字符串,这点在性能上也做到了最好. 一 build.gradle依赖项 compileOnly('org.projec ...
- 使用 ASP.NET Core MVC 创建 Web API(二)
使用 ASP.NET Core MVC 创建 Web API 使用 ASP.NET Core MVC 创建 Web API(一) 六.添加数据库上下文 数据库上下文是使用Entity Framewor ...
- 什么是Servlet(原理,从访问到方法)
Servlet简介 Servlet是SUN公司提供的一门用于开发动态WEB资源的技术.SUN公司在其API中提供了一个Servlet接口,用户若想开发一个动态WEB资源(即开发一个Java程序向浏览器 ...
- 使用SSL安全证书和nginx配置将域名HTTPS化
一.在阿里云后台申请免费版证书: 二.在域名解析里面添加记录: 三.提交审核: 四.等待审核通过后,下载nginx证书: 五.按照文档修改nginx配置文件: https://help.aliyun. ...