elasticsearch服务安装采坑
笔者这里下载的elastic search,是5.3.0版本,下载地址:https://www.elastic.co/downloads/past-releases/elasticsearch-5-3-0。因为要做日志链路追踪。使用的
skywalking-collector.tar.gz,skywalking-web.tar.gz,skywalking-agent.tar.gz。对于版本有个依赖。
- 下载解压之后,直接启动也行,注册成windows服务也行。推荐注册windows服务。注册windows服务方法:打开cmd,进入你的elasticsearch解压目录,如下图:

但是我在启动的时候总是启动失败。日志如下:
[2017-11-30 13:36:52] [info] [ 9428] Commons Daemon procrun (1.0.15.0 32-bit) started
[2017-11-30 13:36:52] [info] [ 9428] Service elasticsearch-service-x86 name Elasticsearch 5.3.0 (elasticsearch-service-x86)
[2017-11-30 13:36:53] [info] [ 9428] Service 'elasticsearch-service-x86' installed
[2017-11-30 13:36:53] [info] [ 9428] Commons Daemon procrun finished
[2017-11-30 13:37:12] [info] [ 9272] Commons Daemon procrun (1.0.15.0 32-bit) started
[2017-11-30 13:37:12] [info] [ 9272] Starting service 'elasticsearch-service-x86' ...
[2017-11-30 13:37:12] [info] [10500] Commons Daemon procrun (1.0.15.0 32-bit) started
[2017-11-30 13:37:12] [info] [10500] Running 'elasticsearch-service-x86' Service...
[2017-11-30 13:37:13] [info] [ 7280] Starting service...
[2017-11-30 13:37:15] [error] [ 9272] Failed to start 'elasticsearch-service-x86' service
[2017-11-30 13:37:15] [error] [ 9272] 传递给系统调用的数据区域太小。
[2017-11-30 13:37:15] [info] [ 9272] Start service finished.根据日志的提示,修改了config/jvm.options配置里的jvm参数:
-Xms512m
-Xmx512m
他默认的是2g。
修改完之后,记得重启电脑。笔者就栽在这条路上……十分无奈。
可能我这也只是个例。如果你也遇到修改配置之后重启应用没有作用。可以考虑重启电脑。- 至于如何结合logstash、skywalking实现日志链路追踪。此处省略一万字,哈哈,笔者也只是刚接触
elasticsearch服务安装采坑的更多相关文章
- oracle11g数据库安装采坑记录
第一处坑: 解决方案: 原文:https://blog.csdn.net/yhj198927/article/details/49178279 1.打开oracle的"Net Manager ...
- Charles 抓包工具安装和采坑记录
Charles 抓包工具安装和采坑记录 网络抓包是解决网络问题的第一步,也是网络分析的基础.网络出现问题,第一步肯定是通过抓包工具进行路径分析,看哪一步出现异常.做网络爬虫,第一步就是通过抓包工具对目 ...
- elasticsearch安装踩坑记
ES的安装与启动时问题解决 环境: 系统环境:CentOS7 JDK:jdk-8u131-linux-x64.tar.gz 不可以通过Root用户来启动ES 通过上面的错误提示可以看出,can ...
- 安装memcached和elasticsearch服务并systemctl管理
[root@izbp18dv3a3metugyd02qxz bin]# rpm -qa | grep memcache [root@izbp18dv3a3metugyd02qxz bin]# yum ...
- Elasticsearch的安装入门
大纲: 一.简介 二.Logstash 三.Redis 四.Elasticsearch 五.Kinaba 一.简介 1.核心组成 ELK由Elasticsearch.Logstash和Kibana三部 ...
- Redis集群搭建采坑总结
背景 先澄清一下,整个过程问题都不是我解决的,我在里面就是起了个打酱油的角色.因为实际上我负责这个项目,整个过程也比较清楚.之前也跟具体负责的同事说过,等过段时间带他做做项目复盘.结果一直忙,之前做的 ...
- Cloudera Manager 5.9 和 CDH 5.9 离线安装指南及个人采坑填坑记
公司的CDH早就装好了,一直想自己装一个玩玩,最近组了台电脑,笔记本就淘汰下来了,加上之前的,一共3台,就在X宝上买了CPU和内存升级了下笔记本,就自己组了个集群. 话说,好想去捡垃圾,捡台8核16线 ...
- Hadoop环境搭建--Docker完全分布式部署Hadoop环境(菜鸟采坑吐血整理)
系统:Centos 7,内核版本3.10 本文介绍如何从0利用Docker搭建Hadoop环境,制作的镜像文件已经分享,也可以直接使用制作好的镜像文件. 一.宿主机准备工作 0.宿主机(Centos7 ...
- v8环境搭建采坑记录
项目组有把js接入C++服务求的需求,故开始了v8接入的工作,用了一天多时间,v8才在centos环境上成功安装,过程中踩了很多坑,下面将采坑过程记录如下: centos下编译安装v8: 查看ce ...
随机推荐
- update + join 多表操作
UPDATE vtiger_notificationcf as a INNER JOIN vtiger_crmentity as b ON a.notificationid = b.crmid SET ...
- [BJOI2018]双人猜数游戏
题解: 彻彻底底的思维题???还是挺难的.. 首先连样例解释都没给..没看题解搞了很久 大概就是 一个人要根据另一个人的决策来猜数 可以去看洛谷那篇题解的解释 然后我们用$f[A/B][i][j][k ...
- 一起学Hadoop——文件的上传、分发与打包
如果我们想把文件上传到Hadoop集群中,使用put命令即可.下面的语句是将本地文件上传到hadoop集群的/目录下. hadoop fs -put fruit.txt / 下面介绍通过脚本将文件 ...
- linux实现自动检测进程是否存活的脚本
可以在性能测试过程中.定期检测startAgent和nmon的状态 #!/bin/sh while true do pnmon=`ps aux | grep nmon | grep -v grep`; ...
- 系统环境变量(就是不需要切换目录,敲击“python”就可以进入编码器)
1.右击我的电脑,选择属性,选择“高级系统设置” 2.选择高级,选择环境变量 3.在系统变量中找到path,点击编辑.然后新建,将python的路径复制进去,点击确定.
- yii2上传七牛图片(超详细)
前期准备 1.在七牛注册账号https://portal.qiniu.com/signup/choice 2.创建空间https://portal.qiniu.com/bucket(记住存储空间名称和 ...
- js中的new Option默认选中
new Option("文本","值",true,true).后面两个true分别表示默认被选中和有效! //js默认选中 var sel = document ...
- windows安装Python虚拟环境
1.pip install virtualenv 安装virtualenv镜像 3.virtualenv scrapytest 新建virtualenv 4.cd到\scrapytest\Scrip ...
- Python 扫盲
yield使用浅析 菜鸟教程:http://www.runoob.com/w3cnote/python-yield-used-analysis.html #!/usr/bin/python # -*- ...
- Eclipse 无输出,但不报错
解决方法: 若界面中都没有console选项,则 工具栏 Window - Show View - Console Window - Preferences - Run/Debug - Console ...