安装mysql参考 网址https://blog.csdn.net/a774630093/article/details/79270080

本文更加详细。

1、先检查系统是否装有mysql

rpm -qa | grep mysql

这里返回空值,说明没有安装

这里执行安装命令是无效的,因为centos-7默认是Mariadb,所以执行以下命令只是更新Mariadb数据库

yum install mysql

删除可用

yum remove mysql

2、下载mysql的repo源(执行以下两个命令的目录可在任意自己指定的路径下)

# wget http://repo.mysql.com/mysql-community-release-el7-5.noarch.rpm

安装mysql-community-release-el7-5.noarch.rpm包

# sudo rpm -ivh mysql-community-release-el7-5.noarch.rpm

安装这个包后,会获得两个mysql的yum repo源:/etc/yum.repos.d/mysql-community.repo,/etc/yum.repos.d/mysql-community-source.repo。

3、安装mysql(在repos.d目录下执行)

# sudo yum install mysql-server

根据步骤安装就可以了,不过安装完成后,没有密码,需要重置密码。

安装后再次查看mysql

如果报错,内容含有

Error: Package: mysql-community-libs-5.6.35-2.el7.x86_64 (mysql56-community)
Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: mysql-community-server-5.6.35-2.el7.x86_64 (mysql56-community)
Requires: libc.so.6(GLIBC_2.17)(64bit)
Error: Package: mysql-community-server-5.6.35-2.el7.x86_64 (mysql56-community)
Requires: systemd
Error: Package: mysql-community-server-5.6.35-2.el7.x86_64 (mysql56-community)
Requires: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Error: Package: mysql-community-client-5.6.35-2.el7.x86_64 (mysql56-community)
Requires: libc.so.6(GLIBC_2.17)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

解决:

#yum install glibc.i686
# yum list libstdc++*

4、重置密码

重置密码前,首先要登录()

# mysql -u root

登录时有可能报这样的错:ERROR 2002 (HY000): Can’t connect to local MySQL server through socket ‘/var/lib/mysql/mysql.sock’ (2),原因是/var/lib/mysql的访问权限问题。下面的命令把/var/lib/mysql的拥有者改为当前用户:

# sudo chown -R openscanner:openscanner /var/lib/mysql(该命令在/var/lib下执行)

如果报chown: 无效的用户: "openscanner:openscanner"错误,更换命令,并用 ll 查看目录权限列表

chown root /var/lib/mysql/
ll(是英文字母)

附: 
① 更改文件拥有者 (chown ) 
[root@linux ~]# chown 账号名称 文件或目录 
② 改变文件的用户组用命令 chgrp 
[root@linux ~]# chgrp 组名 文件或目录 
③ 对于目录权限修改之后,默认只是修改当前级别的权限。如果子目录也要递归需要加R参数 
Chown -R : 进行递归,连同子目录下的所有文件、目录

接下来登录重置密码:(在/usr/bin目录下执行)

 mysql -u root -p
mysql > use mysql;
mysql > update user set password=password('123456') where user='root';
mysql > exit;

重启mysql服务后才生效 # service mysqld restart

必要时加入以下命令行,为root添加远程连接的能力。链接密码为 “root”(不包括双引号)

mysql> GRANT ALL PRIVILEGES ON *.* TO root@"%" IDENTIFIED BY "root";  
密码设置成功后,在/usr/bin目录下执行
create database 数据库;
>mysql -u root -p
>password:你设置的用户密码
然后执行以下命令
mysql>use yourdatabasename;
mysql>set names utf8;
mysql>source /tmp/database.sql;

至此mysql下载完成,也把数据库文件成功导入了你搭建的mysql中了。

可参考该网址:做其他数据表操作,(附:想查看数据表结构用DESC(注意DESC要大写) tablename(注意大小写与你创建的数据表名要一致))https://www.linuxidc.com/Linux/2016-10/136244.htm

6、查询数据库编码格式,确保是 UTF-8

show variables like "%char%";

需要修改编码格式为UTF-8,导入数据库sql的时候,请确保sql文件为utf8编码 
进入mysql命令行后 输入

set names utf8;

(测试数据库数据) 
再进入数据库 use test; 
在导入sql脚本 source test.sql;

7、开放3306端口号 
firewalld 防火墙(centos-7)运行命令,并重启:

firewall-cmd --zone=public --add-port=3306/tcp --permanent
firewall-cmd --reload

iptables 防火墙(centos6.5及其以前)运行命令

vim /etc/sysconfig/iptables

在文件内添加下面命令行,然后重启

-A INPUT -p tcp -m state --state NEW -m tcp --dport 3306 -j ACCEPT
# service iptables restart

外部链接访问效果(一般建立sql数据库和数据表,建议通过远程链接控制,直观易操作)

附:

出现“Warning: Using a password on the command line interface can be insecure.”的错误

第一种方法、修改数据库配置文件 
1、我们需要修改数据库配置文件,这个要看我们数据库的配置的,有些是在/etc/my.cnf,有些是/etc/my.conf

我们需要在[client]部分添加脚本:

socket=/var/lib/mysql/mysql.sock  ( mysql.sock 文件位置 )
host=localhost
user=数据库用户
password='数据库密码'
  • 1
  • 2
  • 3
  • 4
  • 1
  • 2
  • 3
  • 4

这里参数要修改成我们自己的。

2、采用命令导出和导入数据库 
其实在这个时候,我们如果采用”详解使用mysqldump命令备份还原MySQL数据用法整理http://www.laozuo.org/5047.html“介绍的方法也是可以使用的,虽然依旧有错误提示,但是数据库还是可以导出的。您肯定和老左一样是追求细节的人,一点点问题都不能有,但我们可以用下面的命令导出和导入,就没有错误提示。

导出数据库

mysqldump --defaults-extra-file=/etc/my.cnf database > database.sql
  • 1
  • 1

导入数据库

mysql --defaults-extra-file=/etc/my.cnf database < database.sql
  • 1
  • 1

这里我们可以看到上面的命令和以前常用的快速导入和导入命令有所不同了,需要加载我们配置的MYSQL配置文件,这个“/etc/my.cnf”要根据我们实际的路径修改。用这样的命令导出备份和导入是没有错误提示的。

登陆数据库

# mysql -u root -p
  • 1
  • 1

第二种方法、利用mysql_config_editor

1、设置加密模式

mysql_config_editor set --login-path=local --host=localhost --user=db_user --password
  • 1
  • 1

“db_user”是需要修改成我们自己数据库用户名的,回车之后会提示我们输入数据库密码,我们照样输入。

2、执行备份

mysqldump -u db_user -pInsecurePassword my_database | gzip > backup.tar.gz
  • 1
  • 1

-u db_user 
-p.InsecurePassword ( 中间的“.”记得去掉 )

根据我们数据信息修改用户和用户名和数据库密码,执行备份,这里老左测试还是有错误提示,但数据库是可以备份的。

修改MySQL的root用户的密码: 
mysql -u root mysql 
mysql>use mysql; 
mysql>desc user; 
mysql> GRANT ALL PRIVILEGES ON . TO root@”%” IDENTIFIED BY “root”;  //为root添加远程连接的能力。 
mysql>update user set Password = password(‘xxxxxx’) where User=’root’; 
mysql>select Host,User,Password from user where User=’root’; 
mysql>flush privileges; 
mysql>exit;

重新登录:mysql -u root -p 
delete from mysql.user where user=”;  ← 删除匿名用户 
select user,host from mysql.user;  ← 查看用户信息

mysql的配置文件所在目录https://www.cnblogs.com/xj2015/p/6826139.html

linux上安装mysql,亲试成功的更多相关文章

  1. 怎样在 Ubuntu Linux 上安装 MySQL

    本教程教你如何在基于 Ubuntu 的 Linux 发行版上安装 MySQL.对于首次使用的用户,你将会学习到如何验证你的安装和第一次怎样去连接 MySQL. -- Sergiu MySQL 是一个典 ...

  2. linux上安装 mysql

    一.linux 上安装 mysql 1.查看mysql是否安装 rpm -qa|grep mysql 2.卸载 mysql yum remove mysql mysql-server mysql-li ...

  3. linux上安装mysql,tomcat,jdk

    Linux 上安装 1 安装jdk 检测是否安装了jdk 运行 java –version 若有 需要将其卸载 a)         查看安装哪些jdk rmp –qa |grep java b)   ...

  4. 在linux上安装MySQL数据库,并简单设置用户密码,登录MySQL

    在新装的Centos系统上安装MySQL数据库. <p><a href="http://www.cnblogs.com/tijun/">提君博客原创< ...

  5. 亲测linux上安装mysql

    1.rpm -ivh MySQL-server-5.6.19-linux_glibc2.5.x86_64.rpm(这是复制过来的,用Tab键自动补齐吧)2.rpm -ivh MySQL-client- ...

  6. Linux上安装MySQL及其基础配置

    本文主要介绍Linux下使用yum安装MySQL,以及启动.登录和远程访问MySQL数据库. 1.安装 查看有没有安装过: yum list installed mysql* rpm -qa | gr ...

  7. Linux上安装mysql,实现主从复制

    MYSQL(mariadb) MariaDB数据库管理系统是MySQL的一个分支,主要由开源社区在维护,采用GPL授权许可.开发这个分支的原因之一是:甲骨文公司收购了MySQL后,有将MySQL闭源的 ...

  8. linux上安装mysql

    linux下mysql 最新版安装图解教程 1.查看当前安装的linux版本 命令:lsb_release -a 如下图所示 通过上图中的数据可以看出安装的版本为RedHat5.4,所以我们需要下载R ...

  9. Linux上安装Mysql+Apache+Php

    一.安装Mysql 1.卸载默认的mysql yum -y remove mysql-libs-* Removed:  mysql-libs.x86_64 0:5.1.73-3.el6_5 卸载成功 ...

随机推荐

  1. 关于The specified Android SDK Build Tools version (26.0.2) is ignored, as it is below the minimum...

    今天将项目迁移到另一台笔记本,进行build出现以下问题,导致build失败 The specified Android SDK Build Tools version (26.0.2) is ign ...

  2. 一脸懵逼学习Hive的安装(将sql语句翻译成MapReduce程序的一个工具)

    Hive只在一个节点上安装即可: 1.上传tar包:这个上传就不贴图了,贴一下上传后的,看一下虚拟机吧: 2.解压操作: [root@slaver3 hadoop]# tar -zxvf hive-0 ...

  3. [转]利用ssh传输文件

    利用ssh传输文件 http://www.cnblogs.com/jiangyao/archive/2011/01/26/1945570.html 在linux下一般用scp这个命令来通过ssh传输文 ...

  4. User模型扩展和自定义

    参考如下: django文档参考 django signal使用总结 django 信号注册 django信号问题1 django oneTooneFiled     1. django 自定义用户u ...

  5. BZOJ1799 self 同类分布 数位dp

    BZOJ1799self 同类分布 去博客园看该题解 题意 给出a,b,求出[a,b]中各位数字之和能整除原数的数的个数. [约束条件]1 ≤ a ≤ b ≤ 10^18 题解 1.所有的位数之和&l ...

  6. 三次Java实验整理汇报:

    *第一节 eclipse操作,建Javaproject项目(可直接用中文名命名)->建包与类(名字相同) ->public static void main(String[] args){ ...

  7. 045 Java中数据导入到excel

    程序有些参考,不过重要的是思路. 1.导入依赖 <dependencies> <!-- https://mvnrepository.com/artifact/org.apache.p ...

  8. 蓝桥杯 剪邮票(dfs枚举 + bfs)

    剪邮票 如图1, 有12张连在一起的12生肖的邮票.现在你要从中剪下5张来,要求必须是连着的.(仅仅连接一个角不算相连)比如,图2,图3中,粉红色所示部分就是合格的剪取. 请你计算,一共有多少种不同的 ...

  9. redis的主从机制 master&slave

    转载自:https://www.cnblogs.com/qwangxiao/p/9733480.html 一:master&slave的解释? master&slave就是主从复制,主 ...

  10. Web服务API

    Web服务API     内容 [ 隐藏 ]  1 概述 2个 services.php 3 详细教程 4 例子 5 另见 概观 Web服务API允许您将插件的功能(通常是外部函数)公开为Web服务. ...