Dynamics AX 2012 R2 安装额外的AOS
众所周知,AX系统分为三层:Client,Application Server,Database Server。
我们添加额外的Application Server主要是出于以下两个原因:
- 使用多台服务器,分担不同的角色(如批处理任务,报表,服务)。
- 增加基础架构的弹性。
AX中的集群服务器,并不依托于Windows服务器,而是通过自己的技术实现的。它可以提高性能,但没有提高可用性。当一台服务器挂了,客户端会失去连接,任何正在处理的任务都会被回滚。重启客户端后,会连接到集群中的另一台服务器。
下面,跟随Reinhard,安装额外的AOS吧。
1、安装额外的应用服务器
1.1、首先设置权限
- 在新应用服务器(MSDynAX_ApplicationServer)上,将你的Domain Account(MSDynAX\Reinhard)添加到本地管理员组。
- 将你的Domain Account(MSDynAX\Reinhard)添加为MSSQL的管理员。
这样权限就设置好了。
1.2、获取数据库信息
进入System administration>Inquiries>Database>Database Information。

这里我们可以得到Database Server的Database Name(MicrosoftDynamicsAX)和Database Server Name(MSDynAX_DatabaseServer)。
1.3、安装AOS
运行AX安装程序,选择Application Object Server(AOS),下一步。
输入刚刚获取到的Database Name(MicrosoftDynamicsAX)和Database Server Name(MSDynAX_DatabaseServer),下一步。

输入本AOS实例的名称和端口,保持默认即可,下一步。

设置AOS的运行账户。这里,我使用前面分配好权限的Domain Account:MSDynAX\Reinhard。下一步,开始安装。

安装完毕后,服务会自动运行,需要等几分钟。
1.4、配置客户端登陆参数
打开控制面板>管理工具>Microsoft Dynamics AX 2012 Configuration。
在配置中选择Original,点击Manage Button,选择Create configuration。

在弹出的窗口中,输入Configuration name:MSDynAX_ApplicationServer,点击OK。

点击编辑,输入咱们刚刚创建的实例名称,和服务器名。

点击确定,保存配置,退出配置工具。这样就设置好了。
打开客户端,进入System Administration>Common>User>Online Users,查看在线用户。

我们可以发现,在AOS Instance Name中,有一个叫做01@MSDynAX_ApplicationServer的。至此新的应用服务器已经可以使用。
Dynamics AX 2012 R2 安装额外的AOS的更多相关文章
- Dynamics AX 2012 R2 安装Reporting Services 扩展
今天Reinhard在VS中部署SSRS报表时,接到以下错误: 部署因错误而被取消.在报表服务器上,验证:-SQL Server Reporting Services 服务是否正在运行. 接着,Rei ...
- Dynamics AX 2012 R2 安装 AIF IIS上的Web服务
1.为什么使用IIS上的WEB服务 组件? 如果你要在Dynamics AX Service中使用HTTP Adapter,那么你就要安装IIS上的WEB服务 组件.HTTP Adapter会在IIS ...
- Dynamics AX 2012 R2 电子邮件广播错误 0x80040213
Dynamics AX 2012 R2 电子邮件广播错误 0x80040213 今天Reinhard在新环境做邮件广播测试时,发现无法发送邮件,并报以下错误: 类"CDO.Message&q ...
- Dynamics AX 2012 R2 如何处理运行时间较长的报表
当处理的数据量较多,逻辑比较复杂时,报表可能会超时.为了解决这个问题,Reinhard一直使用SrsReportDataProviderPreProcess来做预处理报表.它会在调用SSRS前,在AX ...
- Dynamics AX 2012 R2 业务系列
在之前的一系列博文里,Reinhard介绍了Dynamics AX Demo的安装与配置.相信同学们看完后,都已经成功拥有了一个测试环境. 众所周知的是,ERP作为一个特殊的软件系统,他有着背后的业务 ...
- Dynamics AX 2012 R2 业务系列-销售业务流程
在博文Dynamics AX R2 业务系列中,Reinhard对这个系列做了一个规划,下面我们就按照规划开始说业务吧. 1.销售的主要职责 其实这里说的职责主要是针对销售文员,并非整天外面满世界跑业 ...
- Dynamics AX 2012 R2 业务系列-采购业务流程
在博文Dynamics AX R2 业务系列中,Reinhard对这个系列做了一个规划,下面我们就按照规划开始说业务吧. 国际惯例,从采购开始. 1.采购的主要职责 简单点说,采购的主要职责,是从供应 ...
- Dynamics AX 2012 R2 创建一个专用的批处理服务器
安装额外AOS的另一原因,是要创建一个专用的Batch服务器. AOS实例在处理batch job时,会影响它的响应速度.安装一个专用Batch服务器,可以解决这个问题. 批处理服务器不能加到 ...
- Dynamics AX 2012 R2 创建一个带有负载均衡的服务器集群
安装额外AOS的主要目的,是将它添加到集群,或用于创建批处理服务器. 1.创建集群服务器 这里,Reinhard使用上节Install An Additional AOS 中创建的AOS,来创建集群. ...
随机推荐
- org.hibernate.hql.ast.QuerySyntaxException: XXX is not mapped
因为 String sql2 = "select s from Student s where s.clazz.name=:name"; 此处的 Student 应该为类名.hql ...
- KindEditor用法介绍
KindEditor是一套很方便的html编译器插件.在这里做一个简单的使用介绍. 首先在官网上下载最新的KindEditor文件(里面有jsp,asp等不同版本文件夹,可以删掉你不需要的版本), 把 ...
- jQuery设计思想之取值和赋值
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/ ...
- zk FileUpload(文件上传)
<button label="上传 Image" upload="true,maxsize=1073741824"> <attribute n ...
- ArcGIS AddIN异常之:object reference not set to an instance of an object
异常出现在 frmDownload frd = new frmDownload(); frd.ShowDialog(); 在ArcMap中能正常弹出窗体,点击按钮时显示此异常:object refer ...
- Mysql的实时同步 - 双机互备
设置方法: 步一设 A 服务服 (192.168.1.43) 上用户为 backup, 123456 , 同步的数据库为test; B 服务服 (192.168.1.23) 上用户为 root, 12 ...
- Maven3下的java web项目
咱们使用Maven3构建一个j2ee项目,项目的成果是一个war包,只需把它部署在服务器上,就可以使用浏览器访问. 具体详细信息 参考 http://www.mossle.com/docs/mave ...
- sort将文件的每一行作为一个单位按ASCII码值进行比较
1 sort的工作原理 sort将文件的每一行作为一个单位,相互比较,比较原则是从首字符向后,依次按ASCII码值进行比较,最后将他们按升序输出. [rocrocket@rocrocket progr ...
- 示例-创建表格-指定行列&删除表格的行和列
<body> <script type="text/javascript"> /* *上面的方法和你麻烦. *既然操作的是表格, *那么最方便的方式就是使用 ...
- P4行为模型BMV2依赖关系安装:thrift nanomsg nnpy安装
由于安装p4factory的步骤需要OF的支持,我需要下载p4的行为模型BMV2: thrift是支持BMV2的软件框架:nanomsg是一个实现了几种"可扩展协议"的高性能通信库 ...