Dynamics AX 2012 R2 安装 AIF IIS上的Web服务
1、为什么使用IIS上的WEB服务 组件?
如果你要在Dynamics AX Service中使用HTTP Adapter,那么你就要安装IIS上的WEB服务 组件。HTTP Adapter会在IIS中生成一个Web Service。
2、安装IIS上的WEB服务 组件
下面讲讲怎么安装IIS上的WEB服务 组件。在服务器上,启动AX安装程序,选择添加或修改组件,选中IIS上的Web服务,下一步安装。

安装完毕后,会在在AX的系统管理>服务和应用集成框架>网站 中,添加了一个站点,

并在服务器上IIS的默认站点下,添加一个名为MicrosoftDynamicsAXAif60的应用。

该应用的路径为C:\Program Files\Microsoft Dynamics AX\60\AifWebServices\,网址为http://host:port/MicrosoftDynamicsAXAif60/。
以后,AX的Web Service会安装到这里该路径和网址下。
3、修复MicrosoftDynamicsAXAif60
如果你在启用HTTP Adapter的AIF服务时,收到如下信息:
“The deployment web site was not found for port: XXXX”
3.1、那么有两种可能:
- 你当前的服务器没有安装IIS上的WEB服务 组件 。这种情况,可以参照上面的安装步骤进行安装。
- 如果运行AX安装程序,发现已经安装过该服务了,可能是安装被覆盖导致的。当你将没有安装IIS上的WEB服务 组件的备份数据,还原到已经安装IIS上的WEB服务 组件 的服务器时,就会造成IIS上的WEB服务 组件已经安装,但无法使用的情况。
3.2、以下是修复步骤:
安装 IIS上的WEB服务 组件。如果已经安装过,可以跳过。
确认IIS的默认站点中,已经建立 MicrosoftDynamicsAXAif60 应用。默认由安装程序建立,还原不会造成该应用被删除。
确认AX中系统管理>服务和应用集成框架>网站,添加好了MicrosoftDynamicsAXAif60站点。如果将没有安装IIS上的WEB服务 组件的备份数据,还原到已经安装IIS上的WEB服务 组件 的服务器时,会删除 MicrosoftDynamicsAXAif60 站点。如果没有该站点,那么就手工添加它。点击新建按钮,输入名称,虚拟路径(如“\\HostName\MicrosoftDynamicsAXAif60”),URL(“http://HostName:Port/MicrosoftDynamicsAXAif60”)。然后点击验证,如果提示成功,关闭窗口即可。
如果在启用HTTP Adapter的AIF服务时,依然报权限错误,那么要检查C:\Program Files\Microsoft Dynamics AX\60\AifWebServices\ 路径的权限。
需要确保该文件夹有以下三个权限:
- Microsoft Dynamics AX Web Service Administrators
- IIS_IUSRS
- NETWORK SERVICE

文件夹共享权限:
- Microsoft Dynamics AX Web Service Administrators
- Authenticated Users
- NETWORK SERVICE

Dynamics AX 2012 R2 安装 AIF IIS上的Web服务的更多相关文章
- Dynamics AX 2012 R2 安装Reporting Services 扩展
今天Reinhard在VS中部署SSRS报表时,接到以下错误: 部署因错误而被取消.在报表服务器上,验证:-SQL Server Reporting Services 服务是否正在运行. 接着,Rei ...
- Dynamics AX 2012 R2 安装额外的AOS
众所周知,AX系统分为三层:Client,Application Server,Database Server. 我们添加额外的Application Server主要是出于以下两个原因: 使用多台服 ...
- Dynamics AX 2012 R2 在AIF服务契约中使用DateTime
Reinhard在AIF中使用DateTime作为服务契约的参数,与DotNet程序进行交互时,总是因为时区的问题,导致DotNet提交的System.DateTime与AIF中接收的DateTime ...
- Dynamics AX 2012 R2 电子邮件广播错误 0x80040213
Dynamics AX 2012 R2 电子邮件广播错误 0x80040213 今天Reinhard在新环境做邮件广播测试时,发现无法发送邮件,并报以下错误: 类"CDO.Message&q ...
- Dynamics AX 2012 R2 如何处理运行时间较长的报表
当处理的数据量较多,逻辑比较复杂时,报表可能会超时.为了解决这个问题,Reinhard一直使用SrsReportDataProviderPreProcess来做预处理报表.它会在调用SSRS前,在AX ...
- Dynamics AX 2012 R2 业务系列
在之前的一系列博文里,Reinhard介绍了Dynamics AX Demo的安装与配置.相信同学们看完后,都已经成功拥有了一个测试环境. 众所周知的是,ERP作为一个特殊的软件系统,他有着背后的业务 ...
- Dynamics AX 2012 R2 业务系列-采购业务流程
在博文Dynamics AX R2 业务系列中,Reinhard对这个系列做了一个规划,下面我们就按照规划开始说业务吧. 国际惯例,从采购开始. 1.采购的主要职责 简单点说,采购的主要职责,是从供应 ...
- Dynamics AX 2012 R2 业务系列-销售业务流程
在博文Dynamics AX R2 业务系列中,Reinhard对这个系列做了一个规划,下面我们就按照规划开始说业务吧. 1.销售的主要职责 其实这里说的职责主要是针对销售文员,并非整天外面满世界跑业 ...
- Dynamics AX 2012 R2 报表部署权限错误
今天,Reinhard在 Deploy AX Reporting时,发生权限错误. 配置 ID: HOSTMSSQLSERVER 描述: HOST@MSSQLSERVER 默认值: True 报表服务 ...
随机推荐
- [LintCode] Left Pad 左填充
You know what, left pad is javascript package and referenced by React: Github link One day his autho ...
- android-数据存储之外部file存储(sdcard)
一.基础概要 1.说明: 1>应用程序运行用到的数据文件可以保存到sd卡中 2>文件类型:任意 3>数据保存路径: 路径1:/storage/sdcard/Android/data/ ...
- 运行WampServer时,提示Exception Exception in module wampmanager.exe at 000F15A0.解决办法
出现问题:运行WampServer时,提示Exception Exception in module wampmanager.exe at 000F15A0.解决办法 出现问题原因: ①:缺少Visu ...
- python随机服务器的双线出口ip发送邮件
#-*- coding:utf-8 -*-import smtplibimport sysimport random import socketfrom email.mime.text import ...
- 初探XML
1.XML是什么? XML 指可扩展标记语言(EXtensible Markup Language) XML 是一种标记语言,很类似 HTML XML 的设计宗旨是传输数据,而非显示数据 XML 标签 ...
- linux 查找命令
查找目录:find /(查找范围) -name '查找关键字' -type d查找文件:find /(查找范围) -name 查找关键字 -print
- JQ中的延迟对象deferred中的promise等的使用
一.什么是deferred对象? 开发网站的过程中,我们经常遇到某些耗时很长的javascript操作.其中,既有异步的操作(比如ajax读取服务器数据),也有同步的操作(比如遍历一个大型数组),它们 ...
- zepto源码--核心方法(类数组相关)--学习笔记
从这篇起,在没有介绍到各类插件之前,后面将陆续介绍zepto对外暴露的核心方法.即$.fn={}里面的所有方法的介绍.会配合zepto的API进行介绍. 其实前面已经介绍了几个,如width,heig ...
- NPOI操作excel之读取excel数据
NPOI 是 POI 项目的 .NET 版本.POI是一个开源的Java读写Excel.WORD等微软OLE2组件文档的项目. 一.下载引用 去NPOI官网http://npoi.codeplex. ...
- rndc控制远程dns服务器配置方法
1- 如果不存在/etc/rndc.conf touch /etc/rndc.conf chown named:named /etc/rndc.conf 2- rndc-confgen > /e ...