★ 欢迎来到〖护卫神·V课堂〗,网站地址:http://v.huweishen.com

★ 护卫神·V课堂 是护卫神旗下专业提供服务器教学视频的网站,每周更新视频。

★ 本节我们将带领大家:Serv-U安全设置

·本节接上一节“Serv-U安装配置”,故 Serv-U 已经安装配置好。

·Serv-U 默认是以系统服务运行,运行账户为 SYSTEM ,这样非常危险。需要降权并给予适当的读
写权限。

1、建立一个运行 Serv-U 的系统账户

1)新增一个用户,名为 ServU_HWS ;

2)设置用户 ServU_HWS 只属于 Guests 组 ;

2、设置 Serv-U 目录的权限

1)找到Serv-U执行目录(在系统服务里面获取,服务名默认为Serv-U);

给Serv-U执行目录目录 Administrators、SYSTEM "完全控制" 权限;给 Serv-U_HWS "完全

控制" 权限;

2)找到FTP文件存放目录(Serv-U的管理控制台里面获取);

给FTP文件存放目录 Administrators、SYSTEM "完全控制" 权限;Serv-U_HWS "列出文件夹

内容/读取/写入/删除" 权限;

(如有多个FTP文件存放目录,需要都添加上Serv-U_HWS "列出文件夹内容/读取/写入/删除"

权限;)

3、设置Serv-U服务

1)设置 Serv-U 服务启动帐户为 Serv-U_HWS ;

2)重启 Serv-U 服务;

4、测试结果

1)Serv-U 运行账户是 Serv-U_HWS ,成功降权;

2)FlashFXP连接测试

“读/写/删除”均正常;

5、其他防护办法

如果您的Serv-U不能降权,但又要解决安全问题;可以使用护卫神·防篡改系统(专业版)来

解决。

通过护卫神·防篡改系统(专业版)的“进程限制”模块,

设置Serv-U只能对Serv-U主目录和FTP目录有相关操作权限。

这样黑客就无法通过Serv-U入侵服务器了。

至此,本节已经结束,敬请访问护卫神网站(www.huweishen.com)获得更多教学视频。

转载请注明出处(http://v.huweishen.com/video/42.html)谢谢!

[Windows Server 2008] Serv-U安全设置的更多相关文章

  1. Windows Server 2008 R2常规安全设置及基本安全策略

    这篇文章主要介绍了Windows Web Server 2008 R2服务器简单安全设置,需要的朋友可以参考下 用的腾讯云最早选购的时候悲催的只有Windows Server 2008 R2的系统,原 ...

  2. Windows Server 2008 R2组策略设置计算机配置和用户配置

    一.认识Windows Server 2008 R2域控组策略管理 1.域控服务器zhuyu.com的组策略管理默认会读取AD用户和计算机目录下创建的OU容器(组织单元), 在对应的OU容器创建对应的 ...

  3. Windows Server 2008 Workstation Converter优化设置

    http://www.win2008workstation.com/windows-server-2008-workstation-converter/ If you don’t want to co ...

  4. Windows Server 2008 IIS 并发请求设置

    更新服务器的时候,突然发现部分机器出现了错误,大致描述如下 HTTP Error 503.2 - Service Unavailable 正在超过 serverRuntime@appConcurren ...

  5. [Windows Server 2008] Apache+PHP安全设置

    ★ 欢迎来到[护卫神·V课堂],网站地址:http://v.huweishen.com★ 护卫神·V课堂 是护卫神旗下专业提供服务器教学视频的网站,每周更新视频.★ 本节我们将带领大家:Win2008 ...

  6. 修改Windows Server 2008密码策略,设置简单密码

    最长使用期限为0表示密码永不过期. 如果是VBOX虚拟机安装,在使用共享文件夹功能时候,需要打开控制面板--网络和共享中心--共享设置--启动网络发现.然后才能映射共享文件夹

  7. Windows服务器安全加固实战(Windows Server 2008 R2和Windows Server 2012)

    最近我们立方技术工作室在使用阿里云的过程中,发现服务器安全性也不是很高,而服务端的安全软件都很贵.为了为朋友们提供更加有效的解决方案,我们决定身体力行,高筑墙,大幅度提升服务器的安全防护级别! 主机安 ...

  8. Windows Server 2008 R2 实现多用户同时登陆

    Windows Server 2008 R2远程用户数设置 在windows server 2008 R2里面,默认的远程桌面连接数为1.这对我们的服务器管理带来了很大的不便,那么怎样来修改2008 ...

  9. [转]WINDOWS服务器安全加固实战(WINDOWS SERVER 2008 R2和WINDOWS SERVER 2012)

    主机安全 启用防火墙 阿里云windows Server 2008 R2默认居然没有启用防火墙.2012可能也是这样的,不过这个一定要检查! 补丁更新 启用windows更新服务,设置为自动更新状态, ...

  10. Windows Server 2008 R2 小技巧 (转)

    一些 Windows Server 2008 R2 的小技巧,包括启用「God Mode (上帝模式)」.添加「快速启动」工具栏.启用桌面「个性化」服务.停用「密碼複雜性」要求,对老程序员熟悉新版的 ...

随机推荐

  1. 欧拉回路输出(DFS,不用回溯!)Watchcow POJ 2230

    Time Limit: 3000MS   Memory Limit: 65536K Total Submissions: 8109   Accepted: 3551   Special Judge D ...

  2. FreeMarker与Spring MVC 4结合错误:Caused by: java.lang.NoClassDefFoundError: org/springframework/ui/freemarker/FreeMarkerConfiguration

    添加spring-context-support的依赖到POM: <!-- spring-context-support --> <!-- https://mvnrepository ...

  3. NetCore发布WebApi项目到IIS服务器中

    1.确保已在机器上安装Net Core Runtime,,下载地址: https://dotnet.microsoft.com/download 2.点击WebApi项目右键->发布,选择IIS ...

  4. Centos: Screen tips

    Install yum install screen Useful screen commands List a particular users screen sessions: screen -l ...

  5. php 生成订单号

    最近在练手一个订单提交的小项目,需要用到生成订单号,网上找了下,觉得这个最好. function build_order_no(){ return date('Ymd').substr(implode ...

  6. QT如何修改字符编码格式

    编辑-Select Encoding,然后在弹出窗口中修改字符编码.                      

  7. 运行系统命令而且将输出写到指定日志文件的shell脚本(2)

    上一篇是个简单的能够运行而且写入日志的脚本,可是假设放到生产环境上就显得太粗糙了,所以须要进一步的优化: #! /bin/bash if [ -d "/opt/bmc" ] ; t ...

  8. go语言笔记——是c开发的 lex yacc进行词法和语法分析,go不支持函数和运算符重载,不支持类型继承,也不支持断言,还有泛型

    从 Go 1.0.3 版本开始,不再使用 8g,8l 之类的指令进行程序的构建,取而代之的是统一的 go build 和 go install 等命令,而这些指令会自动调用相关的编译器或链接器. 如果 ...

  9. la3713

    2-sat...求解2-sat方案直接每个变量枚举就行了,lrj的代码很靠谱... #include<bits/stdc++.h> using namespace std; ; struc ...

  10. springAOP注解方式定义切入点报错error at ::0 can't find referenced pointcut

    [说明] 1.使用spring版本:4.0.4 2.springAOP相关依赖包: 1)aopalliance-1.0.jar 2)aspectjweaver-1.8.9.jar 3)aspectjr ...