一、部署mysql5.7二进制版

解压tar -xvf

mv mysql-5.7  /usr/local/mysql5.7  或者其他文件夹

cd  /usr/local/mysql.57

useradd -s /sbin/nologin -M mysql

mkdir  -p /usr/local/mysql5.7/etc

启动初始化数据

bin/mysqld   --initialize  --basedir=/usr/local/mysql5.7  --datadir=/usr/local/mysql5.7/data

修改配置文件

chown –R mysql:mysql  /usr/local/mysql5.7

vim /usr/local/mysql5.7/etc/my.cnf

详见文件my.cnf

制作systemd启动MYSQL服务

vim /lib/systemd/system/mysqld.service ,详见文件

启动服务

systemctl start  mysqld

systemctl  enable  mysqld

更改环境变量

vim /etc/profile

export PATH=$PATH:/usr/local/mysql5.7/bin

source /etc/profile

进入mysql,第一次登录mysql,没有root密码,解决方式:

在/usr/local/mysql5.7/etc/my.cnf 中添加 skip-grant-tables 参数。此参数的作用是登录Mysql 数据库不进行用户密码验证。

[mysqld]

skip-grant-tables

保存my.cnf 后,重启msyql

systemctl restart mysqld

然后登录 mysql  -uroot

执行以下语句: 

update mysql.user set authentication_string=password('密码') where user='root';

flush privileges;

exit;

systemctl restart mysqld

mysql -uroot -p

Enter password:在这里输入刚才设置的密码,如果不成功或者提示密码过期需要修改密码,重新登录mysql

use mysql;

update user set password_expired='N' where user='root';

flush privileges;

重新登录,成功。

在my.cnf文件中的skip-grant-tables注释掉,systemctl restart mysqld

二、导入mysql5.6数据

创建授权账户grant all on *.* to '***'@'%' identified by '***';

flush privileges;

create database *** default character set utf8;

在导入sql数据时,会出现有的函数及过程不能导入的情况,在my.cnf文件的mysqld段加入log_bin_trust_function_creators=1,重启mysql导入成功。成功后注释掉该行。

对于外键限制,先行取消限制,导入后在开启限制

set FOREIGN_KEY_CHECKS=0;

执行sql导入或者用navigat导入,成功后执行Set FOREIGN_KEY_CHECKS=1

三、jboss/wildfly应用项目部署

1、 部署jboss/wildfly

解压,tar xvf ;  mv  /usr/local/jboss/wildfly

设置路径 vim /etc/profile,加 export

WILDFLY_HOME=/usr/local/wildfly;export PATH=$PATH:$WILDFLY_HOME/bin

source /etc/profile

2、更改配置

修改/usr/local/wildfly/standalone/configuration/standalone.xml

<interface name="management">

<inet-address value="${jboss.bind.address.management:0.0.0.0}"/>

</interface>

<interface name="public">

<inet-address value="${jboss.bind.address:0.0.0.0}"/>

更改默认端口,由8080改为80,也可以改为其他

<socket-binding name="http" port="${jboss.http.port:80}"/>

启动服务:standalone.sh,

3、配置数据源

由console管理wildfly添加数据源,提示add-user.sh,添加用户admin

登陆 本机ip:9990

添加driver:

step 1:下载好mysql-connector-java-5.1.47.jar

step 2: 登陆 本机ip:9990 选择 Runtime/Manage Deployments/add mysql-connector,名称为mysql,runname为mysql,然后save,再enable

step 3: 选 Configuration/Connctor/Datasources , 增加jndi数据源

name: ***,JNDI Name: java:jboss/datasources/***, Driver 为我们刚才导入的jar包的驱动:mysql_com.mysql.jdbc.Driver_5_1,connection url: jdbc:mysql://ip/数据库***,其中的IP地址为部署的数据库服务器的ip,username: ***,password:***,save之后enable,同时测试是否连接成功test connection,成功即为创建成功。

4、部署应用项目

编辑standalone.xml文件,在<subsystem xmlns="urn:jboss:domain:deployment-scanner:2.0">端内增加

<deployment-scanner name="项目名" path="项目所在路径" scan-enabled="true" scan-interval="5000" auto-deploy-zipped="true" auto-deploy-exploded="false" deployment-timeout="60"/>

在“项目所在的路径“目录下mkdir 项目名.war,touch 项目名.dodeploy ,把项目所有文件放入项目名.war目录下。

5.重新启动Jboss/wildfly

standalone.sh

四、错误及故障处理

1、ERROR [stderr] (XNIO-1 task-4) Wed Jan 09 15:19:57 CST 2019 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.

排除:在standalone.xml文件中修改

<connection-url>jdbc:mysql://ip地址/数据库名?useSSL=true</connection-url> 添加?useSSL=true

错误排除

2、启动jboss出现

Address "0.0.0.0" is a wildcard address, which will not match against any specific address. Do not use the 'inet-address' configuration elementto specify that an interface should use a wildcard address; use 'any-address', 'any-ipv4-address', or 'any-ipv6-address'

解决:在jboss/standalone/configuration/standlone.xml文件中改

<interface name="public">中inet-address为any-ipv4-address重启 jboss/bin/standlone.sh

3、登录应用项目,提示密码错误,无法登陆

经排查,为mysql5.6数据库升级为mysql5.7而出现的故障,需在my.cnf文件中加入sql_mode=,故障消除

4、应用项目查询特别慢问题

经排查为mysql5.6数据库升级为mysql5.7而出现的故障,需要关闭derived_merge,在mysql启动后执行

mysql -u*** -p***  -e  "set  GLOBAL optimizer_switch='derived_merge=off';"

重新进入应用项目,查询速度恢复正常。

5、配置jboss/wildfly数据源,因数据源超时问题的解决

Caused by: java.lang.RuntimeException: org.springframework.dao.RecoverableDataAccessException:
### Error querying database.  Cause: com.mysql.cj.jdbc.exceptions.CommunicationsException: The last packet successfully received from the server was 154,231 milliseconds ago.  The last packet sent successfully to the server was 154,231 milliseconds ago. is longer than the server configured value of 'wait_timeout'. You should consider either expiring and/or testing connection validity before use in your application, increasing the server configured values for client timeouts, or using the Connector/J connection property 'autoReconnect=true' to avoid this problem.

可以更改my.cnf文件中的

wait_timeout=2147483
interactive_timeout=2147483

将两个值改大,也不能改的太大。

重启mysql服务器,重启应用,问题解决。

mysql5.6升级为mysql5.7部署jboss/wildfly应用项目的更多相关文章

  1. mysql5.1升级到mysql5.6

    这么大跨度的升级,本身不推荐.升级应该是循序渐进的,以防止不兼容.如果确实要这么做,你先要确保你的客户端管理工具要能兼容,比如phpmyadmin,此次升级依然存在一个问题,mysql server和 ...

  2. Windows 10 将MySQL5.5升级为MySQL5.7

    最近想学习一下java.找到一个开源项目需要mysql5.7.11+ 升级 电脑上装的是MySQL 5.5,准备直接升级到最新版本的5.7,对于MySQL好像并没有直接升级到最新版本的功能,下载了Wi ...

  3. mysql5.x升级到mysql5.7后导入之前数据库date出错的快速解决方法【mysql低版本数据导入到高版本出错的解决方法】

    mysql5.x升级至mysql5.7后导入之前数据库date出错,这是由于MySQL的sql_mode的影响,解决方法如下所示: [具体参考:mysql的sql_mode详解]修改mysql5.7的 ...

  4. MySQL5.1升级5.6后,执行grant出错:ERROR 2013 (HY000): Lost connection to MySQL server during query【转载】

    转载: MySQL5.5升级5.6后,执行grant出错:ERROR 2013 (HY000): Lost connection to -mysql教程-数据库-壹聚教程网http://www.111 ...

  5. mysql5.6升级及mysql无密码登录

    mysql5.6升级 mysql5.6的升级可以分为以下几个步骤: 安全关闭正在运行的MySQL实例 把/usr/local/mysql 的连接由MySQL5.6更改为MySQL5.7 启动MySQL ...

  6. MySQL5.6.26升级到MySQL5.7.9实战方案【转】

    MySQL5.6.26升级到MySQL5.7.9实战方案 转自 MySQL5.6.26升级到MySQL5.7.9实战方案 - 其他网络技术 - 红黑联盟http://www.2cto.com/net/ ...

  7. 用Maven打包成EAR远程部署JBoss(二)——部署到远程JBoss

    用Maven打包成EAR远程部署JBoss(一)讲了如何使用Maven打包,可是在文章的最后也留下了一个问题,那就是如何将包部署到远程的JBoss中呢?近期在对之前的学习进行总结,发现少了这样一篇重要 ...

  8. centos6.5环境通达OA数据库mysql5.0.67升级至mysql5.5.48方案

    centos6.5环境通达OA数据库mysql5.0.67升级至mysql5.5.42方案 整体方案: 环境准备,在备用服务器安装mysql5.5数据库 1.停用生产环境的应用访问 直接修改web的访 ...

  9. JBoss/Wildfly 配置SQLserver服务器

    JBoss/Wildfly 配置SQLserver服务器 http://blog.csdn.net/haitaolang/article/details/60467118 wildfly standa ...

随机推荐

  1. 乘风破浪:LeetCode真题_016_3Sum Closest

    乘风破浪:LeetCode真题_016_3Sum Closest 一.前言      这一次,问题又升级了,寻找的是三个数之和最靠近的某个数,这是非常让人难以思考的,需要把三个数相加之后和最后给的目标 ...

  2. Excel课程表

  3. Android sdk manager 更新 5.0 太难了,终于解决

    由于众所周知的原因,必须在hosts中增加一些网址对应,才可以更新 203.208.46.146 www.google.com 203.208.46.1 plus.google.com 203.208 ...

  4. August 16th 2017 Week 33rd Wednesday

    A man can be destroyed but not defeated. 一个人可以被毁灭,但不能被打败. Before he was destroyed, he would have bee ...

  5. 008单例、继承、final

    内容:单例,类继承,final #################################################################################### ...

  6. Innodb_io_capacity 对于IO稳定性的一些研究

    背景:最近在做一台线上服务器IO负载情况的时候发现了以下现象: 24小时的IO_UTIL 的曲线看似风平浪静,毛刺较少 但当图片放大到半小时级别的时候发现IO_UTIL即磁盘使用率出现了规律性的波动, ...

  7. antlr-2.7.6.jar的作用

    项目中没有添加antlr-2.7.6.jar,hibernate不会执行hql语句 并且会报NoClassDefFoundError: antlr/ANTLRException错误

  8. c++ 派生类的构造函数次序

    #include <iostream> using namespace std; class CFatherSum //父类Sum { public: CFatherSum(int iRe ...

  9. 3109. [CQOI2013]新数独【DFS】

    Description Input 输入一共15行,包含一个新数独的实例.第奇数行包含左右方向的符号(<和>),第偶数行包含上下方向的符号(^和v).   Output 输出包含9行,每行 ...

  10. Python 模块化 import 语句介绍(一)

    用法: import 模块1[,模块2,模块3...] os 顶级模块os.path 非顶级模块as 相当于重命名 import 的本质: 解释器负责模块单独加载,单独初始化,生成一个模块对象,当前作 ...