最近在某客户的RHEL7 + 11204 RAC环境上测试遇到不少的坑,好在都赶在正式上线前及时发现并处理完毕。

其中两个问题比较典型所以特别记录下:问题都和主机重启后,O相关服务没有自启动导致,看来RHEL7安装11204RAC后一定要注意下主机重启后O相关服务是否可以自启动,而造成此现象的根本原因是RHEL7的服务管理机制有变化。

1.主机重启后,ohasd不会自启动

之前自己有一套测试环境也存在这个问题,但遗憾的是当时认为是自己用的测试环境就没有深究,每次主机重启都是直接按照`/etc/inittab`中的配置,手工启动`nohup /etc/init.d/init.ohasd run >/dev/null 2>&1

  • Install of Clusterware fails while running root.sh on OL7 - ohasd fails to start (Doc ID 1959008.1)
  • Patch 18370031: RC SCRIPTS (/ETC/RC.D/RC.* , /ETC/INIT.D/* ) ON OL7 FOR CLUSTERWARE
  • 根本解决方法:

    MOS提供的方案:

    Because Oracle Linux 7 (and Redhat 7) use systemd rather than initd for starting/restarting processes and runs them as a service the current > software install of both 11.2.0.4 & 12.1.0.1 will not succeed because the ohasd process does not start properly.

    In OL7 it needs to be set up as a service and patch fix for Bug 18370031 needs to be applied for this , BEFORE you run root.sh when prompted .

    Need to apply the patch 18370031 for 11.2.0.4 .

    也可以使用手工添加服务的方式配置ohasd服务自启动:

    cat /etc/systemd/system/oracle-ohasd.service

    # Copyright (c) 2014, Oracle and/or its affiliates. All rights reserved.
    #
    # Oracle OHASD startup [Unit]
    Description=Oracle High Availability Services
    After=syslog.target [Service]
    ExecStart=/etc/init.d/init.ohasd run >/dev/null 2>&1 </dev/null
    Type=simple
    Restart=always [Install]
    WantedBy=multi-user.target graphical.target

    文件权限建议为750,然后启动服务:

    systemctl enable oracle-ohasd.service

    我这里采用的是直接手工添加服务的方式。

    2.主机重启后,acfsload不会自启动

    还遇到一个acfs集群文件系统自动挂载的问题,同样类似的现象,主机重启后,对应的acfs无法自动挂载,而只重启集群就可以。说明问题还是在os重新启动,对应acfs存在相关服务没有启动成功。
    经过排查是acfsload没有自动启动,使用`acfsload start`手工启动后,正常可以挂载。
    手工虽然可以处理,但还是不符合自动挂载的需求,最终也是通过配置服务自启动的方式来实现acfsload在主机重启后自启动。

    根本解决方法:

    手工添加服务并配置服务自启动:

    cat /etc/systemd/system/oracle-acfsload.service

    #
    # Oracle ACFS Drivers
    #
    [Unit]
    Description=Load ACFS Drivers during boot
    After=syslog.target oracle-ohasd.service
    [Service]
    ExecStart=<GRID_HOME>/bin/acfsload start -s >/dev/null 2>&1 </dev/null
    Type=simple [Install]
    WantedBy=multi-user.target graphical.target

    注意<GRID_HOME>修改为你自己实际环境的,比如我这里是/opt/app/11.2.0/grid,文件权限建议为750,然后启动服务:

    systemctl enable oracle-acfsload.service

    RHEL7安装11204 RAC的注意事项的更多相关文章

    1. AIX 静默安装11gR2 RAC

      AIX安装11gR2  RAC   一.1  BLOG文档结构图       一.2  前言部分   一.2.1  导读和注意事项 各位技术爱好者,看完本文后,你可以掌握如下的技能,也可以学到一些其它 ...

    2. 基于CentOS与VmwareStation10搭建Oracle11G RAC 64集群环境:4.安装Oracle RAC FAQ-4.1.系统界面报错Gnome

      1.错误信息:登录系统后,屏幕弹出几个错误对话框,无菜单.无按钮 GConf error: Failed to contact configuration server; some possible ...

    3. 基于CentOS与VmwareStation10搭建Oracle11G RAC 64集群环境:4.安装Oracle RAC FAQ-4.6.重新配置与缷载11R2 Grid Infrastructure

      1.[root@linuxrac1 ~]# /u01/app/oraInventory/orainstRoot.sh 2.[root@linuxrac2 ~]# /u01/app/oraInvento ...

    4. 基于CentOS与VmwareStation10搭建Oracle11G RAC 64集群环境:4.安装Oracle RAC FAQ-4.5.安装Grid,创建ASM磁盘组空间不足

      因之前分区时,分区的Last cylinder的值选了“1”,导致创建磁盘组空间不足.解决办法是先删除分区,重新创建分区并删除ASM磁盘,然后重建ASM磁盘 1. 先删除分区,重新创建分区: 1)查询 ...

    5. 基于CentOS与VmwareStation10搭建Oracle11G RAC 64集群环境:4.安装Oracle RAC FAQ-4.4.无法图形化安装Grid Infrastructure

      无法图形化安装: [grid@linuxrac1 grid]$ ./runInstaller Starting Oracle Universal Installer... Checking Temp ...

    6. 基于CentOS与VmwareStation10搭建Oracle11G RAC 64集群环境:4.安装Oracle RAC FAQ-4.3.Oracle 集群节点间连通失败

      1.检查节点连通性的错误 [grid@linuxrac1 grid]$ ./runcluvfy.sh stage -post hwos -n linuxrac1,linuxrac2 -verbose ...

    7. 基于CentOS与VmwareStation10搭建Oracle11G RAC 64集群环境:4.安装Oracle RAC FAQ-4.2.Oracleasm Createdisk ASM磁盘失败:Instantiating disk: failed

      1.错误信息:Instantiating disk: failed [root@linuxrac1 /]# /usr/sbin/oracleasm createdisk OCR_VOTE /dev/s ...

    8. CentOS7/RHEL7安装Redis步骤详解

      CentOS7/RHEL7安装Redis步骤详解 CentOS7/RHEL7安装Redis还是头一次测试安装了,因为centos7升级之后与centos6有比较大的区别了,下面我们就一起来看看Cent ...

    9. OPENSTACK在RHEL7安装;admin创建虚拟机模板供demo使用

      版权声明:本文为博主原创文章,未经博主同意不得转载. https://blog.csdn.net/u010026901/article/details/30965601 首先RHEL7安装.导入镜像, ...

    10. 转:centos7/rhel7安装较高版本ruby2.2/2.3/2.4+

      centos7/rhel7安装较高版本ruby2.2/2.3/2.4+   环境需求:  在Centos7.3中,通过yum安装ruby的版本是2.0.0,但是如果有些应用需要高版本的ruby环境,比 ...

    随机推荐

    1. 创新推出 | Serverless 调试大杀器:端云联调

      背景 说起当前最火一个技术, 不可避免地讨论到一个概念: Serverless.作为一种新型的应用架构,Serverless 让我们摆脱了维护基础设施的繁琐,只需要上传代码包或者镜像, 即可得到一个弹 ...

    2. 四、redis增加密码验证

      系列导航 一.redis单例安装(linux) 二.redis主从环境搭建 三.redis集群搭建 四.redis增加密码验证 五.java操作redis 一.登录redis[root@minio4 ...

    3. Xmanager连接linux服务器的桌面

      在办公室使用xshell通过22端口访问linux服务器大家都很熟悉,但有的时候在办公室要远程linux服务器上的桌面应用,该如何实现. 环境准备 客户端:win10 服务器:centos7.9 一. ...

    4. C#爬虫知识介绍

      爬虫 爬虫(Web Crawler)是指使用程序自动获取互联网上的信息和数据的一种技术手段.它通常从一个起始网址出发,按照一定的规则递归地遍历网页,并将有用的信息提取出来,然后存储到本地或者数据库中, ...

    5. 04 Tcl字符串

      Tcl字符串 4.1 Tcl将说有的变量值视作字符串,并将他们作为字符串进行保存. 命令 描述 append 将值追加到字符串尾 binary 二进制化字符串 format 字符串格式化 regexp ...

    6. CSS : 使用 z-index 的前提

      使用 z-index 前  , 需要将元素 定位设置为  position : relative .

    7. [转帖]Oracle 创建和查看DBLink 的方法

      https://www.cnblogs.com/zhouzangood/articles/4612441.html 1.如果需要创建全局 DBLink,则需要先确定用户有创建 dblink 的权限: ...

    8. [转帖]jmeter之发送jdbc请求--06篇

      1.setup线程组中新建一个JDBC Connection Configuration配置元件 2.设置配置信息 Database URL:jdbc:mysql://127.0.0.1:3306/v ...

    9. [转帖]【JVM】Java内存区域与OOM

      引入 Java与C++之间有一堵由内存动态分配和垃圾收集技术所围成的"高墙",墙外面的人想进去,墙里面的人却想出来. Java虚拟机运行时数据区 如图所示 1.程序计数器(线程私有 ...

    10. [转帖]【k8s】5、资源管理命令-声明式

      文章目录 一. yaml和json介绍 1.yuml语言介绍 2.k8s支持的文件格式 3.yaml和json的主要区别 二.声明式对象管理 1.命令式对象配置 2.声明式对象配置 3.声明式对象管理 ...