1、

wget https://dev.mysql.com/get/Downloads/MySQL-5.7/mysql-5.7.25-linux-glibc2.12-x86_64.tar.gz

2、

yum install -y libaio

3、检查你所用的Linux下有没有安装过mysql,没有卸载干净

rpm -qa|grep -i mysql

如果存在,则需要先卸载掉,不然会出现覆盖错误。

yum remove mysql mysql-server mysql-libs mysql-server;
find / -name mysql 将找到的相关东西delete掉;
rpm -qa|grep mysql(查询出来的东东yum remove掉)

4、创建mysql的用户组/用户, data目录及其用户目录

mkdir -p /usr/local/mysql/data # mysql的默认安装路径,建议不要更换,如果更换后续需要更新配置 在mysql文件夹下创建文件夹data
useradd mysql # 创建一个名为mysql的用户组

5、解压缩并转移

# tar -xzvf mysql-5.7.17-linux-glibc2.5-x86_64.tar.gz # 解压文件
# cd mysql-5.7.17-linux-glibc2.5-x86_64 # 进入
# mv * /usr/local/mysql/

6、编译安装

cd /usr/local/mysql/

./bin/mysqld --user=mysql --basedir=/usr/local/mysql --datadir=/usr/local/mysql/data --initialize

记录上面成功安装后的密码,如上:hIE;k,h8gd#q,后续用到!

7、配置mysql

chown -R mysql.mysql /usr/local/mysql # 赋予权限

#进入mysql的安装目录支持文件目录
cd /usr/local/mysql/support-files

# 拷贝配置文件模板为新的mysql配置文件,
cp my-default.cnf /etc/my.cnf

#设置编码,可按需修改新的配置文件选项, 不修改配置选项, mysql则按默认配置参数运行.
#如下是我修改配置文件/etc/my.cnf, 设置编码为utf8以防乱码
vim /etc/my.cnf

[mysqld]

log-bin=mysql-bin

server-id=1
basedir = /usr/local/mysql
datadir = /usr/local/mysql/data

character_set_server=utf8
init_connect='SET NAMES utf8'

[client]
default-character-set=utf8

此处需要注释掉##sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES

否则后续登陆时会报异常:

mysql: [ERROR] unknown variable 'sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES'

8、启动mysql服务

/usr/local/mysql/support-files/mysql.server start

截至目前,证明mysql已运行成功!!!

9、配置mysql服务开机自动启动

# cp /usr/local/mysql/support-files/mysql.server /etc/init.d/mysqld # 拷贝启动文件到/etc/init.d/下并重命令为mysqld
# chmod 755 /etc/init.d/mysqld # 增加执行权限
# chkconfig --list mysqld # 检查自启动项列表中没有mysqld这个,
# chkconfig --add mysqld # 如果没有就添加mysqld:
# chkconfig mysqld on # 用这个命令设置开机启动:

10、mysql服务的启动/重启/停止

# systemctl start mysqld # 启动服务
# systemctl restart mysqld # 重启服务
# systemctl stop mysqld # 停止服务

11、修改mysql用户root的密码以及开放远程授权
ln -s /usr/local/mysql/bin/mysql /usr/bin #软链接到/usr/bin
mysql -u root -p
输入之前记录的密码,登陆mysql
SET PASSWORD = PASSWORD('123456'); # PASSWORD()里面的123456 是设置的新密码,可以设置成你的密码
ALTER USER 'root'@'localhost' PASSWORD EXPIRE NEVER;
flush privileges;
grant all privileges on *.* to 'root'@'localhost' identified by '123456'; #mysql远程授权

12、更改一些编码
use mysql;
\s #查看mysql信息
show variables like 'character%';
SET character_set_database = utf8;
show variables like 'character%';
\s

13、调整防火墙、开启3306端口:
vim /etc/sysconfig/iptables
-A INPUT -p tcp -m tcp --dport 3306 -j ACCEPT

systemctl restart iptables

至此,单机数据库就安装完成了,至于如何创建数据库,请自行查询文档.

PS:如果需要配置主从,请参照以上1-13步,在配置一台新的机器

主从配置

主配置文件修改:

mysql -u root -p #进入mysql
create user 'repl'@'slave_IP' IDENTIFIED BY 'repl'; #给slave创建可以同步数据的账号密码
GRANT REPLICATION SLAVE, REPLICATION CLIENT ON *.* TO 'repl'@'slave_IP' IDENTIFIED BY 'repl'; #给slave授权访问权限
flush privileges;
select user,host,authentication_string from mysql.user;
show master status\G;
获得File信息和Position信息,从库配置稍后需要使用

从库配置:
vim /etc/my.cnf

[mysqld]

log-bin=mysql-bin

server-id=2
basedir = /usr/local/mysql
datadir = /usr/local/mysql/data

character_set_server=utf8
init_connect='SET NAMES utf8'

[client]
default-character-set=utf8

重启从数据库

systemctl restart mysqld

mysql -u root -p #进入mysql
change master to master_host='1master_ip', master_user='repl', master_password='repl', master_port=3306, master_log_file='mysql-bin.000001', master_log_pos=1136, master_connect_retry=30;
start slave; #mysql-bin.000001就是主库的File信息,master_log_pos就是主库的Position信息
show slave status\G; #查看,如果没有报错,即代表成功,你就可以开始尝试在主库建表,看看从库是否有相同信息了。

如有报错:
检查master的状态:
show master status\G;
比对change master的master_log_file和master_log_pos是否和master一致,如果一致,执行以下命令:
stop slave;

reset slave;

start slave;

备份:

mysqldump -u root -p --databases choose test > roverliang.sql

./mysqlbinlog --no-defaults --database=jiashunc --start-datetime="2018-01-25 09:00:00" --stop-datetime="2018-01-26 10:40:00" --base64-output=decode-rows -vv ../data/mysql-bin.000005

l重置root密码:

# systemctl stop mysqld # 停止服务

# /usr/local/mysql/bin/mysqld_safe --skip-grant-tables &  #不检查权限的方式启动

#use mysql;

update mysql.user set authentication_string=password('Aa111111') where user='root' ;

# 然后退出,重启服务

# systemctl restart mysqld

mysql -u root -p
输入之前重置的密码,登陆mysql

mysql> use mysql; #会报如下错误
ERROR 1820 (HY000): You must reset your password using ALTER USER statement before executing this statement.

SET PASSWORD = PASSWORD('Aa111111'); #重新在设置一下密码即可.

mysql-5.7.25安装以及使用的更多相关文章

  1. Mac 下 Nginx、MySQL、PHP-FPM 的安装配置

    用了3年多的本本罢工,最近新入手了一台 rmbp,一堆工作环境要配置,LNMP 里的 NMP 是常规要安装的,恰好也是第一次在 mac 上安装配置 nginx.mysql.php,所以顺便做个记录,免 ...

  2. Ubuntu 15.04下MySQL 5.6.25不支持中文解决办法

    Ubuntu 15.04下MySQL 5.6.25不支持中文解决办法,apt-get install 安装的,不是源码包安装的mysql. 1 修改mysql的配置文件 /etc/mysql/conf ...

  3. CentOS下MySQL 5.7编译安装

    CentOS下MySQL 5.7编译安装   文章目录 安装依赖包 下载相应源码包 添加mysql用户 预编译 编译安装 启动脚本,设置开机自启动 /etc/my.cnf,仅供参考 初始化数据库 设置 ...

  4. resin4.0.25 安装配置 及结合eclipse开发

    resin4.0.25 安装配置 及结合eclipse开发 本文大部分内容是对官网的翻译,及自己配置后的一些体会. 一.  基于win  ,resin基本安装1,安装jdk1.6或更高版本2,配置环境 ...

  5. Mysql的资源(安装版+解压版)

    Mysql的安装(安装版+解压版)! 首先有几个比较好的参考,mysql官网,菜鸟教程: (1)安装版 安装版资源,SQLyog-8.32(sn)(可视化工具), 安装过程基本和安装其它程序没有什么大 ...

  6. Azkaban2.5安装部署(系统时区设置 + 安装和配置mysql + Azkaban Web Server 安装 + Azkaban Executor Server安装 + Azkaban web server插件安装 + Azkaban Executor Server 插件安装)(博主推荐)(五)

    Azkaban是什么?(一) Azkaban的功能特点(二) Azkaban的架构(三) Hadoop工作流引擎之Azkaban与Oozie对比(四) 不多说,直接上干货! http://www.cn ...

  7. MySQL 源码编译安装脚本

    cat mysql_init.shmysql_init.sh               mysql_init.sh.20190401      mysql_init.sh.back20171030  ...

  8. Dubbo入门到精通学习笔记(十九):MySQL源码编译安装、MySQL主从复制的配置

    文章目录 MySQL 源码编译安装(CentOS-6.6+MySQL-5.6) 一.服务器配置: 二.源码安装 MySQL5.6.26: MySQL主从复制的配置 环境 依赖课程 MySQL 主从复制 ...

  9. CentOS MySQL 5.7编译安装

    CentOS MySQL 5.7编译安装 MySQL 5.7 GA版本的发布,也就是说从现在开始5.7已经可以在生产环境中使用,有任何问题官方都将立刻修复. MySQL 5.7主要特性: 更好的性能: ...

  10. Linux下的 Mysql 8.0 yum 安装 并修改密码

    1.MySQL版本: mysql> select @@version;+-----------+| @@version |+-----------+| 8.0.18 |+-----------+ ...

随机推荐

  1. C语言博客作业04数组

    0.展示PTA总分 1.本章学习总结 1.1 学习内容总结 1.int a[10];为定义数组,表示数组有10个数 2.数组的下标都是从0开始,到n-1结束 3.数组里元素的个数不能大于数组的长度 4 ...

  2. 分享几个免费IP地址查询接口(API)

    淘宝IP地址库 提供的服务包括:1. 根据用户提供的IP地址,快速查询出该IP地址所在的地理信息和地理相关的信息,包括国家.省.市和运营商.2. 用户可以根据自己所在的位置和使用的IP地址更新我们的服 ...

  3. jsPDF生成pdf文件和中文编码

    jsPDF的简单使用以及中文编码问题的解决 文中js通过CDN引入,若是为了加载时间最好下载至本地. jsPDF的使用 jsPDF简介 jsPDF 是一个基于 HTML5 的客户端解决方案,用于在客户 ...

  4. SpringBoot 使用定时任务动态执行任务

    import com.patient.core.adapter.CorsFilter; import org.mybatis.spring.annotation.MapperScan; import ...

  5. ShiroFilterFactoryBean 找不到的原因

    是因为参考的那篇shiro的博客,没有引入这个依赖的原因 <dependency> <groupId>org.apache.shiro</groupId> < ...

  6. TCP 之 TCP首部

    TCP首部图 TCP首部说明 源端口,目的端口 用于寻找发送端和接收端应用进程.(源IP,源端口,目的IP,目的端口) 四元组确定唯一一个TCP连接:(IP,端口)也称为一个插口(socket): 序 ...

  7. QBXTD2上午

    话说lyd昨天没讲完他的该死的贪心,所以今天继续讲 贪心思想是考虑AB是最快的人,CD是最慢的人,要把CD两个人送过河,只有两种方案,牵扯到四个人,并且n个规模的原问题化成了n-2个规模的子问题 那么 ...

  8. 有关二次离线和 Yuno loves sqrt technology II

    二次离线 前置技能 莫队 修改查询 \(O(\sqrt n )-O(1)\) 平衡 概念 考虑朴素莫队离线询问,过程中维护信息从 \([l,r]\) 扩展为 \([l\pm 1,r\pm 1]\) , ...

  9. Error-ASP.NET:The Value of property CloneFrom can not be empty string!

    ylbtech-Error-ASP.NET:The Value of property CloneFrom can not be empty string! 1.返回顶部 1. “/”应用程序中的服务 ...

  10. MySQL 创建函数报错 This function has none of DETERMINISTIC, NO SQL, or READS SQL DATA in its declaration and binary logging is enabled (you *might* want to use the less safe log_bin_trust_function_creators

    问题描述 通过Navicat客户端,创建MySQL函数(根据的当前节点查询其左右叶子节点)时报错,报错信息如下: This function has none of DETERMINISTIC, NO ...