FastDFS 分布式文件系统搭建
- 安装依赖环境
yum install make cmake gcc gcc-c++ pcre-devel zlib-devel perl-devel - 安装libfastcommon-master.zip依赖
wget https://github.com/happyfish100/libfastcommon/archive/V1.0.36.tar.gz -O libfastcommon-master.tar.gz
mkdir -p /usr/local/fast/
tar -xf libfastcommon-master.tar.gz -C /usr/local/fast/
cd libfastcommon-1.0.36
./make.sh
./make.sh install
libfastcommon.so默认安装到了/usr/lib64/libfastcommon.so
而FastDFS主程序设置的lib目录是/usr/local/lib/
设置软连接
ln -s /usr/lib64/libfastcommon.so /usr/local/lib/libfastcommon.so
ln -s /usr/lib64/libfastcommon.so /usr/lib/libfastcommon.so
ln -s /usr/lib64/libfdfsclient.so /usr/local/lib/libfdfsclient.so
ln -s /usr/lib64/libfdfsclient.so /usr/lib/libfdfsclient.so - 安装Fastdfs
wget https://github.com/happyfish100/fastdfs/archive/V5.11.tar.gz -O FastDFS-5.1.1.tar.gz
tar -xf FastDFS-5.1.1.tar.gz -C /usr/local/fast/
cd fastdfs-5.11
./make.sh
./make.sh install - storage服务器配置(默认监听端口23000)
安装fastdfs-nginx-module
cd /usr/local/fast/
git clone https://github.com/happyfish100/fastdfs-nginx-module.git
通过nginx或openresty的安装包源目录编译安装
./configure --user=www --group=www --with-http_stub_status_module --with-http_flv_module --with-http_gzip_static_module --add-module=/usr/local/fast/fastdfs-nginx-module/src
./configure --add-module=/usr/local/fast/fastdfs-nginx-module/src
make
make install
### 报错处理
修改 fastdfs-nginx-module-1.20/src/config 文件,修改如下:
ngx_module_incs="/usr/include/fastdfs /usr/include/fastcommon/"
CORE_INCS="$CORE_INCS /usr/include/fastdfs /usr/include/fastcommon/"
然后重新 configure make make install,就可以了
storage配置文件修改
cd /etc/fdfs/
cp storage.conf.sample storage.conf
#### base_path=/fastdfs/FastDFSdata (这里的文件目录如果没有,要自己新建,不然会报错)
#### store_path0=/fastdfs/FastDFSdata (建议与bast_path一样)
#### tracker_server要改为自己的trakcer_server的ip
vim storage.confdisabled=false
group_name=group1
bind_addr=
client_bind=true
port=23000
connect_timeout=30
network_timeout=60
heart_beat_interval=30
stat_report_interval=60
base_path=/fastdfs/FastDFSdata
max_connections=256
buff_size = 256KB
accept_threads=1
work_threads=4
disk_rw_separated = true
disk_reader_threads = 1
disk_writer_threads = 1
sync_wait_msec=50
sync_interval=0
sync_start_time=00:00
sync_end_time=23:59
write_mark_file_freq=500
store_path_count=1
store_path0=/fastdfs/FastDFSdata
subdir_count_per_path=2
tracker_server=10.10.24.237:22122
#tracker_server=10.10.24.238:22122
log_level=info
allow_hosts=*
file_distribute_path_mode=0
file_distribute_rotate_count=100
fsync_after_written_bytes=0
sync_log_buff_interval=10
sync_binlog_buff_interval=10
sync_stat_file_interval=300
thread_stack_size=512KB
upload_priority=10
if_alias_prefix=
check_file_duplicate=0
file_signature_method=hash
key_namespace=FastDFS
keep_alive=0
use_access_log = false
rotate_access_log = false
access_log_rotate_time=00:00
rotate_error_log = false
error_log_rotate_time=00:00
rotate_access_log_size = 0
rotate_error_log_size = 0
log_file_keep_days = 0
file_sync_skip_invalid_record=false
use_connection_pool = false
connection_pool_max_idle_time = 3600
http.domain_name=
http.server_port=80storage.conf
复制配置文件
cp /usr/local/fast/fastdfs-nginx-module/src/mod_fastdfs.conf ./
cp /usr/local/fast/fastdfs-5.11/conf/http.conf ./
cp /usr/local/fast/fastdfs-5.11/conf/mime.types ./
mod_fastdfs.conf 配置
更改/etc/fdfs/mod_fastdfs.conf,增加"#include http.conf",必须加#号
vim /etc/fdfs/mod_fastdfs.confconnect_timeout=2
network_timeout=30
base_path=/fastdfs/FastDFSdata
load_fdfs_parameters_from_tracker=true
storage_sync_file_max_delay = 86400
use_storage_id = false
storage_ids_filename = storage_ids.conf
tracker_server=10.10.24.237:22122
#tracker_server=10.10.24.238:22122
storage_server_port=23000
group_name=group1
url_have_group_name = true
store_path_count=1
store_path0=/fastdfs/FastDFSdata
log_level=info
log_filename=/fastdfs/FastDFSdata/mod_fdfs.log
response_mode=proxy
if_alias_prefix=
#include http.conf
flv_support = true
flv_extension = flv
group_count = 0mod_fastdfs.conf
- tracker服务器配置(默认监听端口22122)
tracker配置文件修改
cd /etc/fdfs/
cp tracker.conf.sample tracker.conf
cp /usr/local/fast/fastdfs-5.11/conf/storage_ids.conf ./
vim tracker.confdisabled=false
bind_addr=
port=22122
connect_timeout=30
network_timeout=60
base_path=/fastdfs/FastDFSdata
max_connections=256
accept_threads=1
work_threads=4
store_lookup=2
store_group=group2
store_server=0
store_path=0
download_server=0
reserved_storage_space = 10%
log_level=info
allow_hosts=*
sync_log_buff_interval = 10
check_active_interval = 120
thread_stack_size = 64KB
storage_ip_changed_auto_adjust = true
storage_sync_file_max_delay = 86400
storage_sync_file_max_time = 300
use_trunk_file = false
slot_min_size = 256
slot_max_size = 16MB
trunk_file_size = 64MB
trunk_create_file_advance = false
trunk_create_file_time_base = 02:00
trunk_create_file_interval = 86400
trunk_create_file_space_threshold = 20G
trunk_init_check_occupying = false
trunk_init_reload_from_binlog = false
trunk_compress_binlog_min_interval = 0
use_storage_id = false
storage_ids_filename = storage_ids.conf
id_type_in_filename = ip
store_slave_file_use_link = false
rotate_error_log = false
error_log_rotate_time=00:00
rotate_error_log_size = 0
log_file_keep_days = 0
use_connection_pool = false
connection_pool_max_idle_time = 3600
http.server_port=8080
http.check_alive_interval=30
http.check_alive_type=tcp
http.check_alive_uri=/status.htmltracker.conf
storage_ids.conf 配置
vi storage_ids.conf
100001 group1 10.10.24.237
#100002 group1 10.10.24.238 - storage服务器nginx配置
touch /fastdfs/FastDFSdata/mod_fdfs.log
chmod 777 /fastdfs/FastDFSdata/mod_fdfs.log
添加nginx虚拟主机配置文件server {
listen 80;
server_name fastcdn.test.com;
access_log /data/logs/nginx/access_fastcdn.test.com_80.log main buffer=10k flush=5s;
error_log /data/logs/nginx/error_fastcdn.test.com_80.log crit;
location /group1/M00 {
alias /fastdfs/FastDFSdata/data;
ngx_fastdfs_module;
}
} - 启停服务
tracker: fdfs_trackerd /etc/fdfs/tracker.conf restart
tracker: fdfs_trackerd /etc/fdfs/tracker.conf stop
storage: fdfs_storaged /etc/fdfs/storage.conf restart
storage: fdfs_storaged /etc/fdfs/storage.conf stop
(storage机器) nginx: /etc/init.d/nginx restart - 功能测试
tracker 服务器
client.conf客户端配置:
cd /etc/fdfs/
cp client.conf.sample client.conf
vim client.confconnect_timeout=30
network_timeout=60
base_path=/fastdfs/FastDFSdata
tracker_server=10.10.24.237:22122
#tracker_server=10.10.24.238:22122
log_level=info
use_connection_pool = false
connection_pool_max_idle_time = 3600
load_fdfs_parameters_from_tracker=false
use_storage_id = false
storage_ids_filename = storage_ids.conf
http.tracker_server_port=80client.conf
文件上传:
cd /usr/local/fast
echo "fdfs">fdfs.txt
执行上传:
fdfs_test /etc/fdfs/client.conf upload fdfs.txt
文件下载:
通过提示的URL,打开网页直接下载 - 集群说明
节点增加
tracker :可以动态扩容增加,需要配置storage 配置中增加tracker IP及端口,并重载配置
storage : 动态添加,tracker 自动发现,文件会自动进行多节点同步
节点删除
tracker : 删除节点,需要同步修改storage配置
storage: 删除节点,tracker 会自动同步
备份策略
tracker:无数据,程序部分可通过多台实现互备
storage: 数据存储,有多台相互之间自动实现同步
分布式方案
tracker: 多台部署,避免单点故障
storage: 多台部署能够自动实现互备 - 安装php拓展
cd /usr/local/fast/fastdfs-5.11/php_client/
/usr/local/php7/bin/phpize
./configure --with-php-config=/usr/local/php7/bin/php-config
make
make install
/usr/local/php7/bin/php -m | grep fastdfs - 查看配置
fdfs_monitor /etc/fdfs/storage.conf
fdfs_monitor /etc/fdfs/client.conf
fdfs_file_info /etc/fdfs/client.conf group1/M00/01/01/rBLin109O96AewiGAADJ2ivPi74763.jpg
FastDFS 分布式文件系统搭建的更多相关文章
- 07.Linux系统-Fastdfs分布式文件系统-互为主从配置搭建部署
Fastdfs分布式文件系统-互为主从配置部署 1.安装基础依赖 yum install -y gcc gcc-c++ pcre pcre-devel zlib zlib-devel openssl ...
- FastDFS分布式文件系统
FastDFS分布式文件系统 阅读目录 相关文章 1 分布式文件系统介绍 2 系统架构介绍 3 FastDFS性能方案 4 Linux基本命令操作 5 安装VirtualBox虚拟机并配置Ubuntu ...
- CentOS7 安装FastDFS分布式文件系统
CentOS7 安装FastDFS分布式文件系统 最近要用到fastDFS,所以自己研究了一下,在搭建FastDFS的过程中遇到过很多的问题,为了能帮忙到以后搭建FastDFS的同学,少走弯路,与大家 ...
- FastDFS分布式⽂文件系统
FastDFS分布式⽂文件系统 1. 什么是FastDFS FastDFS 是⽤用 c 语⾔言编写的⼀一款开源的分布式⽂文件系统.FastDFS 为互联⽹网量量身定制, 充分考虑了了冗余备份.负载均 ...
- Spark环境搭建(一)-----------HDFS分布式文件系统搭建
下载的压缩文件放在~/software/ 解压安装在~/app/ 一:分布式文件系统搭建HDFS 1,下载Hadoop HDFS环境搭建 使用版本:hadoop-2.6.0-cdh5.7. ...
- FastDFS 分布式文件系统的安装与使用(单节点)
FastDFS 分布式文件系统的安装与使用(单节点) 跟踪服务器:192.168.4.121 (edu-dfs-tracker-01) 存储服务器:192.168.4.125 (edu-dfs-sto ...
- 使用Webupload上传图片到FastDFS分布式文件系统
使用Webupload插件上传图片到FastDFS分布式文件系统. 前提条件:1.已安装FastDFS分布式文件系统 2.使用webuploader插件上传文件 3.maven工程已引入FastDFS ...
- FastDFS 分布式文件系统部署实战及基本使用
FastDFS 分布式文件系统部署实战及基本使用 作者:尹正杰 版权声明:原创作品,谢绝转载!否则将追究法律责任. FastDFS是一个开源的高性能分布式文件系统.它的主要功能包括:文件存储,文件同步 ...
- django中使用FastDFS分布式文件系统接口代码实现文件上传、下载、更新、删除
运维使用docker部署好之后FastDFS分布式文件系统之后,提供给我接口如下: fastdfs tracker 192.168.1.216 192.168.1.217 storage 192.16 ...
随机推荐
- 如何打开iPhone 中的heic格式照片
苹果手机拍出来的heic照片相比常见的格式占存更小,但是在安卓和电脑上这种格式无法直接查看,那怎么在电脑上查看呢,需要将其转换格式就可以查看,关于如何打开iPhone 中的heic格式照片,下面即将为 ...
- Dynamics 365-Full Text Index on Stopwords
之前写了一篇关于Online Relevance Search的博文,然后又看到罗勇大神关于Full Text Index的博文:Dynamics CRM中一个查找字段引发的[血案],于是准备写点关于 ...
- 通过Arcpy在ArcMap工具箱中添加脚本计算面图层的起终点坐标
关键词: Arcpy,ArcMap Toolbox, Coordinates of Polygon 需求分析: Arcmap中添加有三个图层:图层“GY乡级河道”(面图层)是全县13个乡镇全部的乡级河 ...
- Xamarin 打包生成 Android apk 文件
Visual Studio 支持 apk 发布 Xamarin.Forms项目或Xamarin.Android项目开发完成之后需要发布.比较常规的发布方式是生成 apk 文件,微软也考虑到开发者有发布 ...
- Kotlin入门(33)运用扩展属性
进行App开发的时候,使用震动器要在AndroidManifest.xml中加上如下权限: <!-- 震动 --> <uses-permission android:name=&qu ...
- 【已解决】报异常:java.lang.ArithmeticException: / by zero
异常名称如下:java.lang.ArithmeticException: / by zero 原因:当我们定义的被除数为整形时候(short int long)会抛出此异常,被除数为整形时不可以 ...
- android Q build 变化
一 概述 android Q build变化整体上越来越严格,语法上之前能够使用的Q上将不能使用. 二 主要变化 2.1 'USER' 弃用 ‘USER’后面的值会被设置成‘nobody',andr ...
- Django 在Django项目里单独运行某个py文件
Python文件开头写以下代码: import os import django # 在environ字典里设置默认Django环境,'xxxx.settings'指Django项目的配置文件 os. ...
- eclipse开发创建web项目
1.打开eclipse,界面如下: 2.首先配置tomcat,操作:Windows--->perferences 如下: 3.操作:server--->Runtime Environmen ...
- asp.net core 2.1 部署 centos7
asp.net core 2.1 部署 centos7 Kestrel 非常适合从 ASP.NET Core 提供动态内容. 但是,Web 服务功能不像服务器(如 IIS.Apache 或 Nginx ...