原文:http://blog.51cto.com/asd9577/1931442

https://www.cnblogs.com/zhangzeyu/p/6379754.html-------CentOS 7进入救援模式的方法

有时候大家可能会忘记自己的root密码,或者错误(命令输入错误,命令位置输入有误等)编辑了一个/etc目录下的核心文件导致系统不能正常启动了!怎么办?重新安装系统那是实在没有办法之举!那我们就进入如下两种方式把错误的配置文件改过来,重启系统不就好了吗!接下来咱们就学习一下两种模式恢复系统Lunix单用户模式+救援模式

单用户模式+救援模式类似windows的安全模式

使用虚拟机在系统里面输入指令重启系统是不能达到我们的要求的,也就是说IDC机房可不是想进就进去的。而且里面有很严格的管理制度,安全性很高。怎么办呢?一般只要你需要使用单用户模式,必须要让当地的驻场工程师帮你重启服务器!所以我们使用Vmware来模拟一下:

进入此界面后,上下晃动鼠标,输入“e”进入GRUB页面!

进入后,找到linux16 开头的一行!按向右的方向键,定位到ro 然后修改ro为rw,并添加如下红框内的命令行!

使用下面的提示使用“Ctrl-x”start!!!

进入系统后,其实只是进入了一个安全模式下的内存系统,并不是真正的咱们正常使用的linux系统,

当我们输入命令

#ls /sysroot/ 下才是我们正常的系统里面的文件!
 

使用命令

#chroot /sysroot/ 切换到正常系统中去!
 

现在我们就可以更改root的密码了!

#passwd root
 

就可以修改密码了(如果linux系统是中文的会出现乱码,使用  "#LANG=en"  即可)。

注意一定要在修改完密码后,输入

#touch /.autorelabel
 

不然会导致系统无法正常登陆!

这样就完成了,

重新启动即可!!!

下面我要分享一下因为个人的粗心大意,导致系统不可以正常启动,这要是真正的IDC机房,可就不好整了!所以建议大家,一定要仔细!三思而后行!!!

其实我是想永久关闭selinux防火墙,如下图:

我直接修改SELINUXTYPE=disabled了,所以导致开机不可以正常启动了!

修改方法就是如上所讲的单用户模式进入修改即可!!!

救援模式

 

CentOS 7 与6不同之处就是 2 3 4的运行级别全部都是多用户模式

使用如下命令查看:

#ls -l /usr/lib/systemd/system/runlevel*target
 

首先我们关闭系统(init 0 OR poweroff),点击虚拟机标签,启动时进入BIOS:

然后通过上下箭头调节CD-ROM至第一启动项,按F10保存:

然后咱们的虚拟机就会开机进入光盘(是不是很熟悉的界面,首次安装linux时的界面),移动到第三项 Troubleshooting

选择救援模式--Rescue a CentOS Linux system:

出现如下界面再次输入 1 回车

继续回车

然后就真正到了救援模式的系统,但是和单用户模式一样的是,这不是我们真正的linux运行系统,查看文件之类的首先我们需要输入:

#chroot /mnt/sysimage
 

然后下面我们就可以查看系统内的文件或者直接修改密码或者重新修改/etc目录下的配置文件即可!

然后我们再次点击编辑咱们的虚拟机,把DVD设备状态断开如下所示,或者进入BIOS恢复启动即可!

至此两种修复系统的方法就结束了!

(转)CentOS 7 单用户模式+救援模式的更多相关文章

  1. Linux学习总结(四)-两种模式修复系统,单用户,救援模式

    一单用户模式 我们举例,比如忘记root 用户密码我们就可以进入单用户模式重置,该单用户模式,类似windos 安全模式开机界面快速按e 进入grub光标定位到 linux16 下一行ro crash ...

  2. CentOS 7 单用户模式+救援模式

    CentOS 7 单用户模式+救援模式 CentOS 7 单用户模式+救援模式.有时候大家可能会忘记自己的root密码,或者错误(命令输入错误,命令位置输入有误等)编辑了一个/etc目录下的核心文件导 ...

  3. centos单用户 救援 运行级别 yum,单用户模式,救援模式,inittab :启动级别 e2fsck wetty mingetty 物理终端 /dev/console 虚拟终端 /dev/tty(0,6) 模拟终端 /dev/pts/# grub-md5-crypt 给grub加密码 initrd 第二节课

    centos单用户 救援 运行级别  yum,单用户模式,救援模式,inittab :启动级别  e2fsck  wetty  mingetty  物理终端 /dev/console  虚拟终端 /d ...

  4. Windows 2008 关闭远程桌面的单用户多会话模式

    Windows 2008 关闭远程桌面的单用户多会话模式 在腾讯云上购买了一台云服务器. 因为设置了自动登录,在远程桌面连接后会启动一个新的会话,然后软件被运行了两次,端口被占用,无法起动. 还有可能 ...

  5. SQLSERVER数据库置疑、可疑、脱机、单用户、紧急模式等的修复

    数据库出现置疑.可疑.脱机.单用户.紧急模式主要是因为数据库的日志文件除了问题,2000和2008修复方式不一样,2008的修复脚本在2000中不适用,主要是不被2000识别. 假设数据库名为:eis ...

  6. Linux系统CentOS进入单用户模式和救援模式详解

    一.概述 目前在运维日常工作中,经常会遇到服务器异常断电.忘记root密码.系统引导文件损坏无法进入系统等等操作系统层面的问题,给运维带来诸多不便,现将上述现象的解决方法和大家分享一下,本次主要以Ce ...

  7. 单用户模式&救援模式&克隆虚拟机&Linux机器相互登录

    1.13 单用户模式 1.14 救援模式 1.15 克隆虚拟机 1.16 Linux机器相互登录 1.单用户模式 关机:init 0 .poweroff 重启:init 6 .reboot 关机:in ...

  8. CentOS 7单用户模式修改root密码

    CentOS 7的单用户模式和6.5稍有不同 把ro改成 "rw init=/sysroot/bin/sh". 完成之后按 "Ctrl+x" chroot /s ...

  9. CentOS 7 单用户模式修改root密码

    1)在启动grub菜单,选择编辑选项启动 2)按键盘e键,来进入编辑界面 3)找到Linux 16的那一行,将ro改为rw init=/sysroot/bin/sh 4)现在按下Control+x,使 ...

随机推荐

  1. 2018.07.06 POJ1273 Drainage Ditches(最大流)

    Drainage Ditches Time Limit: 1000MS Memory Limit: 10000K Description Every time it rains on Farmer J ...

  2. ABP框架系列之七:(About-关于ABP)

    Considerations Source codes Contributors Contact ASP.NET Boilerplate is designed to help us to devel ...

  3. 今天研究了一下手机通信录管理系统(C语言)

    题目:手机通信录管理系统 一.题目要求 二.需求分析 三.设计步骤/编写代码 四.上机/运行结果 五.总结 一.题目要求 模拟手机通信录管理系统,实现对手机中的通信录进行管理操作.功能要求: (1)查 ...

  4. yum 报错:centos yum (28, 'Connection time-out') Trying other mirror.

    前言: 在使用yum安装 软件时,经常出现 centos yum (28, 'Connection time-out') Trying other mirror. 或下面的那样情况imeout on ...

  5. MySQL外键使用及说明详解

    一.外键约束 MySQL通过外键约束来保证表与表之间的数据的完整性和准确性. 外键的使用条件: 1.两个表必须是InnoDB表,MyISAM表暂时不支持外键(据说以后的版本有可能支持,但至少目前不支持 ...

  6. HDU1254 推箱子(BFS) 2016-07-24 14:24 86人阅读 评论(0) 收藏

    推箱子 Problem Description 推箱子是一个很经典的游戏.今天我们来玩一个简单版本.在一个M*N的房间里有一个箱子和一个搬运工,搬运工的工作就是把箱子推到指定的位置,注意,搬运工只能推 ...

  7. 测试与发布(Alpha版本)——小谷围驻广东某工业719电竞大队

    测试与发布(Alpha版本)--小谷围驻广东某工业719电竞大队 一.引言 1.需求规格说明书: https://www.cnblogs.com/TaoTaoLV1/p/9819913.html 2. ...

  8. 配置Jenkins构建失败触发邮件报警机制

    系统管理 1.进入系统管理-->系统设置 定位到Jenkins Location配置项   配置系统管理员邮件地址 系统管理员邮件地址需要同发送报警邮件地址相同 定位到邮件通知   配置SMTP ...

  9. 解决Redis/Codis Connection with master lost(复制超时)问题

    今天在线上环境中遇到了codis-server报警,按照常规处理流程进行处理,报错步骤如下: 首先将codis-slave的rdb文件移除,并重启codis-slave 在codis-dashbord ...

  10. 避免图片路径访问405,可以用图片控件来显示局部相对路径,不需要域名就不会出现jpg静态资源访问错误

    <asp:Image ID="Image1" runat="server"/> protected void Page_Load(object se ...