今天早上使用内网gitlab仓库的时候,发现页面无法打开,ssh也无法连接。

到机房接上显示器,发现如下错误:

Error getting authority: Error initializing authority: Could not connect: No such file or directory (g-io-error-quark, 1)

输入root密码,进入shell界面。

按照提示,使用命令查看日志

# journalctl -xb -p3
-- Logs begin at Tue 2017-09-05 09:34:14 CST, end at Tue 2017-09-05 10:15:57 CST. --
....省略部分内容
Sep 05 09:34:18 localhost.localdomain kernel: :megaswr[ahci]: polling for interrupt status timed out for port=1, slot=0
Sep 05 09:34:18 localhost.localdomain kernel: :megasr[ahci]: warning PortReset called for port[1]
Sep 05 09:34:18 localhost.localdomain kernel: :megasr[ahci]: device on port:[1] online:[0x133] [0] milliseconds after reset
Sep 05 09:34:25 localhost.localdomain kernel: :megaswr[ahci]: polling for interrupt status timed out for port=1, slot=0
Sep 05 09:34:25 localhost.localdomain kernel: :megaswr[ahci]:Trouble port=1, slot=0
Sep 05 09:34:25 localhost.localdomain kernel: :megaswr[osl]: breakpoint called
Sep 05 09:34:25 localhost.localdomain kernel: :megasr[ahci]: Device:[2:INTEL SSDSC2BW48] NCQ:[Yes] Queue Depth:[0x20] capacity=0x37e436b0
Sep 05 09:34:25 localhost.localdomain kernel: :megasr[ahci]: Device:[3:INTEL SSDSC2BW48] NCQ:[Yes] Queue Depth:[0x20] capacity=0x37e436b0
Sep 05 09:34:25 localhost.localdomain kernel: :megasr[ahci]: Device:[4:ST9500620NS ] NCQ:[Yes] Queue Depth:[0x20] capacity=0x3a386030
Sep 05 09:34:25 localhost.localdomain kernel: :megasr[ahci]: Device:[5:ST9500620NS ] NCQ:[Yes] Queue Depth:[0x20] capacity=0x3a386030
Sep 05 09:34:25 localhost.localdomain kernel: :megasr: raid 10 logical drive is degraded, is not initialized, has 2 spans, and has a size of 0x6f869000 sectors
Sep 05 09:34:25 localhost.localdomain kernel: :megasr: raid 1 logical drive is online, is not initialized, has 2 drives, and has a size of 0x3a175800 sectors.
Sep 05 09:34:25 localhost.localdomain kernel: :megasr[raid_key]: [ ] RAID5 support [ ] SAS drive support
Sep 05 09:35:57 localhost.localdomain systemd[1]: Timed out waiting for device dev-sdc1.device.

在日志中看到,dev-sdc1设备出现问题。

查看磁盘分区情况

# fdisk  -l

Disk /dev/sdb: 499.0 GB, 498999492608 bytes, 974608384 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: dos
Disk identifier: 0xfcae2784 Device Boot Start End Blocks Id System
/dev/sdb1 2048 1949216767 974607360 83 Linux
WARNING: fdisk GPT support is currently new, and therefore in an experimental phase. Use at your own discretion. Disk /dev/sda: 958.0 GB, 957997907968 bytes, 1871089664 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: gpt # Start End Size Type Name
1 2048 411647 200M EFI System EFI System Partition
2 411648 821247 200M Microsoft basic
3 821248 1871087615 891.8G Linux LVM Disk /dev/mapper/cl-root: 946.8 GB, 946834767872 bytes, 1849286656 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes Disk /dev/mapper/cl-swap: 10.7 GB, 10737418240 bytes, 20971520 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

很明显,sdc没了,这才记起,当时安装系统的时候,因为多插了一块U盘,当时U盘被识别为sdb,这块磁盘被识别成了sdc。

查看fstab,证明了这一点。

# cat /etc/fstab 

#
# /etc/fstab
# Created by anaconda on Tue Aug 8 13:10:48 2017
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/cl-root / xfs defaults 0 0
UUID=a51fd6f8-a756-4e8f-ba44-5589fb99861e /boot xfs defaults 0 0
UUID=7D74-6C54 /boot/efi vfat umask=0077,shortname=winnt 0 0
/dev/mapper/cl-swap swap swap defaults 0 0
/dev/sdc1 /data ext4 defaults 0 0

看来要把写死的磁盘名称更改为UUID。

# blkid
/dev/sdc1: UUID="ab4c28b5-1708-483c-973a-40f91d320a9d" TYPE="ext4"
...

修改后的fstab为

# cat /etc/fstab 

#
# /etc/fstab
# Created by anaconda on Tue Aug 8 13:10:48 2017
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/cl-root / xfs defaults 0 0
UUID=a51fd6f8-a756-4e8f-ba44-5589fb99861e /boot xfs defaults 0 0
UUID=7D74-6C54 /boot/efi vfat umask=0077,shortname=winnt 0 0
/dev/mapper/cl-swap swap swap defaults 0 0
UUID=ab4c28b5-1708-483c-973a-40f91d320a9d /data ext4 defaults 0 0

尝试重启daemon,仍然弹出同样错误。

# systemctl daemon-reload
Error getting authority. Error initializing authority: Could not connect: No such file or directory (g-io-error-quark, 1)

exit退出shell,再次弹出该错误。

Error getting authority: Error initializing authority: Could not connect: No such file or directory (g-io-error-quark, 1)

不用管,等待几秒,系统已经可以正常启动。

CentOS 7磁盘寻找不到,卡在sulogin,造成的开机失败问题--Error getting authority...的更多相关文章

  1. CentOS使用systemctl daemon-reload报错Error getting authority: Error initializing authority: Error calling StartServiceByName for org.freedesktop.PolicyKit1: Timeout was reached (g-io-error-quark, 24)解决办法

    CentOS修改了系统启动文件后需要重载报错 systemctl daemon-reload Error getting authority: Error initializing authority ...

  2. 【转载】CentOS LVM磁盘扩容

    转自:http://blog.sina.com.cn/s/blog_8882a6260101cpfs.html EXSI5.1主机有一个linux虚拟机,系统是centos运行httpd服务,因为是多 ...

  3. linux(CentOS)磁盘挂载数据盘

    linux(CentOS)磁盘挂载数据盘:第一步:查看是否存在需要挂载的磁盘: sudo fdisk -l 第二步:为需要挂载的磁盘创建分区: sudo fdisk /dev/vdb 执行中:依次选择 ...

  4. Centos下磁盘管理的常用命令记录(如查找大文件)

    Centos下磁盘管理的常用命令记录 查看系统磁盘空间占用,使用命令: df -h 结果: 查看磁盘inode使用情况,如果inode用完了,磁盘就没法写入新的内容了: df -i 结果: 如何查找磁 ...

  5. Android SD卡创建文件和文件夹失败

    原文:Android SD卡创建文件和文件夹失败 功能需要,尝试在本地sd卡上创建文件和文件夹的时候,报错,程序崩溃. 一般情况下,是忘记给予sd卡的读写权限.但是这里面权限已经给了,还是报错. 在网 ...

  6. centos查看磁盘扇区大小等信息

    fdisk -l 说明一下: “Disk /dev/sda: 53.7 GB, 53687091200 bytes” 表示第一块磁盘的大小为53.7GB. "255 heads"表 ...

  7. 详解Centos默认磁盘分区

    对于有经验的Linux系统管理员,在安装系统之前都会对系统的分区进行规划:针对这一需求,下面就通过默认的Centos分区与大家分享一些关于Linux系统的知识.Linux系统的磁盘命名规范:硬盘类型标 ...

  8. CentOS针对磁盘IO[jdb2进程]的优化

    CentOS的jdb2进程总是沾满io,查了一些资料后才知道,这个问题源自系统bug,在此记录一下解决办法: 将高IO的磁盘,用以下参数remount即可 mount -t ext4 -o remou ...

  9. VirtualBox下Linux(centos)扩展磁盘空间

    最近在Linux里做文件合并,做分词,磁盘空间不够,把扩展磁盘空间方法记录一下. 1.在VirtualBox安装路径下(例如C:\Program Files\Oracle\VirtualBox> ...

随机推荐

  1. Myabtis-Plus之QueryWrapper常用方法

    AbstractWrapper 下的方法及使用 方法名 说明 使用 allEq(Map<R, V> params) 全部 =(或个别 isNull) allEq(params,true) ...

  2. IDEA创建XML文件没有Spring Config选项

    我在resources目录下导入3个配置文件时,applicationContext-common.xml文件中有4处http地址红色报错,下图为修正后的图片 了解到可能是由于父工程的pom文件中没有 ...

  3. 浅入kubernetes(5):尝试kubeadm

    本篇介绍利用 kubernetes 的命令行工具,快速创建集群实例,完成 hello world 实践. 上一篇试用 minikube 去搭建集群,这一篇将介绍通过 kubeadm 去操作. 命令行工 ...

  4. 多线程之Lock接口

    之前写了一下synchronized关键字的一点东西,那么除了synchronized可以加锁外,JUC(java.util.concurrent)提供的Lock接口也可以实现加锁解锁的功能. 看完本 ...

  5. JMeter循环读取CSV文件实现接口批量测试

    首先要理解为什么要进行批量测试,当我们在工作中进行接口测试时,项目的接口肯定不止一个,而是很多很多,而且每个接口都需要进行正确参数,错误参数,参数为空,特殊字符等方式来测试接口是否能够正确返回所需的响 ...

  6. fiddler 手机抓包(含https) 完整流程

    第一部分:下载并安装fiddler 一.使用任一浏览器搜索[fiddler下载安装],并下载fiddler 安装包. 二.fiddler安装包下载成功后,将下载的fiddler压缩包解压到自定义文件夹 ...

  7. Civil3d中 如何用管轴线的变坡点桩号控制其他纵断面数据的显示?

    如何用管轴线的变坡点桩号控制其他纵断面数据的显示?如下图所示: 主要进行两步操作,下面以地面高程为例. 第1步: 右键纵断面图,打开纵断面图特性对话框,选择"标注栏"选项卡,分别设 ...

  8. OO第四单元与全课程总结

    OO第四单元与全课程总结 一.作业代码架构设计 1.第一次作业 作业类图如下: 具体架构设计: 第一次作业的全部查询工作都是和类图有关,需要解决的主要问题就是如何解析原有UML类图数据的结构,并形成自 ...

  9. .Net之配置文件

    1. 说明 默认情况下读取配置Configuration的默认优先级:ConfigureAppConfiguration(自定义读取)>CommandLine(命令行参数)>Environ ...

  10. 032- for循环语句

    问题 请在控制台里面打印10次HelloWorld. 这时可能你会这么写: System.out.println("helloworld"); System.out.println ...