启动OpenVPN失败

文:铁乐与猫

[root@yunwei_OpenVPN openvpn]# systemctl status openvpn
● openvpn.service - LSB: start and stop openvpn
   Loaded: loaded (/etc/rc.d/init.d/openvpn; bad; vendor preset: disabled)
   Active: active (exited) since 四 2017-11-16 15:41:52 CST; 1min 31s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1175 ExecStart=/etc/rc.d/init.d/openvpn start (code=exited, status=0/SUCCESS)

11月 16 15:41:52 yunwei_OpenVPN systemd[1]: Starting LSB: start and stop openvpn...
11月 16 15:41:52 yunwei_OpenVPN openvpn[1175]: /etc/rc.d/init.d/openvpn: 第 108 行:[: =: 期待一元表达式
11月 16 15:41:52 yunwei_OpenVPN openvpn[1175]: Starting openvpn: [失败]

## 11月 16 15:41:52 yunwei_OpenVPN systemd[1]: Started LSB: start and stop openvpn.

现怀疑是因为VMware虚拟机上搭建创建不出虚拟网卡所致。
因为/etc/rc.d/init.d/openvpn第108行是:

107 # Check that networking is up.
108 if [ ${NETWORKING} = "no" ]
109 then
110   echo "Networking is down"
111   exit 0
112 fi

解决办法是加载tun内核模块并启用转发

加载tun内核模块以便于openvpn生成虚拟网卡
[root@yunwei_OpenVPN openvpn]# modprobe tun
检验加载成功没有
[root@yunwei_OpenVPN openvpn]# lsmod | grep tun
tun                    31621  0
启用转发
[root@yunwei_OpenVPN openvpn]# echo 1 > /proc/sys/net/ipv4/ip_forward
检验
[root@yunwei_OpenVPN openvpn]# cat /proc/sys/net/ipv4/ip_forward
1
[root@yunwei_OpenVPN openvpn]# locate tun.ko
/usr/lib/modules/3.10.0-514.el7.x86_64/kernel/drivers/net/tun.ko
/usr/lib/modules/3.10.0-693.5.2.el7.x86_64/kernel/drivers/net/tun.ko.xz
  • 后来发现是自己的配置文件还没有设置好tun项导致,改好后,再启动:
    [root@yunwei_OpenVPN openvpn]# openvpn --config /etc/openvpn/server.conf
    (注:这种命令还不是在后台模式运行的)
Thu Nov 16 17:19:39 2017 OpenVPN 2.4.4 x86_64-redhat-linux-gnu [Fedora EPEL patched][SSL (OpenSSL)] [LZO][LZ4] [EPOLL][PKCS11] [MH/PKTINFO][AEAD] built on Sep 26 2017
Thu Nov 16 17:19:39 2017 library versions: OpenSSL 1.0.1e-fips 11 Feb 2013, LZO 2.06
Thu Nov 16 17:19:39 2017 Diffie-Hellman initialized with 2048 bit key
Thu Nov 16 17:19:39 2017 Failed to extract curve from certificate (UNDEF), using secp384r1 instead.
Thu Nov 16 17:19:39 2017 ECDH curve secp384r1 added
Thu Nov 16 17:19:39 2017 ROUTE_GATEWAY 172.16.1.2/255.255.255.0 IFACE=ens33 HWADDR=00:0c:29:96:0a:fe
Thu Nov 16 17:19:39 2017 TUN/TAP device tun0 opened
Thu Nov 16 17:19:39 2017 TUN/TAP TX queue length set to 100
Thu Nov 16 17:19:39 2017 do_ifconfig, tt->did_ifconfig_ipv6_setup=0
Thu Nov 16 17:19:39 2017 /sbin/ip link set dev tun0 up mtu 1500
Thu Nov 16 17:19:39 2017 /sbin/ip addr add dev tun0 local 10.66.72.1 peer 10.66.72.2
Thu Nov 16 17:19:39 2017 /sbin/ip route add 10.66.72.0/24 via 10.66.72.2
Thu Nov 16 17:19:39 2017 Could not determine IPv4/IPv6 protocol. Using AF_INET
Thu Nov 16 17:19:39 2017 Socket Buffers: R=[212992->212992] S=[212992->212992]
Thu Nov 16 17:19:39 2017 UDPv4 link local (bound): [AF_INET][undef]:1194
Thu Nov 16 17:19:39 2017 UDPv4 link remote: [AF_UNSPEC]
Thu Nov 16 17:19:39 2017 MULTI: multi_init called, r=256 v=256
Thu Nov 16 17:19:39 2017 IFCONFIG POOL: base=10.66.72.4 size=62, ipv6=0
Thu Nov 16 17:19:39 2017 IFCONFIG POOL LIST
Thu Nov 16 17:19:39 2017 Initialization Sequence Completed

另开一个终端验证有在运行没有:

[root@yunwei_OpenVPN ~]# lsof -i:1194
COMMAND  PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
openvpn 6864 root    6u  IPv4  42254      0t0  UDP *:openvpn 

正常成功运行。

end

启动OpenVPN失败的更多相关文章

  1. 启动OracleDBConsoleorcl失败,提示错误代码2

    异常问题: 启动OracleDBConsoleorcl失败,提示错误代码2 原因分析: 由于更改计算机名导致的异常 解决方法: 1.管理员权限cmd下执行emctl start dbconsole 2 ...

  2. MyEclipse 启动 tomcate 失败 解决方法

    MyEclipse中启动tomcate失败 十月 20, 2015 9:53:04 下午 org.apache.catalina.startup.VersionLoggerListener log信息 ...

  3. Tomcat学习笔记 - 错误日志 - NetBeans配置tomcat出错情况总结 -- 部署错误: 启动 Tomcat 失败。-- '127.0.0.1' 不是内部或外部命令,也不是可运行的程序

    真的管用,不知道为啥管用.转载自:http://blog.sina.com.cn/s/blog_709548200102vgy4.html 问题描述: 新安装的NetBeans8.0.2,安装过程中还 ...

  4. centos7 启动docker失败的解决

    控制端使用yum install docker安装完成docker后启动docker失败,出现以下信息: Job for docker.service failed because the contr ...

  5. Linux_解决启动网卡失败 Device eth0 does not seem to be present

    Linux_解决启动网卡失败  Device eth0 does not seem to be present 虚拟机克隆  发现service network restart 启动失败 故障现象: ...

  6. docker-compose中启动镜像失败的问题

    http://blog.csdn.net/boling_cavalry/article/details/79050451 解决docker-compose启动镜像失败的问题: 原文地址:http:// ...

  7. ClouderaManager启动NodeManager失败!报错Failed to initialize container executor

    报错信息: 2016-07-27 10:53:14,102 WARN org.apache.hadoop.yarn.server.nodemanager.LinuxContainerExecutor: ...

  8. 启动vsftpd失败

    启动vsftpd失败 在使用centos时, 要用ftp上传文件, 但是一到脚本的ftp命令就会出错: rpm -Uvh http://mirror.centos.org/centos/6/os/i3 ...

  9. android 启动socket 失败:socket(af_inet sock_stream 0) 返回-1

    Android 启动socket 失败:socket(af_inet sock_stream 0) 返回-1 原因权限问题, 应该添加如下权限: <uses-permission android ...

随机推荐

  1. linux下配置nginx负载均衡例子

    准备2台虚拟机: 分别在两个虚拟机上安装tomcat,并在服务器A安装nginx,其中nginx端口设置为了 70. 服务器A的tomcat安装目录: 服务器B的tomcat安装目录: 服务器A的ng ...

  2. sql server 备份与恢复系列八 系统数据库备份与恢复分析

    一.概述 在前面讲过"sql server 备份与恢复系列"都是集中在用户数据库上.sql server还维护着一组系统数据库,这些系统数据库对于服务器实例的运行至关重要.在每次进 ...

  3. Nunit测试工具使用

    Nunit是什么 Nunit是一种TDD工具,和Junit一样的! 怎么样获取Nunit 打开Visual Studio工具,然后在菜单栏中的工具->扩展管理器中的联机库中搜索"nun ...

  4. Oracle的数据并发与一致性详解(上)

    今天想了解下oracle中事务与锁的原理,但百度了半天,发现网上介绍的内容要么太短,要么版本太旧,而且抄袭现象严重,所以干脆查官方帮助文档(oracle 11.2),并将其精华整理成中文,供大家一起学 ...

  5. maven自动部署项目以及常见问题解决

    Maven自动部署war到Tomcat1. 在maven项目的pom里配置如下信息 <build> <finalName>dianxiao</finalName> ...

  6. SpringBoot JPA + H2增删改查示例

    下面的例子是基于SpringBoot JPA以及H2数据库来实现的,下面就开始搭建项目吧. 首先看下项目的整体结构: 具体操作步骤: 打开IDEA,创建一个新的Spring Initializr项目, ...

  7. 一个比较好用的省内存的ORM

    http://www.52chloe.com 记录一下,完了,就这样

  8. .net MVC使用Session验证用户登录(转载)

    .net MVC使用Session验证用户登录   用最简单的Session方式记录用户登录状态 1.添加DefaultController控制器,重写OnActionExecuting方法,每次访问 ...

  9. CSS学习笔记07 盒子模型

    1.盒子模型 所谓盒子模型就是把HTML页面中的元素看作是一个矩形的盒子,也就是一个盛装内容的容器.每个矩形都由元素的内容.内边距(padding).边框(border)和外边距(margin)组成. ...

  10. UserControl VS TemplatedControl

    一:首先来看一下UserControl 熟悉XAML的朋友们都知道,当我们创建一个用户控件的时候,VS会自动为我们生成一个XXX.xaml文件和XXX..xaml.cs文件,XAML文件用于进行控件的 ...