部署DTCMS到Jexus遇到的问题及解决思路---部署
上一篇我们环境已经准备完成,此时可以部署了,我们就以dtcms作为例子,http://bbs.dtcms.net/forum.php?mod=viewthread&tid=2420&extra=page%3D1,到这里下载源码,里面有文档和数据库脚本
用这个项目做例子主要是帮朋友研究的就是这个产品,并且相对来说功能比vs创建的模板网站要多不少,应该会遇到一些问题
1.创建数据库
我们需要一个可在虚拟机中访问到的数据库服务器,大部分同学本机应该就有数据库引擎,数据库创建到本地即可,我这边由于没装,所以使用了一个阿里云上的数据库,执行源码里面的脚本即可
2.修改webconfig连接字符串
3.发布网站,根据文档,我们发布后要把bin目录下的一些dll拷贝到发布文件的bin目录下
4.压缩发布后的文件夹,记得使用zip格式,现在我们遇到的问题就是如何上传到虚拟机的指定文件夹中
1)使用xshell连接Linux虚拟机
2)使用xshell的文件传输功能,需要你下载Xftp

3)和普通的ftp软件差不多,上传zip文件即可
5.解压缩zip,我上传到了/var/www/dtcms文件夹下
|
1
2
|
cd /var/www/dtcms/ #定位到文件unzip -o PublishOutput.zip #解压缩 |
6.创建网站配置
|
1
|
vi /usr/jexus/siteconf/dtcms #创建文件 |
#内容
port=8080
root=/ /var/www/dtcms
indexs=index.aspx,index.html
记得增加防火墙配置
7.重启Jexus
|
1
2
|
cd /usr/jexus/./jws restart |
8.访问测试(发现不通)无任何日志,请求未被网站应用接收,开始尝试解决问题
1)使用vs创建默认网站模板(webform)部署测试不存在问题
2)创建默认mvc网站模板部署测试不存在问题
3)检查cms请求处理管道发现cms为了url重写,采用了自定义的httpModules,因此,尝试注释webconfig中httpModules相关配置,共三处

<system.web>
<compilation debug="true" targetFramework="4.0" />
<customErrors mode="Off"/>
<!--<httpModules>
<add type="DTcms.Web.UI.HttpModule, DTcms.Web.UI" name="HttpModule" />
</httpModules>--> <!--<httpHandlers>
<add verb="*" path="templates/main/*.html" type="System.Web.HttpForbiddenHandler" />
</httpHandlers>-->
<!-- 文件上传大小KB-->
<httpRuntime requestValidationMode="2.0" maxRequestLength="2097151" executionTimeout="36000" />
</system.web> <system.webServer>
<validation validateIntegratedModeConfiguration="false"/>
<!--<modules runAllManagedModulesForAllRequests="true">
<add type="DTcms.Web.UI.HttpModule, DTcms.Web.UI" name="HttpModule" />
</modules>-->
<security>
<requestFiltering>
<requestLimits maxAllowedContentLength="2147483647" />
</requestFiltering>
</security>
</system.webServer>

部署后可以访问管理后台
4)由于xml中第三处依赖第一处,因此通过恢复注释的方法,确认问题出现在
<httpHandlers>
<add verb="*" path="templates/main/*.html" type="System.Web.HttpForbiddenHandler" />
</httpHandlers>
这个节点功能是定义禁止访问下载 templates/main/ 下的html模板文件,主要是考虑安全问题,目前还未找到为何影响了Jexus
目前修改为
<httpHandlers>
<add verb="*" path="*.html" type="System.Web.HttpNotFoundHandler" />
</httpHandlers>
解决了问题,但看起来和上面的配置并不等价
还有个解决的方案,可以通过Jexus配置:
https://www.linuxdot.net/bbsfile-3084
禁止访问某文件夹及其子文件夹中的内容
DenyDirs=网站文件夹路径的URL路径,如 “/abcfiles”或 “~/abcfiles”,多个路径,用英文逗号分开
解决这样的安全问题
5.url大小写问题
|
1
|
vi /usr/jexus/jws |
注释掉export MONO_IOMAP前面的#
目前来说基本功能无问题了,准备生成模板看看url重新有没有问题,结果发现控制面板-界面管理-站点模板管理 没有模板记录,通过代码分析+记录日志发现
\DTcms.Web\admin\settings\templet_list.aspx.cs中的GetInfo方法存在Linux兼容问题,
其实就是路径的/\问题,windows下就两种都可以,而Linux只支持/,修改后重新发布,问题解决(目前发现此问题已无法重现)
部署DTCMS到Jexus遇到的问题及解决思路---部署的更多相关文章
- [.Net跨平台]部署DTCMS到Jexus遇到的问题及解决思路---部署
上一篇我们环境已经准备完成,此时可以部署了,我们就以dtcms作为例子,http://bbs.dtcms.net/forum.php?mod=viewthread&tid=2420&e ...
- [.Net跨平台]部署DTCMS到Jexus遇到的问题及解决思路---Linux环境搭建
最近朋友托我帮忙研究如何把一个DTCMS部署到Linux下,经过1天的研究,部署基本成功,可能有些细节还未注意到,现在把心得分享一下.过程比预期的要简单 身为.Net程序员,这个问题的第一步可能就是如 ...
- 部署DTCMS到Jexus遇到的问题及解决思路---Linux环境搭建
最近朋友托我帮忙研究如何把一个DTCMS部署到Linux下,经过1天的研究,部署基本成功,可能有些细节还未注意到,现在把心得分享一下.过程比预期的要简单 身为.Net程序员,这个问题的第一步可能就是如 ...
- [.Net跨平台]部署DTCMS到Jexus遇到的问题及解决思路--验证码
上一篇博客我们已经基本完成了部署工作,目前发现了验证码出现500错误,分析其代码,我们可以看到验证码使用的是System.Drawing命名空间下的类库, GDI+ 位图,这个在肯定是平台相关的,所以 ...
- 部署DTCMS到Jexus遇到的问题及解决思路--验证码
上一篇博客我们已经基本完成了部署工作,目前发现了验证码出现500错误,分析其代码,我们可以看到验证码使用的是System.Drawing命名空间下的类库, GDI+ 位图,这个在肯定是平台相关的,所以 ...
- 解决Web部署 svg/woff/woff2字体 404错误 iis 解决Web部署 svg/woff/woff2字体 404错误
问题:最近在IIS上部署web项目的时候,发现浏览器总是报找不到woff.woff2字体的错误.导致浏览器加载字体报404错误,白白消耗了100-200毫秒的加载时间. 原因:因为服务器IIS不认SV ...
- 在Ubuntu 16.04上利用Jexus+.Net Core+Linux版SQL Server部署ZKEACMS.Core
百度传课视频地址:https://chuanke.baidu.com/v5849090-223278-1498090.html 一.SQL Server on Linux的安装 官方文档:https: ...
- disconf系列【2】——解决zk部署情况为空的问题
如下图所示,在安装完成之后,发现zk(zookeeper)部署情况为空. 注:承接上篇,环境未发生改变. 1.解决zk没有启动的问题 查看disconf日志,发现zk没有启动. 实际情况是:zk已经启 ...
- 解决IIS7.0服务和用户上传的文件分别部署在不同的电脑上时,解决权限的问题
为解决IIS服务和用户上传的文件分别部署在不同的电脑上时,解决权限的问题. 定义: A:iis服务器 B:文件服务器 步骤: 1.在B上创建一个用户[uploaduser](并设置密码) 2.给B上的 ...
随机推荐
- s5 Docker的持久化存储和数据共享
数据库容器的数据如何才能不会丢失?Docker的持久化存储技术.Docker的数据共享技术能极大提高开发人员的开发效率,边写代码,边看运行结果. 数据持久化之Data Volume Docker持久化 ...
- drf6 权限和频率控制组件
对某件事情决策的范围和程度,我们叫做权限,权限是我们在项目开发中非常常用到的. DRF框架给我们提供的权限组件 权限组件 之前DRF的版本和认证,知道了权限和频率跟版本认证都是在initial方法里初 ...
- uasrt配置
Universal Synchronous/Asynchronous Receiver/Transmitter 同步是指:发送方发出数据后,等接收方发回响应以后才发下一个数据包的通讯方式.同步要有一个 ...
- Django积木块二——邮箱
邮箱 django中自带的功能,因为登录注册都需要邮箱,因此新增了一个小的app--utils用来存放 # email_send.py import random from django.core.m ...
- 三.mysql表的完整性约束
mysql表的完整性约束 什么是约束 not null 不能为空的 unique 唯一 = 不能重复 primary key 主键 = 不能为空 且 不能重复 foreign key ...
- Ngui分辨率适配
必备知识点 1.分辨率适配必然是Orthographic Camera 2.Camera下对应的“Size”(图1)属性大小的理解:当前摄像机高度 = Size * 2 * UnityUnit(Uni ...
- java 项目的路径详情
title: 项目下的路径问题tags:grammar_cjkRuby: true--- 在javaee的项目中,存取文件,解析xml和properties文件,以及项目中的文件,都需要获取路径,常用 ...
- open:在终端打开文件|应用程序等
1. 需求&解决方案 打开文件 或url(用默认应用程序): $ open fileName 打开文件 或url(用指定应用程序): $ open -a appName fileName ## ...
- navicat连接linux系统中mysql-错误:10038
输入 命令 netstat -anp(查看所有的进程和端口使用情况) (注:Local Address一列中: 0.0.0.0 表示监听本地所有ip地址,其他电脑是可以访问的,并且修改ip不受影响. ...
- java之Stack详细介绍
1 Stack介绍 Stack简介 Stack是栈.它的特性是:先进后出(FILO, First In Last Out). java工具包中的Stack是继承于Vector(矢量队列)的,由于Ve ...