搭建版本

版本组合 php5.6+apache/2.4.6(centos7)+mysql5.7.24

因为新系统不能确认哪些指令已经搭建  所以安装前需要确认下是否拥有

检测是否已经安装过Vim

rpm -qa|grep vim

显示出完整的包名:vim-common,vim-enhanced,vim-minimal,vim-filesystem 表示安装成功

若是缺少Vim包名:则使用命令:

比如说: vim-enhanced这个包少了,执行:yum -y install vim-enhanced 命令,它会自动下载安装

若未安装,进行安装:

yum -y install vim*

安装Nginx

添加源

rpm -Uvh http://nginx.org/packages/centos/7/noarch/RPMS/nginx-release-centos-7-0.el7.ngx.noarch.rpm

通过yum search nginx看看是否已经添加源成功。如果成功则执行下列命令安装Nginx。

yum install -y nginx

启动Nginx并设置开机自动运行

systemctl start nginx.service

systemctl enable nginx.service

安装php7

由于linux的yum源不存在php7.x,所以我们要更改yum源:

yum install epel-release

rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm

安装PHP7.2 及其依赖

yum -y install php72w php72w-cli php72w-common php72w-devel php72w-embedded php72w-fpm

php72w-gd php72w-mbstring php72w-mysqlnd php72w-opcache php72w-pdo php72w-xml

开启php-fpm

systemctl start php-fpm   //开启php-fpm 
systemctl enable php-fpm   //开机自动启动

因为我搭建环境接下来有开发个别端口 所以涉及到防火墙的问题

CentOS 7.0默认使用的是firewall作为防火墙 默认关闭 需要设置开机启动

firewalld的基本使用

启动: systemctl start firewalld

关闭: systemctl stop firewalld

查看状态: systemctl status firewalld

开机禁用  : systemctl disable firewalld

开机启用  : systemctl enable firewalld

防火墙设置 打开HTTP 80端口

firewall-cmd --zone=public --add-port=80/tcp --permanent

重启防火墙
firewall-cmd --reload

编辑Nginx环境

创建html文件夹    mkdir -p /var/www/html   #-p选项表示若上层目录未建立,同时建立上层目录

vi /etc/nginx/nginx.conf           #编辑Nginx配置文件

找到server修改以下内容

server {
        listen       80 ;
        server_name  127.0.0.1;      #填写自己的server_name(测试后写什么没影响)

autoindex on;#是否允许访问目录 开放权限   否则会报错403 forbidden
        root         /var/www/html;                   #网站根目录

找到location添加以下内容

location / {

        root  /var/www/html;

        index index.php index.html index.htm;

添加php支持处理请求

location ~ \.php$ {
            root           /var/www/html;
            fastcgi_pass   127.0.0.1:9000;
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME $document_root$fastcgi_script_name;  
             include        fastcgi_params;
         }

nginx -t       #测试Nginx配置文件是否成功

systemctl restart nginx      #重启Nginx服务

centos7 lnmp环境部署的更多相关文章

  1. 用源码搭建LNMP环境+部署WordPress

    首先要做的是就是关闭Centos7.4的防火墙及selinux #systemctl stop firewalld #systemctl disable firewalld #sed -ri 's/^ ...

  2. VM虚拟机 Centos7 lnmp环境 配置域名问题 windows浏览器访问的问题

    CentOS7  ip地址为 192.168.0.155 搭有 LNMP集成环境 执行 lnmp vhost add 配置服务器 指定目录的域名 mark.com 这时windows 机器的 浏览器想 ...

  3. centos7 lnmp环境搭建

    1- 安装gcc c++编译器 yum install gcc gcc-c++ cmake 2- 安装nginx-1.8.1及依赖包 2.1- 安装nginx依赖包 yum -y install pc ...

  4. CentOS7 Tomcat 环境部署

    java由jvm虚拟机和一些本地类库(与操作系统通信的底层库)和java类库组成.javase由jdk和一些基本api组成,而javaee则在javase基础上添加了一些企业常用的类库,其中两个著名a ...

  5. docker中lnmp环境部署laravel框架

    yum install docker     安装docker service docker start   启动docker docker pull  docker.io/skiychan/ngin ...

  6. lnmp环境部署脚本-y

    系统环境:centos6.X #!/bin/bash#date:2018-01-01## MySQL 安装8版本的话不太适合,有待于添加安装脚本进行测试#新版的MySQL安装需要高版本2.8以上cma ...

  7. Dockerfile分离构建LNMP环境部署wordpress

    最近忙着写自己的项目,也把一个站点的bbs论坛打算迁移到Docker中,测试没发现啥大问题.在单台上面的架构如下:(往后我们也是要讲到compose和swarm调度的慢慢来) 1.首先我们先安装一下d ...

  8. 搭建LNMP环境部署Wordpress博客

    !!!首先要做的就是关闭系统的防火墙以及selinux: #systemctl stop firewalld #systemctl disable firewalld #sed -ri 's/^(SE ...

  9. LNMP环境部署

    说明: 操作系统:CentOS 5.6 32位 准备篇: 一.配置好IP.DNS .网关,确保使用远程连接工具能够连接服务器 二.配置防火墙,开启80端口.3306端口 vi /etc/sysconf ...

随机推荐

  1. PHP7 MongDB 安装与使用

    我们使用 pecl 命令来安装: /usr/local/php7/bin/pecl install mongodb 执行成功后,会输出以下结果: …… Build process completed ...

  2. PTA8

    这个作业属于哪个课程 C语言程序设计2 这个作业要求在哪里 https://edu.cnblogs.com/campus/zswxy/software-engineering-class2-2018/ ...

  3. 采用CAS算法 实现高性能的Disruptor 完成多线程下并发、等待、先后等操作

    来源:https://blog.csdn.net/tianyaleixiaowu/article/details/79787377 拓展: https://www.jianshu.com/p/d24b ...

  4. Oracle报错TNS-12532: TNS:invalid argument

    今天一个同事遇到了一个oracle问题,在数据库本机通过sqlplus登录sys用户时报TNS-12532: TNS:invalid argument,这个错误. 造成这个错误的原因主要有三个,一般排 ...

  5. 明令禁止下,哪些APP在违规获取用户信息?

    2019年4月28日消息  移动互联网时代各大APP大行其道,用户为了更便捷地享受互联网服务,常常需要让渡部分个人信息.在信息获取不透明的情况下,不少APP运营企业出现过度获取乃至违规获取用户信息的情 ...

  6. c标签 多个条件

    <c:if test="${(rwyy01.yyry==NULL || rwyy01.yyry=='') && (rwyy01.shry==NULL || rwyy01 ...

  7. Firebird Embedded 部署的一个坑

    今天把旧程序升级了,把DBX组件换成了FireDac组件,在虚拟机里测试的时候,一直报上图中的错误,但是在主机上运行无问题,之前用户使用也一直没报过这个错. 折腾了又折腾,还是搞不定,感觉脑袋有点大了 ...

  8. 为什么选择Go语言 GO语言都能做什么产品

    Go语言,又称Golang,是Google开发的一款静态强类型.编译型.并发型,并具有垃圾回收机制的编程语言,它的运行速度非常之快,同时还有如下特性:具有一流的标准库.无继承关系.支持多核:同时它还有 ...

  9. PCIE读书笔记

    PCIE读书笔记 什么是TLP:

  10. volatile和不加volatile的区别

    http://blog.chinaunix.net/uid-25100840-id-3067899.html 对于一个地址,如果加上了volatile参数,这个地址也就不会经过编译器优化,也就是说这个 ...