select NAME FROM USER$ ORDER BY NAME  ;
CREATE USER pciss IDENTIFIED BY pciss ;
GRANT DBA TO pciss ;
SELECT * FROM dba_directories ;
SELECT * FROM USER$ U WHERE U.NAME=UPPER('pciss') ;
SELECT * FROM Dba_Tablespaces ;
SELECT * FROM Dba_Data_Files ;
CREATE DIRECTORY PUMP_DIR_PCISS AS 'D:\orcl_data\pciss';
grant read,write on directory PUMP_DIR_PCISS to pciss;
DROP DIRECTORY dpdata ;
DROP USER PCISS CASCADE ;
CREATE USER pciss IDENTIFIED BY pciss DEFAULT TABLESPACE pciss_spc TEMPORARY TABLESPACE temp PROFILE Default;
GRANT DBA TO pciss ; SELECT * FROM user_objects o WHERE o.object_name=PCISS ; CREATE TABLESPACE pciss_spc
LOGGING
DATAFILE 'F:\APP\TY\ORADATA\ORCL\pciss_spc.DBF'
SIZE 6144m ;
AUTOEXTEND ON
NEXT 50m MAXSIZE 12803072
EXTENT MANAGEMENT LOCAL ; create tablespace pciss_spc
datafile 'F:\APP\TY\ORADATA\ORCL\pciss_spc1.DBF'
size 5000M
autoextend on next 50M maxsize 7144m;
删除表空间
ALTER TABLESPACE pciss_spc ADD DATAFILE 'F:\APP\TY\ORADATA\ORCL\pciss_spc1.DBF' SIZE 3000M AUTOEXTEND ON NEXT 50M MAXSIZE UNLIMITED; drop tablespace DEMOSPACE including contents and DATAFILES ALTER SYSTEM KILL SESSION '63,33'; ALTER SYSTEM KILL SESSION '132,3765'; ALTER DATABASE
DATAFILE 'F:\APP\TY\ORADATA\ORCL\pciss_spc.DBF' AUTOEXTEND
ON NEXT 500M MAXSIZE UNLIMITED ; SELECT T.TABLESPACE_NAME,D.FILE_NAME,
D.AUTOEXTENSIBLE,D.BYTES,D.MAXBYTES,D.STATUS
FROM DBA_TABLESPACES T,DBA_DATA_FILES D
WHERE T.TABLESPACE_NAME =D.TABLESPACE_NAME
ORDER BY TABLESPACE_NAME,FILE_NAME; SELECT * FROM (
SELECT UPPER(F.TABLESPACE_NAME) "表空间名",
D.TOT_GROOTTE_MB "表空间大小(M)",
D.TOT_GROOTTE_MB - F.TOTAL_BYTES "已使用空间(M)",
TO_CHAR(ROUND((D.TOT_GROOTTE_MB - F.TOTAL_BYTES) / D.TOT_GROOTTE_MB * 100,2),'990.99') "使用比",
F.TOTAL_BYTES "空闲空间(M)",
F.MAX_BYTES "最大块(M)"
FROM (SELECT TABLESPACE_NAME,
ROUND(SUM(BYTES) / (1024 * 1024), 2) TOTAL_BYTES,
ROUND(MAX(BYTES) / (1024 * 1024), 2) MAX_BYTES
FROM SYS.DBA_FREE_SPACE
GROUP BY TABLESPACE_NAME) F,
(SELECT DD.TABLESPACE_NAME,
ROUND(SUM(DD.BYTES) / (1024 * 1024), 2) TOT_GROOTTE_MB
FROM SYS.DBA_DATA_FILES DD
GROUP BY DD.TABLESPACE_NAME) D
WHERE D.TABLESPACE_NAME = F.TABLESPACE_NAME
ORDER BY 4 DESC
) a WHERE "表空间名"='PCISS_SPC'; ----------------------------------------- imp pciss/pciss@orcl file=D:\orcl_data\pciss\PCISS20160729.DMP log=D:\orcl_data\pciss\PCISS20160729.log fromuser=pciss touser=pciss buffer=10240000 impdp pciss/pciss@orcl directory=PUMP_DIR_PCISS dumpfile=PCISS20160729.DMP schemas=pciss
REMAP_TABLESPACE=PCISS_SPC:USERS ; impdp pciss/pciss@orcl directory=PUMP_DIR_PCISS dumpfile=PCISS20160729.DMP REMAP_SCHEMA=pciss:pciss REMAP_TABLESPACE=PCISS_SPC:USERS ; impdp pciss/pciss@orcl directory=PUMP_DIR_PCISS dumpfile=PCISS20160729.DMP REMAP_TABLESPACE=PCISS_SPC:USERS full=y
impdp pciss/pciss@orcl directory=PUMP_DIR_PCISS dumpfile=PCISS20160729.DMP REMAP_SCHEMA=pciss:pciss ;
REMAP_SCHEMA=pciss:pciss ;

解决pciss_spc导入提示表空间不存在以及扩展失败的问题的更多相关文章

  1. 19C imp 导入合并表空间

    因为项目需要从9i 导数据到18C,所以发现如下特性 1.18C imp 导入数据,如果表空间在目标库没有,会将表导入到用户默认表空间 2.18C imp 导入数据,如果表空间在目标库有,但缺少权限. ...

  2. Oracle错误——ORA-01691: Lob 段SFZXP.SYS_LOB0000030381C00004$$无法通过8192(在表空间USERS中)扩展

    问题 Oracle报错:ORA-01691: Lob 段SFZXP.SYS_LOB0000030381C00004$$无法通过8192(在表空间USERS中)扩展 问题原因 Oracle数据表空间不足 ...

  3. oracle暂时表空间 ORA-01652:无法通过16(在表空间XXX中)扩展 temp 字段

    今天在查数据的时候报错  ORA-01652:无法通过16(在表空间temp1中)扩展 temp 字段 查看表空间使用明细 SELECT b.tablespace,        b.segfile# ...

  4. ORA-01653:表无法通过64(在表空间USERS中)扩展

    问题描述:oracle插入数据时显示ORA-01653 表无法通过64(在表空间USERS中)扩展 原因:  oracle  表空间满了,需要扩展 截图: 解决方法: 1.首先查下表空间 select ...

  5. oracle临时表空间 ORA-01652:无法通过16(在表空间XXX中)扩展 temp 字段

    今天在查数据的时候报错  ORA-01652:无法通过16(在表空间temp1中)扩展 temp 字段 查看表空间使用明细 SELECT b.tablespace,        b.segfile# ...

  6. 【Oracle】查看表空间是否为自动扩展

    查看指定的表空间是否为自动扩展 SQL>   select file_name,autoextensible,increment_by from dba_data_files where tab ...

  7. Oracle 数据备份、恢复以及导入时表空间不存在的解决方案

    一.数据备份(导出) 1.exp命令导出dmp文件(exp -help查看帮助信息) 命令:exp username/userpasswd@192.168.99.199/orcl file=C:\jd ...

  8. Oracle数据导入指定表空间

    1. 打开工具Oracle SQL Plus 以dba身份登录sys用户 sqlplus /nologconn sys@url as sysdba 2. 创建用户并指定表空间 使用客户端工具或者Web ...

  9. Oracle 创建表空间及用户授权、dmp数据导入、表空间、用户删除

    1.创建表空间 // 创建表空间 物理位置为'C:\app\admin\oradata\NETHRA\NETHRA.DBF',初始大小100M,当空间不足时自动扩展步长为10M create tabl ...

随机推荐

  1. Testing for diversifying selection for two clades with a background clade

    在利用branch-site检测趋同进化的时候 .可以将各个趋同进化枝分别进行检测,分析的时候不去除某一趋同枝系 .在分析的时候,需要去除其他趋同枝系的影响 I have sequences of a ...

  2. SDR软件无线电知识要点(三)EVM

    SDR软件无线电知识要点(三)EVM 信号质量如何评估 Noise Figure (NF) or sensitivity and Error Vector Magnitude (EVM) provid ...

  3. Linux入门——基础系统设置命令

    以下为centos7实验环境 1.网卡管理工具命令——nmcli 参考:http://www.iteye.com/topic/1141839 2.主机名称设置——hostnamectl [root@s ...

  4. flex tooltip css

    <?xml version="1.0"?> <!-- tooltips/ToolTipStyleManager.mxml --> <mx:Applic ...

  5. 2016-2017-2 20155302 实验四 Android 开发基础

    2016-2017-2 20155302 实验四 Android 开发基础 实验内容 1.下载和安装Android Studio 2.学会使用Android Studio进行简单的Android开发 ...

  6. python开源IP代理池--IPProxys

    今天博客开始继续更新,谢谢大家对我的关注和支持.这几天一直是在写一个ip代理池的开源项目.通过前几篇的博客,我们可以了解到突破反爬虫机制的一个重要举措就是代理ip.拥有庞大稳定的ip代理,在爬虫工作中 ...

  7. js插件实现一键复制功能

    clipboard.js 可以实现纯 JS 的从浏览器复制文本到系统剪贴板的功能. 使用方法: 1. 下载 clipboard.js,并在页面中引入该插件.clipboard.js 下载地址: htt ...

  8. VirtualBox主机和虚拟机互相通信

    默认情况下VirtualBox虚拟机网络设置为网络地址转换,虚拟机中的地址一般是10.0.2.x,虚拟机中访问主机只需要访问默认网关地址即可,但是主机访问虚拟机就需要增加一些配置了,方法有以下几种: ...

  9. html面试题总结

    1.请描述一个网页从开始请求到最终显示的完整过程? 1).在浏览器中输入网址: 2).发送至DNS服务器并获得域名对应的WEB服务器的IP地址: 3).与WEB服务器简历TCP连接: 4).浏览器向W ...

  10. Python列表推导式和嵌套的列表推导式

    列表推导式提供了一个更简单的创建列表的方法.常见的用法是把某种操作应用于序列或可迭代对象的每个元素上,然后使用其结果来创建列表,或者通过满足某些特定条件元素来创建子序列. 例如,假设我们想创建一个平方 ...