WORDPRESS 后台500错误解决方法集合
这篇文章本质上我是不可能会写到,就因为7号那天晚上,我准备搬家的时候,发现前台完好,进入后台却500错误。
这时我就得急的,毕竟明天我就准备去住校上学了,恐怕没时间在去折腾网站,于是我重新安装WordPress 程序,然后还原数据,把图片、附件、插件等这些必备的恢复了,结果开心打开后台却伤心的看结果,还是这样,于是立马百度了下,虽然解决方法有很多,我都一一去做了,但是后台仍然是500,我相信这数字我会永远记得的。不过我一番折腾后,发现当我没把插件上传的时候,后台竟然神奇又淫.荡般的可以访问了。然后我又把插件上传进去时,又发现无法访问了,又是个神奇的数字500,我认定是插件问题了,于是我把插件一个一个上传,发现到上传“all-in-one-seo-pack”插件时,后台立即提示500错误。没错,就是这插件引起的,我立马停用了。
一、all-in-one-seo-pack 插件介绍
All in One SEO Pack能帮助你优化,帮助你在搜索引擎中的收录的插件,用这一个插件你就可以实现 wordpress 的整体优化。不需要 title 插件,meta 插件,tag 插件,也不需要 DupPrevent Plugin 插件,更不用担心因为插件的交替所带来的一堆麻烦。
- 能为每篇文章添加独立的关键词;
- 能为每篇文章添加独立的meta标签;
- 能为每篇文章添加独立的description;
- 能为每篇文章添加独立的摘要;
- 能为每篇文章自动生成摘要;
- 能防止存档页和首页的内容被抓取,从而防止因重复内容被google降权。
当然出现后台无法访问显示500错误的原因可能是我操作错误的原因,或是备份时没把插件停用,总之如果你们出现后台500错误的问题,而且又装了“all-in-one-seo-pack”插件的话,可以按我这样做,把这个插件名更改下,后台在激活。
我在百度看到的其他引起500页面错误的解决方法
二、Wordpress 目录下的权限问题
将Wordpress目录下全部文件权限设置为755。因为500错误的原因之一就在于访问的资源权限被设置成了777,这样的设置本身就很危险,服务器为了确保安全就会拒绝访问。当然还有更稳妥的方法就是把文件夹属性设置为755,文件设置为644.
三、.htaccess文件有错误
WordPress根目录下.htaccess文件有错误,通常是因为写入了不合语法的规则。尤其是安装了 WP super cache 这个插件之后就容易出现这样的错误。备份原来的 .htaccess 文件,新建一个 .htaccess 或者编辑服务器上的原文件,清空其中内容,修改属性为0666,然后在 wordpress 后台的设置–固定链接管理中,更新永久链接即可。
总结
WordPress 强大,WordPress 插件更强大,就算在强大的插件也难免会出现一些兼容问题,使用新插件时最好先在本地测试后在上传使用,避免一些不必要的麻烦,我希望此文能给和我同样出现错误的朋友一个帮助,网上的方法不多,也没有人在发布这类的文章,所以说,如果你出现了这问题,并且本文帮助了你,请留下脚印。
WORDPRESS 后台500错误解决方法集合的更多相关文章
- 【Linux】Gitlab库已损坏前端显示500错误解决方法
背景: 在进行gitlab数据迁移之后,所有页面正常访问,唯独在访问项目repo地址时,报500错误 1 查看日志: 命令查看: gitlab-ctl tail 或者手动查看:/var/log/git ...
- ASP 500错误解决方法
最有效的解决方法: 经 c:\windows\temp 目录增加everyone写权限. 环境: windows2008
- Gitlab库已损坏前端显示500错误解决方法
1.问题起因 办公网机房意外断掉,导致gitlab库文件损坏.开发打开gitlab显示500 2.查看日志 命令查看:gitlab-ctl tail 或者手动查看:/var/log/gitlab/gi ...
- APACHE服务器500错误解决方法
1.APACHE没开启rewrite模块. 解决办法:编辑apache的http.conf文件,找到#LoadModule rewrite_module modules/mod_rewrite.so, ...
- CentOS 7 编译错误解决方法集合
解决 error: the HTTP XSLT module requires the libxml2/libxslt 错误 yum -y install libxml2 libxml2-dev yu ...
- idea运行Tomcat的servlet程序时报500错误解决方法
今天在测试使用Tomcat运行servlet小程序时,在传递参数时,出现了如上错误. 开始我以为是配置出了问题,就把项目删除了又建立了一遍,结果亦然. 经过仔细排查,发现问题,先说明问题原因:idea ...
- IIS 配置错误解决方法集合
问题:405 - 不允许用于访问此页的 HTTP 谓词 解决:IIS处理程序映射中添加模块映射,模块选择:ServerSideIncludeModule,名称:SSINC-HTML
- 【Linux】LNMP1.6 环境报500错误解决方法
vi /usr/local/nginx/conf/fastcgi.conf 进入编辑fastcgi.conf 找到 fastcgi_param PHP_VALUE "open_base ...
- Nginx的500,502,504错误解决方法
Nginx的500,502,504错误解决方法 一.解决500错误: 1.500错误指的是服务器内部错误,也就是服务器遇到意外情况,而无法履行请求. 2.500错误一般有几种情况: (1)web脚本错 ...
随机推荐
- CodeForces 368B Sereja and Suffixes
题意:给你一个序列,问你从l位置到结尾有多少个不同的数字. 水题,设dp[i]表示从i位置到结尾不同数字的个数,那么dp[i] = dp[i+1] + (vis[a[i]] == 0),在O(n)时间 ...
- opencv保存选择图像中的区域
在自己建立行人检测的图像库时用到,参考别人的修改了一下: #include "opencv2/core/core.hpp" #include "opencv2/highg ...
- java 异常架构图
cu 红色为检查异常,就是eclipse要提示你是try catch 还是throws. 非检查异常,就是/0,nullpointexception,数据越界访问indexOfOutBounds 异常 ...
- 求正整数n所有可能的和式的组合(如;4=1+1+1+1、1+1+2、1+3、2+1+1、2+2
作者:张小二 nyoj90 ,可以使用递归的方式直接计算个数,也可以通过把满足的个数求出来计数,因为在juLy博客上看到整数划分,所以重写了这个代码,就是列出所m的可能性,提交后正确.acmer的入门 ...
- ubuntu下arm-linux-gcc安装
我下载的地址随便找的,4.4.3版本的,地址:http://www.cr173.com/soft/42654.html#address 1.我放在了/work/tools/ 2.sudo tar x ...
- sed写的命令收集
1. 替换一行字符串. <title name= > <param name="root", value="haha"/> <pa ...
- Hadoop学习记录(2)|HDFS shell命令|体系结构
HDFS的shell 调用文件系统(FS)shell命令使用hadoop fs的形式 所有的FS shell命令使用URI路径作为参数. URI格式是scheme://authority/path.H ...
- HDOJ-ACM1097(JAVA) A hard puzzle
这道题就是HDOJ的1061的变形: 1061 :求n的n次方的个位数 http://www.cnblogs.com/xiezie/p/5596779.html 1097 :求n的m次方的个位数 因此 ...
- Solution for When browse http://xxx/ReportServer Show Error (rsAccessDenied)
Issue: Reporting Services Error The permissions granted to user 'IDEAAM\William' are insufficient fo ...
- 程序员需要掌握哪些IT技能
据Foote Partners的最新调查:如今,你掌握的 IT 技能的多少决定了你薪资的多少,但你不一定非要比开源架构师或Certified Secure Software Life Cycle Pr ...