CentOS安装GlassFish4.0 配置JDBC连接MySQL
转自:http://linux.it.net.cn/CentOS/course/2014/0724/3319.html
版本glassfish-4.0.zip
1、解压,拷贝到指定安装路径
|
unzip glassfish-4.0.zip
cp cp glassfish4 /usr/local/ -rf
|
2、设置glassfish环境变量 Linux学习,http:// linux.it.net.cn
|
vim /etc/profile
export GLASSFISH_HOME=/usr/local/glassfish4
export PATH=.:$PATH:$JAVAHOME/bin:$MYSQLHOME/bin:$GLASSFISH_HOME/bin
source /etc/profle
|
进入/usr/local/glassfish4/glassfish/config,编辑该目录下的asevn.conf文件,在文件末尾加入AS_JAVA="/usr/local/jdk"(值为本机jdk安装路径) Linux学习,http:// linux.it.net.cn
|
AS_JAVA="/usr/jdk1.7.0_60"
|
IT网,http://www.it.net.cn
3、如果不想使用默认domain可在此步骤创建自己的domain,并指定domaindir和admin port
执行如下命令,创建端口为4848,名称为虹盘的domain
|
asadmin create-domain --adminport 4848 hongpan
|
Enter admin user name [Enter to accept default "admin" / no password]>
Bad Network Configuration. DNS can not resolve the hostname: IT网,http://www.it.net.cn
java.net.UnknownHostException: dev: dev: Name or service not known
Using port 4848 for Admin. Linux学习,http:// linux.it.net.cn
Using default port 8080 for HTTP Instance.
Using default port 7676 for JMS.
Using default port 3700 for IIOP. IT网,http://www.it.net.cn
Using default port 8181 for HTTP_SSL. Linux学习,http:// linux.it.net.cn
Using default port 3820 for IIOP_SSL.
Using default port 3920 for IIOP_MUTUALAUTH. IT网,http://www.it.net.cn
Using default port 8686 for JMX_ADMIN. IT网,http://www.it.net.cn
Using default port 6666 for OSGI_SHELL.
Using default port 9009 for JAVA_DEBUGGER.
Distinguished Name of the self-signed X.509 Server Certificate is:
[CN=localhost,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US] IT网,http://www.it.net.cn
Distinguished Name of the self-signed X.509 Server Certificate is:
[CN=localhost-instance,OU=GlassFish,O=Oracle Corporation,L=Santa Clara,ST=California,C=US]
Domain hongpan created. Linux学习,http:// linux.it.net.cn
Domain hongpan admin port is 4848.
Domain hongpan allows admin login as user "admin" with no password.
Command create-domain executed successfully.
4、启动刚才建立的domain虹盘
|
asadmin start-domain hongpan
|
Waiting for hongpan to start .........................
Successfully started the domain : hongpan
domain Location: /usr/local/glassfish4/glassfish/domains/hongpan
Log File: /usr/local/glassfish4/glassfish/domains/hongpan/logs/server.log IT网,http://www.it.net.cn
Admin Port: 4848
Command start-domain executed successfully.
5、修改刚刚创建的domain的admin密码,并使之能够通过web登录到控制台
|
asadmin change-admin-password
|
Linux学习,http:// linux.it.net.cn
Enter admin user name [default: admin]>
Enter the admin password>
Enter the new admin password>
Enter the new admin password again>
Command change-admin-password executed successfully.
Linux学习,http:// linux.it.net.cn
每次操作的时候控制台都提示输入用户名密码,比较麻烦
可以建立密码配置文件
AS_ADMIN_PASSWORD=xxxx
6、开启远程登录权限
|
asadmin enable-secure-admin
|
Enter admin user name>
Enter admin password>
You must restart all running servers for the change in secure admin to take effect.
Command enable-secure-admin executed successfully.
7、重启domain Linux学习,http:// linux.it.net.cn
|
asadmin restart-domain hongpan
|
现在就可通过控制台进行管理了

IT网,http://www.it.net.cn
下面开始配置jdbc连接mysql
1、拷贝连接mysql的jar包到glassfish库目录里
|
1
|
cp mysql-connector-java-5.1.16-bin.jar /usr/local/glassfish4/glassfish/lib/ |
2、重启domain
3、登陆mysql控制台,到JDBC连接池界面
点击new新建JDBC连接池
Linux学习,http:// linux.it.net.cn
配置连接属性
测试连通性
Succeeded IT网,http://www.it.net.cn
4、创建JDBC资源,程序到时候只需要连接JNDI名称即可 IT网,http://www.it.net.cn

下图JNDI Name填写名称,Pools Name选择刚才创建的JDBC连接池。

配置完成,大功告成!
CentOS安装GlassFish4.0 配置JDBC连接MySQL的更多相关文章
- SpringBoot配置JDBC连接MySql数据库的时候遇到了报错:HikariPool-1 - Exception during pool initialization
使用SpringBoot做JAVA开发时,JDBC连接MySql数据库的时候遇到了报错: ERROR 10392 --- [ main] com.zaxxer.hikari.pool.HikariPo ...
- MyEclipse 2013配置JDBC连接mySQL||Tomcat 7.0 8.0 配置 JDBC |配置mysql-connector-java-5.1.16
MyEclipse->Preferences->MyEclipse->Severs->Intergated Sandbox->Myeclipse Tomcat 7(或者T ...
- WampServer 下载以及安装问题 以及配置远程连接MYSQL
WampServer 3.0 下载: http://dl.pconline.com.cn/download/52877-1.html 碰到的问题DDL无法添加,解决方法:MSVCR110.DLL fo ...
- CentOS 6.5上安装GlassFish4.0 过程笔记
CentOS 6.5上安装GlassFish4.0 过程笔记 1.安装JDK, 注意操作系统的位数, 64 or 32: [root@linuxidc ~]# mkdir /usr/java [ro ...
- (Win10)Java,Maven,Tomcat8.0,Mysql8.0.15安装与环境配置,以及IDEA2019.3使用JDBC连接MySQL、创建JavaEE项目
之前用windows+linux的双系统,最近不怎么舒服就把双系统给卸了,没想到除了问题,导致有linux残余,于是就一狠心重装了电脑,又把Java及其相关的一些东西重新装了回来,还好当初存了网盘链接 ...
- JDBC连接MySQL、Oracle和SQL server的配置
什么是JDBC 我们可以将JDBC看作是一组用于用JAVA操作数据库的API,通过这个API接口,可以连接到数据库,并且使用结构化查询语言(SQL)完成对数据库的查找,更新等操作. JDBC连接的流程 ...
- CentOS下php使用127.0.0.1不能连接mysql的解决方法
这篇文章主要介绍了CentOS下php使用127.0.0.1不能连接mysql的解决方法,本文原因是SELINUX导致的连接失败,需要的朋友可以参考下 php代码很简单: 复制代码代码如下: $ser ...
- JDBC连接MySql,配置url报错
使用JDBC连接MySql时出现:The server time zone value '�й���ʱ��' is unrecognized or represents more than one ...
- JDBC连接MySQL 方法 实例及资料收集
JDBC连接MySQL 方法 实例及资料收集 准备工作 首先,安装MySQL,配置用户名和密码,创建数据库. 可参见之前的文章: http://www.cnblogs.com/mengdd/p/315 ...
随机推荐
- 深入浅出Redis(三)高级特性:管道
Redis是一个响应式的服务,当client发送一个请求后,就处于堵塞状态等待Redis返回结果. 这样一次命令消耗的时间就包含三个部分:请求从client到server的时间.结果从server到c ...
- 微信小程序之 ShoppingCart(购物车)
1.项目目录 2.逻辑层 group.js // pages/group/group.js Page({ /** * 页面的初始数据 */ data: { goodslist: [ { id: &qu ...
- InnoDB: Error: io_setup() failed with EAGAIN after 5 attempts
在一台server中以各数据库的备份文件为数据文件启动多个MySQL实例供SQL Review使用. 之前执行一直没有问题(最多的时候有23个MySQL实例同一时候执行).后来新配置了一台server ...
- IEnumerator<TItem>和IEnumerator Java 抽象类和普通类、接口的区别——看完你就顿悟了
IEnumerable 其原型至少可以说有15年历史,或者更长,它是通过 IEnumerator 来定义的,而后者中使用装箱的 object 方式来定义,也就是弱类型的.弱类型不但会有性能问题,最主要 ...
- 谈谈TensorFlow with CPU support or TensorFlow with GPU support(图文详解)
不多说,直接上干货! You must choose one of the following types of TensorFlow to install: TensorFlow with CPU ...
- the first week study
1.In 1989, a man named Guido create "python" as a kind of computer languages. And now we u ...
- mouseout和mouseover、mouseenter和mouseleave
在前端开发中经常会碰到当鼠标放到一个元素上时会弹出你一个元素,鼠标离开那个弹出元素后隐藏.这类效果一般要用到一些鼠标事件,一类是mouseout和mouseover,另一类是mouseen ...
- Android-shareSDK
1.当数据: 地址:http://sharesdk.mob.com/Download 2.集成数据: DOS命令: java -jar QuickIntegrater.jar (输入自己的项目名 ...
- Tomcat9无法启动
闲来无事,重新学习一下Java, 去Tomcat官网下载Tomcat,各种版本,7-8-9,果断下载最新的9,解压后,无需安装,到bin文件夹下启动, 结果总是一闪而过,百度: 1.查看8080是否占 ...
- 临时表 数据在 内存 转移时间 将160秒的创建临时表时间放入定时任务 不到1秒的求和时间 hadoop 引入Hadoop 分布式计算
SELECT SUM(pv) as pv_t FROM 行 112247817表类型 InnoDB自动递增值 1082428327行格式 Compact索引长度 8.60 GB (9,235,93 ...