Linux 基础学习准备

工欲善其事必先利其器,还是买个服务器折腾比较好。

虚拟机和镜像

推荐吾爱的:吾爱虚拟机2.0

CentOS镜像:

Centos国内下载源

http://man.linuxde.net/download/CentOS

http://mirrors.btte.net/centos/7/isos/x86_64/

http://mirrors.cn99.com/centos/7/isos/x86_64/

http://mirrors.sohu.com/centos/7/isos/x86_64/

http://mirrors.aliyun.com/centos/7/isos/x86_64/

http://centos.ustc.edu.cn/centos/7/isos/x86_64/

http://mirrors.neusoft.edu.cn/centos/7/isos/x86_64/

http://mirror.lzu.edu.cn/centos/7/isos/x86_64/

http://mirrors.163.com/centos/7/isos/x86_64/

http://ftp.sjtu.edu.cn/centos/7/isos/x86_64/

版本介绍:

CentOS-7.0-x86_64-DVD-1503-01.iso 标准安装版,一般下载这个就可以了(推荐)

CentOS-7.0-x86_64-NetInstall-1503-01.iso 网络安装镜像(从网络安装或者救援系统)

CentOS-7.0-x86_64-Everything-1503-01.iso 对完整版安装盘的软件进行补充,集成所有软件。(包含centos7的一套完整的软件包,可以用来安装系统或者填充本地镜像)

CentOS-7.0-x86_64-GnomeLive-1503-01.iso GNOME桌面版

CentOS-7.0-x86_64-KdeLive-1503-01.iso KDE桌面版

CentOS-7.0-x86_64-livecd-1503-01.iso 光盘上运行的系统,类拟于winpe

CentOS-7.0-x86_64-minimal-1503-01.iso 精简版,自带的软件最少

参考

虚拟机无法联网可以在VM的虚拟网络编辑器里面还原默认设置

Xshell和Xftp

这两个软件有免费版,但是由限制(这能开4个标签页?)

绿色版:Xshell 6 和Xftp 6

密码:gcfo

不想用Xftp也可以使用lrzsz

sudo yum install -y lrzsz

使用rz上传文件,sz下载文件

配置Java环境

先卸载open-jdk:

查看是否已安装Java

rpm -qa | grep java

卸载:

rpm -e --nodeps java-1.7.0-openjdk-1.7.0.45-2.4.3.3.el6.x86_64

下载JDK1.8:jdk-8u221-linux-x64.tar.gz

云服务器操作:

直接在oracle官网下,会提示登录,登录后会自动下载,把下载暂停赶紧复制下载链接,在云服务器里用wget 复制的链接下载,最后重命名一下文件就好。

解压:

tar -zxvf jdk-8u181-linux-x64.tar.gz -C /usr/local/src

切换到src目录:cd /usr/local/src

重命名:mv jdk* jdk

配环境:

vim /etc/profile

添加内容:

#set java environment
JAVA_HOME=/usr/local/src/jdk1.8.0_181
CLASSPATH=.:$JAVA_HOME/lib.tools.jar
PATH=$PATH:$JAVA_HOME/bin
export JAVA_HOME CLASSPATH PATH

使配置生效:

source /etc/profile

测试:

java

javac

java -version

CentOS 7 下安装MySQL 5.6.45

下载地址:MySQL:https://dev.mysql.com/downloads/mysql/(默认下载最新的8,可以在页面中找到5.6)

CentOS选择:Red Hat Enterprise Linux / Oracle Linux(CentOS为红帽子免费版)

版本选择:Red Hat Enterprise Linux 7 / Oracle Linux 7 (x86, 64-bit)(这里使用CentOS 7 )

分别下载devel client server 三个包( 8 貌似还需要下载common),或者直接下载第一个RPM Bundle包。

安装

1.查看本机安装的MariaDB
rpm -qa | grep mariadb
mariadb-libs-5.5.56-2.el7.x86_64
2.卸载MariaDB
sudo rpm -e --nodeps mariadb-libs-5.5.56-2.el7.x86_64 解压:
tar -xvf MySQL-5.6.45-1.el7.x86_64.rpm-bundle.tar 开始安装:
sudo rpm -ivh MySQL-devel-5.6.45-1.el7.x86_64.rpm
错误:依赖检测失败:
/usr/bin/perl 被 MySQL-server-5.6.45-1.el7.x86_64 需要
perl(Data::Dumper) 被 MySQL-server-5.6.45-1.el7.x86_64 需要安装依赖即可安装成功
或者这个错误:
error: Failed dependencies:
libaio.so.1()(64bit) is needed by MySQL-server-5.6.45-1.el7.x86_64
libaio.so.1(LIBAIO_0.1)(64bit) is needed by MySQL-server-5.6.45-1.el7.x86_64
libaio.so.1(LIBAIO_0.4)(64bit) is needed by MySQL-server-5.6.45-1.el7.x86_64 解决办法安装依赖:
第一个错误
sudo yum install -y perl-Module-Install.noarch
第二个错误
sudo yum install -y libaio 重新安装:
sudo rpm -ivh MySQL-devel-5.6.45-1.el7.x86_64.rpm
sudo rpm -ivh MySQL-server-5.6.45-1.el7.x86_64.rpm
注意看这一行,初始密码在这里
You will find that password in '/root/.mysql_secret'.
查看初始密码
cat /root/.mysql_secret
安装客户端
rpm -ivh MySQL-client-5.6.45-1.el7.x86_64.rpm

配置

  1. 启动mysql:service mysql start
  2. 连接mysql:mysql -uroot -p随机生成的密码 --cat /root/.mysql_secret 查看默认密码
  3. 修改密码:SET PASSWORD=PASSWORD('1234');
  4. 刷新权限
    • grant all privileges on *.* to 'root'@'%' identified by '这里写密码';
    • flush privileges;

打开3306端口:

/sbin/iptables -I INPUT -p tcp --dport 3306 -j ACCEPT

这是CentOS 6的防火墙,CentOS 7 已经使用FireWalld代替了iptables

CentOS 7 关闭防火墙

连接虚拟机数据库前先关闭虚拟机防火墙

sudo systemctl stop firewalld.service//start是开启

或者直接禁用禁用:

systemctl disable firewalld//enable是启用

配置开机自启

加入到系统服务:

chkconfig --add mysql

自动启动:

chkconfig mysql on

查询列表:

chkconfig

查看MySQL运行状态:

service mysql status

控制台修改root密码:mysqladmin -u root -p password 新密码

参考

tar 命令说明

tar命令详解

-c: 建立压缩档案
-x:解压
-t:查看内容
-r:向压缩归档文件末尾追加文件
-u:更新原压缩包中的文件
这五个是独立的命令,压缩解压都要用到其中一个,可以和别的命令连用但只能用其中一个。 下面的参数是根据需要在压缩或解压档案时可选的。
-z:有gzip属性的
-j:有bz2属性的
-Z:有compress属性的
-v:显示所有过程
-O:将文件解开到标准输出
参数-f是必须的 -f: 使用档案名字,切记,这个参数是最后一个参数,后面只能接档案名。

参考

添加用户

新建用户:adduser 用户名

修改密码(root下使用):passwd 用户名

给予sudo 权限:修改文件vi /etc/sudoers

在下方位置添加

## Allow root to run any commands anywhere
root ALL=(ALL) ALL
用户名 ALL=(ALL) ALL

Redis安装

下载:Redis官网:https://redis.io/

安装gcc:yum install -y gcc-c++

解压:tar -zxvf redis-5.0.5.tar.gz

移动源码文件:mv redis-5.0.5 /usr/local/src

进入目录:redis-5.0.5

编译:make

安装到指定目录:make PREFIX=/usr/local/src/redis install

拷贝redis.conf到安装目录bin下:cp redis.conf ../redis/bin/

修改bin下配置文件:

# 以后端模式启动
daemonize yes
# 注释掉这一句,否则Redis只能本地连接
bind 127.0.0.1
# 下面这里改为no,去除保护模式(或者配置密码或IP)
protected-mode no

后端启动:./redis-server redis.conf

(或者直接前台启动:./redis-server不推荐)

redis客户端:./redis-cli

关闭redis:./redis-cli shutdown,非正常关闭时redis不会持久化,造成数据丢失。

卸载:直接删除安装目录即可。

安装maven

下载Maven:https://maven.apache.org/download.cgi

解压到/usr/local/src下:tar -zxvf apache-maven-3.6.1-bin.tar.gz -C /usr/local/src/

进入目录:cd /usr/local/src/

重命名mv apache-maven-3.6.1 maven

配环境:vim /etc/profile

添加

MAVEN_HOME=/usr/local/src/maven
PATH=$PATH:$JAVA_HOME/bin:$MAVEN_HOME/bin
export JAVA_HOME CLASSPATH PATH MAVEN_HOME

测试:mvn -v

部署web项目

下载Tomcat并解压,一般放在/usr/local/src下,直接运行startup.sh就能启动。

把web文件夹拷入tomcat/webapp/ROOT下,然后启动即可。

在执行./startup.sh的时候可以添加下面的命令吧日志显示在控制台上:

&& tail -f ../logs/catalina.out

最后就可以访问项目了。


最后贴个Linux基础的文章

Linux基础学习准备的更多相关文章

  1. Linux基础练习题(二)

    Linux基础练习题(二) 1.复制/etc/skel目录为/home/tuer1,要求/home/tuser1及其内部文件的属组和其它用户均没有任何访问权限. [root@www ~]# cp -r ...

  2. 大数据每日干货第四天(linux基础之一目录结构与常用命令)

           为了和qq空间同步,也写的第四天,前面几天明天会发布,本来打算把每天学的东西记录下来,通过朋友给的建议要发的话稍微系统化下,从大数据需要的linux基础,到离线数据分析包括hadoop. ...

  3. Linux课程实践一:Linux基础实践(SSH)

    一.SSH服务 1. 安装SSH (1)查看是否已经安装过ssh服务 rpm -qa |grep ssh (2)进行安装 sudo apt-get install openssh-server Ubu ...

  4. 还是不想改报告,伊阿忆啊哟-Linux基础继续

    hi 虽然今天是最最美好的周六(前不着工作日后不着工作日),但老子还要来改报告,但额就是不想改,你拿我有啥办法啊... 争取完结Linux基础 一.Linux常用命令(三) 4.帮助命令 4.1 帮助 ...

  5. 原来今天是感恩节-Linux基础继续&MySQL和PHP

    hi 原来今天是感恩节.虽然一直没有过这个节日的习惯,但仅仅是听到感恩的消息,都能想到一幅幅画面.愿大家安好! 下午开题会议还是有所收获,悄悄的,就变向那个不喜欢自己的人了. 一.Linux基础(二) ...

  6. 买错的电影票,含着泪也得看-LAMP搭建&Linux基础

    hi 没说过,上周五室友过生请客,在龙湖里吃嗨了喝爽了,回去的路上侃侃而谈.说好的这周一起去看年内最后的大片,火星救援的,谁知道老子眼神不好,买错了电影的时间...把周六的约定提前到了今儿个下午,ma ...

  7. Linux基础3(文件权限)

    文件权限 1.普通权限 (登陆用户对文件或目录的读写执行的权限) 普通权限对管理员用户无效 文件和目录 都有4中类型的用户u 所有者 : 文件.目录的创建者g 所属组 : 文件.目录属于的用户组o 其 ...

  8. Linux课程实践一:Linux基础实践(基础操作)

    一.软件源维护 1. 基本操作 (1)查看源列表 sudo vim /etc/apt/sources.list deb:二进制软件安装包 deb-src:源码包 (2)备份软件源列表 sudo cp ...

  9. 实践一:Linux基础实践

    一.Linux基础实践 1.1 1. 掌握软件源的维护方法,配置系统使用软件源镜像.掌握通过软件源来查找,安装,卸载,更新软件的方法. 这部分内容在许多学长学姐的报告里都有很详细的讲解,我在此就不赘述 ...

随机推荐

  1. 1-3SpringBoot之Controller使用

    Controller的使用 @Controller 处理http请求 @RestController Spring4之后新加的注解,原来返回json需要@ResponseBody配合@Controll ...

  2. C#中的扩展类的理解

    扩展类是一种静态的一种类的调用方法,通过实例化进行调用.利用this进行指正该类,有参数的时候直接在后面追加参数. 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 ...

  3. pgsql 查询jsonb中包含某个键值对的表记录

    pgsql 查询jsonb中包含某个键值对的表记录 表名 table_name ,字段 combos 类型为 jsonb 可为空,示例内容如下, $arr_combos = [ ['id' => ...

  4. i春秋-密码-IceCTF-Alien Message

    题目: 对应的解题图片: 解的时候,符号大点的是大写,小点的是小写. IceCTF{gOOd_n3wZ_3vERyoN3_1_L1k3_fU7ur4Ma_4nd_tH3iR_4maZ1nG_3As7e ...

  5. poj 3617 Best Cow Line 贪心模拟

    Best Cow Line Time Limit: 1000MS   Memory Limit: 65536K Total Submissions: 42701   Accepted: 10911 D ...

  6. SQL*Loader-128: SQL*Loader-523

    错误原因: SQL*Loader-128: unable to begin a sessionORA-01017: invalid username/password; logon denied 解决 ...

  7. java实现下划线转驼峰

    废话少说,直接上代码 import java.util.regex.Matcher; import java.util.regex.Pattern; public class Temp { publi ...

  8. [笔记]ul>li>a做分布时, 让其居中显示效果

    结构: <div id="page"> <ul> <li><a href="#">首页</a>< ...

  9. IDA使用初步

    按空格看结构图,再按空格看汇编代码,按F5反编译 shift+F12 搜索中文字符串,通过字符串所在位置定位关键信息. 双击可能出flag的语句跳转至关键字符串. 想F5生成C伪代码,先crtl+X打 ...

  10. 吴裕雄 Bootstrap 前端框架开发——Bootstrap 字体图标(Glyphicons):glyphicon glyphicon-fast-forward

    <!DOCTYPE html> <html> <head> <meta charset="utf-8"> <meta name ...