此次安装是在CentOS7下安装Redis5.0.7

一.首先准备Redis安装包

这里下载的是 redis-5.0.7.tar.gz 安装包,并将其直接放在了 root ⽬录下
压缩包下载地址:https://files.cnblogs.com/files/blogs/726807/redis-5.0.7.tar.gz

二.解压安装包

2.1在/data下创建redis文件夹并进入

cd /data/
mkdir redis
cd redis

2.2将安装包解压到/data/redis/中

tar zxvf /root/redis-5.0.7.tar.gz -C /data/redis

解压完之后会在/data/redis/下生成一个redis-5.0.7的文件夹

三.编译并安装

cd /data/redis/redis-5.0.7
make && make PREFIX=/data/redis install

注意:因为缺少相关的包导致编译失败

举例:
1.缺少gcc,则安装gcc

yum -y install gcc

2.make时报如下错误:
zmalloc.h:50:31: error: jemalloc/jemalloc.h: No such file or directory
zmalloc.h:55:2: error: #error "Newer version of jemalloc required"
make[1]: *** [adlist.o] Error 1
make[1]: Leaving directory `/data0/src/redis-2.6.2/src'
make: *** [all] Error 2

原因是jemalloc重载了Linux下的ANSIC的malloc和free函数。解决办法:make时添加参数。

make MALLOC=libc
3.make之后,会出现一句提示Hint: To run 'make test' is a good idea ;

但是不测试,通常是可以使用的。若我们运行make test ,会有如下提示

[devnote@devnote src]$ make test
You need tcl 8.5 or newer in order to run the Redis test
make: ***[test] Error_1

解决办法是用yum安装tcl8.5(或去tcl的官方网站http://www.tcl.tk/下载8.5版本,并参考官网介绍进行安装)

yum -y install tcl

补:问题解决完了最好再重新编译下。

四.将Redis安装为系统服务并后台启动

    [root@localhost redis-5.0.7]# cd utils/
//运行服务脚本 脚本中redis安装路径为/data/redis //此处我全部选择的默认配置即可,有需要可以按需定制!!!
//参考地址:https://files.cnblogs.com/files/blogs/726807/install_server.sh
//可以直接粘贴上我的我把所有用到的Redis的所有配置都放在了/data/redis目录下 说明:为了方便,最好自己配置一下install_server.sh中的路径,就比如后续启动需要的redis-server 和 配置文件6379.conf 把它俩放到建的redis文件夹下,方便查找
[root@localhost utils]# ./install_server.sh

五.查看Redis服务启动情况,并停止Redis服务

	//查看服务状态
systemctl status redis
//停止服务
systemctl stop redis
//结束进程
ps -ef|grep redis
kill -9 PID

六.修改配置文件和修改系统配置(保证redis的远程可以访问)

6.1.编辑redis配置文件

vi /etc/redis/6379.conf(默认配置文件位置,修改自己实际配置文件)

​ vi /data/redis/16379.conf

修改内容:
1.将 bind 127.0.0.1 修改为 0.0.0.0 //修改IP
2.daemonize yes //在后台运行
3.protected-mode 设置成no(默认是设置成yes的, 防止了远程访问,在redis3.2.3版本后)
4.requirepass 123456 //设置密码 可不设置

6.2.关闭防火墙和SELINUX

6.2.1关闭防火墙

1、停止firewalld服务
systemctl stop firewalld 2、禁止firewalld开机启动
systemctl disable firewalld

6.2.2关闭SELINUX

vi /etc/selinux/config
将`SELINUX=enforcing`修改为`SELINUX=disabled`,保存退出

七.启动Redis并远程访问

7.1启动Redis (使用绝对路径启动,一劳永逸,免去一些找不到命令错误)

    /usr/local/bin/redis-server /etc/redis/6379.conf //此处使用的是默认路径
/data/redis/bin/redis-server /data/redis/16379.conf //自己的路径

​ ps -ef|grep redis //查看是否启动成功

7.2远程访问Redis

​ 输入IP,默认端口号6379,密码,测试连接,搞定!

八.设置开机启动Redis(建议设置)

方式 1 vi /etc/rc.d/rc.local

添加启动命令到 /etc/rc.d/rc.local 中:
/usr/local/redis-5.0.7/bin/redis-server /etc/redis/redis.conf //此处使用的是默认路径
/usr/local/redis/bin/redis-server /usr/local/redis/6379.conf //自己的路径

​ 方式 2 . vi /lib/systemd/system/redis.service

[Unit]
Description=Redis
After=syslog.target network.target remote-fs.target nss-lookup.target [Service]
Type=forking
#PIDFile=/data/redis/redis.pid
ExecStart=/data/redis/bin/redis-server /data/redis/16379.conf
ExecReload=/bin/kill -s HUP $MAINPID
ExecStop=/bin/kill -s QUIT $MAINPID
ExecStartPost=/bin/sh -c "echo $MAINPID > /data/redis/redis.pid"
PrivateTmp=true [Install]
WantedBy=multi-user.target
//重载系统服务
sudo systemctl daemon-reload

CentOS7.6下安装Redis5.0.7的更多相关文章

  1. Centos7.4下安装Redis5.0

    一.下载Redis Redis下载地址:https://redis.io/download 二.安装依赖包 安装Redis之前需要安装c++命令 yum install gcc-c++ 三.上传并解压 ...

  2. CentOS7源码安装Redis5.0.4非关系型数据库

    源码安装redis-5.0.4 一. 下载redis 1. 需要连接网络 二. 案例(另一种安装方法) [root@localhost ~]# wget http://download.redis.i ...

  3. CentOS7下安装Redis5.0.2

    1.下载redis 地址 http://download.redis.io/releases/redis-5.0.2.tar.gz 2.解压tar -zxf redis-5.0.2.tar.gz 3. ...

  4. CentOS7.6离线安装Redis5.0.4

    安装gcc-c++: 检查是否存在gcc-c++:rpm -qa|grep gcc-c++ 如果不存在就下载Linux-GC-C++文件: 访问镜像网站:http://mirrors.aliyun.c ...

  5. CentOS7.6编译安装redis5.0

    yum install gcc wget http://download.redis.io/releases/redis-5.0.0.tar.gz tar xvf redis-5.0.0.tar.gz ...

  6. Linux下安装Redis5.0.2

    1.下载redis 地址 http://download.redis.io/releases/redis-5.0.2.tar.gz 2.解压tar -zxf redis-5.0.2.tar.gz 3. ...

  7. Linux 下安装 redis5.0

    1.redis 安装 wget http://download.redis.io/rele... tar -zxvf redis-5.0.5.tar.gz cd redis-5.0.5.tar.gz ...

  8. CentOS7.X 下安装MySQL8.0(附文件)

    这是64位的安装包.如果需要32位的可以去官网下载哦.步骤一样 1 获取安装资源包 mysql-8.0.18-1.el7.x86_64.rpm-bundle.tar 链接: https://pan.b ...

  9. centos7/rhel7下安装redis4.0集群

    相关介绍:Redis从3.0版本开始支持集群! 集群一般由多个节点组成,节点数量至少6个才能保证组成完整高可用的集群. 每个节点需要开启配置文件中的cluster-enabled yes,让Redis ...

随机推荐

  1. Dubbo声明式缓存

    为了进一步提高消费者对用户的响应速度,减轻提供者的压力,Dubbo提供了基于结果的声明式缓存.该缓存是基于消费者端的,所以使用很简单,只需修改消费者配置文件,与提供者无关 一.创建消费者07-cons ...

  2. 【Java 基础】Java Enum

    概览 在本文中,我们将看到什么是 Java 枚举,它们解决了哪些问题以及如何在实践中使用 Java 枚举实现一些设计模式. enum关键字在 java5 中引入,表示一种特殊类型的类,其总是继承jav ...

  3. VUE3 之 生命周期函数

    1. 概述 老话说的好:天生我材必有用,千金散尽还复来. 言归正传,今天我们来聊一下 VUE 的生命周期函数. 所谓生命周期函数,就是在某一条件下被自动触发的函数. 2. VUE3 生命周期函数介绍 ...

  4. 声临其境,轻松几步教你把音频变成3D环绕音

    在音乐创作.音视频剪辑和游戏等领域中,给用户带来沉浸式音频体验越来越重要.开发者如何在应用内打造3D环绕声效?华为音频编辑服务6.2.0版本此次带来了空间动态渲染功能,可以将人声.乐器等音频元素渲染到 ...

  5. shell脚本 binlog方式增量备份mysql

    一.简介 源码地址 日期:2018/4/12 介绍:复制Binlog日志方式的增量备份脚本,并保存固定天数的备份 效果图: 二.使用 适用:centos6+ 语言:中文 注意:使用前先修改脚本中变量 ...

  6. Jenkins分布式与并行

    目录 一.简介 二.agent 通过JNLP协议增加agent 通过Swarm插件增加agent agent部分详解 三.agent放入Docker 使用Docker 配置Docker私有仓库 四.并 ...

  7. 打印讲义中的幻灯片编号(O365新功能)

    以下听听文档小程序

  8. CF177A1/A2 Good Matrix Elements 题解

    Content 给定一个 \(n\times n\) 的矩阵,每个元素都有一个值,求出处于两条对角线以及中间行和中间列的元素之和. 数据范围:\(1\leqslant n\leqslant 5(\te ...

  9. centos安装宝塔命令

    yum install -y wget && wget -O install.sh http://download.bt.cn/install/install_6.0.sh & ...

  10. SpringBoot项目给静态变量static注入@Value

    @value不能直接注入值给静态属性,spring 不允许/不支持把值注入到静态变量中:spring支持set方法注入,我们可以利用非静态setter 方法注入静态变量 @Component publ ...