RedHat7上安装MySQL5.7.16
[root@chenguo etc]# rpm -qa|grep -i mysql
[root@chenguo ~]# groupadd mysql
[root@chenguo ~]# useradd -r -g mysql -p root mysql
[chenguo@chenguo ~]$ cd /usr/local/
[chenguo@chenguo local]$ tar -xvf mysql-5.7.-.el7.x86_64.rpm-bundle.tar
mysql-community-libs-compat-5.7.-.el7.x86_64.rpm
mysql-community-devel-5.7.-.el7.x86_64.rpm
mysql-community-minimal-debuginfo-5.7.-.el7.x86_64.rpm
mysql-community-libs-5.7.-.el7.x86_64.rpm
mysql-community-common-5.7.-.el7.x86_64.rpm
mysql-community-embedded-compat-5.7.-.el7.x86_64.rpm
mysql-community-test-5.7.-.el7.x86_64.rpm
mysql-community-embedded-devel-5.7.-.el7.x86_64.rpm
mysql-community-server-minimal-5.7.-.el7.x86_64.rpm
mysql-community-server-5.7.-.el7.x86_64.rpm
mysql-community-client-5.7.-.el7.x86_64.rpm
mysql-community-embedded-5.7.-.el7.x86_64.rpm
[chenguo@chenguo local]$ rpm -qa|grep mariadb
mariadb-libs-5.5.-.el7_0.x86_64
[chenguo@chenguo local]$ su -
[root@chenguo ~]# rpm -e mariadb-libs-5.5.-.el7_0.x86_64 --nodeps
[root@chenguo ~]# rpm -e --nodeps mariadb-libs-5.5.-.el7_0.x86_64
[root@chenguo lib]# su -chenguo
[chenguo@chenguo lib]$ cd /usr/local/
[chenguo@chenguo local]$ rpm -ivh mysql-community-common-5.7.-.el7.x86_64.rpm
warning: mysql-community-common-5.7.-.el7.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
error: can't create transaction lock on /var/lib/rpm/.rpm.lock (Permission denied)
[chenguo@chenguo local]$ su -
[root@chenguo local]# rpm -ivh mysql-community-common-5.7.16-1.el7.x86_64.rpm
warning: mysql-community-common-5.7.16-1.el7.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
Preparing... ################################# [100%]
Updating / installing...
1:mysql-community-common-5.7.16-1.e################################# [100%]
[root@chenguo local]# rpm -ivh mysql-community-libs-5.7.16-1.el7.x86_64.rpm
warning: mysql-community-libs-5.7.16-1.el7.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
Preparing... ################################# [100%]
Updating / installing...
1:mysql-community-libs-5.7.16-1.el7################################# [100%]
[root@chenguo local]# rpm -ivh mysql-community-client-5.7.16-1.el7.x86_64.rpm
warning: mysql-community-client-5.7.16-1.el7.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
Preparing... ################################# [100%]
Updating / installing...
1:mysql-community-client-5.7.16-1.er################################# [100%])
[root@chenguo local]# rpm -ivh mysql-community-server-5.7.16-1.el7.x86_64.rpm
warning: mysql-community-server-5.7.16-1.el7.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5072e1f5: NOKEY
Preparing... ################################# [100%]
Updating / installing...
1:mysql-community-server-5.7.16-1.e################################# [100%]
[root@chenguo bin]# cd /usr/local/bin
[root@chenguo bin]# mysqld --initialize --user=mysql
[root@chenguo bin]# mysqld --initialize-insecure --user=mysql
--18T08::.910921Z [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
--18T08::.912342Z [ERROR] --initialize specified but the data directory has files in it. Aborting.
--18T08::.912368Z [ERROR] Aborting
[root@chenguo bin]# cd /var/lib
[root@chenguo lib]# rm -rf mysql
[root@chenguo local]# cd /usr/local/bin/
[root@chenguo bin]# mysqld --initialize-insecure --user=mysql
[root@chenguo lib]# systemctl start mysqld
Job for mysqld.service failed. See 'systemctl status mysqld.service' and 'journalctl -xn' for details.
[root@chenguo lib]# ls -ld /var/lib/mysql-files
[root@chenguo lib]# mkdir /var/lib/mysql-files
[root@chenguo lib]# systemctl start mysqld
[root@chenguo lib]# chown -R mysql:mysql /var/lib/mysql
[root@chenguo ~]# journalctl |grep mysql
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
# enforcing - SELinux security policy is enforced.
# permissive - SELinux prints warnings instead of enforcing.
# disabled - No SELinux policy is loaded.
SELINUX=enforcing
# SELINUXTYPE= can take one of three two values:
# targeted - Targeted processes are protected,
# minimum - Modification of targeted policy. Only selected processes are protected.
# mls - Multi Level Security protection.
SELINUXTYPE=targeted
[root@chenguo ~]# cd /var/log
[root@chenguo log]# cat mysqld.log
--22T02::.860176Z [ERROR] InnoDB: Operating system error number in a file operation.
--22T02::.860231Z [ERROR] InnoDB: The error means mysqld does not have the access rights to the directory.
--22T02::.860238Z [ERROR] InnoDB: os_file_get_status() failed on './ibdata1'. Can't determine file permissions
--22T02::.860246Z [ERROR] InnoDB: Plugin initialization aborted with error Generic error
--22T02::.471773Z [ERROR] Plugin 'InnoDB' init function returned error.
--22T02::.471974Z [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
--22T02::.472096Z [ERROR] Failed to initialize plugins.
--22T02::.472245Z [ERROR] Aborting
[root@chenguo bin]# ls -ld /usr/sbin/mysqld
-rwxr-xr-x. root root Sep : /usr/sbin/mysqld
[root@chenguo bin]# chown -R mysql:mysql /usr/sbin/mysqld
[root@chenguo bin]# chown -R root:root /usr/sbin/mysqld
[root@chenguo lib]# systemctl start mysqld
[root@chenguo ~]# mysql
mysql> use mysql;
mysql> select host, user from user;
mysql> update user set host = '%' where user = 'root';
mysql> select host, user from user;
mysql> exit
[root@chenguo ~]# mysql
mysql> use mysql;
mysql> select Host,user from user where User='root';
mysql> show variables like 'character%';
+--------------------------+----------------------------+
| Variable_name | Value |
+--------------------------+----------------------------+
| character_set_client | utf8 |
| character_set_connection | utf8 |
| character_set_database | latin1 |
| character_set_filesystem | binary |
| character_set_results | utf8 |
| character_set_server | latin1 |
| character_set_system | utf8 |
| character_sets_dir | /usr/share/mysql/charsets/ |
+--------------------------+----------------------------+
rows in set (0.01 sec)
mysql> exit
[root@chenguo ~]# vi /etc/my.cnf
character-set-server=utf8
collation-server=utf8_general_ci
如果要修改其他的属性可以继续添加:
character-set-server=utf8
collation-server=utf8_general_ci
max_connections=
table_open_cache=
thread_cache_size=
open_files_limit=
event_scheduler=ON group_concat_max_len=
# For advice on how to change settings please see
# http://dev.mysql.com/doc/refman/5.7/en/server-configuration-defaults.html [mysqld]
#
# Remove leading # and set to the amount of RAM for the most important data
# cache in MySQL. Start at % of total RAM for dedicated server, else %.
# innodb_buffer_pool_size = 128M
#
# Remove leading # to turn on a very important data integrity option: logging
# changes to the binary log between backups.
# log_bin
#
# Remove leading # to set options mainly useful for reporting servers.
# The server defaults are faster for transactions and fast SELECTs.
# Adjust sizes as needed, experiment to find the optimal values.
# join_buffer_size = 128M
# sort_buffer_size = 2M
# read_rnd_buffer_size = 2M
datadir=/var/lib/mysql
socket=/var/lib/mysql/mysql.sock
character-set-server=utf8
collation-server=utf8_general_ci
max_connections=
table_open_cache=
thread_cache_size=
open_files_limit=
event_scheduler=ON group_concat_max_len= # Disabling symbolic-links is recommended to prevent assorted security risks
symbolic-links= log-error=/var/log/mysqld.log
pid-file=/var/run/mysqld/mysqld.pid
[root@chenguo ~]# systemctl stop mysqld
[root@chenguo ~]# systemctl restart mysqld
[root@chenguo ~]# mysql
mysql> use mysql
mysql> SHOW VARIABLES LIKE 'event_scheduler';
mysql> SHOW VARIABLES LIKE 'group_concat_max_len';
[root@chenguo ~]# mysql
ERROR (): Access denied for user 'root'@'localhost' (using password: NO)
、命令执行完毕后,mysql就安装完成,下面需要做的就是对mysql 进行初始化
[root@chenguo bin]# cd /usr/local/bin
[root@chenguo bin]# mysqld --initialize --user=mysql
[root@chenguo bin]# mysqld --initialize-insecure --user=mysql
--18T08::.910921Z [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
--18T08::.912342Z [ERROR] --initialize specified but the data directory has files in it. Aborting.
--18T08::.912368Z [ERROR] Aborting
解决办法:
进入/var/lib/目录中查看是否有mysql目录,有的话进行删除:
[root@chenguo bin]# cd /var/lib
[root@chenguo lib]# rm -rf mysql
[root@chenguo local]# cd /usr/local/bin/
[root@chenguo bin]# mysqld --initialize-insecure --user=mysql
[root@chenguo ~]# mysql
mysql> use mysql
mysql> update user set password=PASSWORD('root') where User='root';
ERROR (42S22): Unknown column 'password' in 'field list'
mysql> update user set authentication_string=PASSWORD('root') where User='root';
[root@chenguo ~]# systemctl stop mysqld
[root@chenguo ~]# systemctl restart mysqld
[root@chenguo ~]# mysql -u root -p
Enter password:
RedHat7上安装MySQL5.7.16的更多相关文章
- 在 CentOS7 上安装 MySQL5.7
在 CentOS7 上安装 MySQL5.7 1 通过 SecureCRT 连接到阿里云 CentOS7 服务器: 2 进入到目录 /usr/local/ 中: cd /usr/local/ 3 创建 ...
- 在centos上安装mysql5.7的三种方法
带OS信息的是已编译的二进制文件,不带OS信息的是源码包 mysql-5.7.14-linux-glibc2.5-x86_64.tar.gz 二进制包 mysql-5.5.51.tar.gz 源码包 ...
- CentOS 6.9上安装mysql-5.6.36
CentOS 6.9上安装mysql-5.6.36 1.准备数据存放的文件系统 新建一个逻辑卷,并将其挂载至特定目录即可.这里不再给出过程. 这里假设其逻辑卷的挂载目录为/data,而后需要创建/da ...
- CentOS6.7上安装Mysql5.7
CentOS6.7上安装Mysql5.7 2017年07月22日 18:27:05 阅读数:564 环境的配置总是令人作呕,所以这次表明版本条件: 首先,这是一台新机器 其次,CentOS版本如下: ...
- 通过xshell在linux上安装mysql5.7(终极版)
通过xshell在linux上安装mysql5.7(终极版) 0)通过xshell连接到远程服务器 1)彻底删除原来安装的mysql 首先查看:rpm -qa|grep -i mysql 删除操作(一 ...
- CentOS 6.9上安装mysql-5.6.37
CentOS 6.9上安装mysql-5.6.37 1.准备数据存放的文件系统 新建一个逻辑卷,并将其挂载至特定目录即可.这里不再给出过程. 这里假设其逻辑卷的挂载目录为/data,而后需要创建/da ...
- CentOS7 离线安装mysql-5.7.16
CentOS7 离线安装mysql-5.7.16 1 . 安装新版mysql前,需将系统自带的mariadb-lib卸载 [root@slave mytmp]# rpm -qa|grep mariad ...
- Win7安装MySQL-5.7.16过程
1.在C盘新建MYSQL文件夹:2.将mysql-5.7.16-winx64拷贝到C:\MYSQL文件夹下,更名为mysql-5.7.16:3.在mysql-5.7.16目录下,建my.ini文件,内 ...
- linux上安装mysql5.6
CentOS-6.6+MySQL-5.6 部署环境操作系统:CentOS-6.6-x86_64-bin-DVD1.isoMySQL 版本:mysql-5.6.26.tar.gz操作用户:root系统 ...
随机推荐
- 1001. Exponentiation高精度运算总结
解题思路 这道题属于高精度乘法运算,要求输入一个实数R一个指数N,求实数R的N次方,由于R有5个数位,而N又特别大,因此用C++自带的数据类型放不下. 解题思路是通过数组储存每次乘积结果和底数的每一位 ...
- oracle表空间扩容
oracle在使用中会发现,表空间不足的情况:以下介绍了如何1.查询表空间使用率.剩余量:2.如何扩展表空间容量: 1.表空间容量指标查询 SELECT TABLESPACE_NAME "表 ...
- Xcode新建python项目
1.找到电脑上安装Python的路径.OSX系统默认安装了python,默认的路径为/usr/bin/python.不确定的情况下,也可以打开命令行,用 whereis python 命令查看 2.打 ...
- jdk8的新特性 Lambda表达式
很多同学一开始接触Java8可能对Java8 Lambda表达式有点陌生. //这是一个普通的集合 List<Employee> list = em.selectEmployeeByLog ...
- jQuery的工作原理
jQuery是为了改变javascript的编码方式而设计的. jQuery本身并不是UI组件库或其他的一般AJAX类库. 那么它是如何实现它的声明的呢? 先看一段简短的使用流程: (1).查找(创建 ...
- java复习(1)---java与C++区别
[系列说明]java复习系列适宜有过java学习或C++基础或了解java初步知识的人阅读,目的是为了帮助学习过java但是好久没用已经遗忘了的童鞋快速捡起来.或者教给想快速学习java的童鞋如何应用 ...
- yum仓库
1.概念: Yum仓库则是为进一步简化RPM管理软件难度而设计的,Yum能够根据用户的要求分析出所需软件包及其相关依赖关系,自动从服务器下载软件包并安装到系统 yum的工作原理:执行yum命令――&g ...
- [.NET] 《Effective C#》读书笔记(二)- .NET 资源托管
<Effective C#>读书笔记(二)- .NET 资源托管 简介 续 <Effective C#>读书笔记(一)- C# 语言习惯. .NET 中,GC 会帮助我们管理内 ...
- 03(3) 基于GMM-HMM的SR基础
1.GMM-HMM的训练 1)训练GSM-HMM (1)确定HMM拓扑结构 (2)初始化HMM模型参数 (3)在所有的utterances中计算所需的统计量 (4)使用公式更新模型参数 (5)不收敛, ...
- JS第二弹:用Jquery组装html标签,输出到页面
用Ajax从服务端获取数据,遍历到表格中(其实将表格替换了),中间发现不能为新增的元素绑定事件,原来是没有将其作为JQ对象