oracle错误汇总1
这是遇见的第一个整个库正常,但某张表查询报错的情况
某张表数据可以查,但一排序查就报错
select * from acct_daily_bak;
select * from acct_daily_bak order by open_time desc;
ORA-01578: ORACLE data block corrupted (file # 7, block # 27489)
ORA-01110: data file 7: '/u01/app/oracle/oradata/TESTDB/datafile/o1_mf_kyc_acc_dlzsz7mt_.dbf'
ORA-06512: at line 2
ORA-01578: ORACLE data block corrupted (file # 7, block # 27489)
ORA-01110: data file 7: '/u01/app/oracle/oradata/TESTDB/datafile/o1_mf_kyc_acc_dlzsz7mt_.dbf'
01578. 00000 - "ORACLE data block corrupted (file # %s, block # %s)"
*Cause: The data block indicated was corrupt. This was a physical
corruption, also called a media corruption. The cause is unknown
but is most likely external to the database. If ORA-26040 is also
signaled, the corruption is due to NOLOGGING or UNRECOVERABLE
operations.
*Action: The general method to repair a media corrupt block is to restore
a backup and recover the backup. For databases in ARCHIVELOG
mode, use block media recovery or media recovery. In some situations,
you can also drop the segment and re-create it. For example, you can
drop an index and re-create the index.
可以参照oracle存储结构一文

根据上面的报错重新配置oem就可以了
emca -config dbcontrol db
[oracle@rac01 ~]$ emca -config dbcontrol db STARTED EMCA at Nov 1, 2017 6:27:40 PM
EM Configuration Assistant, Version 11.2.0.3.0 Production
Copyright (c) 2003, 2011, Oracle. All rights reserved. Enter the following information:
Database SID: kyc1
Database Control is already configured for the database kyc1
You have chosen to configure Database Control for managing the database kyc1
This will remove the existing configuration and the default settings and perform a fresh configuration
Do you wish to continue? [yes(Y)/no(N)]: y
Listener ORACLE_HOME [ /oracle/app/oracle/product/11.2.0/db_1 ]:
Password for SYS user:
Password for DBSNMP user:
Password for SYSMAN user:
Email address for notifications (optional):
Outgoing Mail (SMTP) server for notifications (optional):
ASM ORACLE_HOME [ /oracle/app/oracle/product/11.2.0/db_1 ]:
ASM SID [ +ASM ]:
ASM port [ 1521 ]:
ASM username [ ASMSNMP ]:
ASM user password:
----------------------------------------------------------------- You have specified the following settings Database ORACLE_HOME ................ /oracle/app/oracle/product/11.2.0/db_1 Local hostname ................ rac01
Listener ORACLE_HOME ................ /oracle/app/oracle/product/11.2.0/db_1
Listener port number ................ 1521
Database SID ................ kyc1
Email address for notifications ...............
Outgoing Mail (SMTP) server for notifications ...............
ASM ORACLE_HOME ................ /oracle/app/oracle/product/11.2.0/db_1
ASM SID ................ +ASM
ASM port ................ 1521
ASM user role ................ SYSDBA
ASM username ................ ASMSNMP -----------------------------------------------------------------
Do you wish to continue? [yes(Y)/no(N)]: y
Nov 1, 2017 6:30:09 PM oracle.sysman.emcp.EMConfig perform
INFO: This operation is being logged at /oracle/app/oracle/cfgtoollogs/emca/kyc/emca_2017_11_01_18_27_39.log.
Nov 1, 2017 6:30:10 PM oracle.sysman.emcp.util.PortManager isPortInUse
WARNING: Specified port 5541 is already in use.
Nov 1, 2017 6:30:10 PM oracle.sysman.emcp.util.PortManager isPortInUse
WARNING: Specified port 5521 is already in use.
Nov 1, 2017 6:30:10 PM oracle.sysman.emcp.util.PortManager isPortInUse
WARNING: Specified port 5500 is already in use.
Nov 1, 2017 6:30:10 PM oracle.sysman.emcp.util.DBControlUtil stopOMS
INFO: Stopping Database Control (this may take a while) ...
Nov 1, 2017 6:30:31 PM oracle.sysman.emcp.EMReposConfig uploadConfigDataToRepository
INFO: Uploading configuration data to EM repository (this may take a while) ...
Nov 1, 2017 6:32:06 PM oracle.sysman.emcp.EMReposConfig invoke
INFO: Uploaded configuration data successfully
Nov 1, 2017 6:32:06 PM oracle.sysman.emcp.ParamsManager getLocalListener
WARNING: Error retrieving listener for rac01
Nov 1, 2017 6:32:13 PM oracle.sysman.emcp.util.DBControlUtil secureDBConsole
INFO: Securing Database Control (this may take a while) ...
Nov 1, 2017 6:32:22 PM oracle.sysman.emcp.util.DBControlUtil secureDBConsole
INFO: Database Control secured successfully.
Nov 1, 2017 6:32:22 PM oracle.sysman.emcp.util.DBControlUtil startOMS
INFO: Starting Database Control (this may take a while) ...
Nov 1, 2017 6:32:36 PM oracle.sysman.emcp.EMDBPostConfig performConfiguration
INFO: Database Control started successfully
Nov 1, 2017 6:32:36 PM oracle.sysman.emcp.EMDBPostConfig performConfiguration
INFO: >>>>>>>>>>> The Database Control URL is https://rac01:5500/em <<<<<<<<<<<
Nov 1, 2017 6:32:40 PM oracle.sysman.emcp.EMDBPostConfig invoke
WARNING:
************************ WARNING ************************ Management Repository has been placed in secure mode wherein Enterprise Manager data will be encrypted. The encryption key has been placed in the file: /oracle/app/oracle/product/11.2.0/db_1/rac01_kyc/sysman/config/emkey.ora. Ensure this file is backed up as the encrypted data will become unusable if this file is lost. ***********************************************************
Enterprise Manager configuration completed successfully
FINISHED EMCA at Nov 1, 2017 6:32:40 PM
[oracle@rac01 ~]$
scanip不能自动漂移
[oracle@rac02 ~]$ srvctl status scan
SCAN VIP scan1 is enabled
SCAN VIP scan1 is running on node rac02
[oracle@rac02 ~]$ sqlplus / as sysdba SQL*Plus: Release 11.2.0.4.0 Production on Wed Nov 1 18:51:39 2017 Copyright (c) 1982, 2013, Oracle. All rights reserved. Connected to:
Oracle Database 11g Enterprise Edition Release 11.2.0.4.0 - 64bit Production
With the Partitioning, Real Application Clusters, Automatic Storage Management, OLAP,
Data Mining and Real Application Testing options SQL> shutdown immediate; 外网1机 外网2机,老版的sqldeveloper可以看到报错
ORA-01089: 正在执行立即关闭 - 不允许进行任何操作
01089. 00000 - "immediate shutdown in progress - no operations are permitted"
*Cause: The SHUTDOWN IMMEDIATE command was used to shut down
a running ORACLE instance, so your operations have been
terminated.
*Action: Wait for the instance to be restarted, or contact your DBA. ============================= Oracle RAC的VIP和SCAN IP
http://www.cnblogs.com/mawanglin2008/articles/3472395.html
oracle错误汇总1的更多相关文章
- oracle错误汇总2
http://blog.itpub.net/30430420/viewspace-1799925/ ============================= 现象!!!!!!!!!!!!!!!!!S ...
- oracle错误汇总解决
1.ORA-12514 http://blog.sina.com.cn/s/blog_5007d1b10100oqo8.html
- Oracle 异常处理汇总
Oracle 异常处理汇总 1.plsql无法连接 安装oracle,中间录入密码,用户是:sys,pass: 录入的密码. 连接数据库,建议创建新的用户,最好别直接用sys 安装完毕,则需要配置Ne ...
- 64位 SQL Server2008链接访问Oracle 过程汇总解决方法记录
64位 SQL Server2008链接访问Oracle 过程汇总解决方法记录 经过几天不停的网上找资料,实验,终于联通了. 环境:系统:win 2008 ,SqlServer2008 R2, 连接O ...
- Oracle异常汇总
持续更新中,可参见https://hnuhell.gitbooks.io/oracle_errmg/content/或https://hnuhell.github.io/Oracle_ERRMG/上的 ...
- Entity Framework学习笔记——错误汇总
之前的小项目做完了,到了总结经验和更新学习笔记的时间了.开始正题之前先啰嗦一下,对之前的学习目标进行一个调整:“根据代码生成表”与“生成数据库脚本和变更脚本”合并为“Code First模式日常使用篇 ...
- (转)对Oracle导出文件错误和DMP文件结构的分析,EXP-00008: 遇到 ORACLE 错误 904 ORA-00904: "MAXSIZE": invalid identifier
EXP-00008: 遇到 ORACLE 错误 904 ORA-00904: "MAXSIZE": invalid identifier 原因:oracle版本不一样 执行 C:/ ...
- Oracle错误:ORA-01033
Oracle错误:ORA-01033 错误编码:ORA-01033: ORACLE initialization or shutdown in progress 故障描述:因为移动了数据库文件([NA ...
- 李洪强iOS开发之OC常见错误汇总
// // main.m // 16 - 常见错误汇总 // // Created by vic fan on 16/7/13. // Copyright © 2016年 李洪强. All r ...
随机推荐
- R导出图后用AI和PS处理
1)使用pdf()函数导出后,用AI打开,首先是将选中所有要用到的元素,组合为一个文件,然后设置为你最终要的大小,比如你要180mm,那么可以考虑设置为178,因为要留个窄窄的边. 2)然后设置字体和 ...
- trueStudio中使用printf函数
1.通过printf输出浮点数需要如下设置: 在工程属性下找到C/C++ build->Settings->Tool Settings->C Linker->Miscellan ...
- HSV色彩空间和颜色分量范围
部分来自: https://wenku.baidu.com/view/eb2d600dbb68a98271fefadc.html http://blog.csdn.net/Taily_Duan/art ...
- ionic 解决APP安装到android上 状态栏显示黑色
首先移除原本的 cordova-plugin-statusbar 运行命令: cordova plugin rm cordova-plugin-statusbar 最后需要重新安装: cordova ...
- Django-2.1基础操作
创建项目 安装django pip3 install django #查看django版本 django-admin --version python -m django --version 2.1. ...
- laravel框架中的邮箱发送
1.设置邮件服务器登录 163邮箱设置 POP3/SMTP/IMAP勾选:POP3/SMTP服务 IMAP/SMTP服务 保存 设置客户端授权密码 2.在laravel中配置服务器 打开.env文件 ...
- Flask之勾子,错误捕获以及模板语法
请求勾子 在客户端和服务器交互的过程中,有些准备工作或扫尾工作需要处理,比如: 在请求开始时,建立数据库连接: 在请求开始时,根据需求进行权限校验: 在请求结束时,指定数据的交互格式: 为了让每个视图 ...
- 『TensorFlow』读书笔记_VGGNet
VGGNet网络介绍 VGG系列结构图, 『cs231n』卷积神经网络工程实践技巧_下 1,全部使用3*3的卷积核和2*2的池化核,通过不断加深网络结构来提升性能. 所有卷积层都是同样大小的filte ...
- VMware 虚拟机centos下链接网络配置
1.点击Network Adapter 设置如下图所示,首先我们在虚拟机中将网络配置设置成NAT, 2.计算机右键->管理->服务和应用程序->服务,启动如下两个服务 3.在etc/ ...
- centos7 安装MySQL7 并更改初始化密码
1.官方安装文档 http://dev.mysql.com/doc/mysql-yum-repo-quick-guide/en/ 2.下载 Mysql yum包 http://dev.mysql.co ...