Docker 启动遇到 Error starting daemon: Error initializing network controller 错误
docker 版本 1.10.3
一台装有 docker 的机器重启后,没法启动,/var/log/messages 展示如下错误信息:
May 17 11:11:14 gziba-hc03 systemd: Starting Docker Storage Setup...
May 17 11:11:14 gziba-hc03 docker-storage-setup: INFO: Volume group backing root filesystem could not be determined
May 17 11:11:14 gziba-hc03 docker-storage-setup: ERROR: No valid volume group found. Exiting.
May 17 11:11:14 gziba-hc03 systemd: docker-storage-setup.service: main process exited, code=exited, status=1/FAILURE
May 17 11:11:14 gziba-hc03 systemd: Failed to start Docker Storage Setup.
May 17 11:11:14 gziba-hc03 systemd: Unit docker-storage-setup.service entered failed state.
May 17 11:11:14 gziba-hc03 systemd: docker-storage-setup.service failed.
May 17 11:11:14 gziba-hc03 systemd: Starting Docker Application Container Engine...
May 17 11:11:14 gziba-hc03 kernel: bio: create slab <bio-0> at 0
May 17 11:11:14 gziba-hc03 docker-current: time="2018-05-17T11:11:14.758608097+08:00" level=warning msg="devmapper: Usage of loopback dev
ices is strongly discouraged for production use. Please use `--storage-opt dm.thinpooldev` or use `man docker` to refer to dm.thinpooldev
section."
May 17 11:11:14 gziba-hc03 kernel: bio: create slab <bio-2> at 2
May 17 11:11:14 gziba-hc03 systemd: Device dev-disk-by\x2duuid-7c76915b\x2d948d\x2d4e21\x2dac45\x2d2e1431303e50.device appeared twice wit
h different sysfs paths /sys/devices/virtual/block/loop0 and /sys/devices/virtual/block/dm-1
May 17 11:11:14 gziba-hc03 docker-current: time="2018-05-17T11:11:14.764266939+08:00" level=warning msg="devmapper: Base device already e
xists and has filesystem xfs on it. User specified filesystem will be ignored."
May 17 11:11:14 gziba-hc03 docker-current: time="2018-05-17T11:11:14.766234454+08:00" level=info msg="[graphdriver] using prior storage d
river \"devicemapper\""
May 17 11:11:14 gziba-hc03 docker-current: time="2018-05-17T11:11:14.777057144+08:00" level=warning msg="Docker could not enable SELinux
on the host system"
May 17 11:11:14 gziba-hc03 docker-current: time="2018-05-17T11:11:14.796060039+08:00" level=info msg="Graph migration to content-addressa
bility took 0.00 seconds"
May 17 11:11:14 gziba-hc03 docker-current: time="2018-05-17T11:11:14.798926194+08:00" level=info msg="Firewalld running: false"
May 17 11:11:15 gziba-hc03 docker-current: time="2018-05-17T11:11:15.058681393+08:00" level=fatal msg="Error starting daemon: Error initi
alizing network controller: could not delete the default bridge network: network bridge has active endpoints"
May 17 11:11:15 gziba-hc03 systemd: docker.service: main process exited, code=exited, status=1/FAILURE
May 17 11:11:15 gziba-hc03 systemd: Failed to start Docker Application Container Engine.
May 17 11:11:15 gziba-hc03 systemd: Unit docker.service entered failed state.
May 17 11:11:15 gziba-hc03 systemd: docker.service failed.
处理办法:
rm -rm /var/lib/docker/network/
systemctl start docker
Docker 启动遇到 Error starting daemon: Error initializing network controller 错误的更多相关文章
- 解决 docker 报错: Error starting daemon: error initializing graphdriver: backing file system is unsupported for this graph driver
CentOS 7.5 x64下 sudo yum install docker -y systemctl enable docker systemctl start docker 发现启动失败 jou ...
- Error starting daemon: error initializing graphdriver: driver not supported
Error starting daemon: error initializing graphdriver: driver not supported systemctl stop docker rm ...
- Error starting daemon: error initializing graphdriver: devmapper: Device docker-thinpool is not a thin pool
Error starting daemon: error initializing graphdriver: devmapper: Device docker-thinpool is not a th ...
- centos6.6下编译安装mysql5.6之后启动失败:Starting MySQL... ERROR! The server quit without updating PID file (/var/lib/mysql/localhost.localdomain.pid).
今天在编译安装mysql5.6时候出现Starting MySQL... ERROR! The server quit without updating PID file (/var/lib/mysq ...
- linux安装mysql后报错启动不了Starting MySQL. ERROR! The server quit without updating PID file (/var/lib/mysql/localhost.localdomain.pid).
今天安装完Mysql后,开启发生了错误: 2.打开错误信息文件,查看错误原因是:Plugin 'FEDERATED' is disabled. /usr/sbin/mysqld: Table 'mys ...
- docker启动常见报错
Docker启动时的报错汇总 22017.11.10 16:30:29字数 575阅读 27184 八个Docker常见故障 https://mp.weixin.qq.com/s/2GNKmRJtBG ...
- docker启动失败问题
内核3.10,systemctl start docker 被阻塞,没有返回,查看状态为启动中. 某兄弟机器安装docker之后,发现systemctl start docker的时候阻塞,由于排查走 ...
- docker启动报错
1.报“can’t create unix socket /var/run/docker.sock: is a directory” 这是由于存在容器自动启动 --restart= always导致的 ...
- DOCKER启动失败Job for docker.service failed because the control process exited with error code. See "syste mctl status docker.service" and "journalctl -xe" for details.
[root@localhost ~]# systemctl start docker Job for docker.service failed because the control process ...
随机推荐
- Thinking in Java from Chapter 7
From Thinking in Java 4th Edition final 1. 对于基本类型,final使数值恒定不变 2. 对于对象引用,final使引用恒定不变,即不能指向别的对象,但指向的 ...
- string Type
Notes from C++ Primer Operations Operations of string support lots of operations of sequential conta ...
- Python环境搭建详解(Window平台)
前言 Python,是一种面向对象的解释型计算机程序设计语言,是纯粹的自由软件,Python语法简洁清晰,特色是强制用空白符作为语句缩进,具有丰富和强大的库,它常被称为胶水语言. Python是一种解 ...
- 处理ios的overflow滚动bug
先说说这个bug的场景 .container{ height:100vh; overflow-y:scroll; } 没毛病,总有这种类似的情况,需要在容器内滚动,但是!这种容器内的滚动在ios上面处 ...
- 国外青少年最喜爱的聊天 app,竟然是 Google Docs
简评: 这还真不是标题党,Google Docs 的协作中内置了实时聊天的功能,也可以进行 comments,颇有种现代「传纸条」的既视感.其实国内的石墨文档.腾讯文档等协作工具也有类似的效果,本文很 ...
- linux中变量的一些操作方法
常见的一般有如下操作,可以对字符串进行简单操作: echo ${#var}打印变量var长度 echo "$var:3:8" 打印变量var第4个字符开始的8个字符echo ${v ...
- 如何在Mac下配置Github和Bitbucket的SSH
--- title: 如何在Mac下配置Github和Bitbucket的SSH date: 2017-12-23 21:10:30 tags: - Mac - Git - Github catego ...
- UFLDL 教程学习笔记(四)主成分分析
UFLDL(Unsupervised Feature Learning and Deep Learning)Tutorial 是由 Stanford 大学的 Andrew Ng 教授及其团队编写的一套 ...
- C# 常用验证
using System; using System.Collections.Generic; using System.Linq; using System.Text; using System.W ...
- Neo4j使用Cypher查询图形数据
Neo4j使用Cypher查询图形数据,Cypher是描述性的图形查询语言,语法简单,功能强大,由于Neo4j在图形数据库家族中处于绝对领先的地位,拥有众多的用户基数,使得Cypher成为图形查询语言 ...