ORA-19625: error identifying file XXXXX
在RMAN备份全库的时候,将归档日志一同进行备份,结果报如下错误,可以看到是无法获得对应归档日志的报错:
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03002: failure of backup command at 07/05/2017 23:52:03
RMAN-06059: expected archived log not found, loss of archived log compromises recoverability
ORA-19625: error identifying file /oradata/gqtzdb/archivelog/1_173_946166147.dbf
ORA-27037: unable to obtain file status
Linux-x86_64 Error: 2: No such file or directory
Additional information: 3
根据报错,进入对应目录查看,发现确实没有此归档日志。所以此报错的原因可能是人为物理删除了该归档,而在控制文件中还记录此归档的存在,因此需要将此归档信息从控制文件的记载中删除,命令如下:
RMAN> crosscheck archivelog all;
RMAN> delete expired archivelog all;
[oracle@KG-ORA-01 archivelog]$ rman target / Recovery Manager: Release 11.2.0.4.0 - Production on Wed Jul 5 23:56:10 2017 Copyright (c) 1982, 2011, Oracle and/or its affiliates. All rights reserved. connected to target database: GQTZDB (DBID=1719892735) RMAN> crosscheck archivelog all; using target database control file instead of recovery catalog
allocated channel: ORA_DISK_1
channel ORA_DISK_1: SID=288 device type=DISK
validation failed for archived log
archived log file name=/oradata/gqtzdb/archivelog/1_173_946166147.dbf RECID=3870 STAMP=948015057
validation failed for archived log
archived log file name=/oradata/gqtzdb/archivelog/1_174_946166147.dbf RECID=3873 STAMP=948015107
validation failed for archived log
archived log file name=/oradata/gqtzdb/archivelog/1_175_946166147.dbf RECID=3875 STAMP=948015107
validation succeeded for archived log
archived log file name=/oradata/gqtzdb/archivelog/1_38_948016496.dbf RECID=3960 STAMP=948585123
validation succeeded for archived log
archived log file name=/oradata/gqtzdb/archivelog/1_39_948016496.dbf RECID=3962 STAMP=948585123
Crosschecked 5 objects RMAN> delete expired archivelog all; released channel: ORA_DISK_1
allocated channel: ORA_DISK_1
channel ORA_DISK_1: SID=288 device type=DISK
List of Archived Log Copies for database with db_unique_name GQTZDB
===================================================================== Key Thrd Seq S Low Time
------- ---- ------- - ---------
3870 1 173 X 30-JUN-17
Name: /oradata/gqtzdb/archivelog/1_173_946166147.dbf 3873 1 174 X 30-JUN-17
Name: /oradata/gqtzdb/archivelog/1_174_946166147.dbf 3875 1 175 X 30-JUN-17
Name: /oradata/gqtzdb/archivelog/1_175_946166147.dbf Do you really want to delete the above objects (enter YES or NO)? yes
deleted archived log
archived log file name=/oradata/gqtzdb/archivelog/1_173_946166147.dbf RECID=3870 STAMP=948015057
deleted archived log
archived log file name=/oradata/gqtzdb/archivelog/1_174_946166147.dbf RECID=3873 STAMP=948015107
deleted archived log
archived log file name=/oradata/gqtzdb/archivelog/1_175_946166147.dbf RECID=3875 STAMP=948015107
Deleted 3 EXPIRED objects RMAN> RMAN> crosscheck archivelog all; released channel: ORA_DISK_1
allocated channel: ORA_DISK_1
channel ORA_DISK_1: SID=288 device type=DISK
validation succeeded for archived log
archived log file name=/oradata/gqtzdb/archivelog/1_38_948016496.dbf RECID=3960 STAMP=948585123
validation succeeded for archived log
archived log file name=/oradata/gqtzdb/archivelog/1_39_948016496.dbf RECID=3962 STAMP=948585123
Crosschecked 2 objects
再次备份成功。
ORA-19625: error identifying file XXXXX的更多相关文章
- ORA-19502: write error on file "xxxxx", block number xxxx
错误现象: 在ORACLE 10g下为表空间IGNITE_EGVSQL01增加数据文件时,报如下错误: SQL> ALTER TABLESPACE IGNITE_EGVSQL01 AD ...
- ORA-19625: error identifying file
问题描述:rman进行备份的时候,出现报错ORA-19625,无效的文件 1.进行数据库备份,然后就出现了报错,没有这个24号的归档日志 RMAN> run{ 2> allocate ch ...
- rac的一次问题 ORA-01565: error in identifying file '+DATA/bol/spfilebol.ora'
昨天安装的测试环境的rac--2节点 CentOS release 6.8 (Final) SQL*Plus: Release 11.2.0.4.0 Production 今天测试突然出现问题 在ra ...
- 萌新笔记——git的问题(error: object file .git/objects/* is empty...)的解决方案及对git版本库文件的了解
由于操作不当,导致git版本库出了大问题,如下所示: error: object file .git/objects/8b/61d0135d3195966b443f6c73fb68466264c68e ...
- MYSQL 5.7 无法启动(Could not open error log file errno 2)
前两天电脑中毒, 病毒好像把mysql的 log.err 文件给删掉了.然后服务一直启动不了:Could not open error log file errno 2. 然后疯狂百度,搜索的结果大多 ...
- mariadb:InnoDB: Error: log file ./ib_logfile0 is of different size 0 5242880 bytes
mariadb 启动中 InnoDB: Error: log file ./ib_logfile0 is of different size 0 起因:线上正在运行的系统,因为需要调整性能,变更了my ...
- linux下解压大于4G文件提示error: Zip file too big错误的解决办法
error: Zip file too big (greater than 4294959102 bytes)错误解决办法.zip文件夹大于4GB,在centos下无法正常unzip,需要使用第三方工 ...
- Nginx启动报错: could not open error log file: open() &q
启动nginx报如下错误: nginx: [alert] could not open error log file: open() "/usr/local/nginx/logs/error ...
- 报错问题:InnoDB: Error: log file ./ib_logfile0 is of different size
InnoDB: Error: log file ./ib_logfile0 is of different size bytesInnoDB: than specified in the .cnf f ...
随机推荐
- Thermally driven workload scheduling in a heterogeneous multi-processor system on a chip
Various embodiments of methods and systems for thermally aware scheduling of workloads in a portable ...
- _Decoder_Interface_init xxxxxx in amrFileCodec.o
Undefined symbols for architecture arm64: "_Decoder_Interface_init", referenced from: Deco ...
- Popup 解决位置不随窗口/元素FrameworkElement 移动更新的问题
原文:Popup 解决位置不随窗口/元素FrameworkElement 移动更新的问题 Popup弹出后,因业务需求设置了StaysOpen=true后,移动窗口位置或者改变窗口大小,Popup的位 ...
- 一起学Python:网络通信过程
1. 2台电脑的网络 image 说明 如果两台电脑之间通过网线连接是可以直接通信的,但是需要提前设置好ip地址以及网络掩码 并且ip地址需要控制在同一网段内,例如 一台为192.168.1.1另一台 ...
- RabbitMQ 延迟队列实现订单支付结果异步阶梯性通知
在第三方支付中,例如支付宝.或者微信,对于订单请求,第三方支付系统采用的是消息同步返回.异步通知+主动补偿查询的补偿机制. 由于互联网通信的不可靠性,例如双方网络.服务器.应用等因素的影响,不管是同步 ...
- dot net core 使用 usb
原文:dot net core 使用 usb 本文告诉大家如何在 dot net core 使用 usb 目录 获得通知 读写 串口通信 LGPL 首先需要打开 Nuget 安装 CoreCompat ...
- Oracle数据库案例整理-Oracle系统执行失败-sql_trace至TRUE导致Oracle在根文件夹中缺乏可用空间
1.1 述 在"$ORACLE_BASE/diag/rdbms/$ORACLE_SID/$ORACLE_SID/trace"文件夹下产生大量"oracle_w ...
- 零基础WINDOWS
课前准备 我们将会从零基础带领大家一步一步的学习Web前端技术,这个零基础是什么概念呢?你只要具备以下技能就可以学习: 一.个人学习条件(必备) 会开关电脑,手机.(哇塞,任老师你逗我们吧!). 会打 ...
- Android的DDMS中的Threads的各个字段的含义
在使用DDMS调试代码时,Threads窗口中各个字段的含义从网上搜了下,如下所示: 该标签页显示了如下信息: ID – a VM-assigned unique thread ID. In Dalv ...
- http_load测试初阶
http_load的标准的两个例子是: 1. http_load -parallel 5 -fetches 1000 urls.txt 2. http_load -ra ...