首先要看看有没有rsync,没有就按装一个rsync

1配置文件

然后创建rsyncd.conf文件,并添加如下内容(文件默认不存在)

[root@chensiqi2 backup]# cat /etc/rsyncd.conf
#rsync_config_____start
#created by chensiqi : --
##blog:http://www.cnblogs.com/chensiqiqi/
##rsyncd.conf start##
# 用户
uid = rsync
# 组
gid = rsync
# 程序安全设置
use chroot = no
# 客户端连接数
max connections =
# 超时时间
timeout =
# 进程号文件位置
pid file = /var/run/rsyncd.pid
# 进程锁
lock file = /var/run/rsync.lock
# 日志文件位置
log file = /var/log/rsyncd.log
##########################################
[backup]
# 使用目录
path = /backup/
# 有错误时忽略
ignore errors
# 可读可写(true或false)
read only = false
# 阻止远程列表(不让通过远程方式看服务端有啥)
list=false
# 允许IP
hosts allow = 192.168.197.0/
# 禁止IP
hosts deny = 0.0.0.0/
# 虚拟用户
auth users = rsync_backup
# 存放用户和密码的文件
secrets file = /etc/rsync.password
##rsync_config______end##
 

2 创建共享目录及添加rsync程序用户

 [root@chensiqi2 ~]# useradd -M -s /sbin/nologin rsync #创建rsync用户
[root@chensiqi2 ~]# cat /etc/passwd | grep rsync
rsync:x::::/home/rsync:/sbin/nologin
[root@chensiqi2 ~]# cat /etc/group | grep rsync
rsync:x::
[root@chensiqi2 ~]# mkdir /backup #创建共享目录

3将A-Server上的/backup文件夹更改属主rsync

 [root@chensiqi2 ~]# chown -R rsync /backup
[root@chensiqi2 ~]# ls -ld /backup
drwxr-xr-x. rsync root 3月 : /backup

4 创建rsync虚拟账户名和密码

 
  1.  1.5. 创建rsync虚拟账户名和密码
    
     [root@chensiqi2 ~]# echo "rsync_backup:123456" >/etc/rsync.password
    [root@chensiqi2 ~]# cat /etc/rsync.password
    rsync_backup:

5 将账户密码文件的权限设置为600(必须否则失败)

 
    1.  [root@chensiqi2 ~]# chmod  /etc/rsync.password
      2 [root@chensiqi2 ~]# ll /etc/rsync.password
      3 -rw-------. root root 3月 : /etc/rsync.password

6 启动服务:rsync --daemon

 
  1. [root@chensiqi2 ~]# rsync --daemon
    [root@chensiqi2 ~]# netstat -antup | grep rsync
    tcp 0.0.0.0: 0.0.0.0:* LISTEN /rsync
    tcp ::: :::* LISTEN /rsync

7 加入开机启动

 
  1. [root@chensiqi2 ~]# echo "rsync --daemon" >> /etc/rc.local
    [root@chensiqi2 ~]# tail - /etc/rc.local
    rsync --daemon

注意: 
当然还可以用chkconfig rsync on命令,但是必须要编写适合chkconfig操作的脚本才行。

如何重启rsync服务? 
pkill rsync #关闭rsync服务 
rsync --daemon #启动rsync服务

至此rsync服务器端A-server配置完毕

2开始部署rsync服务--Rsync客户端B-Server

 首先客户端也要按rsync

1 只需要创建密码文件

[root@chensiqi ~]# rpm -qa rsync
rsync-3.0.-.el6.x86_64
[root@chensiqi ~]# echo "" > /etc/rsync.password
 

2 将密码文件的权限设置为600(必须否则失败)

[root@chensiqi ~]# chmod  /etc/rsync.password
[root@chensiqi ~]# ls -ld /etc/rsync.password
-rw-------. root root Mar : /etc/rsync.password

至此rsync客户端B-Server配置完毕。

rsync的服务端和客户端搭建的更多相关文章

  1. oauth2.0服务端与客户端搭建

    oauth2.0服务端与客户端搭建 - 推酷 今天搭建了oauth2.0服务端与客户端.把搭建的过程记录一下.具体实现的功能是:client.ruanwenwu.cn的用户能够通过 server.ru ...

  2. Oracle服务端及客户端搭建帮助文档

    Oracle服务端及客户端搭建帮助文档 目录 简介 Oracle服务端安装 Oracle客户端安装 PLSQL安装 登录测试 系统配置修改 用户操作 解锁账户.密码 创建账户及密码 配置监听文件 监听 ...

  3. Centos6.9 搭建rsync服务端与客户端 案例:全网备份项目

    rsync的企业工作场景说明 1)定时备份 1.1生产场景集群架构服务器备份方案项目 借助cron+rsync把所有客户服务器数据同步到备份服务器 2)实时复制 本地数据传输模式(local-only ...

  4. SVN服务端和客户端的安装与搭建

    版权声明:本文为博主原创文章,转载请注明原文出处. https://blog.csdn.net/zzfenglin/article/details/50931462 SVN简介 SVN全名Subver ...

  5. eureka服务端和客户端的简单搭建

    本篇博客简单记录一下,eureka 服务端和 客户端的简单搭建. 目标: 1.完成单机 eureka server 和 eureka client 的搭建. 2.完成eureka server 的添加 ...

  6. (转)SVN 服务端、客户端安装及配置、导入导出项目

    SVN服务器搭建和使用(一) Subversion是优秀的版本控制工具,其具体的的优点和详细介绍,这里就不再多说. 首先来下载和搭建SVN服务器. 现在Subversion已经迁移到apache网站上 ...

  7. linux(centos 6.4)下安装php memcache服务端及其客户端(详细教程)

    前言 在搭建个人博客时,由于没有使用任何框架,纯手工code前台和后台,导致遇到许多问题,其中一个问题就是mysql连接导致的页面相应速度异常低.在查询各种途径后,只能考虑使用memcache缓存.在 ...

  8. 在eclipse中使用jax-ws构建webservices服务端和客户端

    服务端: package com.yinfu.service; import javax.jws.WebService; import javax.xml.ws.Endpoint; @WebServi ...

  9. SVN 服务端 和 客户端

    网址大全  |  EF CodeFirst  |  电视  |  MyNPOI  |  开源  |  我的皮肤  |  ASP.NET MVC4  |  前端提升  |  LINQ  |  WCF   ...

随机推荐

  1. 2016-2017 National Taiwan University World Final Team Selection Contest A - Hacker Cups and Balls

    题目: Dreamoon likes algorithm competitions very much. But when he feels crazy because he cannot figur ...

  2. Gentoo64无法启动eth0的问题

    Gentoo64在net文件中配置好eth0的静态IP 代码 1.2: /etc/conf.d/net文件的一个示例 # DHCP config_eth0=( "dhcp" ) # ...

  3. Python高级语法之:一篇文章了解yield与Generator生成器

    Python高级语法中,由一个yield关键词生成的generator生成器,是精髓中的精髓.它虽然比装饰器.魔法方法更难懂,但是它强大到我们难以想象的地步:小到简单的for loop循环,大到代替多 ...

  4. MBR主引导记录

    LBA的寻址方式可以让我们支持2TB,这是因为分区相对起始扇区号(分区项08-11个字节)和分区最大扇区数(分区项12-15个字节)的位数都是32bit.也就是0xFFFFFFFF*512/1024/ ...

  5. Zoom Me FAQ

    Q: How to config custom shortcuts? A: Enter the preferences setting window from menu bar "Prefe ...

  6. MySQL表损坏修复【Incorrect key file for table】

    今天机房mysql服务器异常关机,重新启动后报错如下: -- :: [ERROR] /usr/local/mysql/bin/mysqld: Incorrect key file for table ...

  7. parted 分区

    Linux下的GPT分区 GPT分区 这是另外一种分区,针对MBR分区,它有很多优点: (1)几乎突破了分区个数的限制. 在GPT分区表中最多可以支持128个主分区. (2)单个分区容量几乎没有限制. ...

  8. 同时打印多个worksheets

    https://support.office.com/en-us/article/print-a-sheet-or-workbook-0f104967-ebce-406f-9c37-d3ab0dc02 ...

  9. mybatis动态sql中的bind绑定

    知识点:bind在模糊查询中的用法 在我的博客    mybatis中使用mysql的模糊查询字符串拼接(like) 中也涉及到bind的使用 <!-- List<Employee> ...

  10. iOS学习-字符串的删除替换

    字符串的常用处理,删除,替换.记录一下,方便查找. -------------------------------------------------------------------------- ...