1、Error Code: 1044 - Access denied for user 'root'@'localhost' to database 'information_schema'Query

今天在导入数据库的时候出现了如下的问题:

Error Code: 1044 - Access denied for user 'root'@'localhost' to database 'information_schema'Query

以前没有遇到过这种问题,在度娘上找了下,唉啊,都是什么鬼啊。 算了出了问题还是自己找吧。仔细分析导入时候的报错信息:对于用户localhost对数据库informationschema的查询是拒绝访问的。 可是我并没有要访问informationschema这个数据库啊,然后就看了一下我导入的过程,原来是把sql文件导入到information_schema数据库了,我擦,这不是我想要的啊,于是在本地新建一个数据库,然后导入,然后就可以了。。。

遇到问题还是要先自己分析,找度娘还不如自己静静看 log日志来的快呢。。。。。

2、mysql自增长为什么会每次加2的原因【转】

今天利用一个临时表自增id做操作的时候,查看数据发现自增是每次加2的。。。不知道是谁设置的这个。。

show variables like '%increment%';

+-------------------------------+-------+
| Variable_name | Value |
+-------------------------------+-------+
| auto_increment_increment | |
| auto_increment_offset | |
| div_precision_increment | |
| innodb_autoextend_increment | |
| ndb_autoincrement_prefetch_sz | |
+-------------------------------+-------+
rows in set (0.01 sec) set auto_increment_increment = 1和set @@auto_increment_increment =
如果想永久性的改回为1,在my.cnf or my.ini中查找这个field,然后修改,然后restart MySQL.

3、使用Navicat for MySQ导出日期时间类型数据,存在格式不同的情况,给后续的导入带来麻烦,其实在导出的时候格式化一下导出的日期时间就好了。

没使用时间格式前导出的数据格式如下:

使用如下sql格式化一下时间就可以了:

SELECT user_id, login_id, opt, type, loginip, DATE_FORMAT(`timestamp`,"%Y-%m-%d %H:%i:%s") as `test` FROM stat_login ORDER BY `timestamp` LIMIT 10;

导出数据的时间与日期如下:

mysql工作中常见问题的更多相关文章

  1. MySQL工作中遇到的问题记录

    1:log_slave_updates: 从库1搭建级联从库2,从库1需要开启log_slave_updates,修改/etc/my.cnf,增加一行log_slave_updates=1,重启数据库 ...

  2. centos shell编程6一些工作中实践脚本 nagios监控脚本 自定义zabbix脚本 mysql备份脚本 zabbix错误日志 直接送给bc做计算 gzip innobackupex/Xtrabackup 第四十节课

    centos   shell编程6一些工作中实践脚本   nagios监控脚本 自定义zabbix脚本 mysql备份脚本 zabbix错误日志  直接送给bc做计算  gzip  innobacku ...

  3. 工作中MySql的了解到的小技巧

    工作中MySql的小技巧 1. 跑脚本时,经常遇到有则更新无插入的 逻辑操作:通常情况下,来一波if()判断然后选择 更新还是插入,前两天逛论坛时发现有人在比较REPLACE INTO 和 INSET ...

  4. 工作中遇到的问题——mysql关于年龄,性别的统计

    终于暂时闲下来了,一个项目加班加点一年多,前面太忙就顾不上博客了,慢慢的就懈怠了,最近算是暂时闲下来了,项目已经验收进入后期维护阶段,每天空余的时间也多了,想重新拾起博客,不求写什么高深的东西,以后就 ...

  5. 【mysql】工作中mysql常用命令及语句

    1.查看mysql版本号 MySQL [release_test_oa]> select version(); +------------+ | version() | +----------- ...

  6. MySQL常见6个考题在实际工作中的运用

    题目一 MyISAM和InnoDB的区别,什么时候选择MyISAM 参考回答 InnoDB是目前MySQL主流版本(5.6.5.7.8.0)默认的存储引擎,支持事务.外键.行级锁,对于并发条件下要求数 ...

  7. mysql数据库开发常见问题及优化

    mysql 数据库是被广泛应用的关系型数据库,其体积小.支持多处理器.开源并免费的特性使其在 Internet 中小型网站中的使用率尤其高.在使用 mysql 的过程中不规范的 SQL 编写.非最优的 ...

  8. MySQL优化技巧之四:mysql数据库开发常见问题及优化[转]

    mysql 数据库是被广泛应用的关系型数据库,其体积小.支持多处理器.开源并免费的特性使其在 Internet 中小型网站中的使用率尤其高.在使用 mysql 的过程中不规范的 SQL 编写.非最优的 ...

  9. MySQL存储引擎的实际应用以及对MySQL数据库中各主要存储引擎的独特特点的描述

    MySQL存储引擎的实际应用以及对MySQL数据库中各主要存储引擎的独特特点的描述: 1.MySQL有多种存储引擎: MyISAM.InnoDB.MERGE.MEMORY(HEAP).BDB(Berk ...

随机推荐

  1. 不兼容:不支持SCSI硬盘

    获取机器硬件失败,可能你使用了SCSI硬盘,请更换一台主机进行安装 聚生网管2.11版本不支持scsi硬盘. 终于体会到了不兼容的麻烦了.

  2. Win7没有防火墙:0x80070422

    在"MSDN我告诉你"下载的官方原版Window7 64位,安装后防火墙是这样的: 点击"使用推荐设置",报错:0x80070422,估计是因为使用PE中的工具 ...

  3. 11g relocate scan ip

    今天安装了Oracle 11.2.0.4的数据库,由于在安装GRID软件是,跑脚本的时候是现在节点2上跑的,跑完之后然后在节点1上跑.发现我的scan_ip在节点2上,我想把scan_ip reloc ...

  4. UVA 10700 Camel trading 无括号的表达式 贪心

    题意:给出只包含数字和+*的表达式,你可以自己安排每一个运算的顺序,让你找出表达式可能得到的最大值和最小值. 很明显,先乘后加是最小值,先加后乘能得到最大值. 其实不是很明显... 证明下: 数字的范 ...

  5. 设置TreeView背景色

    以下为在Csdn上找到的Treeview资源管理器代码,怎样改变其背景色?用:SendMessage SysTreeWindow,TVM_SETBKCOLOR,0,byval RGB(255,255, ...

  6. codeforces Epic Game 题解

    Simon and Antisimon play a game. Initially each player receives one fixed positive integer that does ...

  7. java发送email(含代理方式,ssl方式,传统方式)

    package spring.vhostall.com; import java.security.Security; import java.util.Date; import java.util. ...

  8. AIX常用命令汇总(转)

    在本文中,我将讨论这其中的一些核心命令.其目的旨在为您提供一个可用作便捷参考的列表.虽然这些命令的行为在所有 AIX 版本中都应该相同,但是仅在 AIX 5.3 下对它们进行了测试. 注意:以下段落中 ...

  9. SSO之安装CAS Server

    JA-SIG CAS(Central Authentication Service)为Web应用系统提供了单点登录服务.它的特性包括:一个开放和具有很好文档支持的协议:一个Java开源服务器组件:提供 ...

  10. 在centos (linux) 搭建 eclipse c++开发分环境

    网上说得很多,很烦,操作了很多,总有错误,但解决方案很简单.步骤就下面几步就OK了 安装gcc .g++ yum install gcc yum install gcc-c++ 安装jdk,配置jdk ...