本文记录两个内容:

1.win7下打开端口

2.服务器(2003或者其他老版的系统以2003为例)

测试端口时 可用telnet 命令

侦听端口:
C:\Documents and Settings\administrator>netstat -na
测试端口是否开放:
C:\Documents and Settings\administrator>telnet 127.0.0.1 8500
正在连接到127.0.0.1...不能打开到主机的连接, 在端口 8500: 连接失败

下面开始打开端口:

1.win7下打开端口

win7防火墙例外设置方法

控制面板(右上角选择查看方式为大图标)---防火墙---高级设置---高级设置---出站规则---最右边 新建规则“新建出站规则向导”,在向导的第一步,选择要创建的防火墙规则类型,选择第二个“端口”。

win7防火墙添加端口方法

Win7的防火墙做了比较大升级 设置已经分为入站和出站。下面以开通Tomcat的远程访问8080作为例子。控制面板\所有控制面板项\Windows 防火墙 进入

入站规则设置
第一步 选择 入站规则 然后 新建规则,选择 端口,然后下一步

第二步 选择TCP 选择特定端口 然后输入端口,如有多个端口需要用逗号隔开了 例如:88,8080

第三步,选择允许连接

第四步 选择应用规则的范围

第五步 输入规则名称

出站规则设置
第一步 选择 入站规则 然后 新建规则,选择 端口,然后下一步
第二步 选择TCP 选择特定端口 然后输入端口,如有多个端口需要用逗号隔开了 例如:88,8080
第三步,选择允许连接

第四步 选择应用规则的范围

第五步 输入规则名称

至此,防火墙规则设置完毕,启用即可!
另外win7的 IIS7,只需启用 入站规则:BranchCache 内容检索(HTTP-In)
出站规则: BranchCache 内容检索(HTTP-Out) 即可。

步骤图解:

2.window2003服务器端口开放

远程登陆服务器后,进入控制面板双击防火墙:

点击”例外”选项卡可以看到服务器上已添加的开放端口,点击添加端口。

在弹出的框中输入您需要添加的端口号,例如8080之后点击确定。

这样在例外中就可以看到添加的8080端口号了,点击确定就完成了。

再进入控制面板点击”网络连接”

在本地连接上点击鼠标右键属性,并双击”Internet 协议 (TCP/IP)”

点击” 高级”选项

在弹出的框中点击”选项”,点击”属性”

在TCP/IP筛选的弹出框中,添加TCP协议的端口。例如添加8080,然后点击确定。

可以看到8080端口已经添加完毕,确定后重启服务器就可以生效了。

温馨提示:如果服务器上安装有第三方防火墙(带有防火墙级别),操作级别和步骤等同Windows防火墙操作步骤!

侦听端口:
C:\Documents and Settings\administrator>netstat -na
测试端口是否开放:
C:\Documents and Settings\administrator>telnet 127.0.0.1 8080
正在连接到127.0.0.1...不能打开到主机的连接, 在端口 8080: 连接失败

原文地址

(转)开放window是服务器端口——以8080为例的更多相关文章

  1. 开放本地MYSQL服务器端口

    有时候别人需要连接你的数据库,这个时候你就要开放数据库的端口,让别的主机可以连接上,步骤如下: 1.打开防火墙,新建入站规则,开放MySQL3306端口 2.执行以下两个命令: (1)如果你想允许用户 ...

  2. 开放windows服务器端口-----以打开端口8080为例

    [转载]原文地址:https://blog.csdn.net/spt_dream/article/details/75014619 本文记录两个内容: 1.win7下打开端口 2.服务器(2003或者 ...

  3. Tomcat服务器端口的配置

    一.Tomcat服务器端口的配置 Tomcat的所有配置都放在conf文件夹之中,里面的server.xml文件是配置的核心文件. 如果想修改Tomcat服务器的启动端口,则可以在server.xml ...

  4. tomcat服务器端口冲突问题的解决

    问题:tomcat服务器端口冲突 原因:服务器端口被占用:重启服务器之前原来的服务器没有关闭. 解决方案: 方案一:把占用的端口结束(方便快捷) 在cmd窗口输入命令 netstat -ano (查看 ...

  5. [Mongodb] 借mongodb被入侵勒索事件,谈下Linux服务器端口安全问题

    一.缘由: 最近几天Mongodb勒索事件甚嚣尘上:由于对外网开放访问并且没有开启授权机制被删库.远程拖库.勒索.接着又曝出Elasticsearch被勒索事件,缘由一样,Elasticsearch服 ...

  6. linux 检测服务器端口工具

    #nmp# nmap 127.0.0.1 #netstat# netstat -anlp | grep 22 #telnet# 服务器端口即使处于监听状态,但是防火墙iptables屏蔽了该端口,是无 ...

  7. window 杀固定端口的进程

    window 杀固定端口的进程   一. 查看所有进程占用的端口   在开始-运行-cmd,输入:netstat –ano可以查看所有进程       二.查看占用指定端口的程序   当你在用tomc ...

  8. 【Tomcat】2.配置Tomcat服务器端口和HTTPS

    1.修改XML配置文件 找到Tomcat安装目录下的conf文件夹,打开server.xml文件(可以用笔记本打开) 其中有几行代码如下 <Server port="8005" ...

  9. 配置IPv6公网地址DDNS并开放外网访问端口

    目前使用三大运营商宽带服务都会下发公网IPv6地址,这样我们想要在外网访问家里的路由.NAS等设备就可以直接通过IPv6地址来访问了.但是每次重新拨号后IPv6地址都会改变,而且IPv6的地址很长,这 ...

随机推荐

  1. 《Windows核心编程》第3章——深入理解handle

    本文借助windbg来理解程序中的函数如何使用handle对句柄表进行查询的.所以先要开启Win7下Windbg的内和调试功能. 解决win7下内核调试的问题 win7下debug默认无法进行内核调试 ...

  2. centos中nodejs npm安装cordova

    1.安装cordova npm install -g cordova --registry https://registry.npm.taobao.orgnpm install -g ionic -- ...

  3. String的疑问

    ss[]//var ss:String; 和 Pointer(ss)^ 是不是一个意思呢? 答:不是. ss[]表示第一个字符.如:ss:='abc' 则表示]=Length(ss); Pointer ...

  4. php 文件读取方式

    整理了一下PHP中读取文件的几个方法,方便以后查阅. 1.fread string fread ( int $handle , int $length ) fread() 从 handle 指向的文件 ...

  5. 64位系统VBS调用32位COM组件

    64位系统VBS调用32位COM组件 标签: 32位, 64位, COM, COM组件, VB, VBS, VBScript 标题: 64位系统VBS调用32位COM组件作者: Demon链接: ht ...

  6. C++进阶--命名空间和关键字using

    //############################################################################ /* * C++关键字:using * * ...

  7. Quartz不用配置文件配置启动

    StdSchedulerFactory schedulerFactory = null; try { schedulerFactory = new StdSchedulerFactory(); Pro ...

  8. 【Java安装】配置环境变量

    添加环境变量: JAVA_HOME D:\Program Files\Java\jdk1.8.0_131 classpath: .;%JAVA_HOME%\lib;%JAVA_HOME%\lib\to ...

  9. 资源 Des加密

    Unity3d资源管理分析 http://blog.csdn.net/sgnyyy/article/details/39268215 打包资源 http://www.cnblogs.com/sifen ...

  10. Hadoop错误集:Could not find the main class: org.apache.hadoop.*

    在搭建Hadoop机群的时候,之前遇见了很多次找不到类的错误,因为对Hadoop了解不深,所以就在网上漫无目的的找解决方案,所以这里总结下我用的方法. 解决办法一: 我之前遇到了找不到 org.apa ...