ELK全Dokcer 部署
环境准备:
docker-complete 解压
su root
进入目录 rpm -Uvh *.rpm 安装docker
systemctl start docker
systemctl enable docker
修改docker 镜像存储位置
echo '{"data-root":"/app/docker","insecure-registries":["10.191.51.5"]}' > /etc/docker/daemon.json # 如有需要添加,"storage-driver": "devicemapper"
systemctl daemon-reload
systemctl restart docker.service
useradd -d /app/elastic elastic
passwd elastic
echo 'vm.max_map_count=262144' >> /etc/sysctl.conf
sysctl -p
swarm中若想配置远程访问 、在/usr/lib/systemd/system/docker.service,配置远程访问。主要是在[Service]这个部分,加上下面两个参数
# vim /usr/lib/systemd/system/docker.service
[Service]
ExecStart=
ExecStart=/usr/bin/dockerd -H tcp://0.0.0.0:2375 -H unix://var/run/docker.sock
systemctl daemon-reload
1:将elastic用户加入Docker用户组
groupadd docker
gpasswd -a elastic docker
systemctl restart docker
最后设置docker 开机自启动
2:将docker-compose-Linux-x86_64加入/usr/bin/docker-compose
chmod +x /usr/bin/docker-compose
3:修改存储格式为devicemapper #zookeeper节点必备
vi /etc/sysconfig/docker-storage
DOCKER_STORAGE_OPTIONS="--storage-driver devicemapper "
systemctl restart docker
4:su - elastic
10.194.131.133
elasticsearch
docker run -e ES_JAVA_OPTS="-Xms10G -Xmx10G" -d -p 9200:9200 -p 9300:9300 -v /app/elastic/es_docker/config/es1.yml:/usr/share/elasticsearch/config/elasticsearch.yml -v /app/elastic/es_docker/data1:/usr/share/elasticsearch/data --name ES01 10.191.51.5/elk/elasticsearch
docker run -e ES_JAVA_OPTS="-Xms10G -Xmx10G" -d -p 9201:9201 -p 9301:9301 -v /app/elastic/es_docker/config/es2.yml:/usr/share/elasticsearch/config/elasticsearch.yml -v /app/elastic/es_docker/data2:/usr/share/elasticsearch/data --name ES02 10.191.51.5/elk/elasticsearch
zookeeper
docker run -d --name zookeeper -p 2181:2181 -t 10.191.51.5/elk/wurstmeister/zookeeper:3.4.13
kafka
docker run -d --name kafka1 -p 9092:9092 -e KAFKA_BROKER_ID=1 -e KAFKA_ZOOKEEPER_CONNECT=10.194.131.133:2181 -e KAFKA_ADVERTISED_LISTENERS=PLAINTEXT://10.194.131.133:9092 -e KAFKA_LISTENERS=PLAINTEXT://0.0.0.0:9092 -t 10.191.51.5/elk/wurstmeister/kafka:2.1.1
docker run -d --name kafka2 -p 9093:9093 -e KAFKA_BROKER_ID=2 -e KAFKA_ZOOKEEPER_CONNECT=10.194.131.133:2181 -e KAFKA_ADVERTISED_LISTENERS=PLAINTEXT://10.194.131.133:9093 -e KAFKA_LISTENERS=PLAINTEXT://0.0.0.0:9093 -t 10.191.51.5/elk/wurstmeister/kafka:2.1.1
docker run -d --name kafka3 -p 9094:9094 -e KAFKA_BROKER_ID=3 -e KAFKA_ZOOKEEPER_CONNECT=10.194.131.133:2181 -e KAFKA_ADVERTISED_LISTENERS=PLAINTEXT://10.194.131.133:9094 -e KAFKA_LISTENERS=PLAINTEXT://0.0.0.0:9094 -t 10.191.51.5/elk/wurstmeister/kafka:2.1.1
10.194.131.134
elasticsearch
docker run -e ES_JAVA_OPTS="-Xms10G -Xmx10G" -d -p 9202:9202 -p 9302:9302 -v /app/elastic/es_docker/config/es3.yml:/usr/share/elasticsearch/config/elasticsearch.yml -v /app/elastic/es_docker/data3:/usr/share/elasticsearch/data --name ES03 10.191.51.5/elk/elasticsearch
docker run -e ES_JAVA_OPTS="-Xms10G -Xmx10G" -d -p 9203:9203 -p 9303:9303 -v /app/elastic/es_docker/config/es4.yml:/usr/share/elasticsearch/config/elasticsearch.yml -v /app/elastic/es_docker/data4:/usr/share/elasticsearch/data --name ES04 10.191.51.5/elk/elasticsearch
logtash
docker run -d -p 5044:5044 -p 9600:9600 -it -v /app/elastic/logstash_docker/config/:/usr/share/logstashconfig/ -v /app/elastic/logstash_docker/pipeline/:/usr/share/logstash/pipeline/ 10.191.51.5/elk/logstash:6.5.4
ELK全Dokcer 部署的更多相关文章
- 以太坊geth主网全节点部署
以太坊geth主网全节点部署 #环境 ubuntu 16.4 #硬盘500GB(目前占用200G) #客户端安装 # 查看下载页面最新版 # https://ethereum.github.io/go ...
- Centos6.7 ELK日志系统部署
Centos6.7 ELK日志系统部署 原文地址:http://www.cnblogs.com/caoguo/p/4991602.html 一. 环境 elk服务器:192.168.55.134 lo ...
- [转帖]从壹开始前后端分离【重要】║最全的部署方案 & 最丰富的错误分析
从壹开始前后端分离[重要]║最全的部署方案 & 最丰富的错误分析 https://www.cnblogs.com/laozhang-is-phi/p/beautifulPublish-most ...
- dokcer部署code-server web版vscode
#dokcer部署code-server web版vscode codercom/code-server:latest不支持插件在线安装 codercom/code-server:v2目前为最新版1. ...
- elk的安装部署
Elk日志安装文档 需要用到有三个软件包 和redis 分布式部署:已上图就是分布式部署的架构图 Logstash : 是部署在前台的应用上,收集数据的 和部署在redis和elasticsea ...
- ELK集群部署实例(转)
转载自:http://blog.51cto.com/ckl893/1772287,感谢原博. 一.ELK说明 二.架构图 三.规划说明 四.安装部署nginx+logstash 五.安装部署redis ...
- ELK详细安装部署
一.前言 日志主要包括系统日志和应用程序日志,运维和开发人员可以通过日志了解服务器中软硬件的信息,检查应用程序或系统的故障,了解故障出现的原因,以便解决问题.分析日志可以更清楚的了解服务器的状态和 ...
- ELK+KAFKA安装部署指南
一.ELK 背景 通常,日志被分散的储存不同的设备上.如果你管理数十上百台服务器,你还在使用依次登录每台机器的传统方法查阅日志.这样是不是感觉很繁琐和效率低下.当务之急我们使用集中化的日志管理,例如: ...
- ELK windows下部署测试
操作系统 win7 (当时想在linux下部署,虚拟内存过小,转而在windows下) 版本说明 elasticsearch-6.6.2 (elasticsearch-head-master插件) ...
随机推荐
- MVC中使用viewmodel
新建一个类在类中写 public class DataViewmodel { public List<users> usersmodel { get; set; } public List ...
- MTK刷机快捷键
彻底关机后按住音量下键,连接电脑 无法关机的情况下按住音量上+电源键,手机黑屏后松开电源键,连接电脑,出现进度条后松开音量上键
- jquery中关键字写错导致的错误——dataType写成dateType(data写成date)
由于不会报错,会导致原本servlet后端传回的json字符串不能被正确解析为json格式,而只是显示为字符串. 具体错误表现为:在浏览器Console中显示为字符串,但是在json.cn中可以被正常 ...
- XML fragments parsed from previous mappers already contains value for xxxxx
错误信息: Caused by: org.springframework.core.NestedIOException: Failed to parse mapping resource: 'file ...
- webpack基本用法
1. 压缩代码(production模式) optimization: { minimizer: [new UglifyJsPlugin({ cache: true, parallel: true, ...
- ElementUI DatePicker 日期选择器控制选择时间范围
选择今天以及今天之后的日期 <el-date-picker v-model="value1" type="date" placeholder=" ...
- 「SDOI2017」树点涂色 解题报告
「SDOI2017」树点涂色 我sb的不行了 其实一开始有一个类似动态dp的想法 每个点维护到lct树上到最浅点的颜色段数,然后维护一个\(mx_{0,1}\)也就是是否用虚儿子的最大颜色 用个set ...
- Ticwatch2_3G版省电优化
设置 --> 网络与连接 --> 云消息同步(禁用) 设置 --> 声音与震动 --> 铃声与音量(静音) 设置 --> 声音与震动 --> 闹钟音量(静音) 设置 ...
- Druid.jar包
首先了解一下,什么是Druid. Druid是Java语言中最好的数据库连接池,它能够提供强大的监控和扩展功能. Druid是一个JDBC组件,它包括三部分: 1)DruidDriver 代理Driv ...
- 路径分隔符不一致,导致windows下不能开发
最近想要基于YAPI扩展开发一个自己的API管理平台,但是发现在windows下直接跑会报错,在Mac跑就没事 报的错是: Uncaught TypeError: $export is not a f ...