mysql用root用户启动后其他用户无法启动不问题
问题描述:用root账户启动mysql后,在用mysql用户或其他非root账户启动不了mysql
问题解决:通过看mysql的err日志,发现 Failed to open log (robert-bin.000013, errno 13),
查看错误号[root@robert logs]# perror 13 看到OS error code 13: Permission denied。
cd /data/mysql/mysql_3306/logs,ll看到binlog和err日志权限都变成root,执行chown mysql:mysql -R /data/mysql/mysql_3306/
后,就可以用mysql用户启动啦
问题原因:用root用户启动后,产生的binlog和errlog文件的权限就变啦
案例如下:
[root@robert logs]# mysqld_safe --user=root &
[1] 6064
[root@robert logs]# 141231 09:38:43 mysqld_safe Logging to '/data/mysql/mysql_3306/logs/robert.err'.
141231 09:38:43 mysqld_safe Starting mysqld daemon with databases from /data/mysql/mysql_3306/data
[root@robert logs]# /etc/init.d/mysqld status
MySQL running (6412)[ OK ]
[root@robert logs]#mysqladmin -uroot -p123456 shutdown
[root@robert logs]# /etc/init.d/mysqld start //默认是mysql用户启动,ysqld_safe --user=mysql &
Starting MySQL...The server quit without updating PID file (/data/mysql/mysql_3306/data/robert.localdomain.pid).[FAILED]
[root@robert logs]# tail -f robert.err
141231 08:58:25 mysqld_safe Starting mysqld daemon with databases from /data/mysql/mysql_3306/data
141231 8:58:25 [Note] Plugin 'FEDERATED' is disabled.
141231 8:58:25 InnoDB: The InnoDB memory heap is disabled
141231 8:58:25 InnoDB: Mutexes and rw_locks use GCC atomic builtins
141231 8:58:25 InnoDB: Compressed tables use zlib 1.2.3
141231 8:58:25 InnoDB: Using Linux native AIO
141231 8:58:25 InnoDB: Initializing buffer pool, size = 128.0M
141231 8:58:25 InnoDB: Completed initialization of buffer pool
141231 8:58:25 InnoDB: highest supported file format is Barracuda.
141231 8:58:25 InnoDB: Waiting for the background threads to start
141231 8:58:26 InnoDB: 5.5.37 started; log sequence number 396477665
/usr/local/mysql/bin/mysqld: File '/data/mysql/mysql_3306/logs/robert-bin.000013' not found (Errcode: 13)
141231 8:58:26 [ERROR] Failed to open log (file '/data/mysql/mysql_3306/logs/robert-bin.000013', errno 13)
141231 8:58:26 [ERROR] Could not open log file
141231 8:58:26 [ERROR] Can't init tc log
141231 8:58:26 [ERROR] Aborting
[root@robert logs]# perror 13
OS error code 13: Permission denied //没访问权限
[root@robert logs]#
[root@robert logs]# pwd
/data/mysql/mysql_3306/logs
[root@robert logs]# ll
total 65812
-rw-rw---- 1 mysql mysql 126 Dec 28 10:56 robert-bin.000001
-rw-rw---- 1 mysql mysql 126 Dec 28 10:58 robert-bin.000002
-rw-rw---- 1 mysql mysql 126 Dec 28 11:11 robert-bin.000003
-rw-rw---- 1 mysql mysql 1297 Dec 29 10:05 robert-bin.000004
-rw-rw---- 1 mysql mysql 12592454 Dec 29 10:48 robert-bin.000005
-rw-rw---- 1 mysql mysql 4199546 Dec 29 12:28 robert-bin.000006
-rw-rw---- 1 mysql mysql 16792962 Dec 29 14:01 robert-bin.000007
-rw-rw---- 1 mysql mysql 558 Dec 29 14:19 robert-bin.000008
-rw-rw---- 1 mysql mysql 126 Dec 29 14:22 robert-bin.000009
-rw-rw---- 1 mysql mysql 461 Dec 30 14:09 robert-bin.000010
-rw-rw---- 1 root root 386 Dec 31 08:42 robert-bin.000011
-rw-rw---- 1 root root 126 Dec 31 08:48 robert-bin.000012
-rw-rw---- 1 root root 126 Dec 31 08:50 robert-bin.000013
-rw-rw---- 1 mysql mysql 598 Dec 31 08:49 robert-bin.index
-rw-r----- 1 mysql root 33101 Dec 31 08:58 robert.err
-rw-rw---- 1 mysql mysql 33626181 Dec 31 08:58 robert.log
-rw-rw---- 1 mysql mysql 4421 Dec 31 08:58 robert-slow.log
[root@robert logs]#
[root@robert logs]#
[root@robert logs]# chown mysql:mysql -R /data/mysql/mysql_3306/
[root@robert logs]# ll
total 65812
-rw-rw---- 1 mysql mysql 126 Dec 28 10:56 robert-bin.000001
-rw-rw---- 1 mysql mysql 126 Dec 28 10:58 robert-bin.000002
-rw-rw---- 1 mysql mysql 126 Dec 28 11:11 robert-bin.000003
-rw-rw---- 1 mysql mysql 1297 Dec 29 10:05 robert-bin.000004
-rw-rw---- 1 mysql mysql 12592454 Dec 29 10:48 robert-bin.000005
-rw-rw---- 1 mysql mysql 4199546 Dec 29 12:28 robert-bin.000006
-rw-rw---- 1 mysql mysql 16792962 Dec 29 14:01 robert-bin.000007
-rw-rw---- 1 mysql mysql 558 Dec 29 14:19 robert-bin.000008
-rw-rw---- 1 mysql mysql 126 Dec 29 14:22 robert-bin.000009
-rw-rw---- 1 mysql mysql 461 Dec 30 14:09 robert-bin.000010
-rw-rw---- 1 mysql mysql 386 Dec 31 08:42 robert-bin.000011
-rw-rw---- 1 mysql mysql 126 Dec 31 08:48 robert-bin.000012
-rw-rw---- 1 mysql mysql 126 Dec 31 08:50 robert-bin.000013
-rw-rw---- 1 mysql mysql 598 Dec 31 08:49 robert-bin.index
-rw-r----- 1 mysql mysql 33101 Dec 31 08:58 robert.err
-rw-rw---- 1 mysql mysql 33626181 Dec 31 08:58 robert.log
-rw-rw---- 1 mysql mysql 4421 Dec 31 08:58 robert-slow.log
[root@robert logs]# mysqld_safe --user=mysql &
[1] 6470
[root@robert logs]# 141231 09:40:08 mysqld_safe Logging to '/data/mysql/mysql_3306/logs/robert.err'.
141231 09:40:08 mysqld_safe Starting mysqld daemon with databases from /data/mysql/mysql_3306/data
[root@robert logs]#
[root@robert logs]# /etc/init.d/mysqld status
MySQL running (6818)[ OK ]
注:用root用户启动不mysql,产生的文件权限就是root啦。导致其他用户不能读写,禁用root启动。
mysql用root用户启动后其他用户无法启动不问题的更多相关文章
- sudo passwd root输入普通用户密码后显示用户不再sudoers文件中
在写上一篇VirtualBox创建共享文件夹的时候,在运行下图授权时,root密码一直输入错误 然后我就在终端输入 su root,却发现需要密码,但我却不知道密码是什么 于是我就在终端输入如下命令, ...
- windows环境下,mysql的root密码丢失后重置方法
运行窗口输入 services.msc,检查mysql服务是否启动,如果启动手动停止或输入 net stop mysql 停止msyql服务. 打开cmd命令行,使用cd命令进入mysql 的bi ...
- 用c#开发微信(2)扫描二维码,用户授权后获取用户基本信息 (源码下载)
本文将介绍基于Senparc.Weixin微信开发框架来实现网页授权来获取用户基本信息.先生成包含授权及回调url信息的二维码:用户用微信扫描之后,被要求授权以获取Ta的用户基本信息:用户授权后,通过 ...
- linux tomcat 启动后控制台未显示启动日志
在linux 服务器启动的时候未出现启动日志,这个时候,如果执行startup.sh会出现控制台没有打印任何消息的问题 应该执行: ./catalina.sh run
- Centos7忘记mysql的root用户密码
1.先停止mysql服务 [root@CentOS ~]# ps -ef | grep mysql root : pts/ :: /bin/sh /usr/local/mysql/bin/mysql ...
- MySQL 新建用户,为用户授权,指定用户访问数据库
1.登录MySQL mysql -u root -p 2.添加新用户(允许所有ip访问) create user 'test'@'*' identified by '123456';(test:用户名 ...
- CAS3.5.2 Server登录后返回用户信息详细解决方案
单点登录(Single Sign-On, 简称SSO)是目前比较流行的服务于企业业务整合的解决方案之一,SSO使得在多个应用系统中,用户只需要登录一次就可以访问所有相互信任的应用系统.大家在使用时CA ...
- mysql安装完之后,登陆后发现只有两个数据库
mysql安装完之后,登陆后发现只有两个数据库:mysql> show databases;+--------------------+| Database |+------ ...
- MySQL 设置root密码报错:mysqladmin: connect to server at 'localhost' failed
MySQL 设置root密码报错:mysqladmin: connect to server at 'localhost' failed 1.安装完MySQL设置root密码报错如下 [root@vm ...
随机推荐
- 批量数据上传的sql.xml
<!-- User.xml --><?xml version="1.0" encoding="UTF-8" ?><!DOCTYPE ...
- Java线程状态:BLOCKED与WAITING的区别
Doc说明: /** * Thread state for a thread blocked waiting for a monitor lock. * A thread in the blocked ...
- OpenCV——人脸检测
OpenCV支持的目标检测的方法: 利用样本的Haar特征进行的分类器训练,得到的级联boosted分类器(Cascade Classification) 1.加载级联分类器 CascadeClass ...
- 深入C语言内存区域分配(进程的各个段)详解(转)
原文地址:http://www.jb51.net/article/39696.htm 一般情况下,一个可执行二进制程序(更确切的说,在Linux操作系统下为一个进程单元,在UC/OSII中被称为任务) ...
- [转载]Linux 性能监控、测试、优化工具
Linux 平台上的性能工具有很多,眼花缭乱,长期的摸索和经验发现最好用的还是那些久经考验的.简单的小工具.系统性能专家 Brendan D. Gregg 在最近的 LinuxCon NA 2014 ...
- jquery file upload 后台收到的文件名中文乱码, filename中文乱码
在jQuery File Upload.js文件里,在以下这个js中有个成员叫做 _initXHRData, 是一个function, 在这个function的最后部分有一个if-else分支,如下:
- C# 对类中的保护成员进行写操作(邀请大家拍砖)
假如我有一个类库 Lib,提供一个类 ClassA 对外服务,ClassA 中有若干只读属性 PropA, PropB 等等,外部调用者无法对 ClassA 中的 PropA 和 PropB 进行写操 ...
- shell脚本练习(随机取名)
1.写一个脚本,实现随机选人功能,脚本需传递一个参数进去,如 pick.sh 1 出现结果"家驹” pick.sh 3 出现结果 "落叶" "jason ...
- information_schema.routines 学习
information_schema.routines 用户查看mysql中的routine信息 1.information_schema.routines 表中的常用列: 1.
- inotifywait实现目录监控
http://blog.csdn.net/firefoxbug/article/details/8188804