使用ansible控制Hadoop服务的启动和停止
一、环境:
服务器一台,已安装centos7.5系统,做ansible服务器;
客户机三台:hadoop-master(192.168.1.18)、hadoop-slave1(192.168.1.19)、hadoop-slave2(192.168.1.20)
二、ansible软件安装:
[root@centos75 ~]# yum install ansible
三、ansible配置过程:
1、服务器与客户机之间的免密配置:
(1)生成密钥: ssh-keygen -t rsa
(2)传递密钥:
[root@centos75 ~]# ssh-copy-id -i ~/.ssh/id_rsa.pub root@192.168.1.18
[root@centos75 ~]# ssh-copy-id -i ~/.ssh/id_rsa.pub root@192.168.1.19
[root@centos75 ~]# ssh-copy-id -i ~/.ssh/id_rsa.pub root@192.168.1.20
2、ansible配置
(1)Inventory主机清单配置:
[root@centos75 ~]# vi /etc/ansible/hosts
...
[hadoop]
192.168.1.[18:20] #这是一种IP地址段表示方式,也可单列每个IP地址。
(2)配置ansible.cfg:
[root@centos75 ~]# vi /etc/ansible/ansible.cfg
...
host_key_checking = False #禁用每次执行ansbile命令检查ssh key host
...
log_path = /var/log/ansible.log #开启日志记录
...
[accelerate] #ansible连接加速配置
#accelerate_port = 5099
accelerate_port = 10000
...
accelerate_multi_key = yes
...
deprecation_warnings = False #屏蔽弃用告警提示,减少不必要的信息显示
...
四、测试
[root@centos75 ~]# ansible all -m ping
192.168.1.20 | SUCCESS => {
"changed": false,
"ping": "pong"
}
192.168.1.18 | SUCCESS => {
"changed": false,
"ping": "pong"
}
192.168.1.19 | SUCCESS => {
"changed": false,
"ping": "pong"
}
上述信息表明ansible管理对象已全部ping通,ansible配置正常。
五、使用示例
(1) Ad-Hoc模式:
修改Hadoop三台集群服务器的/etc/hosts文件:
[root@centos75 ~]# vi hosts
#127.0.1.1 hadoop-master
192.168.1.18 hadoop-master
192.168.1.19 hadoop-slave1
192.168.1.20 hadoop-slave2
# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
~
[root@centos75 ~]# ansible hadoop -m copy -a "src=/root/hosts dest=/etc/hosts"
192.168.1.20 | SUCCESS => {
"changed": true,
"checksum": "214f72ce3329805c07748997e11313fffb03f667",
"dest": "/etc/hosts",
"gid": 0,
"group": "root",
"md5sum": "127193e1ec4773ce0195636c5ac2bf3a",
"mode": "0644",
"owner": "root",
"size": 298,
"src": "/root/.ansible/tmp/ansible-tmp-1536384515.76-109467000571031/source",
"state": "file",
"uid": 0
}
192.168.1.18 | SUCCESS => {
"changed": true,
"checksum": "214f72ce3329805c07748997e11313fffb03f667",
"dest": "/etc/hosts",
"gid": 0,
"group": "root",
"md5sum": "127193e1ec4773ce0195636c5ac2bf3a",
"mode": "0644",
"owner": "root",
"size": 298,
"src": "/root/.ansible/tmp/ansible-tmp-1536384515.74-269105082907411/source",
"state": "file",
"uid": 0
}
192.168.1.19 | SUCCESS => {
"changed": true,
"checksum": "214f72ce3329805c07748997e11313fffb03f667",
"dest": "/etc/hosts",
"gid": 0,
"group": "root",
"md5sum": "127193e1ec4773ce0195636c5ac2bf3a",
"mode": "0644",
"owner": "root",
"size": 298,
"src": "/root/.ansible/tmp/ansible-tmp-1536384515.75-259083114686776/source",
"state": "file",
"uid": 0
}
还可使用命令查看各客户机hosts文件内容:
ansible hadoop -m shell -a 'cat /etc/hosts'
ansible hadoop -m shell -a 'ls -lhat /etc/hosts'
(2) playbook剧本模式:
启动Hadoop集群服务:
[root@centos75 ~]# vi hadoop-start.yml
---
#“---”符号在yml文件中只能在开头出现一次,多次出现会报错;另外,此符号省略也可,不知为何,待继续研究...
- hosts: hadoop
#注意:“-”符号后必须有空格;“:”后面也必须有空格。
tasks:
#注意:缩进按两个空格规范,不能使用TAB!
- name: startup hadoop datanode services
shell: /root/hadoop-2.7.3/sbin/hadoop-daemon.sh start datanode #尽管集群服务器上已配置hadoop-2.7.3/sbin的环境变量,但这里必须使用绝对路径
- hosts: 192.168.1.18
tasks:
- name: startup hadoop namenode services
shell: /root/hadoop-2.7.3/sbin/hadoop-daemon.sh start namenode
~
[root@centos75 ~]# ansible-playbook hadoop-start.yml
PLAY [hadoop] ******************************************************************
TASK [Gathering Facts] *********************************************************
ok: [192.168.1.20]
ok: [192.168.1.19]
ok: [192.168.1.18]
TASK [startup hadoop datanode services] ****************************************
changed: [192.168.1.19]
changed: [192.168.1.18]
changed: [192.168.1.20]
PLAY [192.168.1.18] ************************************************************
TASK [Gathering Facts] *********************************************************
ok: [192.168.1.18]
TASK [startup hadoop namenode services] ****************************************
changed: [192.168.1.18]
PLAY RECAP *********************************************************************
192.168.1.18 : ok=4 changed=2 unreachable=0 failed=0
192.168.1.19 : ok=2 changed=1 unreachable=0 failed=0
192.168.1.20 : ok=2 changed=1 unreachable=0 failed=0
可在集群服务器上观察服务启动情况:
root@hadoop-master:~# jps
8976 DataNode
9231 Jps
9093 NameNode
root@hadoop-slave1:~# jps
7058 Jps
6972 DataNode
停止hadoop集群服务:
[root@centos75 ~]# vi hadoop-stop.yml
---
- hosts: hadoop
tasks:
- name: stop hadoop datanode services
shell: /root/hadoop-2.7.3/sbin/hadoop-daemon.sh stop datanode
- hosts: 192.168.1.18
tasks:
- name: stop hadoop namenode services
shell: /root/hadoop-2.7.3/sbin/hadoop-daemon.sh stop namenode
~
[root@centos75 ~]# ansible-playbook hadoop-stop.yml
PLAY [hadoop] ******************************************************************
TASK [Gathering Facts] *********************************************************
ok: [192.168.1.20]
ok: [192.168.1.19]
ok: [192.168.1.18]
TASK [stop hadoop datanode services] *******************************************
changed: [192.168.1.20]
changed: [192.168.1.19]
changed: [192.168.1.18]
PLAY [192.168.1.18] ************************************************************
TASK [Gathering Facts] *********************************************************
ok: [192.168.1.18]
TASK [stop hadoop namenode services] *******************************************
changed: [192.168.1.18]
PLAY RECAP *********************************************************************
192.168.1.18 : ok=4 changed=2 unreachable=0 failed=0
192.168.1.19 : ok=2 changed=1 unreachable=0 failed=0
192.168.1.20 : ok=2 changed=1 unreachable=0 failed=0
上述过程可看出,ansible已实现了对集群服务启停作业的集中控制。
使用ansible控制Hadoop服务的启动和停止的更多相关文章
- 通过命令窗口控制mysql服务的启动与停止
mysql服务的启动: 以管理员的身份运行cmd命令窗口,输入命名 net start mysql 如果不是以管理员的身份运行cmd,会提示如下错误 mysql服务的停止: 以管理员的身份运行cmd命 ...
- Centos7.3_x86_64通过systemctl控制tomcat8.0.46启动和停止
Centos7.3_x86_64通过systemctl控制tomcat8..46启动和停止 之前在centos 6上通过脚本控制tomcat 启动和停止的脚本,虽然在centos 7也可以使用,但ce ...
- Linux上服务的启动,停止和重启
(1)查看所有的服务 [berry@berry:practice] service Usage: service < option > | --status-all | [ service ...
- mysql服务的启动和停止 net stop mysql net start mysql
第一招.mysql服务的启动和停止 net stop mysql net start mysql 第二招.登陆mysql 语法如下: mysql -u用户名-p用户密码 键入命令mysql -uroo ...
- Windows服务之启动、停止、暂停、继续
原文:Windows服务之启动.停止.暂停.继续 Windows服务之启动.停止.暂停.继续 2011-11-09 15:07:37 我来说两句 收藏 我要投稿 [字体:小 大] ...
- Jenkins关闭、重启,Jenkins服务的启动、停止方法。
一.Jenkins关闭.重启 1.关闭Jenkins 只需要在访问jenkins服务器的网址url地址后加上exit,关闭Jenkins服务. 例如:http://localhost:8081/ex ...
- 管理weblogic服务的启动和停止
2012-11-10 12:58 26036人阅读 评论(4) 收藏 举报 分类: WebLogic(10) 版权声明:本文为博主原创文章,未经博主允许不得转载. 目录(?)[+] 介绍 Weblog ...
- linux系统下apache服务的启动、停止、重启命令
本文章简单的介绍了关于linux下在利用命令来操作apache的基本操作如启动.停止.重启等操作,对入门者不错的选择.本文假设你的apahce安装目录为 usr local apache2,这些方法适 ...
- hadoop历史服务的启动与停止
a.配置项(在分布式环境中配置) 1.RPC访问地址 mapreduce.jobhistory.address 2.HTTP访问地址 mapreduce.jobhistory.webapp.addre ...
随机推荐
- Dynamics 365 基于 Sql Server 2017 安装 报表 问题
如果使用SQL2017 安装D365 会发现 SSRS与AD不能在同一台服务器上,因为无法安装SSRS,而无SSRS 则D365是无法继续安装的. 所以解决方法有二个: 1.另外准备一台服务器,不需要 ...
- css实现文字相对于图片垂直居中
一 要实现的样式,文字在图片的垂直居中位置 二 实现的代码: <style> .flag{ position: absolute; bottom: 0; width: 23rem; hei ...
- 201771010113 李婷华 《面向对象程序设计(Java)》第十三周总结
一.理论知识部分 第十一章 事件处理 事件源 (event source):能够产生事件的对象都可 以成为事件源 ,如文本框 .按钮等 .一个事件源是一个能够注册监听器并向发送事件对象的对象. 监听器 ...
- 【Hadoop离线基础总结】oozie的安装部署与使用
目录 简单介绍 概述 架构 安装部署 1.修改core-site.xml 2.上传oozie的安装包并解压 3.解压hadooplibs到与oozie平行的目录 4.创建libext目录,并拷贝依赖包 ...
- Excel开始,Excel结束,R语言居中
入职.离职,总公司调往分公司,分公司调往总公司,每月社保.公积金和上月比较有增减.税局导出的为Excel文件,需要和记录对照一番. 用Excel处理,那就是姓名粘贴为两列,条件格式-重复值,没变色的为 ...
- SpringData表关系:多对多
一.编写实体类配置关联关系: 1.多对多使用注解@ManyToMany配置:a. 在实体中添加一个集合属性 b.在属性上添加ManyToMany注解 c.@JoinTable 注解配置关联关系(nam ...
- Python --函数学习3 (将函数存储在模块中)
将函数存储在模块 函数可以将代码块和主程序分离,通过给函数指定描述性名称,可以让主程序更加容易理解,还可以更进一步,将函数存储在模块的独立文件中,再将模块导入到主程序.import 语句允许再当前运行 ...
- 深入理解Java虚拟机第三版,总结笔记【随时更新】
最近一直在看<深入理解Java虚拟机>第三版,无意中发现了第三版是最近才发行的,听说讲解的JDK版本升级,新增了近50%的内容. 这种神书,看懂了,看进去了,真的看的很快,并没有想象中的晦 ...
- Centos7 下代理配置
对于提供服务的服务器来说,一般都配置在内网环境中,而在内网下公司处于安全的考虑,一般不开放外网的访问权限.这时如果想要访问外网,一般需要配置公司提供的代理服务器再进行使用.下面介绍几种配置代理的方法: ...
- Django模板之认证机制(csrf_token)
csrf认证机制: django中对POST请求,csrf会进行认证处理,csrf认证机制是防御跨站伪造功能,在没有任何处理的前提下,POST请求会报错. csrf认证中间件是在process_vie ...