问题描述:
在LINUX 7.5 的环境上安装12.2.0.1 Restart Grid环境,执行root.sh  报 CLSRSC-400 错误

错误如下:

解决办法:

1. 参考(文档ID 1364419.1)或运行./deinstall   清空原有安装文件

2.  通过以下命令提前对GI_HOME打最新RU补丁

12.2.0.1

The steps for 12.2.0.1 are:

1. Unzip Grid Infrastructure Gold Image to the Desired GI Home Location on the Local Node as the Grid user

2. Download and Install the latest OPatch Version (Patch 6880880) to the extracted GI Gold Image as the Grid user:

Note:  Choose Overwrite ALL when prompted, do NOT remove the old OPatch directory from the GI_HOME prior to extracting
 
$ unzip -d $GI_HOME p6880880_<platform version info>.zip

3. Apply the patch to the Gold Image by running the following as the Grid user:

To apply only Release Updates:

$GI_HOME/gridSetup.sh -applyPSU patch location

To apply only Non-RU patches:

$GI_HOME/gridSetup.sh -applyOneOffs patch location

To apply Release Updates and Non-RU patches in one command:

$GI_HOME/gridSetup.sh -applyPSU patch location -applyOneOffs patch location

 

An example is:

$ ./gridSetup.sh -applyPSU /u01/patch/27100009/

Preparing the home to patch...

Applying the patch /u01/patch/27100009/...

Successfully applied the patch.

备注:11g ,12.1  ,12.2 ,18.1 版本不同,用的参数不一样,详细见文档ID 1410202.1

参考: 12.2 Grid Infrastructure Installation: What's New (文档 ID 2024946.1)

             如何应用网格基础结构修补程序在执行根脚本(root.sh或rootupgrade.sh)之前?(文档ID 1410202.1)

3.  重新运行./gridSetup.sh 安装GRID

-----------------------------------------------------------------------------------------------------------------

备注:如若不提前打补丁,在安装后重启主机,HAS 不会自动重启。在补打最新补丁后,也可修复。

不过,在生产环境,建议还是在安装GRID前,提前打GI_HOME补丁

 

                      

 

<wiz_tmp_tag id="wiz-table-range-border" contenteditable="false" style="display: none;">

 
 
 
 

12.2.0.1 restart环境执行root.sh 报 CLSRSC-400 错误的更多相关文章

  1. RAC安装gird,第一个节点执行root.sh报"The ora.asm resource is not ONLINE"错误

    RAC版本:11.2.0.4 OS版本:linux 6.4 RAC安装gird,第一个节点执行root.sh运行失败,报"The ora.asm resource is not ONLINE ...

  2. RAC执行root.sh报libcap.so.1: cannot open shared object file

    Failed to create keys in the OLR, rc = 127, Message: /opt/app/11.2.0/grid/bin/clscfg.bin: error whil ...

  3. Oracle:Redhat 7.4+Oracle Rac 11.2.0.4 执行root.sh报错处理

    一.报错信息 二.原因分析 因为RHEL 7使用systemd而不是initd运行进程和重启进程,而root.sh通过传统的initd运行ohasd进程 三.解决办法 在RHEL 7中ohasd需要被 ...

  4. 【搭建RAC报错】搭建RAC,第二个节点执行root.sh报错:CRS-2800、CRS-4000

    Creating /etc/oratab file...Entries will be added to the /etc/oratab file as needed byDatabase Confi ...

  5. Oracle 12.2.0.1 RAC for rhel 7.X 数据库安装(节点1执行root.sh失败)

    说明: 最开始是用的rehat7.2安装12.2.0.1,后面安装GI节点一执行root.sh脚本失败,排查原因,最开始以为是操作系统的问题,换成rehat7.6,同样的出现问题,经过一番折腾,后面通 ...

  6. Oracle 12C执行root.sh CLSRSC-119 CRS-8503 CLSRSC-366

    1.环境 OS:SUSE Linux Enterprise 12 SP3 X86_64 (Kernel: 4.4.162-94.69.2) DB:12.2.0.1 两节点RAC 参考文档:在 SLES ...

  7. Oracle 11g RAC 第二节点root.sh执行失败后再次执行root.sh

    Oracle 11g RAC 第二节点root.sh执行失败后再次执行root.sh前,要先清除之前的crs配置信息 # /u01/app/11.2.0/grid/crs/install/rootcr ...

  8. 11.2.0.4 aix下运行第二个节点root.sh报错处理

    第二个节点运行root.sh报错如下 Entries will be added to the /etc/oratab file as needed by Database Configuration ...

  9. 【RAC】安装cluster软件 在节点2执行root.sh脚本

    安装cluster软件  在节点2执行root.sh脚本 报错如下: Running vipca(silent) for configuring nodeapps /db/oracle/product ...

随机推荐

  1. MicroRNA 详解

    MicroRNA研究历史和方法   Views 88 1Report

  2. EXCEL 导入 R 的几种方法 R—readr和readxl包

    导入Excel数据至R语言的几种方法 如有如下Excel数据源,如何将数据导入R语言呢?今天主要来介绍几种常见的方法: 一.使用剪贴板,然后使用read.table函数: 首先选择Excel中的数据源 ...

  3. BBS项目之后台管理

    一:后台管理,添加文章样式编写 创建 一个后台管理模板前段页面 <!DOCTYPE html> <html lang="en"> <head> ...

  4. [GO]使用select实现斐波那契

    package main import "fmt" func fibonacci(ch chan <- int, quit <- chan bool) { x, y : ...

  5. C# GDI+绘图介绍

    最近查阅网上资料,将GDI+的基本知识汇总如下: 一.基本的知识 GDI+:Graphics Device Interface Plus也就是图形设备接口,提供了各种丰富的图形图像处理功能; 在C#. ...

  6. ThinkPhp 生成静态页面

    //开启静态缓存'HTML_CACHE_ON' => true, //开启缓存'HTML_CACHE_TIME' =>60, //开启缓存时间'HTML_FILE_SUFFIX' => ...

  7. [LintCode笔记了解一下]41.Maximum Subarray

    Given an array of integers, find a contiguous subarray which has the largest sum. 首先 當題目涉及到求最大最小值時,最 ...

  8. Hortonwork Ambari配置Hive集成Hbase的java开发maven配置

    集群环境 ambari 2.7.3 hdp/hortonwork 2.6.0.3 maven <dependency> <groupId>org.apache.hive< ...

  9. JVM 方法调用之解析

    方法调用并不等同于方法执行,方法调用阶段唯一的任务就是确定被调用方法的版本(即调用哪一个方法),暂时还没有涉及到方法内部的具体运行过程.在程序运行时,进行方法调用是最普遍最频繁的操作,但Class文件 ...

  10. MongoDb安全配置:简单的身份认证

    mongod默认启动不加任何参数时,是没有身份认证的,任何人都可以登录上进行任何操作 启动时添加--auth可以使用身份验证模式 使用mongod -f mongod.conf配置文件启动时,配置文件 ...