Centos6.x搭建lnmp环境
查看系统版本
#cat /etc/redhat-release
CentOS release 6.7 (Final)
配置静态ip
#vi /etc/sysconfig/network-scripts/ifcfg-eth0
将ONBOOT=no 修改为 ONBOOT=yes
将BOOTPROTO=dhcp 修改为 BOOTPROTO=static
然后再末行添加如下:
IPADDR=192.168.5.134
NETMASK=255.255.255.0
NM_CONTROLLED="yes"
:x 保存退出
配置网关:
# vi /etc/sysconfig/network
添加网关参数
NETWORKING=yes
GATEWAY=192.168.5.2
重启网络接口
# /etc/init.d/network restart
正在关闭接口 eth0: 设备状态: (断开连接)
[确定]
关闭环回接口: [确定]
弹出环回接口: [确定]
弹出界面 eth0: 活跃连接状态:激活的
活跃连接路径:/org/freedesktop/NetworkManager/ActiveConnection/ [确定]
配置防火墙,开启80端口、3306端口
vi /etc/sysconfig/iptables
备注:很多网友把这两条规则添加到防火墙配置的最后一行,导致防火墙启动失败,
正确的应该是添加到默认的22端口这条规则的下面
-A INPUT -m state --state NEW -m tcp -p tcp --dport -j ACCEPT #允许80端口通过防火墙
-A INPUT -m state --state NEW -m tcp -p tcp --dport -j ACCEPT #允许3306端口通过防火墙
:x 保存退出
/etc/init.d/iptables restart #最后重启防火墙使配置生效
关闭SELINUX:
vi /etc/selinux/config
#SELINUX=enforcing #注释掉
#SELINUXTYPE=targeted #注释掉
SELINUX=disabled #增加
:x #保存退出
准备工作都配置好了,重启一下(reboot)。
注意:如果发现有yum时出现“Could not retrieve mirrorlist”
如果配置的是DHCP动态网络,则在 /etc/resolv.conf文件中添加 nameserver 8.8.8.8
如果配置的是静态网路,则在/etc/sysconfig/network-scripts/ifcfg-eth0文件中添加,DNS1=8.8.8.8
重启下网路接口 /etc/init.d/network restart
保险起见,重启下系统 reboot。
关闭SELINUX
vi /etc/selinux/config
#SELINUX=enforcing #注释掉
#SELINUXTYPE=targeted #注释掉
SELINUX=disabled #增加
:wq #保存退出
/etc/init.d/iptables restart
shutdown -r now #重启系统
添加网易的源
首先备份/etc/yum.repos.d/CentOS-Base.repo
# mv /etc/yum.repos.d/CentOS-Base.repo /etc/yum.repos.d/CentOS-Base.repo.backup
下载对应版本repo文件, 放入/etc/yum.repos.d/(操作前请做好相应备份)
# wget http://mirrors.163.com/.help/CentOS6-Base-163.repo
# mv CentOS6-Base-.repo /etc/yum.repos.d/
重新生成缓存
# yum clean all
# yum makecache
配置CentOS 6.0 第三方yum源(CentOS默认的标准源里没有nginx软件包)
#wget http://www.atomicorp.com/installers/atomic
#sh ./atomic
#yum check-update
安装开发包和库文件
#yum -y install ntp make openssl openssl-devel pcre pcre-devel libpng libpng-devel libjpeg-6b libjpeg-devel-6b freetype freetype-devel gd gd-devel zlib zlib-devel gcc gcc-c++ libXpm libXpm-devel ncurses ncurses-devel libmcrypt libmcrypt-devel libxml2 libxml2-devel imake autoconf automake screen sysstat compat-libstdc++- curl curl-devel
安装nginx
# yum install nginx
# service nginx start
# chkconfig --levels nginx on
//设2、3、5级别开机启动
安装mysql
# yum install mysql mysql-server mysql-devel
# service mysqld start
# chkconfig --levels mysqld on 登陆MySQL删除空用户,修改root密码
mysql>select user,host,password from mysql.user; mysql>drop user ''@localhost; mysql>update mysql.user set password = PASSWORD('*********') where user='root'; mysql>flush privileges;
安装php
# yum install php lighttpd-fastcgi php-cli php-mysql php-gd php-imap php-ldap php-odbc php-pear php-xml php-xmlrpc php-mbstring php-mcrypt php-mssql php-snmp php-soap
//安装php和所需组件使PHP支持MySQL、FastCGI模式
#yum install php-tidy php-common php-devel php-fpm php-mysql
# service php-fpm start
# chkconfig --levels php-fpm on
添加一个nginx配置文件例子
vi /etc/nginx/conf.d/demo.conf server
{
listen ;
server_name localhost;
index index.html index.htm index.php;
root /mnt/hgfs/web; location / {
try_files $uri $uri/ =;
} #调用php web服务器
location ~ .*\.(php|php5)?$ {
fastcgi_pass 127.0.0.1:;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
include fastcgi_params;
} #图片缓存时间设置
location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$ {
expires 10d;
} #JS和CSS缓存时间设置
location ~ .*\.(js|css)?$ {
expires 5h;
} #禁止直接访问db目录下所有文件资源
location ^~ /db {
deny all;
}
}
注:测试文件目录使用了虚拟机目录共享,网上有详细教程(VMWare tools 共享目录)
在/mnt/hgfs/web/下添加index.php,重启nginx
<?php echo phpinfo(); :x # /etc/init.d/nginx restart
在浏览器测试:http://127.0.0.1:8001
如果需要在另外一台主机上访问 http://ip:8001
记得先在服务器防火墙添加上运行访问端口(vi /etc/sysconfig/iptables,本例添加801端口)
Centos6.x搭建lnmp环境的更多相关文章
- CentOS6.6搭建LNMP环境
CentOS6.6搭建LNMP环境 1.设置yum源,本地安装依赖包 1 yum -y install gcc gcc-c++ automake autoconf libtool make 2.下载依 ...
- CentOS6.7搭建LNMP环境
1:查看环境: [root@localhost ~]# cat /etc/redhat-release 2:关掉防火墙 #重启后生效开启 [root@localhost ~]# chkconfig i ...
- centos6.5搭建lnmp环境
注:本文原文链接:http://www.cnblogs.com/xiaoit/p/3991037.html 本文只是做保存使用 1:查看环境: [root@10-4-14-168 html]# cat ...
- CentOS6.8搭建LNMP环境
selinux可能会致使编译安装失败,我们先禁用它.永久禁用,需要重启生效 sed -i ‘s/SELINUX=enforcing/SELINUX=disabled/g’ /etc/selinux/c ...
- Docker之使用Docker-compose搭建LNMP环境
之前有随笔介绍使用Docker-compose搭建LNMP环境(centos6 php5.6) https://www.cnblogs.com/minseo/p/10146982.html 本文介绍D ...
- Yum搭建LNMP环境(动、静、库分离)(week4_day5)--技术流ken
前言 本篇博客使用yum来搭建lnmp环境,将采用动态,静态以及数据库分开安装的方式即nginx,php,mysql.会被分开安装在不同的服务器之上,搭建出来一套lnmp环境,并部署wordpress ...
- [Linux] deepin15.8搭建LNMP环境
LAMP和LNMP LAMP==Linux+Apache+Mysql+PHP LNMP==Linux+Nginx+Mysql+PHP 安装nginx sudo apt install nginx 安装 ...
- CentOS 7 源码搭建LNMP环境
搭建 LNMP 环境 源码包版本 : CentOS Linux 7 nginx-1.15.1.tar.gz mysql-boost-5.7.21.tar.gz php-7.2.7.tar.gz ...
- Vmware搭建LNMP环境(Centos7+Nginx+Mysql+PHP7.1.8)
参考:1.Linux学习之CentOS(一)----在VMware虚拟机中安装CentOS 7(图文教程) 2.Centos7搭建LNMP环境 3.MySQL5.7修改默认root密码 4.CentO ...
随机推荐
- LeetCode——Nth Digit
Question Find the nth digit of the infinite integer sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, ... ...
- 记jsp判断
empty:表示空字符串,null,空数组,空集合. ! empty:表示非空字符串,非null,非空数组,非空集合.
- java程序结构
if....else.... 1. if都需要接判断表达式 2. else不需要表达式 3. 有if没else可以,但else必须要有一个if,if数>=else数 if (A条件) ...
- Oracle——ORA-01031: 权限不足
报错:ORA-01031: 权限不足 解决方法:给用户admin授予DBA角色 grant dba to admin;
- TCP状态切换流程
enum { /* * Description of States: * * TCP_SYN_SENT sent a connection request, waiting for ack * * T ...
- codeforces103E Buying Sets
本文版权归ljh2000和博客园共有,欢迎转载,但须保留此声明,并给出原文链接,谢谢合作. 本文作者:ljh2000 作者博客:http://www.cnblogs.com/ljh2000-jump/ ...
- django学习错误笔记
1.运行python manage.py makemigrations polls 出现错误
- [Vue]实例化Vue时的两种挂载方式el与$mount
Vue 的$mount()为手动挂载,在项目中可用于延时挂载(例如在挂载之前要进行一些其他操作.判断等),之后要手动挂载上.new Vue时,el和$mount并没有本质上的不同. 1.el Vue实 ...
- HDU-4714-贪心
Tree2cycle Time Limit: 15000/8000 MS (Java/Others) Memory Limit: 102400/102400 K (Java/Others)Tot ...
- nyoj164——卡特兰数(待填坑)
题意:将1~2n个数按照顺时针排列好,用一条线将两个数字连接起来要求:线之间不能有交点,同一个点只允许被连一次. 最后问给出一个n,有多少种方式满足条件. 卡特兰数(列): 令h(0)=1,h(1)= ...