最近在部署storm on yarn ,部署参考文章

http://www.tuicool.com/articles/BFr2Yv
http://blog.csdn.net/jiushuai/article/details/18729367
在安装完zookeeper,配置好storm 和storm on yarn后,启动zookeeper,其中zookeeper的port为2181,
然后通过mvn package 编译工程,发现会出现错误,然后使用mvn packet -DskipTests 重新编译,跳过test
然后向yarn 提交storm任务,storm-yarn launch <path to your storm.yaml file> 提交后查看localhost:8088,发现任务failed,查看错误信息发现错误如下
Application application_1411179375629_0005 failed  times due to AM Container for appattempt_1411179375629_0005_000002 exited with exitCode:  due to: Exception from container-launch: org.apache.hadoop.util.Shell$ExitCodeException:
org.apache.hadoop.util.Shell$ExitCodeException:
at org.apache.hadoop.util.Shell.runCommand(Shell.java:)
at org.apache.hadoop.util.Shell.run(Shell.java:)
at org.apache.hadoop.util.Shell$ShellCommandExecutor.execute(Shell.java:)
at org.apache.hadoop.yarn.server.nodemanager.DefaultContainerExecutor.launchContainer(DefaultContainerExecutor.java:)
at org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch.call(ContainerLaunch.java:)
at org.apache.hadoop.yarn.server.nodemanager.containermanager.launcher.ContainerLaunch.call(ContainerLaunch.java:)
at java.util.concurrent.FutureTask.run(FutureTask.java:)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:)
at java.lang.Thread.run(Thread.java:)
Container exited with a non-zero exit code
.Failing this attempt.. Failing the application.

查看log信息发现具体错误如下

// :: INFO yarn.MasterServer: Starting Master Thrift Server
// :: ERROR auth.ThriftServer: ThriftServer is being stopped due to: org.apache.thrift7.transport.TTransportException: Could not create ServerSocket on address 0.0.0.0/0.0.0.0:.
org.apache.thrift7.transport.TTransportException: Could not create ServerSocket on address 0.0.0.0/0.0.0.0:.
at org.apache.thrift7.transport.TNonblockingServerSocket.<init>(TNonblockingServerSocket.java:)
at org.apache.thrift7.transport.TNonblockingServerSocket.<init>(TNonblockingServerSocket.java:)
at org.apache.thrift7.transport.TNonblockingServerSocket.<init>(TNonblockingServerSocket.java:)
at backtype.storm.security.auth.SimpleTransportPlugin.getServer(SimpleTransportPlugin.java:)
at backtype.storm.security.auth.ThriftServer.serve(ThriftServer.java:)
at com.yahoo.storm.yarn.MasterServer.main(MasterServer.java:)

在启动Master Thrift Server时发生错误,错误为端口错误,因为9000端口已经被hdfs占用监听,因此不能创建ServerSocket

致谢google,搜到的解决办法为修改端口号,帖子如下

https://groups.google.com/forum/#!topic/storm-yarn/A1ds1M6qmN8

修改storm-yarn-master/src/main/resources/master_defaults.yaml,将其中的master.thrift.port修改为一个其他的合适的值,我修改为9001

然后再编译工程,重新提交,这时发现任务没有failed,但是访问localhost:7070,不能访问,查看log后发现错误为nimbus没有启动成功,错误如下:

// :: ERROR yarn.MasterServer: Unhandled error in AM:
org.apache.hadoop.yarn.exceptions.InvalidResourceRequestException: Invalid resource request, requested virtual cores < , or requested virtual cores > max configured, requestedVirtualCores=, maxVirtualCores=
at org.apache.hadoop.yarn.server.resourcemanager.scheduler.SchedulerUtils.validateResourceRequest(SchedulerUtils.java:)
at org.apache.hadoop.yarn.server.resourcemanager.RMServerUtils.validateResourceRequests(RMServerUtils.java:)
at org.apache.hadoop.yarn.server.resourcemanager.ApplicationMasterService.allocate(ApplicationMasterService.java:)
... ... ... ... ... ...
at com.yahoo.storm.yarn.MasterServer$.run(MasterServer.java:)
Caused by: org.apache.hadoop.ipc.RemoteException(org.apache.hadoop.yarn.exceptions.InvalidResourceRequestException): Invalid resource request, requested virtual cores < , or requested virtual cores > max configured, requestedVirtualCores=, maxVirtualCores=
at org.apache.hadoop.yarn.server.resourcemanager.scheduler.SchedulerUtils.validateResourceRequest(SchedulerUtils.java:)
at org.apache.hadoop.yarn.server.resourcemanager.RMServerUtils.validateResourceRequests(RMServerUtils.java:)
    ... ... ... ... ... ...
 at com.sun.proxy.$Proxy7.allocate(Unknown Source) at org.apache.hadoop.yarn.api.impl.pb.client.ApplicationMasterProtocolPBClientImpl.allocate(ApplicationMasterProtocolPBClientImpl.java:) ...  more // :: INFO yarn.StormMasterServerHandler: stopping supervisors... // :: INFO yarn.StormMasterServerHandler: stopping UI... // :: INFO yarn.StormMasterServerHandler: stopping nimbus...

意思是申请的virtual cores超过最大限制maxVirtualCores,google后找到帖子

hadoop - Why cannot more than 32 cores be requested from YARN to run a job? - Stack Overflow
http://stackoverflow.com/questions/29780401/why-cannot-more-than-32-cores-be-requested-from-yarn-to-run-a-job

因此修改yarn-site.xml如下

<property>
<name>yarn.nodemanager.resource.cpu-vcores</name>
<value></value>
</property>

重新启动yarn,然后提交,成功!!!

如果发现以下错误

-- :: o.a.z.ClientCnxn [INFO] Opening socket connection to server MMC/192.168.1.200:
-- :: o.a.z.ClientCnxn [WARN] Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect
java.net.ConnectException: 拒绝连接

有可能是zookeeper没有启动,启动即可

时刻注意自己的防火墙有没有关闭,有些不知名的原因是因为防火墙没有关闭造成的!

用了三四天时间才解决了这个问题,期间走了不少弯路,因为刚开始接触hadoop storm on yarn,因此有时候出错误了不知道怎么去查错,开始时只是自己估计是哪出了问题,然后改一下重新跑一下,结果还是不行,后来学会了去查错误log,在masterhost:8088/logs/下就是所有的错误日志,然后查找相关的错误日志排错事半功倍

致谢:google

吐槽一下万恶的网G络F审W查¥制#度,我操我操我操我操我操!!!Internet上的闭关锁国!!!

 

storm on yarn安装时 提交到yarn失败 failed的更多相关文章

  1. centos7安装apache http server启动失败--Failed to start The Apache HTTP Server.

    centos7安装apache http server启动失败     除了nginx可以开启http服务外,apche http server也可以开启http服务,安装过程如下:1. 首先,检测是 ...

  2. 【已解决】使用 yarn 安装时,报错node_modules\node sass:Command failed.

    npm install -g mirror-config-china --registry=http://registry.npm.taobao.org npm install node-sass y ...

  3. SqlServer2008安装时提示重启计算机失败 解决办法

    问题描述: 在安装Sql Server 2008时提示重启计算机,重启之后不行,仍需要重启计算机. 如下图所示: 解决方法: 1.运行(或按键盘Win+R 组合键),输入regedit,调出注册表管理 ...

  4. sql server2008安装时提示重启计算机失败怎么办

    安装SQL Server 2008时,经常会遇到这样一个问题,软件提示“重启计算机失败”,如果忽略的话,会给后面的安装带来很大的麻烦,这里如何解决呢?   工具/原料 注册表 解决方法   在键盘上按 ...

  5. SQL server安装时显示重启计算机失败问题解决办法

    前几天在装SQL server2016的时候,一直显示重启计算机失败; 网上的方法也找来用了,但是重启完还是同样的问题,试了很多种方法,最后在一次测试中点关机的时候不小心点成了重启(win10有个毛病 ...

  6. sql2008安装时提示重启计算机失败解决方法

    安装sql 2008的时候,在检测安装环境中有一项是”重新启动计算机”显示的结果是“失败”.上网看了半天,找到了解决方案,虽然我没弄明白具体原因,但问题是解决了,解决方案如下: 一.Windows+R ...

  7. 解决SQL Server 2008安装时提示:重新启动计算机 失败

    a.重启机器,再进行安装,如果发现还有该错误,请按下面步骤: b.在开始->运行中输入regedit c.到HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet ...

  8. andoid-sdk 安装时出现 Stopping ADB server failed(code -1) 错

    出错原因: cmd在path路径找不到adb命令,是因为adb.exe文件存在于android-sdk安装目录platform-tools/子目录下,要将这个路径配置到环境变量里面. 解决方案: 按照 ...

  9. Sql Server 2008安装时提示重启计算机失败解决办法

    在键盘上按下组合键[Win]+[R],调出运行窗口.   在窗口中输入“regedit”,点击确定,打开注册表管理界面.   在注册表左侧目录栏中找到如下位置:“HKEY_LOCAL_MACHINE\ ...

随机推荐

  1. LATTICE 编程烧录器HW-USBN-2B使用说明

    HW-USBN-2B说明文档 1.       引脚定义 编程引脚 名称 编程设备引脚类型 描述 VCC 编程电压 输入 连接VCC到目标设备,典型的ICC=10Ma.板子设计必须考虑VCC的电流供应 ...

  2. Unity 公告板 Billboard

    创建脚本如下 Billboard.cs using UnityEngine; using System.Collections; public class Billboard : MonoBehavi ...

  3. Hibernate all-delete-orphan[转]

    博客分类: SSH   当关联双方存在父子关系,就可以在 set 处设定 cascade 为 all-delete-orphan 所谓父子关系,即指由父方控制子方的持久化圣明周期,子方对象必须和一个父 ...

  4. Vue 中使用Ajax请求

    Vue 项目中常用的 2 个 ajax 库 (一)vue-resource vue 插件, 非官方库,vue1.x 使用广泛 vue-resource 的使用 在线文档   https://githu ...

  5. PAT (Advanced Level) 1144~1147:1145Hash二次探查 1146拓扑排序 1147堆

    1144 The Missing Number(20 分) 题意:给定N个数的序列,输出不在序列中的最小的正整数. 分析: 1.给定的N个数可能为正,可能为负,可能重复. 2.由于N≤10​5​​,所 ...

  6. 功耗极低非接触 13.56mhz读卡芯片:SI522

    众所周知13.56mhz是高频,一般用于防伪,做到成品非常薄.在智能门锁以及RFID读卡器是非常多人采用的,不管是在读卡距离.读卡灵敏度都是非常好的.现在智能门锁的竞争性很大,大多厂商及方案商都慢慢往 ...

  7. 兼容和Error

    兼容 IE兼容 ie没有forEach if(!Array.prototype.forEach) { Array.prototype.forEach = function(fun){ var len ...

  8. 如何让Dev支持c++11特性

    1.点击工具选择编译选项 2.在编译时加入以下命令点击之后再将-std=c++11加入,点击确定就ok了

  9. WinForm_UI设计

    下载

  10. delphi关闭和禁用Windows服务

    function StopServices(const SvrName: string): Boolean; var SCH, SvcSCH: SC_HANDLE; SS: TServiceStatu ...