异常描述

在对HDFS格式化,执行hadoop namenode -format命令时,出现未知的主机名的问题,异常信息如下所示:

  1. [shirdrn@localhost bin]$ hadoop namenode -format
  2. 11/06/22 07:33:31 INFO namenode.NameNode: STARTUP_MSG:
  3. /************************************************************
  4. STARTUP_MSG: Starting NameNode
  5. STARTUP_MSG:   <span style="color: #ff0000;">host = java.net.UnknownHostException: centos64:centos64
  6. </span>STARTUP_MSG:   args = [-format]
  7. STARTUP_MSG:   version = 0.20.0
  8. STARTUP_MSG:   build = https://svn.apache.org/repos/asf/hadoop/core/branches/branch-0.20 -r 763504; compiled by 'ndaley' on Thu Apr  9 05:18:40 UTC 2009
  9. ************************************************************/
  10. Re-format filesystem in /tmp/hadoop/hadoop-shirdrn/dfs/name ? (Y or N) Y
  11. 11/06/22 07:33:36 INFO namenode.FSNamesystem: fsOwner=shirdrn,shirdrn
  12. 11/06/22 07:33:36 INFO namenode.FSNamesystem: supergroup=supergroup
  13. 11/06/22 07:33:36 INFO namenode.FSNamesystem: isPermissionEnabled=true
  14. 11/06/22 07:33:36 INFO metrics.MetricsUtil: Unable to obtain hostName
  15. java.net.UnknownHostException: <span style="color: #ff0000;">localhost.localdomain: localhost.localdomain
  16. </span>        at java.net.InetAddress.getLocalHost(InetAddress.java:1353)
  17. at org.apache.hadoop.metrics.MetricsUtil.getHostName(MetricsUtil.java:91)
  18. at org.apache.hadoop.metrics.MetricsUtil.createRecord(MetricsUtil.java:80)
  19. at org.apache.hadoop.hdfs.server.namenode.FSDirectory.initialize(FSDirectory.java:73)
  20. at org.apache.hadoop.hdfs.server.namenode.FSDirectory.<init>(FSDirectory.java:68)
  21. at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.<init>(FSNamesystem.java:370)
  22. at org.apache.hadoop.hdfs.server.namenode.NameNode.format(NameNode.java:853)
  23. at org.apache.hadoop.hdfs.server.namenode.NameNode.createNameNode(NameNode.java:947)
  24. at org.apache.hadoop.hdfs.server.namenode.NameNode.main(NameNode.java:964)
  25. 11/06/22 07:33:36 INFO common.Storage: Image file of size 97 saved in 0 seconds.
  26. 11/06/22 07:33:36 INFO common.Storage: Storage directory /tmp/hadoop/hadoop-shirdrn/dfs/name has been successfully formatted.
  27. 11/06/22 07:33:36 INFO namenode.NameNode: SHUTDOWN_MSG:
  28. /************************************************************
  29. SHUTDOWN_MSG: Shutting down NameNode at java.net.UnknownHostException: localhost.localdomain: localhost.localdomain
  30. ************************************************************/

再执行 /bin/start-all.sh 就不成功。

通过执行hostname命令可以看到:

  1. [shirdrn@localhost bin]# hostname
  2. centos64

也就是说,Hadoop在格式化HDFS的时候,通过hostname命令获取到的主机名是centos64,然后在/etc/hosts文件中进行映射的时候,没有找到,看下我的/etc/hosts内容:

  1. [root@localhost bin]# cat /etc/hosts
  2. # Do not remove the following line, or various programs
  3. # that require network functionality will fail.
  4. 127.0.0.1                   localhost       localhost
  5. 192.168.18.130           localhost       localhost

在:查看一下/etc/sysconfig/network文件: 保存的是hostname 也就是主机名 。

在 /etc/hosts 中修改

127.0.0.1                   localhost       centos64

192.168.18.130           localhost      centos64

让主机名centos64 在 hosts中能有一个IP与之相映射对应 。

2. 或修改 /etc/sysconfig/network 中的 hostname 为 localhost

再:[root@localhost bin]# /etc/rc.d/init.d/network restart

以上修改完后,再执行格式化HDFS命令,以及启动HDFS集群就正常了。

再启用 bin/start-all.sh

再用  jps .

以上是单机版的 hadoop1.2安装,如果是在集群中安装,

1.把在master中的 /etc/hosts 中把所有slave的 IP 加进来,

如 

192.168.18.130          h0

192.168.18.131         h1

192.168.18.132         h2

2. 建立好SSH,实现无密码登陆 ,见另一个blog

3. 修改 vi   /home/hadoop1.2/conf/master

h0

vi   /home/hadoop1.2/conf/slave

h1

h2

zhuanzi http://lihongchao87.iteye.com/blog/1998347

Hadoop格式化HDFS报错java.net.UnknownHostException: centos64的更多相关文章

  1. Hadoop格式化HDFS报错java.net.UnknownHostException: localhost.localdomain: localhost.localdomain

    异常描述: 在对HDFS格式化,执行hadoop namenode -format命令时,出现未知的主机名的问题,异常信息如下所示: [shirdrn@localhost bin]$ hadoop n ...

  2. ha环境下重新格式化hdfs报错

    datanode启动不成功,如下所示,我的136,137.138都是datanode,都启动不了. 查看datanode日志文件发现报错: 一个报错Incompatible clusterIDs in ...

  3. Spark报错java.io.IOException: Could not locate executable null\bin\winutils.exe in the Hadoop binaries.

    Spark 读取 JSON 文件时运行报错 java.io.IOException: Could not locate executable null\bin\winutils.exe in the ...

  4. 【原创】大叔问题定位分享(2)spark任务一定几率报错java.lang.NoSuchFieldError: HIVE_MOVE_FILES_THREAD_COUNT

    最近用yarn cluster方式提交spark任务时,有时会报错,报错几率是40%,报错如下: 18/03/15 21:50:36 116 ERROR ApplicationMaster91: Us ...

  5. 【原创】大叔经验分享(49)hue访问hdfs报错/hue访问oozie editor页面卡住

    hue中使用hue用户(hue admin)访问hdfs报错: Cannot access: /. Note: you are a Hue admin but not a HDFS superuser ...

  6. eclipse启动报错java.lang.IllegalStateException: LifecycleProcessor not initialized - call 'refresh' befo

    报错: java.lang.IllegalStateException: LifecycleProcessor not initialized - call 'refresh' before invo ...

  7. 开着idea,死机了,关机重启。重启之后,重新打开idea报错java.lang.AssertionError:upexpected content storage modification

    开着idea,死机了,关机重启.重启之后,重新打开idea报错java.lang.AssertionError:upexpected content storage modification. goo ...

  8. Eclipse启动报错Java was started but returned exit code=13

    启动Eclipse的时候报错Java was started but returned exit code=13,这个错误的原因是由于eclipse版本与jdk版本不符导致的,可能你的eclipse是 ...

  9. idea中编译项目报错 java: javacTask: 源版本 1.8 需要目标版本 1.8

    问题如上面所叙: > idea中编译项目报错 java: javacTask: 源版本 1.8 需要目标版本 1.8 解决方案: > Setting->Compiler->Ja ...

随机推荐

  1. Sphinx-安装和配置

    本例是在Linux下, 环境 CentOS6.5 + PHP5.6.8 + MySQL5.6.13 + Sphinx2.3.1-beta 到官网下载对应环境的安装包, 按照官方文档指定步骤进行安装 第 ...

  2. 【转贴】J2EE中的13种技术规范

    J2EE平台由一整套服务(Services).应用程序接口(APIs)和协议构成,它对开发基于Web的多层应用提供了功能支持,下面对J2EE中的13种技术规范进行简单的描述(限于篇幅,这里只能进行简单 ...

  3. Repository与UnitOfWork引入

    Repository是什么? 马丁大叔的书上同样也有解释:它是衔接数据映射层和域之间的一个纽带,作用相当于一个在内存中的域对象映射集合,它分离了领域对象和数据库访问代码的细 节.Repository受 ...

  4. 使用C#开发ActiveX控件[Obsolete]

    文章出处:http://www.cnblogs.com/yilin/archive/2009/09/15/1567332.html 附件下载(源代码+安装文件+教程) 0. 前言 ActiveX控件以 ...

  5. 不懂Git,别说自己是程序猿–20分钟git快速上手(转)

    在Git如日中天的今天,不懂git都不好意思跟人说自己是程序猿.你是不是早就跃跃欲试了,只是苦于没有借口(契机). 好吧,机会就在今天. 给我20分钟,是的,只要20分钟, 让你快速用上git. 我们 ...

  6. Python selenium -- cookie处理

    转自:http://www.cnblogs.com/fnng/p/3269450.html 本节重点: driver.get_cookies() 获得cookie信息 add_cookie(cooki ...

  7. 点滴积累【other】---win2003 service pack2 IIS 无法复制CONVLOG.EXE CONVLOG.EX_(转载)

    在安装的时候出现一个错误提示“安装程序无法复制文件CONVLOG.EX_”,上网找了下资料,说是在运行-中输入”esentutl /p %windir%/security/database/seced ...

  8. linux Apache CGI 安装配置

    Apache 中的提交了一种利用扩展应用程序执行动态网页的机制. 称为Common Gateway Interface (通用网关接口)简称CGI. 本文假定已安装好linux(本文的linux版本为 ...

  9. atitit.jquery tmpl模板总结 .doc

    atitit.jquery tmpl模板总结 .doc 1. atitit.动态模版解析1 1.1. Jquery.tmpl.js1 1.2. 比起anrular js方便啊.1 2. 动态模板引擎解 ...

  10. Unity对象与Draw Calls的关系

    什么是Draw Calls? 首先我们先来了解一下,什么叫做“Draw Calls”:一个Draw Call,等于呼叫一次 DrawIndexedPrimitive (DX) or glDrawEle ...