WebIV:View NOTE:159898.1    

Note (Sure)
- Note    Mods
- Note Refs
Error
ORA 600
TAR
TAR-Info
Bug
Bug Matrix
RFI
Diary
Events
Parameters
Locks
Latches
Views
Pkg/Proc
Statistics
Wait Events
Function
BugDB User
Port Names
Prod/Comp
Doc Part
        
Get
Explode
Mail
Fax
Mark
Tag
Tag-References
Check-References
Show Remarks
Edit
Edit (Full Header)
Copy (Full Header)
Attachments
Show Doc Stats
Show ML  Copy


Article-ID: <Note:159898.1>
Alias: VIEW:X$KCBKPFS
Circulation: PUBLISHED (INTERNAL) ***Oracle Confidential - Internal Use Only***
Folder: server.Internals.General
Topic: ** X$ Table Definitions
Title: VIEW: X$KCBKPFS - PreFetch Statistics - (9.0)
Document-Type: REFERENCE
Impact: LOW
Skill-Level: NOVICE
Server-Version: 09.00
Updated-Date: 05-OCT-2001 05:27:02
References:
Shared-Refs:
Authors: MEPRESTO.US
Attachments: NONE
Content-Type: TEXT/PLAIN
Products: 5/RDBMS (9.0);

View: X$KCBKPFS
[K]ernal [C]ache [B]uffer chec[K]point management
[P]re[F]etch [S]tats Column Type Description
-------- ---- --------
ADDR RAW(4|8) address of this row/entry in the array or SGA
INDX NUMBER index number of this row in the fixed table array
INST_ID NUMBER oracle instance number
BUFFER_POOL_ID NUMBER Buffer Pool
TIMESTAMP NUMBER Timestamp
PREFETCH_OPS NUMBER number of prefetch operations
PREFETCH_BLOCKS NUMBER number of blocks prefetched
WASTED_BLOCKS NUMBER number of prefetched blocks wasted
CLIENTS_PREFETCH NUMBER number of clients actually prefetching buffers
PREFETCH_LIMIT NUMBER Limit to be used by for each prefetch operation Notes: This is maintained by the CKPT process which fills in an entry for each timeout period. Size of prefech history is limited to 50 per buffer pool. This section deals with controlling prefetching through the cache. This
is used to determine whether prefetch is wasteful i.e are prefetched blocks
being aged out of the cache before they can be used? This can happen,
for example, if there is a lot of recycling activity in the cache and
each client of the cache prefetched a large number of blocks into the cache. To prevent this the following algorithm is used to limit the amount
of prefetching done in each buffer pool: A history buffer is maintained per buffer pool. This buffer maintains
a history of prefetching performance. This is populated through a
timeout action. The history buffer contains the following information
in each entry (struct kcbkpfs):
- Timestamp at which entry was created.
- Number of prefetch operations since the last timeout action.
- Number of blocks prefetched in this period.
- Number of prefetched blocks that were wasted - this refers to
blocks that were prefetched but had to be aged out before
they could be pinned.
- Prefetch limit (this is the value computed by this function)
- Number of prefetching clients (as a snapshot at the time this
function is executed)
- Number of buffers being read at this time. The algorithm uses the history to determine the prefetch limit. It
the last few history entries (defined by KCBK_HIST_WINDOW) and then
computes the cumulative number of prefetch operations, prefetched
blocks and wasted prefetch blocks over this window. It then applies
the following rules to adjust the limit: - If there are no prefetched blocks, then set the limit to
Q/C where Q is the prefetch quota (in number of buffers) and
C is the number of clients performing prefetching - If there are prefetched blocks and some of them were wasted.
In this case, the limit is reduced by the fraction (P - W)/P
where P is the number of blocks prefetched over the history
window and W is the number of prefetched blocks that were wasted.
If W happens to be greater than P, this implies that the buffers
that were prefetched before the history window were wasted in
this time interval. In this case, we reduce the limit to half
its value. - If there are no wasted prefetch blocks, then there are 3 cases: (a) The number of clients has gone down - in this case we
double the prefetch limit. If this causes any wasted prefetches
it will be reduced by that fraction in the next timeout. Note
that the increase is limited by the ratio (Q/C') where Q is
the prefetch quota and C' is the new number of clients. (b) The number of clients has increased - retain the limit as long
as the it is less than (Q/C') (same ratio as above). If not,
set it to Q/C' (c) The number of clients remains the same - The limit is doubled
if the number of prefetched buffers has decreased by atleast
25% (again subject to the Q/C limit), otherwise the limit is
retained. The rationale is that if the number of prefetched
buffers has gone down, the clients have reduced their
prefetching, so increasing the limit may not lead to wasted
prefetches. Note that if the increase in the limit leads to wasted prefetching,
then at the next timeout, the limit will be reduced by the fraction
of the prefetched blocks that were wasted.

oracle internal: VIEW: X$KCBKPFS - PreFetch Statistics - (9.0)的更多相关文章

  1. oracle internal :VIEW: X$KCBLDRHIST - Direct Read HISTory

    WebIV:View NOTE:159900.1     Note (Sure) - Note    Mods - Note Refs Error ORA 600 TAR TAR-Info Bug B ...

  2. Android查缺补漏(View篇)--在 Activity 的 onCreate() 方法中为什么获取 View 的宽和高为0?

    在 Activity 的 onCreate() 方法中为什么获取 View 的宽和高为0 ? @Override protected void onCreate(Bundle savedInstanc ...

  3. Oracle错误IMP-00010: 不是有效的导出文件, 头部验证失败 分类: Oracle 2015-07-09 13:56 20人阅读 评论(0) 收藏

    Oracle 11g的dmp备份文件导入到Oracle 10g,出现错误信息: Import: Release 10.2.0.1.0 - Production on 星期四 7月 9 13:47:04 ...

  4. Unable to start activity ComponentInfo{com.example.administrator.myapplication/com.example.administrator.myapplication.MainActivity}: android.view.InflateException: Binary XML file line #0: Binary XM

    本来就是把fragment写死在activity的xml模板里面,结果报了这个错误, Unable to start activity ComponentInfo{com.example.admini ...

  5. SPSS Statistics 26.0 下载安装和激活

    目录 1. 其他版本 2. IBM SPSS Statistics 26 新增功能 3. 安装步骤 4. 下载地址 1. 其他版本 参考:https://www.cnblogs.com/coco56/ ...

  6. IBM SPSS Statistics 26.0 Mac Windows Linux安装破解教程

    IBM SPSS Statistics 26.0是IBM公司推出的一款用于统计学分析运算.数据挖掘.预测分析和决策支持任务的软件产品及相关服务的程序. 下载 windows/mac/linux IBM ...

  7. Oracle EBS Concurrent Request:Gather Schema Statistics[Z]

    Oracle EBS 的Concurrent Request"Gather Schema Statistics"是一个和性能相关的Concurrent Program,它会对表,列 ...

  8. Oracle 视图view

    在我看来,oracle的视图就是用于将多个表的关联查询结果映射成[临时表],视图与系统表中的数据是实时对应的. 我们可以像操作表的查询一样来操作视图查询. 视图写法: CREATE OR REPLAC ...

  9. Oracle ERP View - fnd_global.apps_initialize

    在ORACLE APPLICATION FORM中已存储了数据,在客户端TOAD中查找其TABLE找到相关数据行,但当查找其VIEW时就无法找到数据. 原因ORACLE的权责及OU安全机制屏蔽问题. ...

随机推荐

  1. 完美完全卸载Oracle 11g数据库

    Oracle 11g可在开始菜单中卸载,然后同时需要删除注册表中相关内容. 操作系统:windows10专业版. 卸载步骤: 1.停用oracle服务:进入计算机管理,在服务中,找到oracle开头的 ...

  2. mybatis返回HashMap结果类型与映射

    <!-- 返回HashMap结果 类型--> <!-- 如果想返回JavaBean,只需将resultType设置为JavaBean的别名或全限定名 --> <!-- T ...

  3. 转载:Hadoop权威指南学习笔记

    转自:http://pieux.github.io/blog/2013-05-08-learn-hadoop-the-definitive-guide.html 1 前言 Hadoop的内部工作机制: ...

  4. android 官网处理图片 代码

    /** * 获取压缩后的图片 (官网大图片加载对应代码) * * @param res * @param resId * @param reqWidth * 所需图片压缩尺寸最小宽度 * @param ...

  5. IOS AsyncSocket

    导入AsyncSocket.h  AsyncSocket.m   AsyncUdpSocket.h   AsyncUdpSocket.m   以及  CFNetWork.framework async ...

  6. cocos2d-x 添加背景音乐和音效-SimpleAudioEngine

    首先,要想使用音效,需要启用音效引擎库CocosDenshion中的SimpleAudioEngine类, #include "SimpleAudioEngine.h" Cocos ...

  7. 通过简单的Linux内核启动程序代码窥探操作系统的启动原理

    作者:吴乐  山东师范大学 <Linux内核分析> 孟宁 MOOC课程http://mooc.study.163.com/course/USTC-1000029000 一.程序设计与分析 ...

  8. 使用logback.xml配置来实现日志文件输出

    转自:http://sungang-1120.iteye.com/blog/2104296 Logback是由log4j创始人设计的又一个开源日志组件.logback当前分成三个模块:logback- ...

  9. 第二百八十九天 how can I 坚持

    今天好伤啊,太把自己当回事了. 现在在弟弟这,下午和他一块看了看西客站附近的房子,感觉暂时好难,只是暂时的,一切都会好起来的. 弟弟上班也挺不容易,不该来给他添麻烦,替他心疼. 确实不知道该咋办了,好 ...

  10. WebService学习之三:spring+cxf整合

    步骤一:spring项目(java web项目)引入CXF jar包 步骤二:创建webservice服务器 1)创建一个服务接口 package com.buss.app.login; import ...