MySQL 5.7.19 忘记密码 重置密码 配置文件my.ini示例 服务启动后停止 log配置
【参考】java 项目 存入mysql后 变问号 MySql 5.6 (X64) 解压版 1067错误与编码问题的解决方案
一、my.ini 的mysqld下添加
skip-grant-tables
二、重启mysql服务
net start mysqld
三、打开cmd
cd C:\Program Files\MySQL\MySQL Server 5.7\bin
mysql
use mysql
设置新密码
update mysql.user set authentication_string=password('mima****') where user='root' and Host='localhost';
UPDATE user SET authentication_string=password('1234') where user='root' and Host='localhost';
alter user 'root'@'localhost' identified by '123'; 改密码?
flush privileges;
5.7以前版本可用UPDATE user SET Password=PASSWORD('newpassword') where USER='root';更新密码
四、恢复my.ini 重启mysql服务
五、本地计算机上的MySQL服务启动后停止。某些服务在未由其他服务或程序使用时将自动停止
1. 解压mySQL绿色版zip包 -> 配置环境变量
2. 用管理员身份运行cmd,mysqld –initialize-insecure,data文件夹会自动生成,注意单词不要拼错 -> 运行 mysqld –install 安装Windows服务
3. my.ini 配置文件放在MYSQL_HOME目录下,不要配置 basedir,datadir,不要配置 basedir,datadir,不要配置 basedir,datadir!!!【参照】 Mysql-5.7.19-winx64服务无法启动解决方案
my.ini 精简示例 (5.7.19 可放在 MYSQL_HOME 目录下,MySQL能启动不报错)
#代码开始
[client]
port=3306
default-character-set=utf8 [mysqld]
port=3306
character_set_server=utf8 sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES # 创建新表时将使用的默认存储引擎
default-storage-engine=INNODB innodb_buffer_pool_size=2048M
#innodb_buffer_pool_instances=1
innodb_log_buffer_size=4M
innodb_log_file_size=256M
#innodb_additional_mem_pool_size=4M # 允许最大连接数
max_connections=1024
#服务器在关闭它前在一个交互连接上等待行动的秒数
wait_timeout = 7200
#服务器有几个CPU就设置为几,建议用默认设置,一般为8.
innodb_thread_concurrency = 8 key_buffer_size=128M
tmp_table_size=128M
read_buffer_size=4M
read_rnd_buffer_size=16M
sort_buffer_size=32M [mysql]
# 设置mysql客户端默认字符集
default-character-set=utf8
my.ini 常规示例(log配置) (5.7.19)
#配置开始
[client]
port=3306
default-character-set=utf8 [mysqld]
port=3306
character_set_server=utf8
#跳过登陆验证
#skip-grant-tables
#禁止反向解析
#skip-name-resolve #各种日志(查询、错误、慢查询)配置:
#log_bin=..\log\mysql-bin.log
log_error=..\log\mysql.err
long_query_time=1
slow_query_log=ON
slow_query_log_file=..\log\mysql-slow.log
general_log=ON
general_log_file=..\log\log-mysql.log # 允许最大连接数
max_connections=1024
#服务器在关闭它前在一个交互连接上等待行动的秒数
wait_timeout = 7200
#服务器有几个CPU就设置为几,建议用默认设置,一般为8.
innodb_thread_concurrency = 8
innodb_flush_log_at_trx_commit=1
innodb_log_buffer_size=128M
innodb_buffer_pool_size=2048M
innodb_log_file_size=256M
innodb_thread_concurrency=16
innodb-autoextend-increment=1000
#innodb_additional_mem_pool_size=4M table_open_cache=256
query_cache_size=1M
tmp_table_size=128M
thread_cache_size=8
key_buffer_size=128M
read_buffer_size=4M
join_buffer_size=128M
sort_buffer_size=32M
read_rnd_buffer_size=32M
max_allowed_packet=32M
explicit_defaults_for_timestamp=true sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES # 创建新表时将使用的默认存储引擎
default-storage-engine=INNODB [mysql]
# 设置mysql客户端默认字符集
default-character-set=utf8
MySQL 5.7.19 忘记密码 重置密码 配置文件my.ini示例 服务启动后停止 log配置的更多相关文章
- 本地计算机上的MySQL服务启动后停止。某些服务在未由其他服务或程序使用时将自动
重新安装MySQL数据库,由于安装的时候马虎,一路next(事实上,某些地方需要严格的配置,我忘记注意了),导致现在出了很多麻烦. 错误信息: 本地计算机上的MySQL服务启动后停止.某些服务在未由其 ...
- mysql5.7 本地计算机上的mysql 服务启动后停止 的问题解决
mysql5.7 本地计算机上的mysql 服务启动后停止. 问题: 在cmd 下mysql服务mysql服务无法启动任何错误法启动 服务没有报告任何错误 在服务里面启动是 早上来了发现项 ...
- MySQL 安装和启动服务,“本地计算机 上的 MySQL 服务启动后停止。某些服务在未由其他服务或程序使用时将自动停止。”
MySQL 安装和启动服务,以及遇到的问题 MySQL版本: mysql-5.7.13-winx64.zip (免安装,解压放到程序文件夹即可,比如 C:\Program Files\mysql-5. ...
- mysql57重新安装后无法再次启动mysql57服务“本地计算机上的MySQL服务启动后停止。某些服务在未由其他服务或程序使用时将自动。”--解决方法
本地计算机上的MySQL服务启动后停止.某些服务在未由其他服务或程序使用时将自动. (win10,mysql5.7+) 解决方法: 第一步:查看MySQL57安装路径 只要在programData路径 ...
- 本机mysql 5.7服务启动后停止,某些服务在未有其他应用程序使用时停止
本机mysql 5.7服务启动后停止,某些服务在未有其他应用程序使用时停止 出现这种报错,mysql服务启动不了: 错误的尝试: 1:尝试了这个博客:https://blog.csdn.net/wai ...
- MySQL服务启动时显示本地计算机上的MySQL服务启动后停止。某些服务在。。。
之前一直用的好端端的,这次启动服务突然就报了这错误. 更好的阅读体验可访问 这里. 起因 为了使用 LOAD_FILE 函数,在数据库配置文件 my.ini的 [mysqld] 里添加 secure_ ...
- 本地服务开启MySQL57提示本地计算机上MySQL服务启动后停止。。。。
1.首先以管理员身份启动cmd,要不然服务禁止访问. 2.然后在cmd中输入 mysqld --remove mysql或者mysqld --remove mysql57来移除服务. 3.然后进入My ...
- 关于在安装MySQL时报错"本地计算机上的mysql服务启动后停止,某些服务在未由其他服务或程序使用时将自动停止"的解决方法
首先将你下载的MySQL安装或者解压(对应安装版和解压版),下载地址http://dev.mysql.com/downloads/mysql/ 然后复制你安装目录中的my-default.ini,更改 ...
- 关于mysql服务突然运行不了的问题-“本地计算机上的mysql服务启动后停止,某些...”
1.将mysql数据库的安装目录bin文件路径添加到环境的path中,为了让cmd可以直接输入下面的相关命令,不然cd到mysql的bin下也可以 2.cmd输入mysqld --initialize ...
随机推荐
- saltstack 命令2
在Salt主机上,可以快速查看所有Salt minion连接,并查看连接是否被接受,拒绝或挂起 [root@node1 ~]# salt-key -L 接受所有的key [root@node1 ~]# ...
- oracle 列相减——(Oracle分析函数Lead(),Lag())
lag和lead函数,用于取出数据的前n行的数据和后n行的数据,当然要和over(order by)一起组合 其实这2个函数的作用非常好理解,Lead()就是取当前顺序的下一条记录,相对Lag()就是 ...
- spring源码分析系列 (3) spring拓展接口InstantiationAwareBeanPostProcessor
更多文章点击--spring源码分析系列 主要分析内容: 一.InstantiationAwareBeanPostProcessor简述与demo示例 二.InstantiationAwareBean ...
- 用vue的自定义组件写了一个拖拽 组件,局部的 只能在自定义元素内的
简单实现 没有做兼容<!DOCTYPE html> <html lang="en"> <head> <meta charset=" ...
- 归一化(softmax)、信息熵、交叉熵
机器学习中经常遇到这几个概念,用大白话解释一下: 一.归一化 把几个数量级不同的数据,放在一起比较(或者画在一个数轴上),比如:一条河的长度几千甚至上万km,与一个人的高度1.7m,放在一起,人的高度 ...
- ThreadLocal 简介 案例 源码分析 MD
Markdown版本笔记 我的GitHub首页 我的博客 我的微信 我的邮箱 MyAndroidBlogs baiqiantao baiqiantao bqt20094 baiqiantao@sina ...
- SimpleCaptcha生成图片验证码内容为乱码
转自:https://blog.csdn.net/wlwlwlwl015/article/details/51482065 前言 报表中发现有中文乱码和中文字体不整齐(重叠)的情况,首先考虑的就是操作 ...
- Go 语言环境搭建
本文内容 概述 Go SDK LiteIDE 参考资料 2009年Google推出了它的第二个开源语言 Go.对 Go 的评价褒贬不一,中国比国外的热情高.Go 天生就是为并发和网络而生的,除了这点外 ...
- MDX Cookbook 11 - 计算 Year Over Year 增长 (同比计算) ParallelPeriod
这一小节主要介绍如何在一个平行期间的度量值,当前值的对比对象是指当前值的上一年,上一个季度或者其它时间级别上与当前值同一时间点上的的那个对象.有一个非常常见的需求就是对比上一年同一个时间点的某个值来判 ...
- eclipse:报错信息The superclass "javax.servlet.http.HttpServlet" was not found on the Java Build Path
JavaWeb: 报错信息The superclass "javax.servlet.http.HttpServlet" was not found on the Java Bui ...