Hadoop-2.4.0安装和wordcount执行验证
Hadoop-2.4.0安装和wordcount执行验证
下面描写叙述了64位centos6.5机器下,安装32位hadoop-2.4.0,并通过执行
系统自带的WordCount样例来验证服务正确性的步骤。
建立文件夹
/home/QiumingLu/hadoop-2.4.0,以后这个是hadoop的安装文件夹。
安装hadoop-2.4.0,解压hadoop-2.4.0.tar.gz到文件夹
/home/QiumingLu/hadoop-2.4.0就可以
[root@localhosthadoop-2.4.0]# ls
bin etc lib LICENSE.txt NOTICE.txt sbin synthetic_control.data
dfs include libexec logs README.txt share
配置etc/hadoop/hadoop-env.sh
[root@localhosthadoop-2.4.0]#
cat etc/hadoop/hadoop-env.sh
#The java implementation to use.
exportJAVA_HOME=/home/QiumingLu/mycloud/jdk/jdk1.7.0_51
由于hadoop是默认32位的。所以要加这个:
exportHADOOP_COMMON_LIB_NATIVE_DIR=${HADOOP_PREFIX}/lib/native
exportHADOOP_OPTS="-Djava.library.path=$HADOOP_PREFIX/lib"
否则。可能出现一下错误:
Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
Starting namenodes on [Java HotSpot(TM) 64-Bit Server VM warning: You have loaded library /home/hadoop/2.2.0/lib/native/libhadoop.so.1.0.0 which might have disabled stack guard. The VM will try to fix the stack guard now.
It's highly recommended that you fix the library with 'execstack -c <libfile>', or link it with '-z noexecstack'.
localhost]
sed: -e expression #1, char 6: unknown option to `s'
HotSpot(TM): ssh: Could not resolve hostname HotSpot(TM): Name or service not known
64-Bit: ssh: Could not resolve hostname 64-Bit: Name or service not known
Java: ssh: Could not resolve hostname Java: Name or service not known
Server: ssh: Could not resolve hostname Server: Name or service not known
VM: ssh: Could not resolve hostname VM: Name or service not known
配置etc/hadoop/hdfs-site.xml
[root@localhosthadoop-2.4.0]# cat etc/hadoop/hdfs-site.xml
<configuration> <property>
<name>dfs.replication</name>
<value>1</value>
</property>
<property>
<name>dfs.namenode.name.dir</name>
<value>file:/home/QiumingLu/hadoop-2.4.0/dfs/name</value>
</property>
<property>
<name>dfs.datanode.data.dir</name>
<value>file:/home/QiumingLu/hadoop-2.4.0/dfs/data</value>
</property> </configuration>
配置etc/hadoop/core-site.xml
<configuration>
<property>
<name>fs.default.name</name>
<value>hdfs://localhost:9000</value>
</property>
</configuration>
配置etc/hadoop/yarn-site.xml
<configuration> <!--Site specific YARN configuration properties --> <property>
<name>mapreduce.framework.name</name>
<value>yarn</value>
</property>
<property>
<name>yarn.nodemanager.aux-services</name>
<value>mapreduce_shuffle</value>
</property> </configuration>
配置etc/hadoop/mapred-site.xml.template
[root@localhosthadoop-2.4.0]# cat etc/hadoop/mapred-site.xml.template <configuration> <property>
<name>mapreduce.framework.name</name>
<value>yarn</value>
</property> </configuration>
格式化文件系统
[root@localhosthadoop-2.4.0]#
./bin/hadoop namenode -format
启动服务,这里使用root用户,须要输入password的时候,输入root用户password
如果使用非root,并如果分布式服务,须要先解决ssh登录问题,此处不详
细描写叙述。
[root@localhosthadoop-2.4.0]#
sbin/start-all.sh
查看启动状态:
[root@localhosthadoop-2.4.0]#
./bin/hadoop dfsadmin -report
DEPRECATED:Use of this script to execute hdfs command is deprecated.
Insteaduse the hdfs command for it.
14/04/1805:15:30 WARN util.NativeCodeLoader: Unable to load native-hadooplibrary for your platform... using builtin-java
classes whereapplicable
ConfiguredCapacity: 135938813952 (126.60 GB)
PresentCapacity: 126122217472 (117.46 GB)
DFSRemaining: 126121320448 (117.46 GB)
DFSUsed: 897024 (876 KB)
DFSUsed%: 0.00%
Underreplicated blocks: 0
Blockswith corrupt replicas: 0
Missingblocks: 0
-------------------------------------------------
Datanodesavailable: 1 (1 total, 0 dead)
Livedatanodes:
Name:127.0.0.1:50010 (localhost)
Hostname:localhost
DecommissionStatus : Normal
ConfiguredCapacity: 135938813952 (126.60 GB)
DFSUsed: 897024 (876 KB)
NonDFS Used: 9816596480 (9.14 GB)
DFSRemaining: 126121320448 (117.46 GB)
DFSUsed%: 0.00%
DFSRemaining%: 92.78%
ConfiguredCache Capacity: 0 (0 B)
CacheUsed: 0 (0 B)
CacheRemaining: 0 (0 B)
CacheUsed%: 100.00%
CacheRemaining%: 0.00%
Lastcontact: Fri Apr 18 05:15:29 CST 2014
[root@localhosthadoop-2.4.0]# jps
3614DataNode
3922ResourceManager
3514NameNode
9418Jps
4026NodeManager
watermark/2/text/aHR0cDovL2Jsb2cuY3Nkbi5uZXQvdTAxMjQzMjc3OA==/font/5a6L5L2T/fontsize/400/fill/I0JBQkFCMA==/dissolve/70/gravity/Center" alt="">
构造数据文件(file1.txt,file2.txt)
[root@localhosthadoop-2.4.0]# cat example/file1.txt
hello world
hello markhuang
hello hadoop
[root@localhosthadoop-2.4.0]# cat example/file2.txt
hadoop ok
hadoop fail
hadoop 2.4
[root@localhosthadoop-2.4.0]#
./bin/hadoop fs -mkdir /data
把数据文件增加到hadoop系统。
[root@localhosthadoop-2.4.0]#
./bin/hadoop fs -put -f example/file1.txtexample/file2.txt /data
执行WordCount(java)版本号。
[root@localhosthadoop-2.4.0]#
./bin/hadoop jar./share/hadoop/mapreduce/sources/hadoop-mapreduce-examples-2.4.0-sources.jarorg.apache.hadoop.examples.WordCount /data /output
查看结果。
[root@localhosthadoop-2.4.0]#
./bin/hadoop fs -cat /output/part-r-00000
2.4 1
fail 1
hadoop 4
hello 3
markhuang 1
ok 1
world 1
Hadoop-2.4.0安装和wordcount执行验证的更多相关文章
- Hadoop 2.2.0安装和配置lzo
转自:http://www.iteblog.com/archives/992 Hadoop经常用于处理大量的数据,如果期间的输出数据.中间数据能压缩存储,对系统的I/O性能会有提升.综合考虑压缩.解压 ...
- Hadoop 2.2.0部署安装(笔记,单机安装)
SSH无密安装与配置 具体配置步骤: ◎ 在root根目录下创建.ssh目录 (必须root用户登录) cd /root & mkdir .ssh chmod 700 .ssh & c ...
- Ubuntu 12.04下Hadoop 2.2.0 集群搭建(原创)
现在大家可以跟我一起来实现Ubuntu 12.04下Hadoop 2.2.0 集群搭建,在这里我使用了两台服务器,一台作为master即namenode主机,另一台作为slave即datanode主机 ...
- Hadoop 2.2.0 4结点集群安装 非HA
总体介绍 虚拟机4台,分布在1个物理机上,配置基于hadoop的集群中包括4个节点: 1个 Master, 3个 Salve,i p分布为: 10.10.96.33 hadoop1 (Master) ...
- Centos 6.5 hadoop 2.2.0 全分布式安装
hadoop 2.2.0 cluster setup 环境: 操作系统:Centos 6.5 jdk:jdk1.7.0_51 hadoop版本:2.2.0 hostname ip master ...
- Ubuntu14.04用apt在线/离线安装CDH5.1.2[Apache Hadoop 2.3.0]
目录 [TOC] 1.CDH介绍 1.1.什么是CDH和CM? CDH一个对Apache Hadoop的集成环境的封装,可以使用Cloudera Manager进行自动化安装. Cloudera-Ma ...
- Hadoop 2.0安装以及不停集群加datanode
Hadoop2.0是对Hadoop1.0全面升级,针对Namenode单点问题,提出了HDFS Federation,让多个NameNode分管不同的目录进而实现访问隔离和横向扩展.诞生了通用的计算框 ...
- Hadoop 2.4.0完全分布式平台搭建、配置、安装
一:系统安装与配置 Hadoop选择下载2.4.0 http://hadoop.apache.org / http://mirror.bit.edu.cn/apache/hadoop/common/h ...
- 菜鸟玩云计算之十八:Hadoop 2.5.0 HA 集群安装第1章
菜鸟玩云计算之十八:Hadoop 2.5.0 HA 集群安装第1章 cheungmine, 2014-10-25 0 引言 在生产环境上安装Hadoop高可用集群一直是一个需要极度耐心和体力的细致工作 ...
随机推荐
- 如果一个Object对象可能是数组那么如何对其进行迭代
需求:一个方法传入的参数是Object类型(假设对象为“items”,使用Object类型也是为了使用多态而增加方法复用性),但已知这个Object对象可能是基本类型数组,也可能是对象数组,如何将这个 ...
- jdom dom4j解析xml不对dtd doctype进行验证(转)
一.写在所有之前:因为dom4j和jdom在这个问题上处理的方法是一模一样的,只是一个是SAXBuilder 一个SAXReader,这里以jdom距离,至于dom4j只需要同理替换一下就可以了.二. ...
- (Android) Download Images by AsyncTask API
1. Check network status AndroidManifest.xml <uses-sdk> ... </> <uses-permission andro ...
- DLNA_百度百科
DLNA_百度百科 DLNA
- “HTTP 错误 401.1 - 未授权:登录失败” iis配置和权限问题
今天,将项目发布到IIS服务器上,出现此问题,本地IIS访问正常. 登录失败说明根本登录不了,谈何访问网页,所以要从两方面下手,一.账户:二.账户权限: 一.设置你网站属性的时候,目录安全性-匿名访问 ...
- BUG系列:转让startActivityForResult()&onActivityResult()没有反应
前天遇到了一个麻烦,还真是麻烦啊. 我使用startActivityForResult()&onActivityResult().由Activity-A 跳转到Activity-B 页面,然后 ...
- 腾讯測试project师笔试面试记录
从3月29日參加腾讯笔试開始,開始了为期1周的腾讯之旅,尽管最后还是跪在了二面上,可是感觉收获非常多,至少明确了自己与向往的BAT公司的差距,明确了自己还是路漫漫其修远兮. 腾讯非常注 ...
- 【BASH】自己主动清理rman脚本备份文件
************************************************************************ ****原文:blog.csdn.net/clark_ ...
- Codeforce 143B - Help Kingdom of Far Far Away 2
B. Help Kingdom of Far Far Away 2 time limit per test 2 seconds memory limit per test 256 megabytes ...
- ruby中的模块
什么是模块 模块(module)是Ruby特有的功能之一.类用来表现具有数据与行为(程序)的"东西", 而模块大致来说,则是只有程序部分的集合体.类与模块最大的不同在于: 1.模块 ...