centos   邮件服务  腾讯企业邮箱(免费) 使用iRedmail 需要有公网的centos主机 发邮件协议:smtp 端口25  收邮件协议:pop3 端口110  iredmail安装配置  使用邮箱系统  第三十一节课

常见企业邮箱:腾讯企业邮箱、263企业邮箱(网易)

iRedMail的服务器在国外,最近的也在日本,所以最好买国外vps来搭建iRedMail,老师演示的时候根本下载不了

上半节课

两种解决方案
腾讯企业邮箱(免费)
使用iRedmail 需要有公网的centos主机

下半节课

发邮件协议:smtp 端口25
收邮件协议:pop3 端口110
收邮件协议:imap 优于pop

iredmail安装配置
使用邮箱系统

1. 两种解决方案:
(1)腾讯企业邮箱(免费)50人限制 http://exmail.qq.com/
需要有自己的域名,设置mx记录

(2) 使用iRedmail 需要有公网的centos主机

2. 基础知识
发邮件协议:smtp(Simple Mail Transfer Protocol) 端口25
收邮件协议:pop3(Post Office Protocol 3 ) 端口110
收邮件协议:imap, 优于pop3,可以根据用户需求指定下载删除邮件,而不是下载全部,端口143

MTA: mail transfer agent 邮件传输代理,发邮件的(sendmail,postfix)
MRA: mail retravial agent 邮件检索代理,收邮件(dovecot)
MDA: mail delivery agent 邮件投递代理,帮助投递邮件(maildrop)
MUA: mail user agent 邮件用户代理,个人主机上的收发代理软件(outlook,foxmail)

3. iredmail安装配置
iRedMail 为一个开源项目,基于GPL(v2)协议发布。官网 www.iredmail.org (国内不能访问),可以通过www.iredmail.com访问。

iRedMail 核心组件及其对应的功能:
Postfix: SMTP 服务器
Dovecot: POP3/IMAP/Managesieve 服务器
Apache: Web 服务器
MySQL: 用于存储其它程序的数据,也可用于存储邮件帐号。
OpenLDAP: 用于存储邮件帐号。
Policyd: Postfix policy server
Amavisd: 提供 DKIM 签名及校验、SPF校验、为外发邮件添加“免责声明”内容,并调用 SpamAssassin 做基于邮件内容的发垃圾扫描,调用 ClamAV 做邮件病毒扫描。
Roundcube: Webmail
Awstats: 用于分析 Apache 和 Postfix 日志文件,并生成简单的图表。 awstats 分析 Nginx访问日志 http://www.ibm.com/developerworks/cn/linux/l-cn-awstats-nginx/
Fail2ban: 扫描各种日志文件,发现多次密码错误等情况时可自动封禁对方 IP 一段时间。用于保证服务器安全。
iRedAdmin:基于 web 的邮件帐号管理程序。

4. iredmail安装
准备工作:
hostname mail.lishiming.net
vim /etc/hosts //加入
127.0.0.1 mail.lishiming.net
106.187.51.47 www.iredmail.org iredmail.org
配置DNS解析:
MX记录 mail.lishiming.net
A 记录 把mail.lishiming.net 指向一个IP,这个IP就是我们要做邮件服务器的ip

下载iRedMail
wget http://www.iredmail.com/iRedMail-0.9.1.tar.bz2 (当前最新版本为0.9.1,以后会变,请到http://www.iredmail.com/download.html 下载最新版本)

若你的服务器为国内服务器,那么在安装前需要做一些处理:
tar jxvf iRedMail-0.9.1.tar.bz2
cd iRedMail-0.9.1/pkgs
vi get_all.sh // 把 https://mirrors.fedoraproject.org 改为 http://mirrors.fedoraproject.org

sed -i 's/iredmail.org/106.187.51.47/g' get_all.sh
cd ..; sh iRedMail.sh //这个过程需要很久,耐心等待有一步骤是问我们是否打开防火墙,建议大家不要开启:
Would you like to use firewall rules provided by iRedMail now?
< Question > File: /etc/sysconfig/iptables, with SSHD port: 22. [Y|n]n

5. 使用邮箱系统
安装完后,看下这些服务是否启动: 使用命令pstree
for s in httpd iredapd amavisd clamd postfix dovecot cbpolicyd spamassassin clamd.amavisd saslauthd fail2ban; do /etc/init.d/$s restart; done

安装完后,登陆iredadmin 创建用户,并登录 Roundcube系统测试收发邮件。在该步骤中,你可能会遇到这样的问题:发邮件正常,收邮件非常慢,需要等十分钟之久,查看maillog发现这样的提示:Recipient address rejected: Greylisting in effect, please come back later。这是因为Policyd服务造成的,解决办法:
vim /etc/policyd/cluebringer.conf //找到 Greylisting这个模块,在前面加#
然后重启dovecot/postfix/cbpolicyd服务 : service dovecot restart; service postfix restart; service cbpolicyd restart

参考文档: http://wiki.ubuntu.org.cn/IRedMail
扩展学习:
电子邮件原理 http://www.cnblogs.com/qiubole/archive/2007/08/22/865209.html
电子邮件发送原理以及简易实现 http://blog.csdn.net/lishuhuakai/article/details/27503503
postfix配置详解 http://os.51cto.com/art/201101/243430.htm
dovecot 启动报错 http://www.apelearn.com/bbs/thread-7397-1-1.html

foxmail

f

f

f

f

centos 邮件服务 腾讯企业邮箱(免费) 使用iRedmail 需要有公网的centos主机 发邮件协议:smtp 端口25 收邮件协议:pop3 端口110 iredmail安装配置 使用邮箱系统 第三十一节课的更多相关文章

  1. 风炫安全web安全学习第三十一节课 命令执行以及代码执行演示

    风炫安全web安全学习第三十一节课 命令执行以及代码执行演示 参考: http://blog.evalshell.com/2020/12/20/风炫安全web安全学习第三十一节课-命令执行以及代/

  2. centos LAMP第三部分php,mysql配置 php配置文件 配置php的error_log 配置php的open_basedir 安装php的扩展模块 phpize mysql配置第二十一节课

    centos   LAMP第三部分php,mysql配置 php配置文件   配置php的error_log  配置php的open_basedir 安装php的扩展模块 phpize  mysql配 ...

  3. centos shell编程3【告警系统】 没有服务器端和客户端的概念 main.sh mon.conf load.sh 502.sh mail.php mail.sh disk.sh 第三十七节课

    centos shell编程3[告警系统]  没有服务器端和客户端的概念 main.sh mon.conf load.sh 502.sh mail.php mail.sh  disk.sh  第三十七 ...

  4. centos DNS服务搭建 DNS原理 使用bind搭建DNS服务器 配置DNS转发 配置主从 安装dig工具 DHCP dhclient 各种域名解析记录 mydns DNS动态更新 第三十节课

    centos  DNS服务搭建  DNS原理  使用bind搭建DNS服务器 配置DNS转发 配置主从  安装dig工具  DHCP  dhclient  各种域名解析记录  mydns DNS动态更 ...

  5. centos 阶段复习 2015-4-6 dd命令 hosts.allow和hosts.deny 啊铭的myssh脚本 清空history命令历史 /dev/zero 零发生器 /dev/null 黑洞 /dev/random 生成随机数 第十一节课

    centos 阶段复习 2015-4-6  dd命令 hosts.allow和hosts.deny 啊铭的myssh脚本 清空history命令历史  /dev/zero 零发生器  /dev/nul ...

  6. centos LAMP第二部分apache配置 下载discuz!配置第一个虚拟主机 安装Discuz! 用户认证 配置域名跳转 配置apache的访问日志 配置静态文件缓存 配置防盗链 访问控制 apache rewrite 配置开机启动apache tcpdump 第二十节课

    centos    LAMP第二部分apache配置  下载discuz!配置第一个虚拟主机 安装Discuz! 用户认证 配置域名跳转  配置apache的访问日志  配置静态文件缓存  配置防盗链 ...

  7. 风炫安全web安全学习第三十节课 命令执行&代码执行基础

    风炫安全web安全学习第三十节课 命令执行&代码执行基础 代码执行&命令执行 RCE漏洞,可以让攻击者直接向后台服务器远程注入操作系统命令或者代码,从而控制后台系统. 远程系统命令执行 ...

  8. 第三百三十一节,web爬虫讲解2—Scrapy框架爬虫—Scrapy安装—Scrapy指令

    第三百三十一节,web爬虫讲解2—Scrapy框架爬虫—Scrapy安装—Scrapy指令 Scrapy框架安装 1.首先,终端执行命令升级pip: python -m pip install --u ...

  9. 风炫安全web安全学习第三十七节课 15种上传漏洞讲解(二)

    风炫安全web安全学习第三十七节课 15种上传漏洞讲解(二) 05后缀名黑名单校验之上传.htaccess绕过 还是使用黑名单,禁止上传所有web容器能解析的脚本文件的后缀 $is_upload = ...

随机推荐

  1. Jquery实现$.fn.extend和$.extend函数

    $.fn.extend(   {      method:function(){   }   })   $.extend(   {      method:function(){   }   })

  2. linux中,查看某个命令是来自哪个RPM包或者是通过哪个RPM包安装的

    需求描述: 今天在测试ssh命令到底是哪个RPM包,安装之后生成的,找了一些文档 在这里进行记录下,主要是rpm -qf命令的使用,查询文件在哪个包里. 操作过程: 1.通过whereis 定位ssh ...

  3. Java精选笔记_国际化

    国际化 什么是国际化 指软件在开发时就应该具备支持多种语言和地区的功能,当应对不同国家和地区的用户访问,针对不同国家和地区的用户,提供相应的.符合来访者阅读习惯的页面和数据. 由于国际化interna ...

  4. CentOS6.5安装图形界面(Gnome)

    因为是以最小化安装的Linux,无法使用图形界面,从网上看到资料,我使用yum安装果然很简单 ----------------------------------------------------- ...

  5. 什么叫做hack

    由于不同的浏览器,比如Internet Explorer 6,Internet Explorer 7,Mozilla Firefox等,对CSS的解析认识不一样,因此会导致生成的页面效果不一样,得不到 ...

  6. win10下安装Oracle 11g 32位客户端遇到INS-13001环境不满足最低要求

    在以管理员身份运行setup.exe之后,出现了:[INS-13001]环境不满足最低要求,通过网上搜索之后找到了解决途径 首先,打开你的解压后的database文件夹,找到stage,然后cvu,找 ...

  7. PHP中str_replace和substr_replace有什么区别?

    两个函数的定义:(1)str_replace() 函数替换字符串中的一些字符(区分大小写). 该函数必须遵循下列规则: 如果搜索的字符串是一个数组,那么它将返回一个数组. 如果搜索的字符串是一个数组, ...

  8. 编译boost程序出现如下错误fatal error LNK1104: cannot open file 'libboost_system-vc100-mt-gd-1_54.lib'的解决方法

    对于如下程序: #include <iostream> #include <boost/asio.hpp> #include <boost/date_time/posix ...

  9. Linux 启动文件、设置环境变量的位置

    系统级启动文件  ==================================== 1./etc/rc  主启动文件,不要修改它 2./etc/rc.conf  决定启动哪些系统自带的守护进程 ...

  10. 如何在Linux系统通过命令行生成随机文件

    版权声明:本文由胡恒威原创文章,转载请注明出处: 文章原文链接:https://www.qcloud.com/community/article/86 来源:腾云阁 https://www.qclou ...