CentOS6.5安装ElasticSearch6.2.3

1、Elastic 需要 Java 8 环境。(安装步骤:http://www.cnblogs.com/hunttown/p/5450463.html)

2、安装包下载:

#官网地址

https://www.elastic.co/downloads/elasticsearch

3、新建用户

Elastic高版本不建议使用root用户

(1)创建elastic用户组

[root@mycentos ~]# groupadd elastic

(2)创建用户elastic

useradd elastic(用户名) -g elastic(组名) -p 123456(密码)

[root@mycentos ~]# useradd elastic -g elastic -p 123456

4、解压安装包

建议将安装包放到/usr/local目录下   .放到新建用户目录下,要不报错    错误: 找不到或无法加载主类 org.elasticsearch.tools.java_version_checker.JavaVersionChecker

[root@mycentos local]# unzip elasticsearch-6.2.3.zip
tar zxvf xxx.gz

5、添加权限

chown -R elastic elasticsearch-6.2.3

6、修改配置文件

(1)ERROR: bootstrap checks failed

memory locking requested for elasticsearch process but memory is not locked

原因:锁定内存失败

解决方案:使用root用户,编辑limits.conf配置文件, 添加如下内容:

[root@mycentos ~]# vim /etc/security/limits.conf

* soft memlock unlimited
* hard memlock unlimited

备注:* 代表Linux所有用户名称,保存、退出、重新登录生效。

(2)ERROR: bootstrap checks failed

max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]

原因:无法创建本地文件问题,用户最大可创建文件数太小。

解决方案:使用root用户,编辑limits.conf配置文件, 添加如下内容:

[root@mycentos ~]# vim /etc/security/limits.conf

* soft nofile 65536    #软件
* hard nofile 131072 #硬件

(3)max number of threads [1024] for user [es] is too low, increase to at least [2048]

原因:无法创建本地线程问题,用户最大可创建线程数太小

解决方案:使用root用户,进入limits.d目录下,修改90-nproc.conf 配置文件。

[root@mycentos ~]# vim /etc/security/limits.d/90-nproc.conf

soft nproc 1024
#修改为:
soft nproc 4096

(4)max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]

原因:最大虚拟内存太小

解决方案:使用root用户下,修改配置文件sysctl.conf

[root@mycentos ~]# vim /etc/sysctl.conf

添加下面配置:

vm.max_map_count=655360

并执行命令生效:

sysctl -p

(5)system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk

原因:因为Centos6不支持SecComp

解决方法:在elasticsearch.yml中配置bootstrap.system_call_filter为false,注意要在Memory下面:

[root@mycentos config]# vim elasticsearch.yml

bootstrap.memory_lock: false
bootstrap.system_call_filter: false

(6)配置host

[root@mycentos config]# vim elasticsearch.yml

network.host: 0.0.0.0 #所有用户都可以访问
http.port: 9200

7、切换用户

[root@mycentos local]# su elastic

8、启动es

 [elastic@mycentos elasticsearch-6.2.3]$ bin/elasticsearch

后台启动:

[elastic@mycentos elasticsearch-6.2.3]$ bin/elasticsearch -d
或
[elastic@mycentos elasticsearch-6.2.3]$ bin/elasticsearch &

9、浏览器访问

或者:

安装完毕!

声明:本文仅为作者个人笔记,请勿转载!

CentOS6.5安装ElasticSearch6.2.3的更多相关文章

  1. 【ELK】之Centos6.9_x64安装elasticsearch6.2.1

    1.下载elasticsearch6.2.1 wget https://artifacts.elastic.co/downloads/elasticsearch/elasticsearch-6.2.1 ...

  2. Linux环境CentOS6.9安装配置Elasticsearch6.2.2最全详细教程

    Linux环境CentOS6.9安装配置Elasticsearch6.2.2最全详细教程 前言 第一步:下载Elasticsearch6.2.2 第二步:创建应用程序目录 第四步:创建Elastics ...

  3. vmware Centos6.6安装64位

    Centos6.6安装64位 必须开启BIOS中的虚拟化技术 首先开机进入BIOS,一般机器是按F2,我的T420是按F1,然后进入Security,Virtualization,选择Enable即可 ...

  4. Gitlab完美安装【CentOS6.5安装gitlab-6.9.2】

    摘要: 拆腾了几天,终于在今天找到了快速安装Gitlab的方法.CentOS6.5安装gitlab-6.9.2 参考网址:https://gitlab.com/gitlab-org/omnibus-g ...

  5. CentOS6.5安装Tomcat

    安装说明 安装环境:CentOS-6.4 安装方式:源码安装 软件:apache-tomcat-7.0.56.tar.gz 下载地址:http://tomcat.apache.org/download ...

  6. Centos6 yum安装openldap+phpldapadmin+TLS+双主配置

    原文地址:http://54im.com/openldap/centos-6-yum-install-openldap-phpldapadmin-tls-%E5%8F%8C%E4%B8%BB%E9%8 ...

  7. centos6.5安装oracle11g_2

    centos7安装oracle数据库不成功,换成centos6.5安装,可以安装成功,记录一下 安装系统时,主机名如果不是用localhost,安装成功后,要用主机名和ip做映射,修改/etc/hos ...

  8. CentOS6.6安装vmware workstation报错

    本人系统用的是centos6.6,安装了vmware workstation,启动后一直如下图报错,相关内核已经安装了的,哪位前辈如果解决过这样的问题,麻烦指点指点,小弟在此先谢过了.

  9. CentOS6.6安装virtualbox4.1.44

    本人用的是centos6.6,安装了virtualbox 4.1.44,启动后一直如上图报错,哪位前辈如果解决过这样的问题,麻烦指点指点,小弟在此先谢过了.

随机推荐

  1. Maven的基础了解与使用

    目录 Maven的介绍: 什么是Maven: 为什么要学习maven? 安装与配置: 下载: 配置环境变量 测试安装结果: Maven概念: 坐标 仓库 入门示例 创建maven工程: 添加依赖 Ma ...

  2. Yapi部署说明

    1.环境搭建 确保 node 版本=> 7.6,请运行 node -v 查看版本号 确保 mongodb 版本 => 2.6,请运行 mongo --version 查看版本号 确保安装了 ...

  3. Linux命令学习总结:ls

    命令简介: ls命令用来列出目标目录(缺省的话为当前目录)中所有的子目录和文件.指令英文原义:list 指令所在路径:/bin/ls 执行权限:All User 命令语法: ls [OPTION].. ...

  4. SQLServer之PRIMARY KEY约束

    PRIMARY KEY约束添加规则 1.在表中常有一列或多列的组合,其值能唯一标识表中的每一行,这样的一列或多列成为表的主键(PrimaryKey). 2.一个表只能有一个主键,而且主键约束中的列不能 ...

  5. redis.clients.jedis.exceptions.JedisDataException: ERR invalid DB index

    添加redis配置文件, 启动后,调用报错  redis.clients.jedis.exceptions.JedisDataException: ERR invalid DB index ERR i ...

  6. LivePhoto开发,你要知道的知识点

    前言 Apple从iPhone6s开始支持Live Photo.Live Photo 会录下拍照前后 1.5 秒所发生的一切,因此用户获得的不仅仅是一张精美照片,还有拍照前后时刻的动作和声音.具体的操 ...

  7. 爬虫实例系列一(requests)

    一 爬虫简介 ''' 爬虫:通过编写程序,模拟浏览器上网,让其去互联网上爬取数据的过程 分类: 通用爬虫:爬取全部的页面数据 聚焦爬虫:抓取页面中局部数据 增量式爬虫:爬取网站中更新出的数据 反爬机制 ...

  8. 无post按钮提交表单

    <form id="form1" name="form" action="url" method="GET"> ...

  9. Kafka简介、基本原理、执行流程与使用场景

    一.简介 Apache Kafka是分布式发布-订阅消息系统,在 kafka官网上对 kafka 的定义:一个分布式发布-订阅消息传递系统. 它最初由LinkedIn公司开发,Linkedin于201 ...

  10. JDK1.8源码(十)——java.util.LinkedHashSet类

    同 HashSet 与 HashMap 的关系一样,本篇博客所介绍的 LinkedHashSet 和 LinkedHashMap 也是一致的.在 JDK 集合框架中,类似 Set 集合通常都是由对应的 ...