oracle 归档日志:db_recovery_file_dest、log_archive_dest和log_archive_dest_n的区别和使用
概念:
db_recovery_file_dest:默认的指定闪回恢复区路径
log_archive_dest:指定归档文件存放的路径,所有归档路径必须是本地的,默认为’’。log_archive_duplex_dest的主路劲。
注意:设置log_archive_dest需要把db_recovery_file_dest设置为空:alter system set DB_RECOVERY_FILE_DEST='';
log_archive_dest_n:默认值为’’,n从1到10,归档地址可以为本地磁盘,或者网络设备
log_archive_duplex_dest:log_archive_dest的从路径
注意:当db_recovery_file_dest、log_archive_dest、log_archive_dest_n都没有设置时,归档日志会存放在$ORACLE_HOME/dbs/arch/目录下
未设置db_recovery_file_dest,则需关闭闪回(alter database flashback off;)
pfile:文本参数文件又叫静态参数文件,ASCII文本文件(可以直接编辑)
spfile:服务器参数文件。二进制文件(不可以直接编辑,db启动后通过sql命令在线修改。)。 判断db系统以pfile还是spfile启动:如果Value为空,则表示使用以pfile启动db,未创建spfile
共存:
db_recovery_file_dest可以和log_archive_dest_n共存
log_archive_dest可以和log_archive_duplex_dest共存
db_recovery_file_dest和log_archive_dest_n不能和log_archive_dest共存
常用命令:
关闭数据库: shutdown immediate;
开启数据库: startup mount; 注意:修改归档模式必须是在mount下
开启归档模式:alter database archivelog;
查看数据库的归档模式:archive log list;
查看spfile存放位子:show parameter spfile;
查看日志默认存放路径:show parameter DB_RECOVERY_FILE_DEST;
查看日志存放路径:show parameter log_archive_dest;
检查flash recovery area的使用情况(db_recovery_file_dest模式下):select * from V$FLASH_RECOVERY_AREA_USAGE
修改log_archive_dest日志存放路径:alter system set log_archive_dest='路径' scope=both;
修改数据库的状态为打开:alert database open;
切换日志(强制生成日志):alter system switch logfile;
oracle 归档日志:db_recovery_file_dest、log_archive_dest和log_archive_dest_n的区别和使用的更多相关文章
- Oracle归档日志与非归档日志的切换及路径设置
--==================== -- Oracle 归档日志 --==================== Oracle可以将联机日志文件保存到多个不同的位置,将联机日志转换为归档日志的 ...
- 查看oracle归档日志路径
转至:https://blog.csdn.net/u010098331/article/details/50729896/ 查看oracle归档日志路径 1.修改归档日志的格式 默认格式是:" ...
- oracle归档日志增长过快处理方法
oracle归档日志一般由dml语句产生,所以增加太快应该是dml太频繁 首先查询以下每天的归档产生的情况: SELECT TRUNC(FIRST_TIME) "TIME", SU ...
- ORACLE归档日志比联机重做日志小很多的情况总结
ORACLE归档日志比联机重做日志小很多的情况 前几天一网友在群里反馈他遇到归档日志比联机重做日志(redo log)小很多的情况,个人第一次遇到这种情况,非常感兴趣,于是在一番交流沟通后,终于弄 ...
- oracle归档日志关闭和打开
查询归档日志状态 方法一 SQL> archive log list; 方法二 SQL> select name,log_mode from V$database; 打开归档日志 orac ...
- 修改Oracle归档日志方法
修改Oracle归档日志的方法 Oracle默认安装的归档日志只有50M,在做大量操作的时候会经常切换日志文件,造成性能问题,下面是具体操作方法 1. 下面是查看现有归档日志大小: SQL> ...
- 清除oracle归档日志
清除oracle归档日志 1. 连接oracle报如下错误 ORA-00257: archiver error. Connect internal only, until freed 产生原因:出现O ...
- ORACLE归档日志满了之后,如何删除归档日志
当ORACLE归档日志满后如何正确删除归档日志 版权声明:本文为博主原创文章,未经博主允许不得转载. 当ORACLE 归档日志满了后,将无法正常登入ORACLE,需要删除一部分归档日志才能正常登入OR ...
- Oracle归档日志所在目录时间不对&&Oracle集群日志时间显示错误
Oracle归档日志所在目录时间不对&&Oracle集群日志时间显示错误 前言 这个问题在18年的时候遇到了,基本不注意并且集群或者数据库运行正常是很难注意到的. 忘记当时怎么发现的了 ...
- Oracle归档日志暴增排查优化
1.ORACLE归档日志介绍 归档日志暴增是oracle比较常见的问题,遇到归档日志暴增,我们该如何排查: 归档日志暴增一般都是应用或者人为引起的 理解归档日志存储的是什么 如何排查归档日志暴增原因 ...
随机推荐
- PHP中DirectIO直操作文件扩展的使用
关于 PHP 的文件操作,我们也将是通过一系列的文章来进行学习.今天我们先学习的是一个很少人使用过,甚至很多人根本不知道的扩展,它与我们日常的文件操作有些许的不同.不过这些差别并不是我们肉眼所能直观看 ...
- 一起搞懂PHP的错误和异常(三)
关于错误与异常的最后一篇文章,我们来进行一些总结. PHP中错误和异常的区别 通过前面两篇文章的学习,我们来直接将错误和异常摆上来进行对比,看看他们的区别与联系: 错误的出现通常是语法或编译运行时错误 ...
- mysql数据库备份参数
我用来实现自动全备份的脚本(可以满足一般有前后版本兼容要求的导出导入操作,我的字符集是latin1): mysqldump.exe -umyusername -pmypass -h localhost ...
- 安装 MongoDb
下面具体说下MongoDB安装之后的一些配置操作 [声明]我的安装路径是:C:\Program Files\MongoDB\Server\3.4 1. 创建数据库路径(data目录).日志路径(log ...
- Orchard Core 简介
Orchard Core 是基于ASP.NET Core 对Orchard CMS的 二次开发. Orchard Core由两部分组成: Orchard Core Framework: 一个基于ASP ...
- 在Ubuntu18.04安装docker之后,以登陆用户身份执行docker pull jenkins,报错:connect: permission denied
Using default tag: latest Got permission denied while trying to connect to the Docker daemon socket ...
- java 工具类 验证码
第一步: 引入工具类 工具类一: import java.awt.Color; import java.awt.Font; import java.awt.Graphics2D; import jav ...
- mysql 建表后 重新构建 自增字段 (保留 原有字段结构)
添加字段 1.去除原id的自增功能:ALTER TABLE A_A MODIFY COLUMN id int(10) NOT NULL FIRST ; 2.添加名称为cstId,类型为bigint的字 ...
- MacOS上通过虚拟机搭建基础CentOS7系统环境
MacOS上通过虚拟机搭建基础CentOS7系统环境 尽管从Mac的Terminal可以看出,macOS与UNIX.Linux或多或少都有血缘关系(shell.bash等),但是在mac进行Linux ...
- 基于nginx实现私有yum仓库
基于本地光盘的源 server端IP:10.0.0.79 nginx使用默认路径.端口 yum install nginx -y #更改以root运行 sed -i '/^user/s/nginx/r ...