使用Symantec Backup Exec将几台Linux服务器上的RMAN备份收带时,偶尔会遇到作业备份失败的情况,检查Job History,就会发现有“Access denied to directory u05/backup/backupsets" 这类错误,当然实际路径为/u05/backup/backupsets. 另外错误代码为E0008488

在官方文档" Troubleshooting error "Access is denied" with Backup Exec Remote Agent for Linux/UNIX server (RALUS) backups"这篇文章有下面介绍:

Problem

Troubleshooting error "Access is denied" with Backup Exec Remote Agent for Linux/UNIX server (RALUS) backups.

Error Message

V-79-57344-33928 - Access is denied

or

Error in the job log

Backup -\\<linuxservername>\[ROOT]

V-79-57344-33928 - Access is denied

Access denied to directory home/jdoering/.

V-79-57344-33928 - Access is denied

or

Final error: 0xe0008488 - Access is denied.

Error in the job log

Backup - $$testlab.veritas.com $  [ROOT]

V-79-57344-33928 - Access is denied

Access denied to file p01/orabackup/devp/u01/control01.ctl

V-79-57344-33928 - Access is denied

Solution

The error 0xe0008488 - Access is denied can occur due to following issues with RALUS:

  1. The Backup Exec Remote Agent for Linux/UNIX Servers is unable to browse directories on remote Linux/UNIX computers with filenames containing non EUC encoded characters.
  1. Job Fails with "V-79-57344-33928 - Access is Denied" on few folders on SUSE Enterprise Linux 11.
  1. 0xe0008488 - Access is denied when a backup up of Solaris Snapshot Volume runs.
  1. The Backup Exec Remote Agent for Linux/UNIX Servers is unable to browse directories on remote Linux/UNIX computers with filenames containing non EUC encoded characters.

The above error occurs because Backup Exec is unable to read the characters in the UNIX/Linux file system that are non EUC encoded. EUC (Extended Unix Code) is a multi byte encoding standard used to represent large Asian character sets.

As a workaround, the Backup Exec Remote Agent for Linux and UNIX Servers (RALUS) config file can be edited so that Backup Exec will override the agent's localization detection and cause it to use an encoding that should allow the Unicode characters to be translated correctly. Perform the following at the remote Linux/UNIX computer:

  1. Stop the RALUS by executing the command  /etc/init.d/VRTSralus.init stop
  1. The configuration file of the RALUS is ralus.cfg, located in the path /etc/VRTSralus on the remote UNIX/Linux server.
  1. Open ralus.cfg in a text editor such as vi and locate the following line:

Software\VERITAS\Backup Exec\Engine\RALUS\Encoder=

  1. Add the following to the above line: LATIN-1. The new line should like this:
  1. Software\VERITAS\Backup Exec\Engine\RALUS\Encoder=LATIN-1
  1. Execute the command /etc/init.d/VRTSralus.init start to start the RALUS on the remote Linux/UNIX server.
  1. Job Fails with "V-79-57344-33928 - Access is Denied" on few folders on SUSE Enterprise Linux 11.

Issue is caused if the customer is or was using GNOME Desktop and has mounted the .gvfs directory in the folder

  1. Unmount the .GVFS Directory Mount from the folder

Note: GVFS is the virtual filesystem for the GNOME desktop.

  1. 0xe0008488 - Access is denied when a backup up of Solaris Snapshot Volume runs.

As a workaround, the Backup Exec Remote Agent for Linux and UNIX Servers (RALUS) needs to be restarted after the snapshot has been mounted.

Terms of use for this information are found in Legal Notices.

那么我们来分析一下Symantec Backup Exec 报“Access is denied”错误的几种原因

1:The Backup Exec Remote Agent for Linux/UNIX Servers is unable to browse directories on remote Linux/UNIX computers with filenames containing non EUC encoded characters.

目录/u05/backup/backupsets/,以及/u05/backup/backupsets/下的所有文件名称均不包含非EUC编码字符。也没有使用任何中文字符。那么这个原因可以排除。

2: Job Fails with "V-79-57344-33928 - Access is Denied" on few folders on SUSE Enterprise Linux 11.

我们系统版本为Red Hat Enterprise Linux Server release 5.7 ,不是SUSE企业版本. 但是报的错误信息“V-79-57344-33928 - Access is Denied”跟文档一模一样。 另外桌面系统也确实为gnome,但是找了一下没有找到挂载.gvfs目录。

3:0xe0008488 - Access is denied when a backup up of Solaris Snapshot Volume runs.
As a workaround, the Backup Exec Remote Agent for Linux and UNIX Servers (RALUS) needs to be restarted after the snapshot has been mounted.

关于这个我们这几台确实都设置了Snapshot Volume.因为DR方案使用了paltespin进行复制。看来很有可能就是这个原因造成的。

参考资料:

https://www.veritas.com/support/en_US/article.TECH38357

Symantec Backup Exec 报"Access denied to directory xxx" Error Code E0008488的更多相关文章

  1. ERROR 1045 (28000): Access denied for user xxx & ERROR 1449 (HY000): The user specified as a definer xxx does not exists

    今天在一个修改过权限的MySQL数据库遇到了"ERROR 1045 (28000): Access denied for user 'xxx'@'xxx.xxx.xxx.xxx' (usin ...

  2. Symantec Backup Exec 2010 安装报 bad ELF interpreter: No such file or directory

    在64位的Red Hat Enterprise Linux Server release 6.6上安装Symantec Backup Exec 2010时, 遇到下面错误: # ./installra ...

  3. Symantec Backup Exec 2012 Agent For Linux安装

    Backup Exec 2012 介绍 Backup Exec 2012 是一种为虚拟和物理环境提供保护的集成产品,能够简化备份和灾难恢复,并提供了无可匹敌的恢复功能.借助于强大的 Symantec ...

  4. Symantec Backup Exec 2010 Agent For Linux安装

    以前写过一篇文章介绍过Symantec Backup Exec 2012 Agent For Linux安装安装,今天介绍一下Symantec Backup Exec 2010 Agent For L ...

  5. Symantec Backup Exec Remote Agent 2010在Redhat Enterprise 6.6上启动问题

    在Red Hat Enterprise Linux Server release 6.6 (Santiago)上安装了Symantec Backup Exec Remote Agent 2010后,启 ...

  6. Symantec Backup Exec备份作业服务器盘符变更

    Symantec Backup Exec的备份作业中,如果某个服务器的磁盘更改了盘符,如果不修改备份作业里面的相关配置,就会出现类似下面的错误信息,如下截图所示 因为这台服务器上我们将原先的G盘的盘符 ...

  7. Symantec Backup Exec 2012 Agent for Linux 卸载

    本文介绍一下如何卸载Symantec Backup Exec 2012 Agent for Linx.首先我们来看看Symantec_Backup_Exec2012管理员手册的文档介绍: 卸载 Age ...

  8. Symantec Backup Exec Agent For Linux防火墙问题

    如果在Unix或Linux安装配置好了Symantec Backup Exec Agent For Linux,但是在Symantec Backup Exec服务端无法访问Symantec Backu ...

  9. Symantec Backup Exec恢复数据库

    Insus.NET是使用Symantec Backup Exec来备份数据以及一些服务器文件.下面步骤是怎样恢复一个数据库.当我们数据库有问题,或是想恢复某一天的数据,得需要操作数据恢复Restore ...

随机推荐

  1. TextBox禁止复制粘贴和数字验证,小数验证,汉字验证

    验证小数 #region 验证小数 /// <summary> /// 验证小数 /// </summary> /// <param name="sender& ...

  2. 删除div

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/ ...

  3. Eclipse下FatJar插件的安装与使用

    在Eclipse下生成jar包分很多种情况.最简单的情况是没有用到第三方jar包,那么直接Export就可以生成jar包.但是如果用到了第三方jar包,那么就比较繁琐了,很不方便.FatJar可以解决 ...

  4. 修正 Memo 設定為 ReadOnly 後, 無法有複製的功能

    问题:当 Memo 設定為 ReadOnly = True 後, 选取一段文字后,無法有複製的功能. 适用:XE6 Android 系统(目前 iOS 还找不到方法) 修正方法: 请将源码 FMX.P ...

  5. 最小生成二叉树-prim算法

    1.prim算法:一种计算生成最小生成树的方法,它的每一步都会为一棵生长中的树添加一条边. 2.时间复杂度:

  6. Android开发中Eclispe相关问题及相应解决(持续更新)

    1.Eclipse项目中的Android Private Libraries没有自动生成. 一般而言,在Android开发中,项目中引用到的jar包会放到项目目录中的libs中,引入库会放到Andro ...

  7. Alfresco 4 项目介绍

    body{ font: 16px/1.5em 微软雅黑,arial,verdana,helvetica,sans-serif; }       Alfresco 是一个开源的企业内容管理系统(ECM) ...

  8. 说说IT技术团队招聘那点事

    因为近来由于新项目的需要,各种招聘比较多,几乎每周都要面试几个人,顺便对以前的面试和带开发经验进行简单的总结 1.首先负责招聘的人一定得是自己团队的人,而且在招聘的时候一定要想清楚目标候选人进来的职责 ...

  9. MongoDB的内置角色 Built-In Roles

    关于芒果的权限控制说白了就是定义 Role(角色) 来控制对数据库进行的操作(调用的方法比如查询方法find). 系统内置的Role分为 以下几大类: Database User Roles 这个是针 ...

  10. Google Web Designer – 创建引人入胜的 HTML5 网站

    Google Web Designer 可以帮助你创建引人入胜,互动的基于 HTML5 的设计和动画,可以在任何设备上运行.如果你喜欢自己动手,设计背后的所有的代码都是可以手工编辑的. 虽然可视化工具 ...