Installation Oracle11gR2 RAC---常见报错处理
6.1 root.sh脚本执行失败处理
安装grid时,执行rootsh脚本报错如下:
Adding Clusterware entries to inittab
USM driver install actions failed
/u01/app/11.2.0/grid/perl/bin/perl-I/u01/app/11.2.0/grid/perl/lib -I/u01/app/11.2.0/grid/crs/install/u01/app/11.2.0/grid/crs/install/rootcrs.pl execution failed
查看mos发现为一个bug,ROOT.SH OR ACFSROOT INSTALL,FAILS: ACFS-9109: SLES11 SP3。分别在节点1与节点2上打补丁。
unzip p17475946_112040_Linux-x86-64.zip
grid@jason2:/u01/app/11.2.0/grid/OPatch>./opatch napply -oh /u01/app/11.2.0/grid -local /mnt/17475946
Oracle Interim Patch Installer version11.2.0.3.4
Copyright (c) 2012, Oracle Corporation. All rights reserved.
Oracle Home : /u01/app/11.2.0/grid
Central Inventory : /u01/app/oraInventory
from :/u01/app/11.2.0/grid/oraInst.loc
OPatch version : 11.2.0.3.4
OUI version : 11.2.0.4.0
Log file location :/u01/app/11.2.0/grid/cfgtoollogs/opatch/opatch2015-05-15_09-04-45AM_1.log
Verifying environment and performingprerequisite checks...
OPatch continues with these patches: 17475946
Do you want to proceed? [y|n]
y
User Responded with: Y
All checks passed.
Please shutdown Oracle instances runningout of this ORACLE_HOME on the local system.
(Oracle Home = '/u01/app/11.2.0/grid')
Is the local system ready for patching?[y|n]
y
User Responded with: Y
Backing up files...
Applying interim patch '17475946' to OH'/u01/app/11.2.0/grid'
Patching component oracle.usm,11.2.0.4.0...
Verifying the update...
Patch 17475946 successfully applied.
Log file location:/u01/app/11.2.0/grid/cfgtoollogs/opatch/opatch2015-05-15_09-04-45AM_1.log
OPatch succeeded.
grid@jason2:/u01/app/11.2.0/grid/OPatch>
6.2 Crsctl执行关闭时报错
Crsctl执行关闭时报错。
jason1:/u01/app/11.2.0/grid/bin# ./crsctl stop crs
CRS-2791: Starting shutdownof Oracle High AvailabilityServices-managed resources on 'jason1'
CRS-2673: Attempting to stop'ora.crsd' on 'jason1'
CRS-2790: Starting shutdownof Cluster Ready Services-managedresources on 'jason1'
CRS-2673: Attempting to stop'ora.OCR.dg' on 'jason1'
CRS-2673: Attempting to stop'ora.registry.acfs' on 'jason1'
CRS-2673: Attempting to stop'ora.oracle.db' on 'jason1'
CRS-2673: Attempting to stop'ora.LISTENER_SCAN1.lsnr' on'jason1'
CRS-2673: Attempting to stop'ora.cvu' on 'jason1'
CRS-2673: Attempting to stop'ora.LISTENER.lsnr' on 'jason1'
CRS-2673: Attempting to stop'ora.oc4j' on 'jason1'
CRS-2677: Stop of 'ora.LISTENER.lsnr'on 'jason1' succeeded
CRS-2673: Attempting to stop'ora.jason1.vip' on 'jason1'
CRS-2677: Stop of 'ora.cvu'on 'jason1' succeeded
CRS-2672: Attempting to start'ora.cvu' on 'jason2'
CRS-2677: Stop of'ora.LISTENER_SCAN1.lsnr' on 'jason1'succeeded
CRS-2673: Attempting to stop'ora.scan1.vip' on 'jason1'
CRS-2677: Stop of'ora.jason1.vip' on 'jason1' succeeded
CRS-2672: Attempting to start'ora.jason1.vip' on 'jason2'
CRS-2676: Start of 'ora.cvu'on 'jason2' succeeded
CRS-2677: Stop of 'ora.scan1.vip'on 'jason1' succeeded
CRS-2672: Attempting to start'ora.scan1.vip' on 'jason2'
CRS-2677: Stop of'ora.oracle.db' on 'jason1' succeeded
CRS-2673: Attempting to stop'ora.DATA.dg' on 'jason1'
CRS-2673: Attempting to stop'ora.FRA.dg' on 'jason1'
CRS-2677: Stop of'ora.registry.acfs' on 'jason1' succeeded
CRS-2676: Start of'ora.jason1.vip' on 'jason2' succeeded
CRS-2676: Start of'ora.scan1.vip' on 'jason2' succeeded
CRS-2672: Attempting to start'ora.LISTENER_SCAN1.lsnr' on'jason2'
CRS-2677: Stop of'ora.OCR.dg' on 'jason1' succeeded
CRS-2677: Stop of'ora.FRA.dg' on 'jason1' succeeded
CRS-2677: Stop of'ora.DATA.dg' on 'jason1' succeeded
CRS-2673: Attempting to stop'ora.asm' on 'jason1'
CRS-2676: Start of'ora.LISTENER_SCAN1.lsnr' on 'jason2'succeeded
CRS-2677: Stop of 'ora.asm'on 'jason1' succeeded
CRS-2677: Stop of 'ora.oc4j'on 'jason1' succeeded
CRS-2672: Attempting to start'ora.oc4j' on 'jason2'
CRS-2676: Start of 'ora.oc4j'on 'jason2' succeeded
CRS-2673: Attempting to stop'ora.ons' on 'jason1'
CRS-2677: Stop of 'ora.ons'on 'jason1' succeeded
CRS-2673: Attempting to stop'ora.net1.network' on 'jason1'
CRS-2677: Stop of'ora.net1.network' on 'jason1' succeeded
CRS-2792: Shutdown of ClusterReady Services-managed resourceson 'jason1' has completed
CRS-2677: Stop of 'ora.crsd'on 'jason1' succeeded
CRS-2673: Attempting to stop'ora.crf' on 'jason1'
CRS-2673: Attempting to stop'ora.ctssd' on 'jason1'
CRS-2673: Attempting to stop'ora.evmd' on 'jason1'
CRS-2673: Attempting to stop'ora.asm' on 'jason1'
CRS-2673: Attempting to stop'ora.mdnsd' on 'jason1'
CRS-2673: Attempting to stop'ora.drivers.acfs' on 'jason1'
CRS-2677: Stop of 'ora.crf'on 'jason1' succeeded
CRS-2677: Stop of 'ora.evmd'on 'jason1' succeeded
CRS-2677: Stop of 'ora.mdnsd'on 'jason1' succeeded
CRS-2677: Stop of 'ora.ctssd'on 'jason1' succeeded
CRS-5022: Stop of resource"ora.drivers.acfs" failed:current state is "UNKNOWN"
CRS-2675: Stop of'ora.drivers.acfs' on 'jason1' failed
CRS-2677: Stop of 'ora.asm'on 'jason1' succeeded
CRS-2673: Attempting to stop'ora.cluster_interconnect.haip' on'jason1'
CRS-2677: Stop of'ora.cluster_interconnect.haip' on 'jason1'succeeded
CRS-2673: Attempting to stop'ora.cssd' on 'jason1'
CRS-2677: Stop of 'ora.cssd'on 'jason1' succeeded
CRS-2673: Attempting to stop'ora.gipcd' on 'jason1'
CRS-2677: Stop of 'ora.gipcd'on 'jason1' succeeded
CRS-2673: Attempting to stop'ora.gpnpd' on 'jason1'
CRS-2677: Stop of 'ora.gpnpd'on 'jason1' succeeded
CRS-2799: Failed toshut down resource 'ora.drivers.acfs' on 'jason1'
CRS-2795: Shutdownof Oracle High Availability Services-managedresources on 'jason1' has failed
CRS-4687: Shutdowncommand has completed with errors.
CRS-4000: CommandStop failed, or completed with errors.
jason1:/u01/app/11.2.0/grid/bin#
查看crs日志发现每次关闭时否有如下日志存在
CRS-10001:07-Jan-16 23:23ACFS-9118: oracleacfs.ko driver in use - cannot unload
证明每次在关闭资源ora.drivers.acfs时,还有程序在使用该模块导致关闭失败。查看MOS内容如下:
SLES: 11.2.0.3 "crsctl stop crs" Fails to Stop ora.drivers.acfs With CRS-2675 (文档 ID 1417294.1)
In this Document
APPLIES TO:
Oracle database - Enterprise Edition - Version 11.2.0.3 and later
SUSE \ UnitedLinux x86-64
SYMPTOMS
11.2.0.3 Grid Infrastructure on Suse Linux, "crsctl stop crs" or "crsctl stop crs -f" fails:
· "crsctl stop crs" or "crsctl stop crs -f" output
CRS-2675: Stop of 'ora.drivers.acfs' on 'racnode1' failed
..
CRS-2799: Failed to shut down resource 'ora.drivers.acfs' on 'racnode1'
CRS-2795: Shutdown of Oracle High Availability Services-managed resources on 'racnode1' has failed
CRS-4687: Shutdown command has completed with errors.
CRS-4000: Command Stop failed, or completed with errors.
· $GRID_HOME/log/<node>/alert<node>.log
[client(4936)]CRS-10001:01-Feb-12 12:35 ACFS-9290: Waiting for ASM to shutdown.
[client(5098)]CRS-10001:01-Feb-12 12:35 ACFS-9118: oracleacfs.ko driver in use - cannot unload.
[client(5117)]CRS-10001:01-Feb-12 12:35 ACFS-9118: oracleacfs.ko driver in use - cannot unload.
/log/racnode1/agent/ohasd/orarootagent_root/orarootagent_root.log"
· "$GRID_HOME/bin/acfsload stop" output
..
ACFS-9119: oracleacfs driver failed to unload.
· $GRID_HOME/log/<node>/agent/ohasd/orarootagent_root/orarootagent_root.log
2012-02-15 09:44:43.219: [ AGFW][2097063696] {0:0:36062} Agent received the message: RESOURCE_STOP[ora.drivers.acfs 1 1] ID 4099:217493
2012-02-15 09:44:43.219: [ AGFW][2097063696] {0:0:36062} Preparing STOP command for: ora.drivers.acfs 1 1
2012-02-15 09:44:43.219: [ AGFW][2097063696] {0:0:36062} ora.drivers.acfs 1 1 state changed from: ONLINE to: STOPPING
2012-02-15 09:44:43.220: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] (:CLSN00108:) clsn_agent::stop {
2012-02-15 09:44:43.220: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] Arg Value = http://dreamsanqin.blog.51cto.com/845412/stop
2012-02-15 09:44:43.220: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] getOracleHomeAttrib: oracle_home = /ocw/grid
2012-02-15 09:44:43.220: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] Utils::getCrsHome crsHome /ocw/grid
..
2012-02-15 09:44:43.220: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] Adding Environment Variables _ORA_AGENT_ACTION=TRUE
2012-02-15 09:44:43.220: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] Adding Environment Variables __IS_HASD_AGENT=
2012-02-15 09:44:43.220: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] Utils:execCmd action = 2 flags = 6 ohome = (null) cmdname = acfsload.
2012-02-15 09:44:43.220: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] getOracleHomeAttrib: oracle_home = /ocw/grid
2012-02-15 09:44:43.321: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] (:CLSN00010:)ACFS-9290: Waiting for ASM to shutdown.
2012-02-15 09:44:43.321: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] (:CLSN00010:)
..
2012-02-15 09:44:53.433: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] (:CLSN00010:)ACFS-9118: oracleacfs.ko driver in use - cannot unload.
2012-02-15 09:44:53.433: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] (:CLSN00010:)
2012-02-15 09:44:53.433: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] execCmd ret = 0
2012-02-15 09:44:53.434: [ora.drivers.acfs][2094962448] {0:0:36062} [stop] (:CLSN00108:) clsn_agent::stop }
2012-02-15 09:44:53.434: [ AGFW][2094962448] {0:0:36062} Command: stop for resource: ora.drivers.acfs 1 1 completed with status: SUCCESS
CAUSE
The issue was investigated in bug 13726093 and it's closed as OS issue
SOLUTION
Engage OS vendor to disable software that scans ACFS devices.
The temporary workaround is to disable the resource if ACFS is not needed. To disable:
# $GRID_HOME/bin/acfsroot disable
Once it's disabled and node rebooted, it's status will be
ora.registry.acfs
ONLINE OFFLINE racnode1
Note:
It's known that multipath daemon may open /dev/ofsctl:
lsof /dev/ofsctl
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
multipath 5356 root 58r BLK 251,0 0t0 41683748 /dev/ofsctl
Adding ofsctl to multipath blacklist solves the issue.
for findability: rootcrs.pl -unlock ; roothas.pl -unlock
REFERENCES
BUG:13606669 - CRSCTL STOP CLUSTERWARE FAILS TO STOP, ACFS-9118
BUG:13613644 - CRSCTL STOP CRS IS NOT STOPPING THE ORA.DRIVERS.ACFS RESOURCE 11.2.0.3
BUG:13726093 - CRSCTL STOP CRS FAILS TO STOP ACFS
BUG:13736590 - CRS-2799: FAILED TO SHUT DOWN RESOURCE 'ORA.DRIVERS.ACFS'
BUG:13810374 - FAILS TO STOP ACFS RESOURCE IN 11.2.0.3
因本实例中使用multipath绑定硬盘作为ASM磁盘,故multipath服务打开/dev/ofsctl设备,所以导致ora.drivers.acfs失败,最终整个关闭命令完成带有错误。根据提示在multipath配置文件中设置
blacklist{
devnode "^sda"
devnode "ofsctl"
}
设置后,再次重试关闭命令问题解决。
本文出自 “技术成就梦想!” 博客,请务必保留此出处http://dreamsanqin.blog.51cto.com/845412/1737038
Installation Oracle11gR2 RAC---常见报错处理的更多相关文章
- web报表工具FineReport使用中遇到的常见报错及解决办法(二)
web报表工具FineReport使用中遇到的常见报错及解决办法(二) 这里写点抛砖引玉,希望大家能把自己整理的问题及解决方法晾出来,Mark一下,利人利己. 出现问题先搜一下文档上有没有,再看看度娘 ...
- java常见报错及解决
Java常见报错信息: Java 常见异常种类 Java Exception: 1.Error 2.Runtime Exception 运行时异常 3.Exception 4.throw 用户自定 ...
- HDFS集群常见报错汇总
HDFS集群常见报错汇总 作者:尹正杰 版权声明:原创作品,谢绝转载!否则将追究法律责任. 一.DataXceiver error processing WRITE_BLOCK operation 报 ...
- 03:git常见报错解决方法
1.1 git常见报错解决方法 1.warning: LF will be replaced by CRLF in .idea/workspace.xml. 参考博客:https://www.cnbl ...
- JavaScript 调试常见报错以及原因
JavaScript 调试常见报错以及原因 测试环境 chrome 版本 66.0.3359.170(正式版本) (64 位) TypeError 类型错误 不是操作符所接受的数据类型. //---- ...
- Nginx 常见报错
Nginx 常见报错 启动报错:[emerg]: bind() to 0.0.0.0:80 failed (98: Address already in use) 原因:这个是nginx重启时经常遇到 ...
- Django 连接 MySQL 数据库及常见报错解决
目录 Django 连接 MySQL数据库及常见报错解决 终端或者数据库管理工具连接 MySQL ,并新建项目所需数据库 安装访问 MySQL 的 Python 模块 Django 相关配置 可能会遇 ...
- C语言开发中常见报错的解决方案
C语言开发中常见报错的解决方案 整理来源于网络,侵权请通知删除.*禁止转载 ---- fatal error C1003: error count exceeds number; stopping c ...
- Git常用命令及常见报错:You have not concluded your merge (MERGE_HEAD exists)、清理无效的远程追踪分支
一.常用命令 切换到master分支:git checkout master 查看已有本地及远程分支:git branch -a(先git pull拉下全部数据) 查看远程分支:git branch ...
- 内置Jetty配置JSP支持过程中的常见报错
目录 1. 常见报错及解决 1.1 JSP support not configured 1.2 JSTL标签解析 1.3 JSP编译 1.4 JSP实现依赖 1.5 EL表达式支持 2. 小结 1. ...
随机推荐
- spring的第二天
spring的第二天 ssm框架 spring 在昨天简单的介绍了一下spring,那么今天接着继续介绍. spring值的注入 自动装配[autowire] 引用资源 applicationCon ...
- c# 封装Dapper操作类
using Dapper; using DapperExtensions; using System.Collections.Generic; using System.Configuration; ...
- appendChild简单表格的增删改查
---恢复内容开始--- <!DOCTYPE html><html xmlns="http://www.w3.org/1999/xhtml"><hea ...
- CSS学习笔记09 简单理解BFC
引子 在讲BFC之前,先来看看一个例子 <!DOCTYPE html> <html lang="en"> <head> <meta cha ...
- centos 配置ssh远程登录
参考博客: http://blog.csdn.net/sangjian1006/article/details/51603236 1.修改SSH配置文件/etc/ssh/sshd_config 2.在 ...
- Flask的Context(上下文)学习笔记
上下文是一种属性的有序序列,为驻留在环境内的对象定义环境.在对象的激活过程中创建上下文,对象被配置为要求某些自动服务,如同步.事务.实时激活.安全性等等. 比如在计算机中,相对于进程而言,上下文就是进 ...
- canvas-star3
<!DOCTYPE html> <html lang="en"> <head> <meta charset="UTF-8&quo ...
- linux学习笔记-开机流程与主引导分区(MBR)
我的邮箱地址:zytrenren@163.com欢迎大家交流学习纠错! 读鸟哥的linux私房菜-基础学习篇(第三版)3.2.4章节作此笔记 一.术语介绍: Bios:写入到主板上的一个程序,计算机开 ...
- 自定义jq插件,鼠标悬浮展示图片或者视频放大图,可自定义展示内容
网站项目经常会遇到一些视频或者图片素材的展示功能,那么就需要自己写一个功能,就是在一些列表页面你想要是这个数据的详细内容,弹框在页面某个位置 例如这是视频悬浮展示效果,可自定义自动播放等属性标签 又例 ...
- git命令详解( 二 )
这是git详解的第二篇,最近这个加班有点虚,所以文章也写的比较懒了,一到加班不得已,保温杯里泡枸杞啊,不扯了,今天我们来看看git的第二篇 这篇内容主要是git的一些远程命令 远程仓库 git clo ...