oracle dg 状态检查

先检查备库的归档日志同步情况

SELECT NAME,applied FROM v$archived_log;

alter database recover managed standby database cancel;

select thread#,sequence#,standby_dest,archived,applied,status from v$archived_log order by 1,2;

alter database
recover managed standby database using current logfile disconnect from session;

.在备库 查看gap

1.     
select * from
v$archive_gap;

ALTER  DATABASE RECOVER MANAGED
STANDBY  DATABASE DISCONNECT FROM SESSION;

查看主库的基本信息:

SYS@enmo1
hey~1->select open_mode,protection_mode,database_role,switchover_status from
v$database;

OPEN_MODE
           PROTECTION_MODE      
      DATABASE_ROLE        
SWITCHOVER_STATUS
-------------------- -----------------------------
------------------------ ------------------------
READ WRITE           MAXIMUM PERFORMANCE  
   PRIMARY                
     TO STANDBY

查看备库的基本信息:

SYS@enmo2
hey~2->select open_mode,protection_mode,database_role,switchover_status from
v$database;

OPEN_MODE
                  PROTECTION_MODE
            DATABASE_ROLE      
  SWITCHOVER_STATUS
------------------------- -----------------------------
------------------------ ------------------------
READ ONLY WITH APPLY MAXIMUM PERFORMANCE      PHYSICAL
STANDBY      NOT ALLOWED

备库应用日志保持和主库数据一致(如果不一致,执行如下语句应用日志)

SYS@enmo2
hey~2->recover managed standby database using current logfile disconnect
from session;
Media recovery complete.

SYS@enmo2
hey~2->recover managed standby database cancel;
Media recovery complete.

主库切换到备库角色并查看切换之后的状态为RECOVERY NEEDED

SYS@enmo1
hey~1->alter database commit to switchover to physical standby with session
shutdown;

Database
altered.

SYS@enmo1
hey~1->shutdown abort;

ORACLE instance
started.

Total System
Global Area 830930944 bytes
Fixed Size 2257800 bytes
Variable Size 700451960 bytes
Database Buffers 121634816 bytes
Redo Buffers 6586368 bytes
Database mounted.
SYS@enmo1 hey~1->select switchover_status from v$database;

SWITCHOVER_STATUS
--------------------
RECOVERY NEEDED

切换应用日志,然后在查看切换状态为TO primary正常:

SYS@enmo1
hey~1->recover managed standby database using current logfile disconnect
from session;
Media recovery complete.
SYS@enmo1 hey~1->select switchover_status from v$database;

SWITCHOVER_STATUS
--------------------
TO PRIMARY

备库切主库:

SYS@enmo2
hey~2->select open_mode,protection_mode,database_role,switchover_status from
v$database;

OPEN_MODE
PROTECTION_MODE DATABASE_ROLE SWITCHOVER_STATUS
-------------------- -------------------- ----------------
--------------------
MOUNTED MAXIMUM PERFORMANCE PHYSICAL STANDBY TO PRIMARY

SYS@enmo2
hey~2->alter database commit to switchover to primary with session shutdown;

Database
altered.

SYS@enmo2
hey~2->alter database open;

Database
altered.

SYS@enmo2
hey~2->select switchover_status,database_role from v$database;

SWITCHOVER_STATUS
DATABASE_ROLE
-------------------- ----------------
FAILED DESTINATION PRIMARY

SYS@enmo2
hey~2->select open_mode,protection_mode,database_role from v$database;

OPEN_MODE
PROTECTION_MODE DATABASE_ROLE
-------------------- -------------------- ----------------

READ WRITE MAXIMUM PERFORMANCE
PRIMARY

二、备库不同步的问题检查方法

1、检查主备两边的序号
select max(sequence#) from v$log;   ---检查发现一致

2、备库执行,查看是否有数据未应用
select name,SEQUENCE#,APPLIED from v$archived_log order by sequence#;

select
SEQUENCE#,FIRST_TIME,NEXT_TIME ,APPLIED from v$archived_log order by 1;

3、检查备库是否开启实时应用
select recovery_mode from v$archive_dest_status where dest_id=2;

4、检查备库状态
select switchover_status from v$database; --发现状态not allowed

3、看看进程MRP是否存在
 ps aux|grep mrp      --发现进程不存在

4、如果不存在执行以下:
alter database recover managed standby database using current logfile
disconnect;

alter
database recover managed standby database disconnect from session;  --后台执行

alter
database recover managed standby database --前台执行,执行这个可以看到报错的情况

如果有报错,查看alert日志和log.xml日志

5、验证是否正常
select process,status from v$managed_standby;
select process,status,sequence# from v$managed_standby;

如果看到mrp0正常

6、以上步骤处理好后,如果数据还不正常,接着处理

关闭备库,接着处理:
把主库上 undotbs01.dbf 文件,物理的重拷到备库机上以前undotbs01.dbf 所在目录下;

$scp /data/oracle/oradata/voip/undotbs01.dbf   192.168.122.204:/data/oracle/oradata/voip

再在主库上重新生成一个standby control file ,拷到备库机上相应目录下,

alter
database create standby controlfile as '/data/oracle/oradata/voip/qyqdg01.ctl'

$scp
/data/oracle/oradata/voip/qyqdg01.ctl  
192.168.122.204:/data/oracle/oradata/voip
$ mv qyqdg01.ctl  control01.ctl
$ cp control01.ctl /data/oracle/flash_recovery_area/qyq/
$cd /data/oracle/flash_recovery_area/qyq/
$ mv control01.ctl  control02.ctl

接着
STARTUP NOMOUNT;
ALTER DATABASE MOUNT STANDBY DATABASE;
ALTER DATABASE RECOVER MANAGED STANDBY DATABASE DISCONNECT FROM SESSION;

--------------------------------------
session恢复完成后,重启打开备库;

alter
database open read only;

oracle dg状态检查及相关命令的更多相关文章

  1. linux系统状态查看/管理相关命令

    系统状态查看命令: w 查看用户 top 系统进程监控 uptime 查看某台服务器运行了多久 htop 更加先进的交互式监控工具(需要安装) iotop 监控并实时显示磁盘IO输入和输出和程序进程( ...

  2. Oracle dg 状态校验

    查看主库状态: select open_mode,protection_mode,database_role,switchover_status from v$database; OPEN_MODE ...

  3. pgpool如何对数据库节点进行状态检查及相关数据结构描述

    /* * configuration parameters */typedef struct {    char *listen_addresses;            /* hostnames/ ...

  4. [ SHELL编程 ] 编程常用的ORACLE相关命令

    本文主要描述shell编程中常用的Oracle相关命令. 1.sqlplus -L/-S参数 sqlplus -L user/password #-L参数表示用户只尝试登录一次, 而不是在出错时再次提 ...

  5. oracle相关命令收集-张

    orcle相关命令收集 1,用管理员登陆 /as sysdba:2, 更改用户密码 alter user name identified by password: alter user exptest ...

  6. Oracle基础介绍及常用相关sql*plus命令

    以管理员身份运行Database Configuration Assistant,新建数据库实例. 要使用Oracle首先要启动Oracle服务,在任务管理器中找到服务,打开有关OracleServi ...

  7. 某控股公司OA系统ORACLE DG搭建

    *此处安装ORACLE DATAGUARD是利用ORACLE RMAN DUPLICATE方式安装.*可以搭建好ORACLE DG再来impdp生产数据,也可以先导入主库数据再来做DG*注意看下面的配 ...

  8. ORACLE 12c RAC的常用管理命令

    ORACLE 12c RAC的常用管理命令 一.查询 1.RAC查询 1.1.查询节点 [grid@swnode1 ~]$ su - grid [grid@swnode1 ~]$ /u01/app/1 ...

  9. oracle之 调整 I/O 相关的等待

    I/O相关竞争等待简介 当Oracle数据库出现I/O相关的竞争等待的时候,一般来说都会引起Oracle数据库的性能低下,发现数据库存在I/O相关的竞争等待一般可以通过以下的三种方法来查看Oracle ...

随机推荐

  1. 海思Hi3519A MPP从入门到精通(二 系统控制)

    系统控制根据 Hi35xx 芯片特性,完成硬件各个部件的复位.基本初始化工作,同时负责完成 MPP(Media Process Platform 媒体处理平台)系统各个业务模块的初始化.去初始化以及管 ...

  2. docker卷管理(四)

    什么是数据卷 overlay2存储卷 docker镜像是由多个只读层叠加而成,启动容器时,docker会加载只读镜像层,并在镜像栈顶部添加一个可写层 如果运行中的容器修改了现有的一个已存在文件,那该文 ...

  3. CentOS7打开、关闭防火墙。

    CentOS7 以上机器一些命令和低版本CentOS是有些差异的,本文只针对CentOS7 以上版本. CentOS7使用firewalld打开关闭防火墙与端口1.firewalld的基本使用启动: ...

  4. 解构如何运用的解构--报错 throw new TypeError('Router.use() requires a middleware function but got a ' + gettype(fn))

    let aa={ error_code: 0, reason: "插入数据成功" };//如何拿到 error_code 和 reason 的值 let { error_code, ...

  5. ubuntu18.40 rtx2080ti安装显卡驱动/cuda/cudnn/tensorflow-gpu

    电脑环境 ubuntu 18.40 gpu  rtx2080ti 一.安装显卡驱动 刚开始尝试用手动安装方式安装驱动 下载了驱动程序但是因为没有gcc所以放弃这种方法 后尝试最简单的方式 在 菜单-- ...

  6. 启动tomcat内存溢出

    在运行项目的过程中,启动tomcat内存溢出.查阅了一些解决办法,总结出来留个笔记. 1.使用Myeclipse2014+tomcat 7 ,在MyEclipse中将项目部署到Tomcat下,启动to ...

  7. C++ 静态库与动态库以及在 Windows上 的创建、使用

    一.什么是库 库是写好的现有的,成熟的,可以复用的代码.现实中每个程序都要依赖很多基础的底层库,不可能每个人的代码都从零开始,因此库的存在意义非同寻常. 本质上来说库是一种可执行代码的二进制形式,可以 ...

  8. torch_12_BigGAN全文解读

    1.摘要: 尽管近来生成图片模型取得了进步,成功生成了高分辨率的图片,但是在复杂的数据集中,样本的多样性仍然是难以捉摸的目标.本文尝试在大规模上训练生成对抗网络,并研究这种规模下的不稳定性.我们发现将 ...

  9. Oracle索引知识学习笔记

    目录 一.Oracle索引简介 1.1 索引分类 1.2 索引数据结构 1.3 索引特性 1.4 索引使用注意要点 1.5.索引的缺点 1.6.索引失效 二.索引分类介绍 2.1.位图索引 1.2.函 ...

  10. 十、自定义ThreadPoolExecutor线程池

    自定义ThreadPoolExecutor线程池 自定义线程池需要遵循的规则 [1]线程池大小的设置 1.计算密集型: 顾名思义就是应用需要非常多的CPU计算资源,在多核CPU时代,我们要让每一个CP ...