openstack-glance-api.service start request repeated too quickly, refusing to start
问题描写叙述
openstack J版 centos7部署
重新启动服务时起不来,日志也不报错。以glance服务为例,例如以下:
# systemctl start openstack-glance-api.service openstack-glance-registry.service
Job for openstack-glance-api.service failed. See 'systemctl status openstack-glance-api.service' and 'journalctl -xn' for details.
# systemctl status openstack-glance-api.service
openstack-glance-api.service - OpenStack Image Service (code-named Glance) API server
Loaded: loaded (/usr/lib/systemd/system/openstack-glance-api.service; enabled)
Active: failed (Result: start-limit) since Sat 2015-07-11 22:25:43 EDT; 19s ago
Process: 11841 ExecStart=/usr/bin/glance-api (code=exited, status=1/FAILURE)
Main PID: 11841 (code=exited, status=1/FAILURE)
Jul 11 22:25:43 node-82 systemd[1]: Failed to start OpenStack Image Service (code-named Glance) API server.
Jul 11 22:25:43 node-82 systemd[1]: Unit openstack-glance-api.service entered failed state.
Jul 11 22:25:43 node-82 systemd[1]: openstack-glance-api.service holdoff time over, scheduling restart.
Jul 11 22:25:43 node-82 systemd[1]: Stopping OpenStack Image Service (code-named Glance) API server...
Jul 11 22:25:43 node-82 systemd[1]: Starting OpenStack Image Service (code-named Glance) API server...
Jul 11 22:25:43 node-82 systemd[1]: openstack-glance-api.service start request repeated too quickly, refusing to start.
Jul 11 22:25:43 node-82 systemd[1]: Failed to start OpenStack Image Service (code-named Glance) API server.
Jul 11 22:25:43 node-82 systemd[1]: Unit openstack-glance-api.service entered failed state.
错误分析
之前mariadb起不来也是相似错误,可是输入journalctl -xn 后,会显示配置错误。订正my.cnf 就能够但glance报这个错误怎么解决?我还没做什么呢,他说连接过快。无奈之下想起了“重新启动试试,不行就分”。重新启动吧,重新启动也没用,那就卸掉glance组件,删掉数据库,删掉keystone链接重来吧,结果还是没卵用。
相似这样的服务起不来的情况,依个人经历作例如以下总结
1.配置文档有错,订正配置文档,再次启动
2.相关目录/文件的权限有问题。查看权限,改动权限
错误解决
由于我都是root权限操作的,所以同步数据库经经常使用用的是glance-manage db_sync 这次也没什么问题,同步是成功的,问题找不到原因就仅仅能乱撞了。google也没找到。当我输入了su -s /bin/sh -c "glance-manage db_sync" glance 狐狸尾巴最终露出来了。同步出错,错误信息:
Traceback (most recent call last):
File "/usr/bin/glance-manage", line 10, in <module>
sys.exit(main())
File "/usr/lib/python2.7/site-packages/glance/cmd/manage.py", line 273, in main
log.setup('glance')
File "/usr/lib/python2.7/site-packages/glance/openstack/common/log.py", line 460, in setup
_setup_logging_from_conf(product_name, version)
File "/usr/lib/python2.7/site-packages/glance/openstack/common/log.py", line 529, in _setup_logging_from_conf
filelog = logging.handlers.WatchedFileHandler(logpath)
File "/usr/lib64/python2.7/logging/handlers.py", line 392, in __init__
logging.FileHandler.__init__(self, filename, mode, encoding, delay)
File "/usr/lib64/python2.7/logging/__init__.py", line 902, in __init__
StreamHandler.__init__(self, self._open())
File "/usr/lib64/python2.7/logging/__init__.py", line 925, in _open
stream = open(self.baseFilename, self.mode)
IOError: [Errno 13] Permission denied: '/var/log/glance/api.log'
api.log 权限有问题,查看之
# ll /var/log/glance/api.log
-rw-r--r--. 1 root root 14783 Jul 11 22:25 /var/log/glance/api.log
果然,将它改成glance组glance的,再次同步。再次重新启动。ok
# chown -R glance:glance /var/log/glance/api.log
# su -s /bin/sh -c "glance-manage db_sync" glance
# systemctl start openstack-glance-api.service
openstack-glance-api.service start request repeated too quickly, refusing to start的更多相关文章
- 重启osd服务失败:Start request repeated too quickly
背景 OS:Ubuntu 16.04 修改了osd的一些配置,修改后,需要重启osd服务才能生效.第一次重启后,配置立刻生效.再改了一些配置,重启osd服务后,配置却不再生效了.ps命令查看进程,发现 ...
- systemctl start docker失败,提示start request repeated too quickly for docker.service
情景说明 本来服务器docker服务运行的很好,但客户重启了服务器-于是服务有些问题,遂进入到服务器再次启动docker及服务.不料提示上面的错误-- 解决办法 尝试1 Google了一圈,发现说法很 ...
- OpenStack Identity API v3
Table Of Contents OpenStack Identity API v3 What’s New in Version 3.7 What’s New in Version 3.6 What ...
- 使用curl调试openstack的api
一 系统环境 OpenStack: Mitaka 工具: 最简单的工具:restclient,本次使用curl 二 开搞 访问openstack的API之前,用户使用用户名和密码向keystone进行 ...
- Openstack Restful API 开发框架 Paste + PasteDeploy + Routes + WebOb
目录 目录 Paste PasteDeploy Routes WebOb 简介 WSGI入口 Paste和PasteDeploy 配置文件 pasteini 中间件的实现 Routes WebOb 参 ...
- OpenStack Identity API v3 (CURRENT)
Table Of Contents Identity API v3 (CURRENT) Authentication and token management Password authenticat ...
- OpenStack Identity API v3 extensions (CURRENT)
Table Of Contents Identity API v3 extensions (CURRENT) OS-ENDPOINT-POLICY API Associate policy and e ...
- Openstack glance 镜像服务 (五)
Openstack glance 镜像服务 (五) 引用: 官方文档glance安装 https://docs.openstack.org/ocata/zh_CN/install-guide-rdo/ ...
- Openstack python api 学习文档 api创建虚拟机
Openstack python api 学习文档 转载请注明http://www.cnblogs.com/juandx/p/4953191.html 因为需要学习使用api接口调用openstack ...
随机推荐
- 10C++类和对象
类和对象 8.1 面向对象程序设计方法概述 到目前为止,我们介绍的是C++在面向过程的程序设计中的应用.对于规模比较小的程序,编程者可以直接编写出一个面向过程的程序,详细地描述每一瞬时的数据结构及对其 ...
- windows 下安装 RabbitMQ
一.安装 RabbitMQ 前需要先安装 Erlang http://www.erlang.org/downloads 下下载对应版本的安装文件进行安装. 安装完成后配置环境变量: ERLANG_HO ...
- IIS更改根目录
服务器中打开IIS管理器,选择网站,再选展开后的站点,点击右边高级设置,最后更改弹框中的物理地址即可:
- Jedis集成到项目中
Jedis整合到项目中,就可以在项目中使用redis了,作为Java程序狗,这个可以会,贴代码了,不截图了,哈哈 一.maven中的pom.xml中添加依赖 <dependency> &l ...
- LogisticRegressionCV 参数使用以及含义 笔记
第一次接触LogisticRegressionCV ,记录一下. Logistic回归是分类算法,不能应用于回归中(传入模型的y值,不能是float类型,必须是int类型) 正则化选择参数 :pena ...
- 【2019 1月集训 Day1】回文的后缀
题意: 给定 n,s,求有多少个字符集大小为 s ,长度为 n 的字符串,使得其不存在一个长度大于 1 的回文后缀. 答案对 m 取模. 分析: 考场见到计数题的链式反应,想写暴力—>暴力难写— ...
- Python飞机大战实例有感——pygame如何实现“切歌”以及多曲重奏?
目录 pygame如何实现"切歌"以及多曲重奏? 一.pygame实现切歌 初始化路径 尝试一 尝试二 尝试三 成功 总结 二.如何在python多线程顺序执行的情况下实现音乐和音 ...
- python3.x Day5 面向对象
类:类是指:对具有相同属性的事物的抽象.蓝图.原型.在类中定义了这些事物都具备的属性和共同的方法. 对象:一个对象就是一个类实例化以后的实例,一个类必须经过实例化后才能在程序中被使用,一个类可以实例化 ...
- atom 安装插件列表
插件列表 atom-beautify docblockr autocomplete-python goto-definition platformio-ide-terminal symbols-tre ...
- UVa 10129 单词 (欧拉通路)
题意: 输入n(n≤100000)个单词,是否可以把所有这些单词排成一个序列,使得每个单词的第一个字母和上一个单词的最后一个字母相同(例如acm.malform.mouse).每个单词最 多包含100 ...